PROBLEMA Leggere cartelle hdd NAS raid

Fittone

Utente Attivo
123
12
Hardware Utente
CPU
intel core i7 4790k @4.8 ghz
Dissipatore
Corsair Hydro H115i
Scheda Madre
Asus rog maximus VI Hero
Hard Disk
SSD Kingston HyperX 3K Edizione Limitata Natus Vincere 240 Gb
RAM
DDR3 Corsair Vengeance 16GB (2x8GB)1600MHz CL9
Scheda Video
2X SLI Nvidia Geforce GTX 970 MSI Twin Frozr V
Scheda Audio
On Board
Monitor
Samsung U28E570D Ultra HD 28"
Alimentatore
Corsair cx750m
Case
Corsair 780t graphite Full-tower
Sistema Operativo
Windows 10 64-bit
Ciao ragazzi, mi servirebbe una mano, il mio nas ha smesso di funzionare (non era più visibile in rete ed altri problemi) così ho deciso di recuperare i dati presenti, il problema è che il file system è di tipo Linux, non so quale ext a dir la verità, quindi chiaramente non visibile su Windows, come procedo? Grazie mille
 

michael chiklis

Utente Èlite
4,534
1,347
Hardware Utente
CPU
Intel i5-3550 @ 3,3 GHz
Scheda Madre
ASROCK Z77 Pro3
Hard Disk
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX1600C9AD3/2G 8 GB (4x2GB)
Scheda Video
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
Alimentatore
Tecno 1000 W modulare
Sistema Operativo
Win7 x64
Ciao,
per prima cosa dicci da quanti hdd era composto il NAS e che tipo di array era montato (raid0, raid1, jbod, ecc), se era in configurazione di striping (esempio raid 0) magari dicci il valore (se lo conosci) dello stripe.
Poi ti suggerisco di non avviare alcun programma di recupero e di non smanettare con Linux prima di aver effettuato una clonazione di ogni singolo drive che compone l'array, è facile perdere i dati definitivamente o non ottenere un recupero ottimale quando si ha a che fare con sistemi raid se non si effettua nel modo corretto, ma se cloni gli hdd in caso di errore potrai ritornare alla situazione iniziale per riprovarci.

P.S.
Tieni presente che il recupero dagli array è molto più complesso rispetto al recupero da singoli hdd, a meno che non si tratti di un raid 1 (mirroring)

- - - Updated - - -

Dimenticavo...
è possibile che uno o più hdd del NAS abbiano qualche problema fisico.
Mi sembra di capire che hai provato a collegare gli hdd singolarmente sul pc da cui fai girare windows, mentre che eri in windows hai provato a verificare lo stato SMART degli hdd con CrystalDisk?
Se si, qual è la situazione? Puoi postare le schermate smart qui?

Spero tu non abbia tentato di ricreare l'array in windows o di inizializzare gli hdd... :look:
Sono errori che spesso gli utenti fanno.
 
Ultima modifica:

Fittone

Utente Attivo
123
12
Hardware Utente
CPU
intel core i7 4790k @4.8 ghz
Dissipatore
Corsair Hydro H115i
Scheda Madre
Asus rog maximus VI Hero
Hard Disk
SSD Kingston HyperX 3K Edizione Limitata Natus Vincere 240 Gb
RAM
DDR3 Corsair Vengeance 16GB (2x8GB)1600MHz CL9
Scheda Video
2X SLI Nvidia Geforce GTX 970 MSI Twin Frozr V
Scheda Audio
On Board
Monitor
Samsung U28E570D Ultra HD 28"
Alimentatore
Corsair cx750m
Case
Corsair 780t graphite Full-tower
Sistema Operativo
Windows 10 64-bit
Ciao,
per prima cosa dicci da quanti hdd era composto il NAS e che tipo di array era montato (raid0, raid1, jbod, ecc), se era in configurazione di striping (esempio raid 0) magari dicci il valore (se lo conosci) dello stripe.
Poi ti suggerisco di non avviare alcun programma di recupero e di non smanettare con Linux prima di aver effettuato una clonazione di ogni singolo drive che compone l'array, è facile perdere i dati definitivamente o non ottenere un recupero ottimale quando si ha a che fare con sistemi raid se non si effettua nel modo corretto, ma se cloni gli hdd in caso di errore potrai ritornare alla situazione iniziale per riprovarci.

P.S.
Tieni presente che il recupero dagli array è molto più complesso rispetto al recupero da singoli hdd, a meno che non si tratti di un raid 1 (mirroring)

- - - Updated - - -

Dimenticavo...
è possibile che uno o più hdd del NAS abbiano qualche problema fisico.
Mi sembra di capire che hai provato a collegare gli hdd singolarmente sul pc da cui fai girare windows, mentre che eri in windows hai provato a verificare lo stato SMART degli hdd con CrystalDisk?
Se si, qual è la situazione? Puoi postare le schermate smart qui?

Spero tu non abbia tentato di ricreare l'array in windows o di inizializzare gli hdd... :look:
Sono errori che spesso gli utenti fanno.
Ciao grazie per la risposta, allora il nas era composto da due HDD in raid 1, l'ho collegato a Windows e non me lo legge in quanto file system non riconosciuto, però viene rilevato come hd esterno quello si ma non posso aprirlo dal gestione risorse, poi l'ho collegato su Linux ma me lo rilevava come partizione di Linux o qualcosa del genere, ho cercato di montarlo da terminale con scarsi risultati.
Allego screen Crystaldisk
Cattura.JPG
 
Ultima modifica:

michael chiklis

Utente Èlite
4,534
1,347
Hardware Utente
CPU
Intel i5-3550 @ 3,3 GHz
Scheda Madre
ASROCK Z77 Pro3
Hard Disk
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX1600C9AD3/2G 8 GB (4x2GB)
Scheda Video
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
Alimentatore
Tecno 1000 W modulare
Sistema Operativo
Win7 x64
Quello riportato da Crystaldsik è lo smart di un hdd WD Green, questi non sono adatti per stare in un array raid dove sono richiesti hdd più veloci e più adatti a stare sempre accesi.
Come mai hai postato lo smart solo di un hdd?
Potresti postare lo smart anche dell'altro hdd che componeva l'array?

L'hdd di cui hai postato lo smart è rimasto acceso per oltre 32.500 ore (sono tantissime per questo tipo di hdd), lo smart non mostra alcun errore quindi aspetto che posti losmart anche dell'altro hdd.
Detto questo, se il NAS era configurato in RAID 1 come di ci tu, ti basta avere solo uno dei 2 hdd che componeva l'array per recuperare i dati con un SW di recupero dati o in Linux.

Se non riesci a recuperarli è perchè probabilmente si è danneggiato il filesystem.
 

Fittone

Utente Attivo
123
12
Hardware Utente
CPU
intel core i7 4790k @4.8 ghz
Dissipatore
Corsair Hydro H115i
Scheda Madre
Asus rog maximus VI Hero
Hard Disk
SSD Kingston HyperX 3K Edizione Limitata Natus Vincere 240 Gb
RAM
DDR3 Corsair Vengeance 16GB (2x8GB)1600MHz CL9
Scheda Video
2X SLI Nvidia Geforce GTX 970 MSI Twin Frozr V
Scheda Audio
On Board
Monitor
Samsung U28E570D Ultra HD 28"
Alimentatore
Corsair cx750m
Case
Corsair 780t graphite Full-tower
Sistema Operativo
Windows 10 64-bit
Quello riportato da Crystaldsik è lo smart di un hdd WD Green, questi non sono adatti per stare in un array raid dove sono richiesti hdd più veloci e più adatti a stare sempre accesi.
Come mai hai postato lo smart solo di un hdd?
Potresti postare lo smart anche dell'altro hdd che componeva l'array?

L'hdd di cui hai postato lo smart è rimasto acceso per oltre 32.500 ore (sono tantissime per questo tipo di hdd), lo smart non mostra alcun errore quindi aspetto che posti losmart anche dell'altro hdd.
Detto questo, se il NAS era configurato in RAID 1 come di ci tu, ti basta avere solo uno dei 2 hdd che componeva l'array per recuperare i dati con un SW di recupero dati o in Linux.

Se non riesci a recuperarli è perchè probabilmente si è danneggiato il filesystem.
Ne ho postato solo uno appunto perchè era in raid 1, l'altro in ogni caso ce l'ho però non dovrebbe servire. Sisi infatti nel NAS nuovo ho montato dei caviar RED, io sono infatti tranquillo che entrambi gli hd siano perfettamente funzionanti, tant'è che come ti dicevo era proprio il NAS (sul circuito stampato) che si è rotto gli hdd stanno benone, mi servirebbe sapere proprio la procedura per leggere i dati dai dischi, sia su linux che su windows mi va bene, basta che riesca a recuperare i dati

Qui è l'errore che ricevo quando cerco di montarlo:
federico@federico-desktop:~$ sudo mount /dev/sdc4 /media/prova
mount: unknown filesystem type 'linux_raid_member'
 
Ultima modifica:

michael chiklis

Utente Èlite
4,534
1,347
Hardware Utente
CPU
Intel i5-3550 @ 3,3 GHz
Scheda Madre
ASROCK Z77 Pro3
Hard Disk
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX1600C9AD3/2G 8 GB (4x2GB)
Scheda Video
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
Alimentatore
Tecno 1000 W modulare
Sistema Operativo
Win7 x64
Faccio prima a mostrartelo in remoto che spiegarlo ...
Ce l'hai un hdd con abbastanza spazio libero su cui salvare i dati da recuperare?

Non salvarli assolutamente sugli stessi hdd che componevano l'array, prendi possibilmente un hdd vuoto.
 

Fittone

Utente Attivo
123
12
Hardware Utente
CPU
intel core i7 4790k @4.8 ghz
Dissipatore
Corsair Hydro H115i
Scheda Madre
Asus rog maximus VI Hero
Hard Disk
SSD Kingston HyperX 3K Edizione Limitata Natus Vincere 240 Gb
RAM
DDR3 Corsair Vengeance 16GB (2x8GB)1600MHz CL9
Scheda Video
2X SLI Nvidia Geforce GTX 970 MSI Twin Frozr V
Scheda Audio
On Board
Monitor
Samsung U28E570D Ultra HD 28"
Alimentatore
Corsair cx750m
Case
Corsair 780t graphite Full-tower
Sistema Operativo
Windows 10 64-bit
Faccio prima a mostrartelo in remoto che spiegarlo ...
Ce l'hai un hdd con abbastanza spazio libero su cui salvare i dati da recuperare?

Non salvarli assolutamente sugli stessi hdd che componevano l'array, prendi possibilmente un hdd vuoto.
Ho appena risolto tramite questo comando!
federico@federico-desktop:~$ sudo mdadm -A -R /dev/md9 /dev/sdc4
mdadm: /dev/md9 has been started with 1 drive (out of 2).

Grazie per il tuo tempo comunque! In ogni caso credo che sia necessario fare una guida per chi dovesse avere problemi simili, grazie ancora!
 

dirklive

Utente Èlite
2,530
882
Hardware Utente
Hard Disk
troppi
I file su un mirror è noto che sono scritti per intero ergo non necessitano di nessuna guida per poter accedere al contenuto del disco, quel comando da terminale che hai impartito non è altro che un comando per leggere un disco singolo facente parte di un array, ed è tipico del sistema Linux.
 

Entra

oppure Accedi utilizzando