PROBLEMA Bash: comando non trovato

Metallkros

Nuovo Utente
60
18
Ho installato Debian 10 su un mio pc, e sto studiando il manuale per imparare meglio l'utilizzo di linux.
Ora mi sono accorto che comandi come : reboot - service - adduser - shutdown, non vengono eseguiti, e mi rimanda indietro sempre Bash: comando non trovato.
Cosa devo fare? Anche perché così non riesco a studiare molte cose.
 

EmanueleC

Utente Èlite
5,361
1,704
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
  • Like
Reactions: Metallkros

Metallkros

Nuovo Utente
60
18
è la stessa roba che sto leggendo...
ho cercato in giro il mio problema, se divento root con su non riesco a usare questi comandi, mentre se lo faccio con su - ci riesco;
Credo che il problema sia il PATH, nel senso che quando uso su normale nel PATH non è presente la directory sbin , provo a settario manualmente, anche se mi sono accorto che all'interno della directory root non c'è nulla. (leggevo su internet che invece dovrebbe esserci il file bash_profile)
Post automatically merged:

ok ho anche letto il capitolo sulla variabile PATH , forse ne posso venire fuori. domani vi aggiorno
 

EmanueleC

Utente Èlite
5,361
1,704
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
è la stessa roba che sto leggendo...
ho cercato in giro il mio problema, se divento root con su non riesco a usare questi comandi, mentre se lo faccio con su - ci riesco;
Credo che il problema sia il PATH, nel senso che quando uso su normale nel PATH non è presente la directory sbin , provo a settario manualmente, anche se mi sono accorto che all'interno della directory root non c'è nulla. (leggevo su internet che invece dovrebbe esserci il file bash_profile)
Post automatically merged:

ok ho anche letto il capitolo sulla variabile PATH , forse ne posso venire fuori. domani vi aggiorno
È normale che devi avere i privilegi per poter spegnere il sistema. Su Ubuntu ti basta digitare "poweroff" o "systemctl poweroff" (che fanno la stessa cosa) per poter spegnere senza privilegi, questo perché Ubuntu usa polkit.
 

Metallkros

Nuovo Utente
60
18
È normale che devi avere i privilegi per poter spegnere il sistema. Su Ubuntu ti basta digitare "poweroff" o "systemctl poweroff" (che fanno la stessa cosa) per poter spegnere senza privilegi, questo perché Ubuntu usa polkit.
il problema è che nonostante io sia root i comandi non vanno(sicuramente perché il PATH è da impostare) se invece di su mi autentico con su - riesco a lanciarli tutti. domani proverò a cambiare le impostazioni del PATH, ora non ci sto dietro ahahah
Post automatically merged:

ho inserito l'utente tra i sudoers, quindi in teoria se digito sudo shotdown -h now dovrebbe chiedermi la pass, e dopodiché spegnersi.
 
Ultima modifica:

clessidra

Utente Attivo
766
272
CPU
VIA C3
GPU
Ati Rage
OS
linux - Red Hat 1.1
Diversi comandi possono essere eseguiti solo come root come impostazione predefinita.
 

EmanueleC

Utente Èlite
5,361
1,704
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
il problema è che nonostante io sia root i comandi non vanno(sicuramente perché il PATH è da impostare) se invece di su mi autentico con su - riesco a lanciarli tutti. domani proverò a cambiare le impostazioni del PATH, ora non ci sto dietro ahahah
Post automatically merged:

ho inserito l'utente tra i sudoers, quindi in teoria se digito sudo shotdown -h now dovrebbe chiedermi la pass, e dopodiché spegnersi.
systemctl poweroff o systemctl reboot
 

Metallkros

Nuovo Utente
60
18
systemctl poweroff o systemctl reboot
ma questi comandi servono solo per spegnere e riavviare il sistema
Post automatically merged:

allora, sono riuscito a capire qual'è il problema, ma non riesco a risolverlo(sicuramente sbaglio qualcosa).
quello che voglio fare è modificare il file ~/.bash_profile per aggiungere alla variabile PATH la directory /sbin, in modo che io possa utilizzare i comandi citati nel primo messaggio. il problema è che non riesco a trovare questo file , neanche nella directory /root.
Post automatically merged:

Diversi comandi possono essere eseguiti solo come root come impostazione predefinita.
forse mi sono spiegato male, anche da root molti di questi comandi non vengono trovati dal bash
 
Ultima modifica:

clessidra

Utente Attivo
766
272
CPU
VIA C3
GPU
Ati Rage
OS
linux - Red Hat 1.1
Una soluzione è mettere nel file .bashrc dell'utente root:
export PATH="$PATH:/sbin"
Spero che per la tua distro valga questa soluzione.
 

Metallkros

Nuovo Utente
60
18
Una soluzione è mettere nel file .bashrc dell'utente root:
export PATH="$PATH:/sbin"
Spero che per la tua distro valga questa soluzione.
nella cartella root non c'è nessun file
Post automatically merged:

non riesco a trovareil file .bashrc da nessuna parte
Post automatically merged:

ok l'ho trovato con ls -a , una curiosità devo aggiungere direttamente dentro il file questo? : # export PATH="$PATH:/sbin
p.s. la cartella è /root?
 
Ultima modifica:

« MoMy »

Utente Attivo
1,357
607
Strana 'sta cosa. Se gli mancasse il path il sistema (forse si avvierebbe) si avvierebbe con grossi problemi.
La prima cosa da fare è logarsi come root e lanciare il comando echo $PATH e se nel risultato vedi /usr/bin voldì che il problema è altrove.
La seconda è controllare che effettivamente i vari esistano, quindi per esempio: which reboot
Ovvio, questo prima di esportare il path.

Bye^^

EDIT: Debian lo conosco poco e nulla quindi mi affido a terzi. Qui ho trovato qualcosa che parrebbe il caso tuo. https://linuxconfig.org/command-not-found-missing-path-to-sbin-on-debian-gnu-linux
 

clessidra

Utente Attivo
766
272
CPU
VIA C3
GPU
Ati Rage
OS
linux - Red Hat 1.1
Come ho già scritto, senza '#':
export PATH="$PATH:/sbin"
Poi devi uscire e rientrare nell'utente root. O fai un reboot.
 

EmanueleC

Utente Èlite
5,361
1,704
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
ma questi comandi servono solo per spegnere e riavviare il sistema
Post automatically merged:

allora, sono riuscito a capire qual'è il problema, ma non riesco a risolverlo(sicuramente sbaglio qualcosa).
quello che voglio fare è modificare il file ~/.bash_profile per aggiungere alla variabile PATH la directory /sbin, in modo che io possa utilizzare i comandi citati nel primo messaggio. il problema è che non riesco a trovare questo file , neanche nella directory /root.
Post automatically merged:

forse mi sono spiegato male, anche da root molti di questi comandi non vengono trovati dal bash
Ma è questo che stai lamentando.
Quei comandi ti danno "Bash: comando" Perché quel comando è per il vecchio init. Infatti se vai con systemctl poweroff o altri comandi per il riavvio etc funziona.
Quindi è ovvio che non ti trova il comando.
 

« MoMy »

Utente Attivo
1,357
607
@EmanueleC None! L' OP lamenta il fatto che alcuni comandi funzionano via user ma non via root. I comandi funzionano con sudo, ma non funzionano con su ergo quando si loga admin con su, gli stessi comandi non gli funzionano.
Codice:
/* Funziona */
$ sudo reboot
Codice:
/* Non funziona */
# reboot
 
  • Like
Reactions: Metallkros

EmanueleC

Utente Èlite
5,361
1,704
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
@EmanueleC None! L' OP lamenta il fatto che alcuni comandi funzionano via user ma non via root. I comandi funzionano con sudo, ma non funzionano con su ergo quando si loga admin con su, gli stessi comandi non gli funzionano.
Codice:
/* Funziona */
$ sudo reboot
Codice:
/* Non funziona */
# reboot
Aah, ok. Ho provato su Debian testing in VM e a me funziona. Quindi boh. Ma io su Debian non ho impostato la password dell'utente root, quindi è disattivato. Se può essere utile...
 

Entra

oppure Accedi utilizzando

Hot: PS5 VS XBOX X/S?

  • Playstation 5

    Voti: 458 63.4%
  • XBOX Series X/S

    Voti: 264 36.6%