Archlinux e Windows 10 su 2 HDD differenti

Icedemon 89

Nuovo Utente
12
0
CPU
Core i5-6500
Scheda Madre
AsRock H170M Pro4s
HDD
WD 1 TB
RAM
HyperX Fury 8GB DDR4 2133Mhz
GPU
Sapphire R9 380 4GB Nitro OC
Audio
Integrata
Monitor
Asus VX279
PSU
EVGA 500B
Case
Enermax Torex
OS
Windows 10
Un saluto a tutto il forum,

come si intuisce dal titolo vorrei installare Archlinux su un PC dove c'è già installato windows 10. I due S.O. risiederanno su due hard disk separati, windows 10 è già installato.
Ho installato varie volte Archlinux ma mai su un hard disk separato da windows, per questo mi chiedo: dove installo il bootloader di archlinux? sull'hd dove è installato windows o sull'altro? Su windows 10 il secure boot è disattivato mentre fastboot è attivo, ma se serve lo disattiverò.
Non mi è chiara anche la gestione della partizione riservata UEFI se devo modificarla per far partire entrambi i sistemi o se invece durante l'installazione di archlinux farà tutto da solo.
Ho letto la guida ufficiale e cercato in internet ma non riesco a trovare nulla su un dualboot con doppio HD.

Grazie del tempo che mi dedicherete.
 

tunnel

Utente Èlite
1,613
256
Non trovi nulla perché non c'è nulla da trovare.
Installi linux sul secondo disco e il "grub" sulla partizione efi del primo, il boot avviene sempre selezionando il sistema dal BIOS/EFI.
Il fastboot va disattivato, il secure boot può essere attivo o disattivo dipende dai differenti BIOS.
 
  • Like
Reactions: Icedemon 89

21hopper21

Utente Attivo
328
64
CPU
Intel i7 4790k
Dissipatore
Noctua NH12
Scheda Madre
Asus Maximus Hero VII
HDD
Samsung 850evo 250GB, Samsung 840evo 120GB, WD Green 3TB, WD Green 2TB, WD Blu 1 TB
RAM
G.Skill Ripjaws x 2133MHz
GPU
Zotac GTX 1080 Amp Extreme
Monitor
AOC C3583FQ
PSU
Evga Supernova G2 850 watt
Case
Thermaltake View 31 TG RGB
Periferiche
Tastiera Ozone Strike Battle, Mouse Ozone Argon, Headset Logitech G231, Webcam Logitech C920
OS
Debian e Windows 10
Salve a tutti. Scusate se mi intrometto, ma visto che sono quasi nella stessa situazione dell'utente icedemon 89 ho preferito accodarmi al suo topic piuttosto che aprirne un altro. Dunque ho un PC con windows 10 installato in modalità NON Uefi in un SSD. Ho aggiunto un altro SSD sul quale ho installato debian sempre in non Uefi. Al momento di scegliere dove installare GRUB ho scelto l SSD dove c'è debian, ma al momento del riavvio non mi vede w10, nemmeno dopo un update-grub. Dove sto sbagliando?
 

IkaGen

Utente Attivo
110
15
CPU
i5-4670k
Scheda Madre
asrock z87 extreme4
HDD
1TB WDBlue + 250GB Maxtor
RAM
HyperX Fury 8GB 1600Mhz
GPU
R9 270X 2GB Sapphire
Monitor
AOC E2460S
PSU
XFX TS 550W
Case
Zalman z9 u3
OS
Windows 8.1 PRO + Xubuntu
Allora, il GRUB dovresti installarlo sull'ssd dove hai windows e non debian. Ti consiglio poi di verificare da bios a quale disco dai la priorità.
 
  • Like
Reactions: 21hopper21

21hopper21

Utente Attivo
328
64
CPU
Intel i7 4790k
Dissipatore
Noctua NH12
Scheda Madre
Asus Maximus Hero VII
HDD
Samsung 850evo 250GB, Samsung 840evo 120GB, WD Green 3TB, WD Green 2TB, WD Blu 1 TB
RAM
G.Skill Ripjaws x 2133MHz
GPU
Zotac GTX 1080 Amp Extreme
Monitor
AOC C3583FQ
PSU
Evga Supernova G2 850 watt
Case
Thermaltake View 31 TG RGB
Periferiche
Tastiera Ozone Strike Battle, Mouse Ozone Argon, Headset Logitech G231, Webcam Logitech C920
OS
Debian e Windows 10
Allora, il GRUB dovresti installarlo sull'ssd dove hai windows e non debian. Ti consiglio poi di verificare da bios a quale disco dai la priorità.
Grazie per la tua risposta. Dunque ricapitolando, GRUB sul MBR di windows, boot dal SSD di windows. Praticamente come in una installazione su singolo disco o sbaglio?
 

rebellion

Utente Èlite
1,567
490
CPU
intel i5 9500
Dissipatore
cooler master hyper 212 evo
Scheda Madre
asrock b360 pro4
HDD
samsung 850evo 250GB+samsung 840pro 128GB+seagate barracuda 2TB+seagate barracuda 2TB
RAM
corsair vengeance lpx ddr4 2133MHz 2x4GB CL13
GPU
integrata intel hd graphics 630
Audio
integrata
Monitor
samsung ue55mu6500u
PSU
xfx pro series 550w core edition
Case
mastercooler
OS
archlinux x64 + gnome3.34.1 && windows10 pro x64
Io ho messo grub sul disco Linux, così ciascun disco parte se stacchi l'altro (m'è successo di aver problemi e di staccare un disco partendo dell'altro).
Ovviamente se fai così devi mettere il disco Linux come primo al boot da BIOS eppoi fare la procedura di aggiornamento grub.
 

EmanueleC

Utente Èlite
5,444
1,739
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
Salve a tutti. Scusate se mi intrometto, ma visto che sono quasi nella stessa situazione dell'utente icedemon 89 ho preferito accodarmi al suo topic piuttosto che aprirne un altro. Dunque ho un PC con windows 10 installato in modalità NON Uefi in un SSD. Ho aggiunto un altro SSD sul quale ho installato debian sempre in non Uefi. Al momento di scegliere dove installare GRUB ho scelto l SSD dove c'è debian, ma al momento del riavvio non mi vede w10, nemmeno dopo un update-grub. Dove sto sbagliando?

Hai disattivato il fastboot di Windows? Devi installare Debian in UEFI, se hai Windows in UEFI.
 

21hopper21

Utente Attivo
328
64
CPU
Intel i7 4790k
Dissipatore
Noctua NH12
Scheda Madre
Asus Maximus Hero VII
HDD
Samsung 850evo 250GB, Samsung 840evo 120GB, WD Green 3TB, WD Green 2TB, WD Blu 1 TB
RAM
G.Skill Ripjaws x 2133MHz
GPU
Zotac GTX 1080 Amp Extreme
Monitor
AOC C3583FQ
PSU
Evga Supernova G2 850 watt
Case
Thermaltake View 31 TG RGB
Periferiche
Tastiera Ozone Strike Battle, Mouse Ozone Argon, Headset Logitech G231, Webcam Logitech C920
OS
Debian e Windows 10
Hai disattivato il fastboot di Windows? Devi installare Debian in UEFI, se hai Windows in UEFI.
Windows non è installato in UEFI. Avevo provato comunque a disabilitare fastboot ma nada
 

21hopper21

Utente Attivo
328
64
CPU
Intel i7 4790k
Dissipatore
Noctua NH12
Scheda Madre
Asus Maximus Hero VII
HDD
Samsung 850evo 250GB, Samsung 840evo 120GB, WD Green 3TB, WD Green 2TB, WD Blu 1 TB
RAM
G.Skill Ripjaws x 2133MHz
GPU
Zotac GTX 1080 Amp Extreme
Monitor
AOC C3583FQ
PSU
Evga Supernova G2 850 watt
Case
Thermaltake View 31 TG RGB
Periferiche
Tastiera Ozone Strike Battle, Mouse Ozone Argon, Headset Logitech G231, Webcam Logitech C920
OS
Debian e Windows 10
Allora, il GRUB dovresti installarlo sull'ssd dove hai windows e non debian. Ti consiglio poi di verificare da bios a quale disco dai la priorità.
Dunque ho seguito il tuo suggerimento, ma purtroppo ancora non va. Ho installato debian su SSD /dev/sda e windows 10 su /dev/sdb. Giunto all'installazione di GRUB o scelto manualmente /dev/sdb, cioè dove c'è l'MBR di windows, ma quando ho riavviato è partito windows, di GRUB neanche l'ombra. Dal BIOS il boot è impostato sul disco windows. Francamente non saprei che altro fare...
 

21hopper21

Utente Attivo
328
64
CPU
Intel i7 4790k
Dissipatore
Noctua NH12
Scheda Madre
Asus Maximus Hero VII
HDD
Samsung 850evo 250GB, Samsung 840evo 120GB, WD Green 3TB, WD Green 2TB, WD Blu 1 TB
RAM
G.Skill Ripjaws x 2133MHz
GPU
Zotac GTX 1080 Amp Extreme
Monitor
AOC C3583FQ
PSU
Evga Supernova G2 850 watt
Case
Thermaltake View 31 TG RGB
Periferiche
Tastiera Ozone Strike Battle, Mouse Ozone Argon, Headset Logitech G231, Webcam Logitech C920
OS
Debian e Windows 10
Alla fine sono riuscito a risolvere. Non ho ben capito cosa sia successo. Sembra quasi che il BIOS si fosse impallato, nel senso che nonostante il boot era settato nell'ssd di windows lo faceva invece da quello dove sta debian. Ho staccato la spina, atteso un paio di minuti e dopo aver riacceso tutto funziona. Meglio così...grazie comunque a chi mi aiutato.
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 37 22.8%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 103 63.6%
  • Square Enix

    Voti: 14 8.6%
  • Capcom

    Voti: 7 4.3%
  • Nintendo

    Voti: 21 13.0%
  • Altro (Specificare)

    Voti: 15 9.3%

Discussioni Simili