RISOLTO Java + ide

Stato
Discussione chiusa ad ulteriori risposte.

petrusic

Nuovo Utente
110
6
Hardware Utente
CPU
AMD Athlon - X86_64
Scheda Madre
Acer RS780HVF
Hard Disk
SSD PLUS da 240GB (ospita 3 S.O Linux), WDC WD10EFRX-68F da 1000GB (ospita solo archivi dati)
RAM
n.2 DDR" per 2GB
Sistema Operativo
fedora 28 Mate, Ubuntu Mate, Linux Mint 19
Sono sul punto di abbandonare il mio progetto di programmazione in Java, però prima di decidermi, vorrei provare ancora ad installare anche NetBeans e Ecilpse, per verificare la "lentezzza" di esecuszione di un semplice programma anche coni suddeti IDE.
Il primo che che ho installato dei 2 suddetti ambienti è NetBeans, ma, durante la procedura di caricamento ottengo il messaggio di Errore allegato.
NetBeans_ERRO_mini.png

Per l'installazione di NetBeans. ho seguito questa guida.
 

pabloski

Utente Èlite
1,903
341
Hardware Utente
Sono sul punto di abbandonare il mio progetto di programmazione in Java, però prima di decidermi, vorrei provare ancora ad installare anche NetBeans e Ecilpse, per verificare la "lentezzza" di esecuszione di un semplice programma anche coni suddeti IDE.
Ma perchè fissarsi? Tempo fa non avevi installato Visual Studio Code e funzionava tutto bene?

Gli IDE sono dei mattoni. Purtroppo è così. O si usa un computer super carrozzata o nada. Per questo un mucchio di gente preferisce usare VS Code, Sublime Text, Vim, Emacs.
 

fabio93

Utente Attivo
372
98
Hardware Utente
CPU
AMD Ryzen 5 2400G
Dissipatore
Arctic Alpine64 Plus
Scheda Madre
Gigabyte GA-AX370-Gaming 3
Hard Disk
Crucial MX500 250 GB, Crucial BX500 240 GB
RAM
G.Skill F4-3200C14D-16GFX FlareX 16 GB
Monitor
HP 2010i
Alimentatore
Corsair TX550M
Case
Sharkoon M25-W
Sistema Operativo
Windows 10 Pro, Ubuntu 19.04
Gli IDE sono dei mattoni. Purtroppo è così. O si usa un computer super carrozzata o nada.
Nì. All'università abbiamo dei vecchi computer con processori core 2 quad e i3 Sandy Bridge eppure eclipse gira, non ottimamente ma gira. Io stesso ho usato intensamente per diversi mesi un Thinkpad T61 con core 2 duo da 1,8 GHz e 4 GB di ram eppure riuscivo a usare Eclipse e Docker Toolbox (pesantuccio) senza grossi problemi. Chiaramente le prestazioni non erano eccelse ma nulla che rendesse impossibile lavoraci, almeno per le mie limitate esigenze.
 

pabloski

Utente Èlite
1,903
341
Hardware Utente
Nì. All'università abbiamo dei vecchi computer con processori core 2 quad e i3 Sandy Bridge eppure eclipse gira, non ottimamente ma gira. Io stesso ho usato intensamente per diversi mesi un Thinkpad T61 con core 2 duo da 1,8 GHz e 4 GB di ram eppure riuscivo a usare Eclipse e Docker Toolbox (pesantuccio) senza grossi problemi. Chiaramente le prestazioni non erano eccelse ma nulla che rendesse impossibile lavoraci, almeno per le mie limitate esigenze.
Ma a lui dà fastidio proprio il fatto che le prestazioni non siano eccelse. Cioè vuole premere Run e vedere istantaneamente l'output del programma. IntelliJ, poi, fa dei giri incredibili, avviando un server di compilazione e tutt'altra roba che ha un senso nel mondo enterprise, ma non ce l'ha nel mondo amatoriale.
 

fabio93

Utente Attivo
372
98
Hardware Utente
CPU
AMD Ryzen 5 2400G
Dissipatore
Arctic Alpine64 Plus
Scheda Madre
Gigabyte GA-AX370-Gaming 3
Hard Disk
Crucial MX500 250 GB, Crucial BX500 240 GB
RAM
G.Skill F4-3200C14D-16GFX FlareX 16 GB
Monitor
HP 2010i
Alimentatore
Corsair TX550M
Case
Sharkoon M25-W
Sistema Operativo
Windows 10 Pro, Ubuntu 19.04
Sul Thinkpad ho lavorato a un progetto di gruppo per l'università in Java 8, che si interfacciava tramite relative API a Google BigQuery e Google Sheets, e ci lavoravo con aperto anche Git bash, Docker Toolbox e diverse schede Chrome (anche più di 10 talvolta). Si trattava di un progetto molto piccolo se paragonato ad applicazioni "vere", ma nemmeno così leggero rispetto ai programmi che si fanno da principianti. L'esecuzione era immediata, il tempo di attesa dipendeva dal fatto che il programma faceva una query sul db di BigQuery. Casomai eclipse era lento ad avviarsi - e lo fa anche su pc più potenti - ma era più che utilizzabile.
 

Moffetta88

Utente Èlite
2,764
892
Hardware Utente
Ma perchè fissarsi? Tempo fa non avevi installato Visual Studio Code e funzionava tutto bene?

Gli IDE sono dei mattoni. Purtroppo è così. O si usa un computer super carrozzata o nada. Per questo un mucchio di gente preferisce usare VS Code, Sublime Text, Vim, Emacs.
uso un notebook del 2008 con cpu T3200 e 4GB DDR2, con eclipse, e non ho problemi.!
Sul Thinkpad ho lavorato a un progetto di gruppo per l'università in Java 8, che si interfacciava tramite relative API a Google BigQuery e Google Sheets, e ci lavoravo con aperto anche Git bash, Docker Toolbox e diverse schede Chrome (anche più di 10 talvolta). Si trattava di un progetto molto piccolo se paragonato ad applicazioni "vere", ma nemmeno così leggero rispetto ai programmi che si fanno da principianti. L'esecuzione era immediata, il tempo di attesa dipendeva dal fatto che il programma faceva una query sul db di BigQuery. Casomai eclipse era lento ad avviarsi - e lo fa anche su pc più potenti - ma era più che utilizzabile.
beh un progetto abbastanza esoso direi ^^
Se provi con eclipse posso seguirti per filo e per segno, dall'installazione alla configurazione
 

petrusic

Nuovo Utente
110
6
Hardware Utente
CPU
AMD Athlon - X86_64
Scheda Madre
Acer RS780HVF
Hard Disk
SSD PLUS da 240GB (ospita 3 S.O Linux), WDC WD10EFRX-68F da 1000GB (ospita solo archivi dati)
RAM
n.2 DDR" per 2GB
Sistema Operativo
fedora 28 Mate, Ubuntu Mate, Linux Mint 19
Se provi con eclipse posso seguirti per filo e per segno, dall'installazione alla configurazione
Temo di non riuscire ad installare Eclipse. Oggi ho provato ad installarlo seguendo qui, ma senza fortuna:
Codice:
sudo apt update
sudo apt upgrade
sudo apt install eclipse
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Il pacchetto eclipse non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "eclipse" non ha candidati da installare
 

petrusic

Nuovo Utente
110
6
Hardware Utente
CPU
AMD Athlon - X86_64
Scheda Madre
Acer RS780HVF
Hard Disk
SSD PLUS da 240GB (ospita 3 S.O Linux), WDC WD10EFRX-68F da 1000GB (ospita solo archivi dati)
RAM
n.2 DDR" per 2GB
Sistema Operativo
fedora 28 Mate, Ubuntu Mate, Linux Mint 19
Ho fatto come mi hai suggerito, ma non riesco a installarvi il language.pack.it
In internet si trovano tutte linee pseudo-guida datate, non corrispondenti con quella installata.
Post automaticamente unito:

come ti avevo già scritto nell'altro topic, eclipse non va assolutamente installato dai repo!
Scaricalo, estrailo e fallo partire
ho installato anche questo, ma in una directory diversa, l'ho mandato in esecuzione ed anche questo parla inglese.
Che barba, che noia, che barba, che noia! (per dirlo alla Sandra Mondaini) :)
 
Ultima modifica:

fabio93

Utente Attivo
372
98
Hardware Utente
CPU
AMD Ryzen 5 2400G
Dissipatore
Arctic Alpine64 Plus
Scheda Madre
Gigabyte GA-AX370-Gaming 3
Hard Disk
Crucial MX500 250 GB, Crucial BX500 240 GB
RAM
G.Skill F4-3200C14D-16GFX FlareX 16 GB
Monitor
HP 2010i
Alimentatore
Corsair TX550M
Case
Sharkoon M25-W
Sistema Operativo
Windows 10 Pro, Ubuntu 19.04
Vedi qui per i language pack (sono per la versione 2018-12): https://www.eclipse.org/babel/downloads.php
Comunque per programmare un minimo di dimestichezza con l'inglese ci vuole, non foss'altro per capire il significato delle keyword e soprattutto perché molto materiale didattico, software ecc. sono in inglese.
 

Moffetta88

Utente Èlite
2,764
892
Hardware Utente
Ma lascia perdere i language pack!
Che di comandi sulla ide ne userai 4 se va bene, e saranno :
run ( per compilare e lanciare il codice )
create new project ( per creare un progetto )
new class ( per creare una classe )
new package ( per creare un pacchetto nel progetto )
Questi sono i comandi BASE.
Poi se hai bisogno di qualche tips per "accelerare" il lavoro son ben contento di dirti cosa pigiare
 

petrusic

Nuovo Utente
110
6
Hardware Utente
CPU
AMD Athlon - X86_64
Scheda Madre
Acer RS780HVF
Hard Disk
SSD PLUS da 240GB (ospita 3 S.O Linux), WDC WD10EFRX-68F da 1000GB (ospita solo archivi dati)
RAM
n.2 DDR" per 2GB
Sistema Operativo
fedora 28 Mate, Ubuntu Mate, Linux Mint 19
Vedi qui per i language pack (sono per la versione 2018-12): https://www.eclipse.org/babel/downloads.php
Comunque per programmare un minimo di dimestichezza con l'inglese ci vuole, non foss'altro per capire il significato delle keyword e soprattutto perché molto materiale didattico, software ecc. sono in inglese.
Quello che dici è corretto e lo so da una vita. I primi volumi di programmazione in inglese li ho dovuti scorrere da professionista nel lontano 1975, ma l'inglese non l'ho mai mandato giù e, quando lo devo, per necessità di cose, affrontare, lo faccio sempre col massimo senso di repulsione.
Perciò, se posso, cerco di evitarlo. Purtroppo ciò depone a mio sfavore, perchè non ho mai imparato a leggere i manuali tecnici, ma ormai, ... , il più è fatto.
Quel package che mi hai indicato sopra, credo di averlo visto già ieri, ma non sono riuscito ad installarlo, perchè ho trovato nel percorso una triplice alternativa, "for phton, for oxygen, for neon". Ne volevo capire la differenza e quale fosse compatibile con la versione di eclipse installata, ma non vi sono riuscito. Ho allora tentato di installare il pachetto "for Oxygen", ma mi sono impantanato e l'avvio di eclipse si avviava senza mai completarsi.
Allora l'ho dovuto abbandonare.
Ora riprovo, ma con molta scetticità.
 
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando