PROBLEMA "directory" non si aprono i file nelle cartelle

Stato
Discussione chiusa ad ulteriori risposte.

Kurosakiichi92

Nuovo Utente
73
3
Buonasera, sono sempre... ne ho sempre una XD

A un pc che ho messo win 10 ho fatto altri seguenti passaggi:
- ripristino backup dati win 7 da pannello di controllo "ripristina backup"
- pulizia con Ccleaner
- deframmentazione disco con Auslogics Disk Defrag
Descrizione problema:
Ora il backup era di una grande cartella che contiene tante altre sotto e sotto cartelle e in alcune di queste, non tutte, i file odt che stanno dentro non si aprono. Dà un errore segnalando un problema di Directory e se provo a copiare il file odt sul desktop chiede il permesso di amministratore segnalando il file come non sicuro.
Però se prendo la sottocartella d'appartenenza e la copio sul desktop, l'azione si esegue e posso aprire i file all'interno senza problemi. Stessa cosa se copio direttamente il file in un'altra località del PC. Al contrario se provo a copiare file esterni dentro la sottocartella che dà rogne, quei file non vengono copiati.
Aiuto...
Che problema è? La cartella è come se non esistesse più? il directory sarebbe la fonte di reperibilità? Come cavolo l'avrei cancellata? E' attribuibile a qualcuno dei passaggi che ho fatto tra pulizia e deframmentazione?
COME RISOLVO?
Nota: una ricopiatura manuale per ricreare le directory è snervante perché (come se non ci mancava anche questa) molti file hanno nomi lunghissimi (il motivo è lungo da spiegare) e per via di questo fattore non posso misteriosamente copiarli in altre cartelle perché win dice che i file andrebbero rinominati oppure faccio "ignora" e perdo però quei file nella copiatura.

Il problema vero è che il danno l'ho fatto sul pc della mia ragazza, se non risolvo so c**** XD.

Datemi una mano come avete sempre fatto alla grande :).
Grazie ragazzi!
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
  • Mi piace
Reazioni: Kurosakiichi92

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
  • Mi piace
Reazioni: Kurosakiichi92

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
con quel sw ti ci puoi divertire se prendi mano fai anche backup dei dati incrementale con la differenza dei dati
 

Kurosakiichi92

Nuovo Utente
73
3
con quel sw ti ci puoi divertire se prendi mano fai anche backup dei dati incrementale con la differenza dei dati
si infatti ho visto! utilissimo.
Però c'è un mistero che non capisco... 6788 file e 831 cartelle dell'originale a cui mancava la directory. La nuova copia ha 6694 e 810 cartelle. WTF?
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
si infatti ho visto! utilissimo.
Però c'è un mistero che non capisco... 6788 file e 831 cartelle dell'originale a cui mancava la directory. La nuova copia ha 6694 e 810 cartelle. WTF?
guarda il log sicuramente ci sono file che ha saltato perchè ci sono percorsi troppo lunghi oltre i 256 caratteri
 

Kurosakiichi92

Nuovo Utente
73
3
guarda il log sicuramente ci sono file che ha saltato perchè ci sono percorsi troppo lunghi oltre i 256 caratteri
Ora qui ho chiuso il programma e non posso più vedere la cronologia dei file e quelli che non ha copiato. Mi tocca rifare la procedura domani col calma e vedere cosa manca. Userò "comparazione: contenuto del file".
Cmq sta cosa mi fa strippare..
Pure quando feci il backup di win 7 della stessa cartella, e lo ripristinai su win 10 risultavano meno file su "proprietà".... Significa che ho perso dei file importanti ma come è possibile che un backup non copi tutto?
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
Ora qui ho chiuso il programma e non posso più vedere la cronologia dei file e quelli che non ha copiato. Mi tocca rifare la procedura domani col calma e vedere cosa manca. Userò "comparazione: contenuto del file".
Cmq sta cosa mi fa strippare..
Pure quando feci il backup di win 7 della stessa cartella, e lo ripristinai su win 10 risultavano meno file su "proprietà".... Significa che ho perso dei file importanti ma come è possibile che un backup non copi tutto?
con cosa hai fatto backup? se intendi copia incolla non è un backup è solo uno spostamento di file... se usavi tipo 7zip e facevi anche una lieve compressione riuscivi a bypassare il problema ... prima di mettere le mani e far danno passa di qua e chiedi XD magari ti verrà data qualche dritta
 

Kurosakiichi92

Nuovo Utente
73
3
con cosa hai fatto backup? se intendi copia incolla non è un backup è solo uno spostamento di file... se usavi tipo 7zip e facevi anche una lieve compressione riuscivi a bypassare il problema ... prima di mettere le mani e far danno passa di qua e chiedi XD magari ti verrà data qualche dritta
il backup l'ho fatto da pannello di controllo, ho usato la procedura base di windows e sono andato convinto. C**** per ora pare non abbia mancato di copiare cose importanti da quel backup di due settimane fa... per ora. E cmq nel dubbio avevo fatto anche un copia incolla semplice su hd esterno e appunto non copiò tutto. Tuttavia la differenza è risultata anche sul file fatto in automatico da win. Poi io perché so pignolo e vado a vede ste cose prima e dopo... ma chi se l'aspettava.

Cmq ecco, con file 7zip posso fare "comprimi" e quindi copiare su un hd esterno tutti i file, anche i dati con troppi caratteri e quindi poi estrarre anche quelli senza perdere nulla?


--------------------------------------------------------------------------------------

EDIT:
La comparazione tra l'originale cartella e la sua copia specchio è finita e restituisce 0 file di 8021. Ho fatto la contro verifica con altre due cartelle piccole e totalmente diverse e restituisce risultati. Quindi funziona, ma non mi torna: lui dice 0 file quindi cartelle identiche quando se confronto le voci "proprietà" la differenza c'è. Allora mi chiedo o perso o non ho perso dei file con l'azione "specchio"?
EDIT:
verificato cmq che la nuova cartella ottenuta con funzione "specchio" non ha dato risultati. il file che tento di aprire dà msg di avviso "percorso specificato non esiste. verificare il percorso e riprovare". E rimane una cartella fantasma dove all'interno di quelle stesse sottocartelle in cui nulla si apre non posso manco copiarvi o salvarvi dentro file.
Se cerco una di queste sotto cartelle non funzionanti nella barra di ricerca: le cartelle hanno l'icona di foglio bianco tipico di percorsi file inesistenti. Senza mettermi a ricopiare manualmente tutte queste cartelle... Cosa altro posso tentare? un altra funzione oltre specchio? sennò?

poi non capisco una cosa: fatto manualmente la copia ha successo, gli si crea un percorso... posso aprirla... usando il programma esterno con funzione specchio invece non ha funzionato.

Basta, ora spengo, sto scoppiando :V.

grazie per l'aiuto cmq!
 
Ultima modifica:

Kurosakiichi92

Nuovo Utente
73
3
in sintesi gli lo screen del problema che sto riscontrando:

1. Il percorso non è valido, cioè la cartella, che contiene file e sotto cartelle danneggiati, per il sistema non esiste.

2. Se faccio la copiatura del file dalla cartella con tasto destro "copia" e destro su desktop "incolla" dà msg di sicurezza. TUTTAVIA se faccio la copiatura con ctrl-c e poi su desktop ctrl-v non compare msg di avviso. Cmq copiando il file su desktop diventa apribile ed è tutto ok. Ma fare manualmente sta cosa per ogni file è un suicidio.
 

Allegati

  • directory.png
    directory.png
    9.9 KB · Visualizzazioni: 167
  • file danneggiati.png
    file danneggiati.png
    17.6 KB · Visualizzazioni: 171

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,202
6,220
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
in sintesi gli lo screen del problema che sto riscontrando:

1. Il percorso non è valido, cioè la cartella, che contiene file e sotto cartelle danneggiati, per il sistema non esiste.

2. Se faccio la copiatura del file dalla cartella con tasto destro "copia" e destro su desktop "incolla" dà msg di sicurezza.
effettivamente è come credevo nomi troppo lunghi...

proviamo così

Per attivare NTFS Long Paths in Windows 10 Anniversary Update (Build 14352 e successive):

  1. Digitate nel box di ricerca di Cortana Editor Criteri di gruppo locali (o in alternativa digitate gpedit.msc).
  2. Recatevi in Configurazione computer > Modelli amministrativi > Sistema > File system
dopo di che si apre una finestra così
upload_2017-10-27_10-43-41.png


upload_2017-10-27_10-43-31.png
chiudi e dai da prompt dei comandi questo comando

gpupdate /force e riprova a copiare i dati
 

Kurosakiichi92

Nuovo Utente
73
3
effettivamente è come credevo nomi troppo lunghi...

proviamo così

Per attivare NTFS Long Paths in Windows 10 Anniversary Update (Build 14352 e successive):

  1. Digitate nel box di ricerca di Cortana Editor Criteri di gruppo locali (o in alternativa digitate gpedit.msc).
  2. Recatevi in Configurazione computer > Modelli amministrativi > Sistema > File system
dopo di che si apre una finestra così
chiudi e dai da prompt dei comandi questo comando

gpupdate /force e riprova a copiare i dati

Sta soluzione mi ha rinsavito. Spero funzioni! Edito questo post e ti dico!
 
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando