PROBLEMA WinXP: Hard Disk "bloccato" in PIO mode

ZioLollo

Utente Attivo
232
9
Cambio l'HD ad un portatile Asus A600 series (A6VA), perche' il precedente si era guastato.
Installo WinXP, e noto subito un appesantimento del sistema, soltanto per caricare WinXp ci mette un saccco.....provo a trasferire un file e con mio stupore la velocita' e' di appena 1,5MB/Sec.

nella gestione periferiche - Canale IDE primario - Impostazioni avanzate:
Modalita' di trasferimento: DMA se disponibile
Modalita' di trasferimento corrente: Modalita' PIO (non posso cambiare impostazioni)
Da BIOS l'HD viene visto come un UDMA5


Gli HD usb funzionano normalmente
Ubuntu funziona normalmente (il problema e' solo su XP)


Installo un'altra versione di WinXP SP3 originale (la prima era una lite), stesso risultato, HD int lentissimo!


Ho provato ad aggiornare i driver intel SATA senza risultati




Consigli????
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
che trasfer rate ha quel disco? con ubuntu ha lo stesso trafer rare?
 

ZioLollo

Utente Attivo
232
9
Non so che transfer rate abbia il disco, ma non 1,5 mb/s di sicuro.
Solo Win ha questo problema
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
hmmm se è un 4200rmp credo sia normale che sia così lento... conta che c'è anche il file di paging sopra... quindi non è un fulmine di guerra..
 

ZioLollo

Utente Attivo
232
9
Scusa, forse non hai letto bene, l'HD sotto WinXP va a 1,5MB/sec, anche l'HD piu' lento di questa terra non va cosi' piano :p

Ho provato ora una live di lubuntu, trasferisce file sullo stesso HD a circa 40MB/sec
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
si ma lubuntu non ha il file di paging attivo e scusa se è poco già quello influisce moltissimo il pio mode se non sbaglio è una proprietà del disco e non può essere cambiata.
 

ZioLollo

Utente Attivo
232
9
Purtroppo non sono riuscito a risolvere il problema in alcun modo :/

Ora uso il portatile con lubuntu, Windows e' inutilizzabile
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
prova così:
Attivare/Disattivare il DMA su tutte le periferiche IDE
Windows 2000/XP/2003:
  • Pannello di controllo ---> Sistema ---> Hardware ---> Gestione periferiche ---> Controller IDE ATA/ATAPI ---> Proprietà Canale Primario/Secondario IDE ---> Impostazioni avanzate ---> Madalità di trasferimento... e selezionare "Solo Pio(per disattivarlo)" o "DMA se disponibile(per attivarlo)".
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,322
2,252
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
si ma lubuntu non ha il file di paging attivo e scusa se è poco già quello influisce moltissimo il pio mode se non sbaglio è una proprietà del disco e non può essere cambiata.

lo ha, lo ha , ma lo utilizza in modo diverso, funge semplicemente da "troppo pieno" per la ram .

se riempisse almeno il 61% della ram, inizierebbe a vadere i file in paging ( o meglio swap..)
 

ZioLollo

Utente Attivo
232
9
Il problema non e' la configurazione del sistema, il file paging o altro..... il problema e' che windows usa l'HD in PIO mode e non trovo il modo per imporgli di abilitare l'UDMA
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
lo ha, lo ha , ma lo utilizza in modo diverso, funge semplicemente da "troppo pieno" per la ram .

se riempisse almeno il 61% della ram, inizierebbe a vadere i file in paging ( o meglio swap..)
ok ma diciamo che se era in live il carico sarebbe tutto sulla ram e non sul disco
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 37 23.1%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 101 63.1%
  • Square Enix

    Voti: 14 8.8%
  • Capcom

    Voti: 7 4.4%
  • Nintendo

    Voti: 21 13.1%
  • Altro (Specificare)

    Voti: 15 9.4%

Discussioni Simili