sendamail non va...

corona33cl

Utente Attivo
190
0
Ciao a tutti usi sendmail con asterisk... sun una macchina ho notato che le mail non uscivano più dal server e mi sono messo a vedere cosa accadeva sul log di sendamail....ho notato che il log era pienissimo di messaggio così fatti ....
Jun 11 16:52:34 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:52:39 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:52:49 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:52:54 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:53:06 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:53:08 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:53:19 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:53:32 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:53:33 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:53:38 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:53:49 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:53:54 host114-255-static sm-mta[4673]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:54:04 host114-255-static sm-mta[4673]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:55:35 host114-255-static sm-mta[4143]: starting daemon (8.13.5.20060308): SMTP+queueing@00:10:00
Jun 11 16:55:35 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:55:35 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:55:50 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:55:50 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:56:06 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:56:06 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:56:20 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:56:20 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:56:34 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:56:34 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:56:49 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:56:49 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:57:04 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:57:04 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:57:19 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:57:19 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:57:34 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:57:34 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:57:50 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:57:50 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
Jun 11 16:58:05 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 13
Jun 11 16:58:05 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 13
Jun 11 16:58:19 host114-255-static sm-mta[4143]: rejecting connections on daemon MTA-v4: load average: 12
Jun 11 16:58:20 host114-255-static sm-mta[4143]: rejecting connections on daemon MSP-v4: load average: 12
.....


qualcuno sa darmi una mano?
Sapete aiutarmi?
grazie mille
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
quei messaggi ti dicono solo che la macchina è talmente intasata di processi attivi da non accettare le connessioni. dovresti vedere cosa porta la macchina a quel livello di saturazione.
 

corona33cl

Utente Attivo
190
0
bene...anzi...male....
airex... grazie mille...sempre pronto!
Come posso fare a vedere tutti i processi attivi e cosa posso eliminare... da dove comincio?
Grazie mille
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
loggati sulla macchina intasata (con pazienza) e usa:
- top
- ps eax
- uptime
- free

con questi 4 comandi dovresti ottenere una buona dose di informazioni per vedere cosa sta girando e quanta memoria disponibile c'è ;)
 

corona33cl

Utente Attivo
190
0
grazie mille air... saresti così gentile da dirmi cosa restituisce uptime? nel senso ...quel load average (13.71 13.39 13.22) che mi esce ... per cosa sta?
Deve essere più basso?

In più ho notato che la memoria non viene utilizzata tutta ...mi avanzano sempre un 200Mb liberi...eppure sendmail viene rifiutato... non può dipendere dalla CPU che non ce la fa? Stiamo parlando di una 600Mhz
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
tratto da "man uptime"

uptime gives a one line display of the following information. The current time, how long the system has been running, how many users are currently logged on, and the system load averages for the past 1, 5, and 15 minutes.

in pratica:
- il primo numero ti dice quanti processi in stato "running" ci sono nel corso dell'ultimo minuto
- il primo numero ti dice quanti processi in stato "running" ci sono nel corso degli ultimi 5 minuti
- il primo numero ti dice quanti processi in stato "running" ci sono nel corso degli ultimi 15 minuti

più è basso il valore meno carica è la macchina.
 

corona33cl

Utente Attivo
190
0
Scusa la mia ignoranza ...ma una macchina con 600 Mhz di processore non risce a tenere più di 13-16 processi? Non credo sia una cosa possibile...o sbaglio?
13 processi non sono niente!..mmm
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
13 processi in stato di esecuzione contemporanea NON sono proprio pochi.
mi sa che interpreti male lo stato "Running": qui si intende una serie di processi che è ATTIVAMENTE impegnata a succhiare risorse dalla tua CPU non l'insieme di processi GENERICAMENTE in esecuzione

esempio: la mia macchina ora ha 86 (calcolo spannometrico con "ps ax|wc -l") processi in esecuzione ma solo 1-2 running (con "top" vedi questo dato)
 

corona33cl

Utente Attivo
190
0
caxxo hai perfettamente ragione..il comando uptime su tutte le altre mie macchine da un load average vicino allo 0.... ma allora sta macchina cosa ha che non va?
Chi si ciuccia tutte le risorse?
Devo provare a riavviarla....e vedere cosa succede
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
con "ps ax" vedi in fretta i processi in Running (terza colonna con valore R)
 

corona33cl

Utente Attivo
190
0
tutti i processi in esecuzione sono rasterisk -vvvvvvr è come se lo stesso processo fosse ripetuto tante volte....
ma questo comando manda i processi in running al momento?
POi ci sono una sfilza di processi contrassegnati con S.
Qui sta da capirci bene cosa succede
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
magari i tanti rasterisk non sono processi "veri", molti spero siano dei thread creati dal processo principale (ma questo conta poco, alla fine sono cose in esecuzione).

controlla bene come si comporta tale programma con i parametri che gli sono stati passati e intanto che ci sei controlla i file di configurazione.

Quelli con la "S" non considerarli, sono processi in attesa di qualcosa e non attivi nell'istante corrente
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 37 23.1%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 101 63.1%
  • Square Enix

    Voti: 14 8.8%
  • Capcom

    Voti: 7 4.4%
  • Nintendo

    Voti: 21 13.1%
  • Altro (Specificare)

    Voti: 15 9.4%

Discussioni Simili