DOMANDA Problema di gateway con macchina client Debian?

jeyhw

Utente Attivo
273
8
Ciao,
Questa volta per approfondire i miei studi sul networking ho pensato di utilizzare due macchine virtuali linux giusto per affrontare le problematiche anche da questa prospettiva.
In pratica per simualre una semplice LAN fatta di un server e di un client, ho installato due VM linux (ho scelto debian 10.4 con Interafaccia grafica Xfce) su Vmware workstation. La prima Vm dovrebbe fare da server, la seconda da client; ho quindi creato due network adapter sulla prima macchina: una settata a NAT e l'altra a custom VMnet2 in modo da avere la prima interfaccia cone WAN e la seconda come LAN. Sulla seconda macchina ho quindi settato il network adapter in custom VMnet2. In pratica il client dovrebbe far riferimento alla macchina linux server per il DHCP, DNS, firewall ecc una volta che sono riuscito a configurare il tutto.
Queste le configurazioni nel network editor di VMware workstation 12:

Per la macchina server:

server1.jpg


nat.jpg


Per la macchina linux client:

client.jpg


Non conosco adeguatamente Vmware workstation quindi non sono sicuro che sia la configurazione più adatta al mio scopo
Ho quindi installato alcuni pacchetti utili e anche il dhcp server sulla Vm con il server debian in modo da assegnare alla macchina linux client un IP di rete.
Fino a qui tutto ok. Il problema però è che non riesco dalla macchina client a pingare indirizzi in internet tipo 8.8.8.8. Riesco invece a pingare l'Ip LAN 10.10.10.1 del server e anche il suo IP "WAN" 192.168.40.134.
Dal server risco a fare tutto , non solo a pingare e l'nslookup ma anche a navigare dal Browser. Sto cercando di capire quale sia il problema facendo delle prove.
Forse problemi con il gateway, le route. Non ne sono venuto ancora a capo.
Questo il contenuto del file interfaces in /etc/network/

Codice:
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# Assegnare un IP statico per questo server DHCP attraverso ens37:
auto ens37
iface ens37 inet static
address 10.10.10.1/24
gateway 10.10.10.1
Mi aiutate a risolvere la questione?
Se vi servono ulteriori dettagli e informazioni...
Grazie
 

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento