DOMANDA Uso di .htaccess

devils999

Nuovo Utente
5
0
Salve,
non so se la sezione è giusta, ma ho un problema con un redirect 301 usando .htaccess con wordpress.

avendo dei link scaduti che puntavano ad un forum, devo rimandare questi link alla root

devo spostare da https://www.wolfseo.it/subdir/viewtopic.php?p=63634 a https://www.wolfseo.it/

ho questo .htaccess
Codice:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Redirect 301 /subdir/viewtopic.php?p=63634 https://www.wolfseo.it/

</IfModule>
che non funziona.

poi ho provato questo:
Codice:
RewriteCond %{QUERY_STRING}  ^p=63634$ [NC]
RewriteRule ^subdir/viewtopic\.php$ https://www.wolfseo.it/? [R=301,NE,NC,L]
e non va ugualmente
 
Ultima modifica da un moderatore:

Krona

Nuovo Utente
49
22
forse

Redirect 301 https://www.wolfseo.it/subdir/viewtopic.php?p=63634 https://www.wolfseo.it/
 

devils999

Nuovo Utente
5
0
no non dà risultati, come se non facesse nulla e rimane il primo URL
poi avevo capito che il primo parametro era senza radice del dominio
 

Krona

Nuovo Utente
49
22
Ok, ho controllato, la sintassi giusta è proprio
redirect 301 /subdir/viewtopic.php?p=63634 https://www.wolfseo.it/

magari prova a spostare la riga in alto o in basso nel htaccess, potresti avere altre regole che impediscono\sovrascrivono\bloccano l'esecuzione.
 

devils999

Nuovo Utente
5
0
in quel caso poi devo anche avere il reindirizzamento https, che credo funzioni. si quello del reindizzamento https funziona puntando a www.wolfseo.it

però il problema forse erano i parametri in GET
 
Ultima modifica:

Entra

oppure Accedi utilizzando