[RISOLTO] impossibile installare W10 su SSD M.2 allocato per errore, come MBR

palmer23

Nuovo Utente
19
1
Ciao,
da due giorni sono bloccato dietro all'installazione di Windows10 su di un SSD M.2.
Di base ce l'ho installato su di un altro SSD, normale, non M.2.
Che sia questo il problema? cioè il Sistema vede un disco avviabile di sistema, e poi un altro (l'M.2) che sto cercando di creare avviabile e di sistema anche quello.

Ecco cosa mi è successo.
Una volta inserito l'M2, in Windows lo vedevo da "gestione dischi" come "da allocare", così mi compariva il messaggio automatico che mi proponeva di formattarlo in modalità MBR o GPT (tale messaggio ora non compare più; anche se ho già provato a disabilitare o a disinstallare il disco). Se non erro, avrei dovuto scegliere GPT per renderlo poi "avviabile" per il W.

Purtroppo (se si è trattato di un errore) sceglievo MBR, così una volta avviato il W da una chiavetta USB che avevo reso "avviabile" in precedenza (e che avevo verificato funzionante proprio installando il W sul precedente SSD), ho tentato di installarlo sul nuovo M2 che effettivamente vedevo tra le possibili scelte di disco, ma mi compariva l'errore di impossibilità in quanto formattato in modalità MBR.
Così ho cercato in Rete e ho trovato la procedura per convertirlo in GPT tramite prompt dei comandi (DOS) in W.

L'ho fatto ma una volta avviata la procedura di installazione del W, e scollegato l'attuale disco C (SSD normale, sul quale era/è installato già il W10), giunto al riavvio (dopo le fasi di preparazione, copia, installazione vera e propria) mi ritrovo alla prima schermata dell'installazione; cioè il PC continua a leggere la USB riavviabile.

Così ho provato anche a toglierla poco prima del riavvio del sistema, ma il PC si avvia entrando nella schermata del BIOS!
Insomma sono incastrato in questo ciclo e non riesco a risolvere.

Attualmente, vedendo il disco M2 da dentro "gestione dischi" del W, trovo le due partizioni tipiche di un disco di avvio come è attualmente C ("ripristino" da 499Mb e "partizione di sistema EFI" da 100Mb).

Mi viene il dubbio che la lettera C sia già occupata dall'SSD normale, mentre questo disco M2 ha la lettera J; ma mi pare una stupidaggine.

Resto in attesa di un vostro gentile aiuto.
Andrea
 

giulore

Utente Attivo
741
133
CPU
i5-6600k
Dissipatore
H75i
Scheda Madre
Asrock Z170 Pro Gaming I7
Hard Disk
SSD Crucial M550
RAM
16GB ddr4-3000
Scheda Video
Intel HD530
Scheda Audio
Intel
Monitor
Philips 23IT
Alimentatore
CoolMaster GX650W
Case
Sharkoon
Periferiche
Ricoh SP277SNwX
Internet
ADSL-HoMobile-Vodafone
Sistema Operativo
Win7- Win10
Probabilmente devi inserire il disco M2 tra quelli di avvio.
Volendo tagliare la testa al toro, puoi reinstallare Windows ma da disco di setup (DVD o USB ) durante il setup quando vedi la finestra dove selezioni il disco (puoi farlo anche prima di questa finestra ) su cui installare apri il prompt con shift+F10 e lancia diskpart da lì selezioni il disco e usa il comando CLEAN , esci e premi aggiorna nella finestra precedente e continua il setup. Qui se il BIOS è in modalità UEFI ti creerà il disco GPT ed avvierà il setup.
Non è necessario manipolare prima il disco.

.
Post automaticamente unito:

Il comando CLEAN ti porta il disco a zero, ti fa ricomparire il messaggio di inizializzazione del disco che hai visto in precedenza.

.
 

palmer23

Nuovo Utente
19
1
Grazie Giulore, però lo avevo già fatto (dove scrivevo di aver trovato la procedura per convertirlo in GPT tramite prompt dei comandi) e non ha risolto.
Inoltre il messaggio di avviso inizializzazione, non è mai più ricomparso.
 

palmer23

Nuovo Utente
19
1
Buon giorno.
Purtroppo non ho ancora risolto questo problema.

Non è che il W vede di essere stato già installato su altro disco (magari leggendolo dalla scheda madre), seppure io lo scollego durante l'installazione?
 

giulore

Utente Attivo
741
133
CPU
i5-6600k
Dissipatore
H75i
Scheda Madre
Asrock Z170 Pro Gaming I7
Hard Disk
SSD Crucial M550
RAM
16GB ddr4-3000
Scheda Video
Intel HD530
Scheda Audio
Intel
Monitor
Philips 23IT
Alimentatore
CoolMaster GX650W
Case
Sharkoon
Periferiche
Ricoh SP277SNwX
Internet
ADSL-HoMobile-Vodafone
Sistema Operativo
Win7- Win10
NO, al massimo prende il product key da UEFI se ne contiene uno.

La conversione non è il CLEAN .

.
 

palmer23

Nuovo Utente
19
1
Sì c'è.

Oltre alla conversione avevo fatto anche il clean, ma non si era comunque sistemato.

Come ne esco secondo te? Qualcosa sbaglio evidentemente.
Non riesco a liberarmi del disco col sistema già installato, e allo stesso tempo non riesco a installarlo sull'M2.

Non capisco, ho iniziato qualche giorno fa installando il W10 dall'8 1 tramite chiavetta USB e inserendo l'SSD normale. Non appena sono andato su "gestione disco" mi è comparsa la scelta tra MBR e GPT, ho scelto GPT e tutto è andato ok.
Poi ho tentato di fare lo stesso inserendo l'M2 e purtroppo sbagliando a dare l'ok su MBR...
 
Ultima modifica:

giulore

Utente Attivo
741
133
CPU
i5-6600k
Dissipatore
H75i
Scheda Madre
Asrock Z170 Pro Gaming I7
Hard Disk
SSD Crucial M550
RAM
16GB ddr4-3000
Scheda Video
Intel HD530
Scheda Audio
Intel
Monitor
Philips 23IT
Alimentatore
CoolMaster GX650W
Case
Sharkoon
Periferiche
Ricoh SP277SNwX
Internet
ADSL-HoMobile-Vodafone
Sistema Operativo
Win7- Win10
Il CLEAN ti porta il disco a zero, cancella tutte le informazioni relative a qualunque configurazione del disco e partizioni tipo quando è nuovo, per cui partendo da zero , dal CLEAN , tieni la condizione :
1) PC
2) HDD M2 ( nuovo )
3) Pendrive USB di installazione

Quindi colleghi HDD(M2) a PC e inserci pendrive USB di installazione, avvii da USB e installi Windows ( ti verrà in GPT se hai la modalità UEFI attiva e Secure Boot Attivo ), sul disco prima di lanciare il setup non devi fare nulla se non scegliere la dimensione della partizione per Windows nella finestra dove vedi unità disco e partizioni presenti .Solo la dimensione della partizione se vuoi dedicare tutto il disco M2 a Windows non modificare la dimensione vai avanti e basta .

Installato Windows, se devi rimetterci anche il precedente HDD, lo colleghi e nel UEFI metti la priorità all'M2 .

Basta, non c'è altro da fare di fondamentale.

Se segui queste operazioni cosa ti succede ?? Falle non supporre o ...già l'ho fatto non ha funzionato .
Non ha funzionato significa poco, scrivi o fotografa quello che vedi sul monitor.



.
 

Kelion

Quid est veritas?
Utente Èlite
23,149
7,332
Cosa fondamentale scollega tutti gli HD che hai tranne l'M.2 per installare windows.
 
Ultima modifica:
  • Mi piace
Reactions: BWD87

palmer23

Nuovo Utente
19
1
-> Giulore
"Se segui queste operazioni cosa ti succede ?? Falle non supporre o ...già l'ho fatto non ha funzionato ."
Tra le altre prove, lo avevo già fatto. Scrivevo prima, di aver tentato anche il "CLEAN" ma nulla era cambiato: il W al termine dell'installazione (da USB) si riavvia e compare il BIOS.
Credo sia meglio che io riscriva la storia in modo più sintetico e chiaro possibile.

"... ( ti verrà in GPT se hai la modalità UEFI attiva e Secure Boot Attivo )"
Cos'è il BOOT SECURE? Da dove lo imposto?

"... sul disco prima di lanciare il setup non devi fare nulla"
In che senso? Avevo sempre avviato da USB (come indichi anche tu poco prima), quindi come lancio il setup?

"... se non scegliere la dimensione della partizione per Windows nella finestra dove vedi unità disco e partizioni presenti ."
Come faccio a sceglierla? Durante l'installazione (da USB) mi viene sempre e solo chiesto su quale disco voglia installare il W; poi ci sono le opzioni di "elimina", "formatta", "aggiorna" ...

"Solo la dimensione della partizione se vuoi dedicare tutto il disco M2 a Windows non modificare la dimensione vai avanti e basta ."
Perdonami, non mi è chiaro.
Comunque vorrei sì dedicare a W e anche i programmi, tutto il disco M2.

"Installato Windows, se devi rimetterci anche il precedente HDD, lo colleghi e nel UEFI metti la priorità all'M2 ."
Qui viene fuori un'altra questione che mi sta facendo riflettere: io non vedo alcun disco M2 (ne ho 2) nel BIOS, e di conseguenza a oggi non ho mai specificato da dove riavviare; in automatico si prende la USB, nient'altro.
Dischi M2 che invece avviando W da SSD normale, vedo tranquillamente.
E' forse qui il nocciolo del problema?

-> Kelion
"Cosa fondamentale scollega tutti gli HD che hai tranne l'M.2 per installare windows."
Lo avevo fatto con una piccola differenza, ma dimmi se può essere determinante: ho lasciato dentro anche un secondo M2, questo installato su scheda PCI express.
Post automaticamente unito:

Spero di chiarire meglio la vicenda.


INIZIO
Da 3 anni e fino a qualche giorno fa usavo il W8.1, installato a suo tempo su un SSD normale.
Decidevo di passare al 10.
Scaricavo il tool per creare una USB bootabile.
Prendevo un SSD normale e lo inserivo nel PC. Lo vedevo "non allocato" e una volta su "gestione disco" mi compariva automaticamente la scelta tra le modalità MBR e GPT. Sceglievo GPT e avviavo il PC con la USB collegata e sceglievo il disco su cui installare il W10.
Tutto ok.

Poi inserivo un altro SSD, questa volta M2, sul quale avrei voluto installare nuovamente il W10 (dunque, quello che avevo già installato sull'SSD normale - vedi sopra).
Andavo dentro "gestione disco", compariva la scelta MBR o GPT, ma questa volta SBAGLIAVO e selezionavo MBR!
Qui sono cominciati i guai da cui ancora non esco; ma ancora non lo sapevo.
Scollegavo il precedente SSD, avviavo il PC da USB e sceglievo di installare su SSD M2. Lì mi compariva l'errore "Sui sistemi EFI Windows non può essere installato su MBR, ma solo GPT".

Pensavo di risolvere con poco e convertivo da MBR a GPT, nel prompt dei comandi (diskpart, select, convert), ma niente si è risolto; fino al momento in cui W avvisa che sta per riavviarsi, toglievo la USB e mi compariva la schermata del BIOS!

Provavo anche con "clean" sperando di ripristinare il messaggio di inizializzazione del disco, che non è più ricomparso.
Niente.

Ho poi trovato un'altra procedura: bootsect sia con SYS che con ALL.
Niente.

Scollegavo tutti gli altri dischi (4 HD normali | 3 SSD normali) e lasciavo collegati:
1 SSD M2 direttamente su slot in piastra madre, sul quale voglio che sia installato il W
1 SSD M2 su scheda PCI Express
ottenendo lo stesso risultato: il W al termine dell'installazione, in fase di riavvio si trova nel ciclo: o schermata del BIOS o nuova installazione.

Qui iniziavo a non sapere più quale fosse la causa del problema, se abbia fatto tutto correttamente (tranne la scelta del MBR), se stia sbagliando ancora oggi qualche procedura, qualche azione.


CONCLUSIONE
E' possibile che in qualche modo, sbagliando io qualcosa, il W riconosca come avviabile/di sistema solo il primo SSD normale, e non ne accetti altri?
Arrivato a oggi mi domando se sia normale nel BIOS non vedere due dischi M2 (avendo scollegato tutti gli altri) che invece poi vedo avviando Windows ricollegando/riavviando dall'SSD normale, e se non sia questo il problema (appena capisco come, manderò una schermata di tutti i dischi presenti e con quali partizioni, visti da "gestione disco").
 
Ultima modifica:

Kelion

Quid est veritas?
Utente Èlite
23,149
7,332
Per risolvere la questione devi assolutamente lasciare un solo disco collegato sul quale installare il sistema operativo. Tutti gli altri toglili o scollegali. Li colleghi solo dopo aver installato il sistema operativo sul disco che diventerà il disco c: dal quale farà il boot windows. Devi far riassegnare le lettere di unità agli altri hd lasciando il boot dal disco c: che sarà a questo punto quello con l'unico windows di default all'avvio. Solo dopo formatterai gli altri dischi per utilizzarli come archivio. Anche se non li formatti ma sicuramente dovrai cancellare windows da essi specie se hai usato lo stesso product key
 
  • Mi piace
Reactions: BWD87

palmer23

Nuovo Utente
19
1
Ricevuto, lo faccio subito.

Però come potrò formattarli o comunque cancellarci Windows?
Una volta che li collegavo mi venivano sempre riconosciuti come "di sistema" e non me li faceva mai formattare.
Post automaticamente unito:

Fatto. Niente da fare: il W si riavvia e torna al BIOS.

Ribadisco che dal BIOS, nei dispositivi SATA, vedevo soltanto il DVD, dunque nemmeno l'M2 che avevo lasciato come unico disco; che però vedo se apro ora le risorse del computer, avendo ricollegato l'SSD normale sul quale avevo installato da subito il W.
Dunque ora nelle risorse vedo il C (l'SSD normale) e il D (l'M2).
Post automaticamente unito:

situazione attuale (W su SSD normale, ricollegato per poter usare il PC) | risorse del computer
risorse.png


gestisci / gestione disco
gestione.png
 
Ultima modifica:

palmer23

Nuovo Utente
19
1
A quanto pare è un caso inedito e di difficile soluzione.
A questo punto penso che ci sia incompatibilità con il BIOS o con la piastra madre.
Sentirò Asus.
Grazie a chi è intervenuto.
 

giulore

Utente Attivo
741
133
CPU
i5-6600k
Dissipatore
H75i
Scheda Madre
Asrock Z170 Pro Gaming I7
Hard Disk
SSD Crucial M550
RAM
16GB ddr4-3000
Scheda Video
Intel HD530
Scheda Audio
Intel
Monitor
Philips 23IT
Alimentatore
CoolMaster GX650W
Case
Sharkoon
Periferiche
Ricoh SP277SNwX
Internet
ADSL-HoMobile-Vodafone
Sistema Operativo
Win7- Win10
Che modello di scheda madre ?
Hai l'ultima versione di BIOS ? Potrebbe essere un bug poi corretto.

Ma visto che hai chiesto cos'è il secure boot , perché vuoi inizializzare i dischi in GPT e non ti va bene l'mbr.

.
Post automaticamente unito:

Anche il modello dell'adattatore pci-express dove è montato l'altro M2.

.
 
Ultima modifica:

Kelion

Quid est veritas?
Utente Èlite
23,149
7,332
Può essere che la scheda PCI-e con M.2 sia incompatibile e ti incasina tutto. Hai provato a toglierla e ripetere l'installazione con l'M.2 solo sulla scheda madre? Controlla anche che il connettore M.2 non condivida la linea con un connettore SATA. A quel punto dovresti spostare l'HD che condivide la stessa linea.
 

palmer23

Nuovo Utente
19
1
-> Giulore
"Che modello di scheda madre?"
Asus X99-Pro

"Hai l'ultima versione di BIOS ? Potrebbe essere un bug poi corretto."
Non credo, risale al 2015.
Li ho chiamati Venerdì ma stavano per cessare il servizio e non avevo con me il seriale della scheda, che volevano per dirmi qualunque cosa.
I primi a sconsigliare l'aggiornamento del BIOS sono loro... se la macchina non dà problemi. Nel mio caso, forse...

"Ma visto che hai chiesto cos'è il secure boot , perché vuoi inizializzare i dischi in GPT e non ti va bene l'mbr."
Perdonami, è una domanda? Se sì, lo avevo poi trovato sul BIOS, ed era/è abilitato.
Lo dovuto fare non per mio capriccio ma per l'avviso del W che compariva in fase di installazione (vedi sopra): "...sui sistemi EFI non puoi installare su dischi inizializzati in MBR..."

"Anche il modello dell'adattatore pci-express dove è montato l'altro M2."
X99-Pro - è della Asus, era assieme alla scheda.

-> Kelion
"Può essere che la scheda PCI-e con M.2 sia incompatibile e ti incasina tutto."
Non incompatibile, non credo proprio; però comincio a pensare che magari il BIOS... (vedi Giulore).
Dunque sembrerebbe non c'entrare "l'errore" di formattare il disco in MBR (che poi comunque lo avevo convertito [vedi sopra]).

"Hai provato a toglierla e ripetere l'installazione con l'M.2 solo sulla scheda madre?"
E' l'unica (credo) prova che mi resta da fare. Tra poco...
Poco fa facevo l'inverso: lasciato quello sulla scheda e tolto quello sulla piastra. Ebbene, nemmeno così il disco si vedeva nel BIOS (ammesso che questo debba avvenire a prescindere), nemmeno così a W andava bene com'era formattato (non come MBR -perché era formattato come GPT- ma perché "non ho trovato partizioni su cui installare W; controlla il file di log per i dettagli"; così le ho eliminate, sempre da dentro l'installazione, e fatto formattare a lui. Riavviato ed eccomi nuovamente alla schermata del BIOS [!]).

"Controlla anche che il connettore M.2 non condivida la linea con un connettore SATA. A quel punto dovresti spostare l'HD che condivide la stessa linea."
Non comprendo. L'unico connettore è lo slot sulla piastra madre.
Post automaticamente unito:

Fatto anche l'altra prova: niente, stesso problema.

Mi stavo chiedendo se il problema potesse dipendere da questo: creavo la USB di avvio (tramite lo strumento di Windows) senza i due M.2 nel PC.
 
Ultima modifica:

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento