PROBLEMA Problema affinità cpu

Fran1985

Nuovo Utente
6
0
Salve a tutti, frequento questo forum da molto tempo e tramite voi sono riuscito in passato a risolvere vari problemi con i pc.
Ma ora mi trovo a dover inserire un post mio perchè non riesco a venire a capo di un problema che mi stà facendo impazzire!!!

Ho un notebook MSI gt 740
CPU: Intel core i7-720 QM 1.60 Ghz
VGA: Nvidia Geforce GTS 250M
RAM: DDRIII 4 GB (2x2GB)
HDD: SATA 500 GB

3 partizioni sull'hdd:
ubuntu da una parte con 150 gb, windows xp moddato sull'altra con 150 gb e hard disk dati da 200 gb.

Il problema credo si possa capire all'istante dall'immagine:

prestazioni.jpg

Nonostante nei processi non è presente niente che lavori, la CP0 è a palla mentre le altre 6 giocano a tressette e briscola in attesa di non sò cosa...
Il consumo è comunque normale (solo xp, con antivirus e qualche programmino che parte all'accensione) ma il carico invece di essere distribuito sui 7 processori (superato il 25% del primo) resta accollato tutto su quello.
Questo problema si amplifica quando comincio ad aprire roba (file leggeri word, excel, photoshop, ecc), tutto quello che apro và a carico della CPU0 mentre le altre continuano a non lavorare.
Se poi comincio ad aprire programmi più seri come archicad, autocad, conversioni video o video a palla su youtube succede questo:

you.JPG

Praticamente le altre 6 CPU si destano da sonno, ma cmq a livelli molto diversi e sempre in maniera molto inferiore alla CPU0 e solo dopo che la prima arriva al 100% facendo laggare l'intero pc (e facendomi innervosire a mille).

Ho risolto il problema lag usando "taskassign" o comunque modificando le affinità da taskmanager dei programmi che apro togliendo la spunta dalla CPU0 ma capite che non è tollerabile una situazione del genere e comunque non è una soluzione, perchè facendo questo impedisco solamente di caricare ulteriormente la CPU0 dirottando sulle altre il programma aperto, ma non dovrebbe essere fatto in automatico da windows?

Potete suggerirmi qualche soluzione a questo problema?

Per escludere le banalità vi informo che ho scansionato il pc con hijackthis, antivirus, antibagle, e tutti gli anti possibili...non è un problema di virus.

Non ho mai toccato il bios per avventurarmi in inutili (dato il mezzo a disposizione) overclock o altro.

Ho inoltre aggiornato tutto sul pc, dai driver degli hardware a xp stesso ma senza soluzione.
Sò che xp è in grado di gestire più CPU contemporaneamente, ma c'è un limite di cui non sono informato? Magari sugli i7 non riesce?

XP è stato moddato da me con nlite partendo da un cd SP2 e inserendo:

SP3
tutti i driver del mio notebook
gli aggiornamenti fino a quando ho fatto la copia (un lavoraccio per metterli in ordine e evitare aggiornamenti obsoleti)
Qualche cab (tipo la directx9, firefox, vlc, ecc)

e rimuovendo questi servizi:

Componenti eliminati

Accesso Facilitato
ClipBook Viewer
Deframmentazione
Giochi
Giochi internet
Pinball
Screensaver
Sincronia File

Lingue

Tutte

Multimedia

Codec Intel indeo
Immagini e Sfondi
Media Center
Movie maker
Sample Musicali
Sintesi e riconoscimento vocale

Opzioni sistema operativo

Assistente di ricerca
DR Watson
Editor carattere personale
Framework
MS XML 2.0
Pulitura disco
Pulitura guidata desktop
Strumento di rimozione blaster/Nachi
Tour
Trasferimento guidato file e impostazioni

Rete

Client per la rete Netware
Estensioni di fontPage
Manager di sincronizzazione
MSN Explorer
Netmeeting
Peer-to-peer
Windows messanger

Servizi

Accesso secondario
Archivi rimovibili
Avvisi
Gruppo di continuità
Messenger
Registro Remoto
Servizi Fax
Servizio COM di masterizzazione CD IMAPI
Servizio di indicizzazione


# Tastiere #
Tutte

# Cartelle #
DOCS
SUPPORT
VALUEADD

Per caso con Nlite c'è la possibilità di eliminare il "gestore" di affinità o è solo una mia paranoia?
Forse essendo partito da un SP2 non c'era il gestore affinità decente e ho saltato un'aggiornamento che lo migliorava?
C'è un'aggiornamento per il gestore dell'affinità?

Ho smontato e pulito ventole e prese d'aria (le ho provate tutte) e le temperature restano sempre nella norma.

Naturalmente tutto questo succede solo su xp...su ubuntu và tutto liscio...

Mi rimetto alla vostra sapienza ed esperienza sperando di riuscire a scoprire l'arcano mistero....
 

Chiccolino

UTENTE LEGGENDARIO
Utente Èlite
19,360
5,265
CPU
i7 4770k delidded
Dissipatore
EK Supremacy
Scheda Madre
Gigabyte Z87X-OC
HDD
Samsung 830 pro 256
RAM
2x4GB Samsung ultra low voltage
GPU
Gigabyte GTX 780Ti Windforce rev.1.0
Audio
Integrata
Monitor
BenQ XL2420T
PSU
XFX Pro Series 750W BE Silver
Case
Banchetto in plexi con liquido su CPU
OS
Windows 10 x64 Professional
non ho idea di cosa potrebbe essere il problema, qui c'è bisogno del guru di win @Federico83 :inchino:

comunque sposto in sezione win, dato che sembra palese che sia un problema di win e non della cpu.
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
cosa pretendi da un sistema operativo di 10 anni fa? la parallelizzazione io direi di far una prova con un sistema a 64bit non mettere xp 64 che fa pena ma metti win7 o 8 poi ne riparliamo
 
  • Like
Reactions: Chiccolino

Fran1985

Nuovo Utente
6
0
cosa pretendi da un sistema operativo di 10 anni fa? la parallelizzazione io direi di far una prova con un sistema a 64bit non mettere xp 64 che fa pena ma metti win7 o 8 poi ne riparliamo

per carità...pretendo semplicemente quello che ha sempre fatto...lavorare come una scheggia anche mentre elabora un file artlantis di 350 mega...cioè quello che ha sempre fatto per 4 anni fino a 6 mesi fà...quando ha cominciato a fare queste cose...
ho moddato xp e installato dal primo giorno in modo da tenerlo il più leggero possibile e non ho mai avuto problemi.
Riuscivo a lavorare senza problemi aprendo 3-4 file archicad 1-2 excel firefox e vlc :rock::rock::rock:....
da qualche tempo a questa parte invece i programmi si avviano a "sentimento", nel senso che alcune volte appena clicco sul .exe impiegano pochi istanti a partire, altre volte impiegano secoli a partire e una volta avviati laggano in maniera oscena.
Quando succede questo li chiudo e li riapro, ma non è detto che alla seconda si avvii bene...anzi mi capita (anche spesso) di chiudere e riaprire il programma 3 o 4 volte fino a quando non "parte bene" senza laggare, ci sono volte, dopo aver cliccato sul .exe, in cui ho il tempo di aprire task manager e terminare il programma prima che si apra (per non apettare di premere sulla crocetta una volta aperto)...mi capita con tutti i programmi, anche il blocco note, e in quelle situazioni c'è la cpu0 a 100% mentre le altre dormono...per questo ho chiesto qui, perchè non riesco a venirne a capo...
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
mha un i7 con xp è come aver un motore di una ferrari su un carro armato non so se mi spiego la tua cpu lavorerà meglio secondo me con i nuovi sistemi operativi in grado di sfruttare tutte le funzioni della cpu perché non fai un bel dualboot e ci piazzi su 7 x64 pro? io te la butto li secondo me dovrebbe andar meglio di xp... che ormai sta andando fuori supporto.
 

Fran1985

Nuovo Utente
6
0
quando comprai il notebook c'era montato windows vista...senza pensarci due volte formattai montando ubuntu, poi mi trovai obbligato a dover installare uno della famiglia windows per far girare i programmi professionali (come appunto archicad, autocad, ecc).
La scelta mi sembrò ovvia (tra xp e vista), xp tutta la vita, allegerito delle cose superflue avevo praticamente un sistema al primo avvio che mi teneva occupato 120 mega di ram, aperture file quasi immediata e tutta la stabilità garantita da 6 anni di vita de SO.
Ritornare a vista non ci penso proprio, per 7 o 8 c'ho pensato ma mi ha sempre urtato il ciucciarsi di 1 gb di ram solo per funzionare, anche se poi avrei la possibilità di sfruttare la quarta ram di memoria che ora xp non sfrutta...quindi avrei cmq la stessa quantità di memoria fisica libera.
Ma il discorso del post era un'altro, cioè come mai c'è stata questa inversione di funzionamento sul mio pc attuale?
E soprattutto cercavo spiegazioni su questo strano modo di avviarsi dei programmi...intendo questa incertezza su come si avvierà il programma, che alcune volte partono bene e altre vanno lenti e laggano senza apparenti spiegazioni se non per il discorso della maldistribuzione del lavoro CPU che prima non aveva...
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
quando comprai il notebook c'era montato windows vista...senza pensarci due volte formattai montando ubuntu, poi mi trovai obbligato a dover installare uno della famiglia windows per far girare i programmi professionali (come appunto archicad, autocad, ecc).
La scelta mi sembrò ovvia (tra xp e vista), xp tutta la vita, allegerito delle cose superflue avevo praticamente un sistema al primo avvio che mi teneva occupato 120 mega di ram, aperture file quasi immediata e tutta la stabilità garantita da 6 anni di vita de SO.
Ritornare a vista non ci penso proprio, per 7 o 8 c'ho pensato ma mi ha sempre urtato il ciucciarsi di 1 gb di ram solo per funzionare, anche se poi avrei la possibilità di sfruttare la quarta ram di memoria che ora xp non sfrutta...quindi avrei cmq la stessa quantità di memoria fisica libera.
Ma il discorso del post era un'altro, cioè come mai c'è stata questa inversione di funzionamento sul mio pc attuale?
E soprattutto cercavo spiegazioni su questo strano modo di avviarsi dei programmi...intendo questa incertezza su come si avvierà il programma, che alcune volte partono bene e altre vanno lenti e laggano senza apparenti spiegazioni se non per il discorso della maldistribuzione del lavoro CPU che prima non aveva...

la spiegazione è che c'è qualche update M$ e in molti lo hanno notato che ha fatto diventare winxp un mattone allucinante... dici bene 6 mesi fa questo udate non c'era è stato introdotto a maggio\giugno da li sono cominciati i veri problemi di pesantezza... prova giusto per a fare una iso con nlite senza gli update a partire da aprile quindi fino a marzo 2013 e vedi se continua ad essere così pesante come stai rilevando ultimamente...
 

Fran1985

Nuovo Utente
6
0
era quello che temevo...speravo fosse qualche problema risolvibile senza formattone...purtroppo sono in un periodo un pò impegnativo...fra 2 settimane mi libero e mi metto a fare prove con diverse versioni di xp...magari all'inizio provo ad installarlo senza aggiornamenti e vediamo come và...speravo che fosse qualche problema già conosciuto e risolvibile...evidentemente l'aggiornamento di cui parli crea questi tipi di problema di gestione cpu...
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
non saprei sono almeno due anni che non uso più xp ma son swappato prima su 7 e ora su 8 quindi non saprei dirti con precisione quale kb possa far questo
 

Fran1985

Nuovo Utente
6
0
non saprei sono almeno due anni che non uso più xp ma son swappato prima su 7 e ora su 8 quindi non saprei dirti con precisione quale kb possa far questo

capito, prevedo che tra qualche giorno comincerò a caricare singolarmente ogni aggiornamento su un'xp pulito per scoprire quali degradano il SO...quando mi metto in testa qualcosa...:asd::asd::asd:....oppure vorrà dire che dopo aver inserito il sp3 e pochi altri fedeli e utili aggiornamenti (alla fine sono ben pochi) chiudo definitivamente gli aggiornamenti...tanto su internet ci vado poco e cmq stò attentissimo.
Escludendo i pochi aggiornamenti di stabilità tutti gli altri sono tappa falle di sicurezza...quindi li evito proprio.
Sul discorso windows 7 windows 8 tu quale trovi migliore?
Considerando anche le versioni professional, enterprise, ultimate ecc
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
io ho 8 pro mi trovo bene
 

Fran1985

Nuovo Utente
6
0
Ho installato coretemp per visualizzare le temperature dopo un'altra pulizia profonda del pc e ho notato che rileva solo 4 cpu invece di 7...è normale o è qualcosa di strano?

coretemp.JPG
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,207
6,218
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
Ho installato coretemp per visualizzare le temperature dopo un'altra pulizia profonda del pc e ho notato che rileva solo 4 cpu invece di 7...è normale o è qualcosa di strano?

Visualizza allegato 77368

se è una cpu con hypertrading 4 cpu sono fisiche e 4 sono virtuali... quindi si è normale che rilevi solo 4 core.
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 14 16.1%
  • Gearbox

    Voti: 1 1.1%
  • Xbox & Bethesda

    Voti: 62 71.3%
  • Square Enix

    Voti: 3 3.4%
  • Capcom

    Voti: 5 5.7%
  • Nintendo

    Voti: 13 14.9%
  • Altro (Specificare)

    Voti: 7 8.0%

Discussioni Simili