Help su formula su file excel

wifi75

Nuovo Utente
33
1
Buongiorno a tutti.

ho la necessità di avere una cella in cui in in base ad una data inserita in un'altra cella mi dia la data di scadenza, ma in questo modo:

la data di scadenza è sempre di tre giorni mentre se il giorno di produzione cade di venerdi la scadenza sarà di 4 giorni.
quindi se ho

esempio 1:
produzione = 09 marzo 2016
scadenza = 12 marzo 2106
(questa formula vale dal lunedi al giovedi, il sabato e la domenica)

esempio 2.

produzione= 11 marzo 2016
scadenza= 15 marzo 2016

queste regole devono essere valide per tutto l'anno.

si puo avere una cosa el genere?
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
Ciao io ho provato su excel 2007 e funziona. Formatti le caselle in formato "data" e poi semplicemente facendo la somma della casella che ti interessa (la data di partenza) + 3 ti compare la data esatta (data di partenza + i 3 giorni)
 

LordNight

UTENTE LEGGENDARIO
Utente Èlite
24,287
10,142
CPU
Intel i7-6700K @ 4,7GHz // Intel i7-3770K @ 4,6GHz
Dissipatore
NZXT Kraken X61 // Cryorig R1 Ultimate
Scheda Madre
Asrock Z170 Extreme 6 // Asrock Z77 Extreme 6
HDD
Samsung SM951 NVMe 512GB + Seagate Barracuda 2TB + vari // Samsung 850 EVO + Seagate Barracuda 2TB
RAM
GSkill Trident Z 2*8GB 3200MHz CL16 @ 3325 MHz CL14 // GSkill Sniper 2*8GB 2400MHz CL11
GPU
Asus GTX 1080 Strix // Intel HD4000
Audio
Vedi "Mainboard"
Monitor
QNIX QX2710 WQHD (2560*1440) IPS 8bit+FRC // Dell U2515H
PSU
EVGA SuperNova 750W G2 // Cooler Master Silent Pro M 500W
Case
Anidees AI Crystal White // Cooler Master Masterbox 5
Periferiche
Sharkoon Skiller SGK1 - Logitech G602 // Microsoft Sculpt Keyboard & Mouse
OS
Win 10 Pro
La formula che chiedi necessita prima di tutto di individuare il giorno della settimana in cui avviene la produzione. In questo caso devi utilizzare la funzione "giorno.settimana" collocata all'interno di una funzione "se". Pertanto, se in A1 c'è la data di produzione ed in A2 vuoi quella di scadenza, la formula da scrivere è:

=SE(GIORNO.SETTIMANA(A1)=6;A1+4;A1+3)

Tradotto:

=se il giorno della settimana della cella A1 ha valore 6 (*), allora aggiungi 4 giorni alla data di A1, altrimenti sommane 3

ciò in quanto in excel i giorni della settimana vanno da domenica a sabato, come si usa negli States, invece che da lunedì a domenica come da noi. Pertanto, venerdì corrisponde al 6, sabato al 7, domenica 1 e così via.
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
Vero Lord, mi ero perso il discorso del venerdi :sisilui:
 

wifi75

Nuovo Utente
33
1
Ciao Lord, però nella cella di scadenza mi deve apparire la data e non il numero dei giorni,
si puo fare?
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
Prova a formattare la casella del risultato come data, funziona ! (con la formula di Lord)
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
Immagine.jpg
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
Immagine1.jpg
Excel 2007 -- formatta così sia la cella di partenza che quella di destinazione (dove deve comparire il risultato)
 

wifi75

Nuovo Utente
33
1
maledizione ho provato proprio cosi ma non funziona...

- - - Updated - - -

La formula che chiedi necessita prima di tutto di individuare il giorno della settimana in cui avviene la produzione. In questo caso devi utilizzare la funzione "giorno.settimana" collocata all'interno di una funzione "se". Pertanto, se in A1 c'è la data di produzione ed in A2 vuoi quella di scadenza, la formula da scrivere è:

=SE(GIORNO.SETTIMANA(A1)=6;A1+4;A1+3)

Tradotto:

=se il giorno della settimana della cella A1 ha valore 6 (*), allora aggiungi 4 giorni alla data di A1, altrimenti sommane 3

ciò in quanto in excel i giorni della settimana vanno da domenica a sabato, come si usa negli States, invece che da lunedì a domenica come da noi. Pertanto, venerdì corrisponde al 6, sabato al 7, domenica 1 e così via.

ma io ho solo due celle:

su una ci sta la data di consegna, mentre sull'altra la data di scadenza.

forse per questo non funziona?
 

sognatore761

Utente Attivo
1,176
362
CPU
i5-4690
Scheda Madre
Asus h97-pro
HDD
samsung 840 evo
RAM
8 GB
GPU
Asus strix 970
OS
8.1 64 bit
ma non funziona la formula o non compare la data in formato giorno mese anno?
La cella con la data di consegna deve avere la data normale (una data che imposti tu) mentre la scadenza usi la formula. Attento che nella formula postata A1 rappresenta la cella con la data di consegna. Se la data è su un'altra cella (E2 ad esempio) devi sostituire A1 con E2
 
Ultima modifica:

LordNight

UTENTE LEGGENDARIO
Utente Èlite
24,287
10,142
CPU
Intel i7-6700K @ 4,7GHz // Intel i7-3770K @ 4,6GHz
Dissipatore
NZXT Kraken X61 // Cryorig R1 Ultimate
Scheda Madre
Asrock Z170 Extreme 6 // Asrock Z77 Extreme 6
HDD
Samsung SM951 NVMe 512GB + Seagate Barracuda 2TB + vari // Samsung 850 EVO + Seagate Barracuda 2TB
RAM
GSkill Trident Z 2*8GB 3200MHz CL16 @ 3325 MHz CL14 // GSkill Sniper 2*8GB 2400MHz CL11
GPU
Asus GTX 1080 Strix // Intel HD4000
Audio
Vedi "Mainboard"
Monitor
QNIX QX2710 WQHD (2560*1440) IPS 8bit+FRC // Dell U2515H
PSU
EVGA SuperNova 750W G2 // Cooler Master Silent Pro M 500W
Case
Anidees AI Crystal White // Cooler Master Masterbox 5
Periferiche
Sharkoon Skiller SGK1 - Logitech G602 // Microsoft Sculpt Keyboard & Mouse
OS
Win 10 Pro

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 30 22.4%
  • Gearbox

    Voti: 2 1.5%
  • Xbox & Bethesda

    Voti: 87 64.9%
  • Square Enix

    Voti: 10 7.5%
  • Capcom

    Voti: 6 4.5%
  • Nintendo

    Voti: 18 13.4%
  • Altro (Specificare)

    Voti: 12 9.0%

Discussioni Simili