RISOLTO Wake on Lan remoto

Stato
Discussione chiusa ad ulteriori risposte.

Macchi0

Nuovo Utente
97
27
Salve,
ho un problema e cerco consigli su come risolverlo: non riesco a far funzionare il wake on lan remoto usando una qualsiasi altra connessione terza adsl o anche mobile. Mi serve per connettermi al computer a casa dei miei genitori da casa mia o da lavoro.

Alcuni dettagli:

- Il router in uso è un TP-Link TD-W8960N;
- Entrambi i pc utilizzano Windows 10 Pro;
- Nella stessa rete LAN il wake on lan funziona perfettamente.

Apro una parentesi. Per funzionare il wake on lan a livello locale ho:
a. disabilitato "Attiva avvio rapido";
b. tramite telnet sul protocollo arp ho reso permanenti IP locale pc cui connettermi e il suo indirizzo mac, altrimenti il wake on lan da pc spento non funzionava neanche in locale;
c. ho attivato su scheda di rete il wake on lan;​
- usando zerotier che crea una sorta di rete locale virtuale stile hamachi posso connettermi al pc remoto con IP locale virtuale SOLO SE è già acceso anche se fermo alla schermata di login;
- ho lasciato perdere altre soluzioni (aprire porte per da router avviare il desktop remoto) perché sono poco sicure e poi non mi funzionavano neanche;
- ho aperto la porta locale 9 UDP utilizzando sia la stessa esterna, sia una differenze provando a lasciare entrambi i protocolli sia tcp e udp;
- sul firewall di Windows come consigliano alcune guide ho aperto la porta locale 9 sia TCP che UDP;
- da router su DDNS ho creato un dns con NO-IP. Il ping sul DNS dinamico usando una connessione terza mostra l'indirizzo IP corretto della macchina a cui devo connettermi.

Il problema è quindi limitato al fatto che utilizzando IP/DNS corretti da connessione terza il wake on lan non funziona!

Il programma utilizzato per gestire il wake on lan è WakeOnLAN di Aquila che sembra il più completo ma anche soluzioni su app android non cambia nulla.

In ogni caso se i parametri per far funziona il wake on lan locale sono indirizzo mac e ip broadcast 255.255.255.255 ovvero tutti gli indirizzi di rete, i parametri per far funzionare il wake on lan remoto dovrebbero essere sempre l'indirizzo mac e su IP/DNS/FDQN il DNS creato con no-ip o a limite l'indirizzo IP della connessione a internet. Ovviamente non funziona e non capisco perché considerando che come ho già evidenziato da connessione terza il ping sul dns mi da l'IP corretto.
Credo ma non ne sono sicuro che il problema potrebbe essere a livello router ma non riesco a capire quale voce.
Suggerimenti? Grazie!

[edit1] aggiungo come ho scritto sotto che attivando la gestione remota web del router vi è accesso allo stesso usando il DNS di No-IP
[edit2] per qualche motivo che ignoro il binding su arp aggiunto con telnet su IP-locale:indirizzo-mac era saltato diventato 00:00:00:00:00:00. Il motivo del non funzionamento del wake on lan remoto era qui.

Consiglio per tutti a chi è interessato a questa funzione e non vuole dannarsi l'anima: si assicuri che il proprio router abbia la funzione ARP-binding di default o con firmware terzo.
 
Ultima modifica:
  • Mi piace
Reazioni: mr.frizz

mr.frizz

Utente Grafene
Utente Èlite
93,239
17,851
CPU
i7 2600k@4.5
Dissipatore
truespirit 140
Scheda Madre
msi z77a-g45
HDD
500 spinpoint f3 + 840 pro 256 + sandisk ultraII 240
RAM
2*4gb tridentZ 2133 cl9
GPU
Sapphire Rx 580 nitro oc+ 4GB
Audio
integrata
Monitor
lg m2232
PSU
corsair tx650v1
Case
Corsair 300r WW
OS
7 ultimate 64
ciao e benvenuto
ma da remoto raggiungi il modem?
 

Macchi0

Nuovo Utente
97
27
Ciao, se da router attivo la gestione remota via web e quindi usando il mio indirizzo DNS di no-ip usando la connessione mobile del mio smartphone vedo la schermata di login del mio router e quindi posso tranquillamente loggarmi (avevo dimenticato di segnalare anche questo fatto).

E' per questo motivo che non capisco cosa cavolo sbaglio!!

[edit] Risolto aggiunta la soluzione.
 
Ultima modifica:
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando

Discussioni Simili