Ubuntu e notebook con drive ibrido

  • Autore discussione Utente cancellato 106622
  • Data d'inizio
U

Utente cancellato 106622

Ospite
Ciao ragazzi, ho cercato per ore sul web per risolvere questo problema, ma non riesco a trovare una soluzione.

Il mio HP Envy 4 1070-el ha 2 drive in Raid1: UN hdd DA 500gb Hitachi e un SSD Kingston da 32GB usato come cache. Ubuntu non rileva nessun disco durante l'installazione e , auqnato leggo, questo fatto è normale su questo tipo di notebook. Ora mi chiedo, sarei disposto ad instraprendere 2 soluzioni

1) Lasciare tutto come su Windows e usare l'hard disk per i dati e l'ssd come cache. Si puo fare? Come?

2) Eliminare il RAID e usare l'ssd per l'OS e l'hard disk per i dati e i programmi. Ma è possibile su Ubuntu installare i programmi su una cartella separata dal drive dell'oS come su windows?


Grazie per l'aiuto :vv:
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,305
2,231
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
elimina il raid, in linux hai fstab che ti permetterà di vedere i 2 dischi " come uno solo"
 
U

Utente cancellato 106622

Ospite
Ah, perfetto. Il raid lo devo eliminare segendo le guide che ho trovato su google (rimuovendo hard disk ed entrando nella config etc) oppure lo psoso fare direttamente da linux via console?

Poi quando installo devo installare sull'ssd o sull'hard disk? Ammesso che non debba usare fstab prima di installare?

Scusa per le tante domande, e ti ringrazio ancora per la tempestiva risposta, ma ho davvero poca esperienza di linux su config simili.

Ciao ;)
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,305
2,231
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
durante l'instalazione fai partizionamento avanzato , vedrai i 2 dischi.

sul disco ssd fai una sola partizione ext4, come mountpunt metti / , sul disco meccanico fai una partizione da 50 GB , raiserfs come filesystem e mountpoint /var , l'altra lasciala per tutto lo spazio , ext4 e mountpoint /home

così hai i pro di un ssd ( il sistema "vive" li) ed i pro di un hdd per i dati
 
U

Utente cancellato 106622

Ospite
Perfetto, ho impostato tutto. Una cosa sola, mi dice che è consigliato creare una partizione di swap. Posso farne a meno dato che ho 8 GB di ram installati sul notebook?

Grazie ancora per tutti i consigli, sono stati utilissimi :birra:

- - - Updated - - -

Pensavo fosse tutto risolto, invece no. Ho un problema: ho installato tutto, ho premuto su riavvia e ora mi dice No bootable device -- insert boot disk and press any key. Non carica nemmeno il grub, nulla.
 

davethecipo

Utente Èlite
3,326
1,157
CPU
i5 4660
Scheda Madre
H97 PC Mate
HDD
qualcuno
RAM
8 GB
GPU
R9 280
Monitor
Samsung SyncMaster 940BW 19'
PSU
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
OS
Arch Linux con KDE...Windows 10
Riguardo alla swap puoi farne a meno. Per l'altro problema non so aiutarti
 
U

Utente cancellato 106622

Ospite
ok, allora eviterò la swap. Ho provato a reinstallare tutto selezionando come drive per il Boot Loader (Grub) l'HDD invece dell'SSD ma continua a darmi lo stesos errore...
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,305
2,231
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
ma il radi è software o hardware ?

hai indicato , come disco di installazione di grub, il disco meccanico ?
 
U

Utente cancellato 106622

Ospite
Il raid era un RAID gestito da un utility del BIOS. Per disattivarlo bisogna aprire il notebook e scollegare l'hard disk meccanico, avviando poi il PC ad hdd scollegato. Compare così la gestione dei dischi in RAID, si cancella il RAID e si ricollega il disco meccanico. Andando su Windows (che continuava ad avviarsi correttamente, essendo salvato solo su hdd meccanico) ho visto in gestione disco l'ssd da 32 GB, che quindi viene correttamente riconosciuto.

Il boot manager l'ho installato sul disco meccanico, ma ho provato anche, dopo l'errore, a installarlo sull'ssd, senza cambiamento.

Posso canfermare che windows da SSD si avvia normalmente, ho provato a installarlo in questo momento.
 
Ultima modifica da un moderatore:

Giacobazzi

Nuovo Utente
66
9
Hai disabilitato l'Intel SRT (Smart Response Technology) o Rapd Start Technology da bios? Dovrebbe essere quello che gestisce l'ssd caching.
 
U

Utente cancellato 106622

Ospite
Ho provato sia disabilitando Intel RST sia tenendolo attivo, ma allo startup continua a dirmi che non trova il disco dal quale eseguire il boot. Altre voci nel bios non ne vedo, é molto scarno.

Ciao
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 17 17.9%
  • Gearbox

    Voti: 1 1.1%
  • Xbox & Bethesda

    Voti: 67 70.5%
  • Square Enix

    Voti: 4 4.2%
  • Capcom

    Voti: 5 5.3%
  • Nintendo

    Voti: 14 14.7%
  • Altro (Specificare)

    Voti: 9 9.5%