PROBLEMA ubuntu 13.04 - problea unity dopo installazione driver amd

abcdeeeeff

Utente Attivo
521
289
CPU
Ryzen 9 5900X
Dissipatore
Noctua NH-D15
Scheda Madre
MSI B550 Gaming Edge WiFi
HDD
WD Black SN850 1 TB
RAM
4x8GB crucial ballistix 3600 CL16 (OC a 3733)
GPU
Gigabyte HD 7950 (3080 in arrivo)
Audio
integrata nella MB
Monitor
Dell 2721DGF
PSU
Antec HCG 750W
Case
Corsair 4000D airflow
OS
Windows 10 + Arch Linux
Ciao a tutti,
ho avuto qualche problema con i driver della scheda video su ubuntu, e adesso se entro in un account vedo solo lo sfondo del desktop e nient'altro(nè la barra sopra, nè quella laterale), quindi ho dovuto installare lxde per poter usare normalmente il pc.
Però se creo un altro utente unity funziona alla perfezione.

Suggerimenti su come risolvere e tornare a far funzionare unity anche sugli altri account?

PS: Per quanto riguarda i problemi avuti con i driver:
- li ho installati come spiegato qui Ubuntu Raring Installation Guide - cchtml.com
- Ubuntu non partiva(rimaneva fisso sulla schermata viola dopo aver selezionato l'os con grub)
- ho provato a disinstallarlo e reinstallarlo sempre come spiegato sopra, il problema è rimasto
- disattivando da bios la vga dedicata e passando all'integrata ubuntu è partito normalmente
- ho disinstallato i driver come spiegato nel link, ho provato ad attivare quelli proprietari presenti in "Driver aggiuntivi", stesso problema
- ho disinstallato anche quelli e ho messo gli open source, dopo aver riattivato la dedicata ubuntu parte ma unity non si vede
 

EmanueleC

Utente Èlite
5,458
1,745
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
OS: 240GB Toshiba TR200, Dati: 1TB Toshiba p300, Game: 2TB Toshiba P300
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 34
Prova a ripristinare unity con questi comandi:
Codice:
[COLOR=#000000][FONT=UbuntuBeta Mono]sudo apt-get install dconf-tools
[/FONT][/COLOR][COLOR=#000000][FONT=UbuntuBeta Mono]dconf reset -f /org/compiz/
[/FONT][/COLOR]​[COLOR=#000000][FONT=UbuntuBeta Mono]setsid unity[/FONT][/COLOR]
 

abcdeeeeff

Utente Attivo
521
289
CPU
Ryzen 9 5900X
Dissipatore
Noctua NH-D15
Scheda Madre
MSI B550 Gaming Edge WiFi
HDD
WD Black SN850 1 TB
RAM
4x8GB crucial ballistix 3600 CL16 (OC a 3733)
GPU
Gigabyte HD 7950 (3080 in arrivo)
Audio
integrata nella MB
Monitor
Dell 2721DGF
PSU
Antec HCG 750W
Case
Corsair 4000D airflow
OS
Windows 10 + Arch Linux
Prova a ripristinare unity con questi comandi:
Codice:
[COLOR=#000000][FONT=UbuntuBeta Mono]sudo apt-get install dconf-tools
[/FONT][/COLOR][COLOR=#000000][FONT=UbuntuBeta Mono]dconf reset -f /org/compiz/
[/FONT][/COLOR]​[COLOR=#000000][FONT=UbuntuBeta Mono]setsid unity[/FONT][/COLOR]

L'ho fatto da lxde, è partito compiz(avvisando che non è riuscito a caricare il plugin opengl) e la finestra del terminale di lxde è diventata tipo quella di unity. Ho riavviato, ho provato unity, ma una volta entrato nell'account lo schermo rimane nero.

Può servire provare ad aprire una shell con ctrl+alt+f1 e provare da lì? devo prima far partire l'X server?
 

EmanueleC

Utente Èlite
5,458
1,745
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
OS: 240GB Toshiba TR200, Dati: 1TB Toshiba p300, Game: 2TB Toshiba P300
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 34
Lo puoi fare anche da lxde, prova a eliminare i file di configurazione nascosti sulla home. Ovviamente lo devi fare con l'account che non funziona.
 

abcdeeeeff

Utente Attivo
521
289
CPU
Ryzen 9 5900X
Dissipatore
Noctua NH-D15
Scheda Madre
MSI B550 Gaming Edge WiFi
HDD
WD Black SN850 1 TB
RAM
4x8GB crucial ballistix 3600 CL16 (OC a 3733)
GPU
Gigabyte HD 7950 (3080 in arrivo)
Audio
integrata nella MB
Monitor
Dell 2721DGF
PSU
Antec HCG 750W
Case
Corsair 4000D airflow
OS
Windows 10 + Arch Linux
si, l'ho fatto da uno che non funzionava. appena si libera il pc riprovo.

Intendi i file di configurazione di unity, no? robe del tipo *unity*.conf(o comunque file che contengono unity nel nome)?
 
Ultima modifica:

EmanueleC

Utente Èlite
5,458
1,745
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
OS: 240GB Toshiba TR200, Dati: 1TB Toshiba p300, Game: 2TB Toshiba P300
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 34
Le cartelle: .compiz, .config/compiz-1 e comunque riesci a capire le cartelle che non ti interessano tipo: chromium, vlc etc... e comunque anche se li elimini ripristini solo la configurazione non succede nulla.
 

abcdeeeeff

Utente Attivo
521
289
CPU
Ryzen 9 5900X
Dissipatore
Noctua NH-D15
Scheda Madre
MSI B550 Gaming Edge WiFi
HDD
WD Black SN850 1 TB
RAM
4x8GB crucial ballistix 3600 CL16 (OC a 3733)
GPU
Gigabyte HD 7950 (3080 in arrivo)
Audio
integrata nella MB
Monitor
Dell 2721DGF
PSU
Antec HCG 750W
Case
Corsair 4000D airflow
OS
Windows 10 + Arch Linux
Le cartelle: .compiz, .config/compiz-1 e comunque riesci a capire le cartelle che non ti interessano tipo: chromium, vlc etc... e comunque anche se li elimini ripristini solo la configurazione non succede nulla.

Da un account ho cancella .compiz, .config/compiz-1 e .config/unity3d da lxde, sono uscito dall'account, sono rientrato con uniity impostato e funziona.

Dall'altro non ho cancellato .config/unity3d perchè non c'era, il resto l'ho cancellato. Ho chiuso l'account e sono rientrato con unity, si vede solo lo sfondo e le icone del desktop. Ho ricancellato i file di configurazione(sul desktop avevo un link al terminale, quindi potevo usarlo), ma il problema rimane.
altri consigli per questo account?
 

EmanueleC

Utente Èlite
5,458
1,745
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
OS: 240GB Toshiba TR200, Dati: 1TB Toshiba p300, Game: 2TB Toshiba P300
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 34
Allora prova a eliminare qualsiasi file di configurazione sia cartelle che file e riavvia
 
  • Like
Reactions: abcdeeeeff

abcdeeeeff

Utente Attivo
521
289
CPU
Ryzen 9 5900X
Dissipatore
Noctua NH-D15
Scheda Madre
MSI B550 Gaming Edge WiFi
HDD
WD Black SN850 1 TB
RAM
4x8GB crucial ballistix 3600 CL16 (OC a 3733)
GPU
Gigabyte HD 7950 (3080 in arrivo)
Audio
integrata nella MB
Monitor
Dell 2721DGF
PSU
Antec HCG 750W
Case
Corsair 4000D airflow
OS
Windows 10 + Arch Linux

Znikrot

Nuovo Utente
6
0
Sistemato, grazie

Salve, so che la discussione è vecchia ma da quello che ho capito ho lo stesso problema: dopo aver aggiornato i driver ed effettuato il login vedo solo lo sfondo del desktop. Dopo aver premuto Ctrl+Alt+F1 cosa devo digitare nella riga di comando per eliminare tutti i file di configurazione? Grazie mille :D
 

Ico Bellungi

Utente Èlite
2,921
626
Fai login col tuo utente, accedi al terminale, dai ls -lart e vedi quante directory e file iniziano col . e riguardano Unity/compiz.
Cancellale o rinominane più che puoi (chissà quale sarà il file che blocca tutto!) e dovresti aver risolto
 

Znikrot

Nuovo Utente
6
0
Fai login col tuo utente, accedi al terminale, dai ls -lart e vedi quante directory e file iniziano col . e riguardano Unity/compiz.
Cancellale o rinominane più che puoi (chissà quale sarà il file che blocca tutto!) e dovresti aver risolto
Se digito ls -lart mi fa vedere un elenco tra cui una directory .compiz di colore blu ma nient'altro che riguardi unity/compiz. Ovviamente se provo a rimuoverla con "sudo rm" mi dice che non posso perché è una directory... Scusate se faccio qualche errore banale ma è da poco che mi sono avvicinato ad Ubuntu :D
 

Ico Bellungi

Utente Èlite
2,921
626
Per eliminare una directory rm -r nomedirectory. Puoi anche rinominarla con mv .compiz .compiz_old, così ti tieni anche la directory vecchia. Fai fuori anche .config magari
 

Znikrot

Nuovo Utente
6
0
Ho provato a fare come mi hai suggerito: ho eliminato tramite rm -r sia .config che .compiz. Tuttavia dopo aver premuto invio non mi dava nessun messaggio, solo la riga dove scrivere il comando successivo, è normale? :) Diciamo che mi dà lo stesso problema, però almeno stavolta vedo il puntatore del mouse xD

Non so quanta importanza abbia ma ora al posto del desktop da me impostato vedo quello predefinito...

Suggerimenti? :D
 
Ultima modifica:

Ico Bellungi

Utente Èlite
2,921
626
Ho provato a fare come mi hai suggerito: ho eliminato tramite rm -r sia .config che .compiz. Tuttavia dopo aver premuto invio non mi dava nessun messaggio, solo la riga dove scrivere il comando successivo, è normale? :) Diciamo che mi dà lo stesso problema, però almeno stavolta vedo il puntatore del mouse xD

Non so quanta importanza abbia ma ora al posto del desktop da me impostato vedo quello predefinito...

Suggerimenti? :D
Hai riavviato?
Un suggerimento può essere quello di provare ad aggiungere un utente, vedi se lui riesce a vedere tutto. E poi ti sposti tutti i file dell'utente precedente. Unity è il male
 

Entra

oppure Accedi utilizzando

Hot: Sei vaccinato? [sondaggio anonimo]

  • Primo ciclo vaccinale completo (1-2 dosi)

    Voti: 454 78.5%
  • Fatta 1a dose, in attesa della 2a

    Voti: 20 3.5%
  • Sono prenotato per la 1a dose

    Voti: 13 2.2%
  • Non so se vaccinarmi

    Voti: 16 2.8%
  • Non ho intenzione di vacciarmi

    Voti: 59 10.2%
  • Fatta anche la terza dose

    Voti: 16 2.8%