PROBLEMA SSD PCIe NVMe M.2 non riconosciuto per il boot

Devil9

Nuovo Utente
80
5
Ciao a tutti,
Recentemente ho deciso di ridare nuova vita al mio HP Pavilion 15-bc018nl aumentando la RAM da 8 a 16GB e comprando un SSD da mettere nello slot M.2.
L'idea era quella di trasferire tutti i dati ed il so direttamente sul nuovo ssd e tenere il vecchio hdd come storage di scorta e per i backup.
Ho acquistato il Samsung 970 EVO Plus (https://www.amazon.it/gp/product/B07MBQPQ62/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1), l'ho installato nello slot M.2 e da Windows l'ho formattato per farlo riconoscere come volume aggiuntivo.
Ho utilizzato Samsung Data Migration per fare la copia di dati e so ed ho impostato il boot legacy dal BIOS, impostando come primo disco quello dell'ssd.
Tuttavia al momento del boot continua a partire il vecchio hdd.
Ho anche provato direttamente dalle opzione di Windows a fare il restart dall'ssd ma in quel caso compare la scritta "No bootable device...".

Qualcuno sa come risolvere per caso? Sono giorni che ci sto sbattendo la testa e non so più cosa fare.

Grazie
 

gpsambe

Utente Attivo
417
111
Ciao a tutti,
Recentemente ho deciso di ridare nuova vita al mio HP Pavilion 15-bc018nl aumentando la RAM da 8 a 16GB e comprando un SSD da mettere nello slot M.2.
L'idea era quella di trasferire tutti i dati ed il so direttamente sul nuovo ssd e tenere il vecchio hdd come storage di scorta e per i backup.
Ho acquistato il Samsung 970 EVO Plus (https://www.amazon.it/gp/product/B07MBQPQ62/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1), l'ho installato nello slot M.2 e da Windows l'ho formattato per farlo riconoscere come volume aggiuntivo.
Ho utilizzato Samsung Data Migration per fare la copia di dati e so ed ho impostato il boot legacy dal BIOS, impostando come primo disco quello dell'ssd.
Tuttavia al momento del boot continua a partire il vecchio hdd.
Ho anche provato direttamente dalle opzione di Windows a fare il restart dall'ssd ma in quel caso compare la scritta "No bootable device...".

Qualcuno sa come risolvere per caso? Sono giorni che ci sto sbattendo la testa e non so più cosa fare.

Grazie
Per vedere se la clonazione è andata a buon fine, devi togliere il vecchio disco e con solo il nuovo ssd nel pc, vedere se fa il boot correttamente. Nel caso non faccia il boot, prova a fare una installazione pulita con il solo ssd nuovo installato, tieni da parte il vecchio con i dati da salvare. In ogni caso se Windows non è molto recente sul vecchio disco, è molto meglio una nuova installazione.
 
  • Mi piace
Reazioni: Devil9

Devil9

Nuovo Utente
80
5
Per vedere se la clonazione è andata a buon fine, devi togliere il vecchio disco e con solo il nuovo ssd vedere se fa il boot correttamente.
Intanto grazie per la risposta.
Dici che non è indicativo il risultato che da facendo il restart di Windows dal SSD?
 

gpsambe

Utente Attivo
417
111
Intanto grazie per la risposta.
Dici che non è indicativo il risultato che da facendo il restart di Windows dal SSD?
Ti sto dicendo che devi "semplificare" la sequenza di boot, eliminando delle variabili.
Prima variabile :clonazione ok oppure no.
Seconda variabile : la clonazione è ok ma il sistema non è correttamente impostato per il boot da ssd.
Quindi non puoi verificare la seconda variabile finché non hai un sistema sicuramente funzionante sull'ssd, e per averlo con certezza devi togliere di mezzo il disco originario, affinché il sistema non si "confonda" se si trova 2 dischi uguali (uno è l'esatta copia dell'altro). A quel punto se non si avvia non hai nulla da perdere a reinstallare da zero, ma per installare da zero, ci deve essere un solo disco, inoltre devi mettere da parte (al sicuro) il disco originale che contiene preziosi dati, se non ne hai altre copie. Hai capito il ragionamento?
Se hai dubbi sulle impostazioni del bios, carica i settaggi di default, salva con F10, riavvia e vedi se fa il boot.
 
  • Mi piace
Reazioni: Devil9

Devil9

Nuovo Utente
80
5
Ti sto dicendo che devi "semplificare" la sequenza di boot, eliminando delle variabili.
Prima variabile :clonazione ok oppure no.
Seconda variabile : la clonazione è ok ma il sistema non è correttamente impostato per il boot da ssd.
Quindi non puoi verificare la seconda variabile finché non hai un sistema sicuramente funzionante sull'ssd, e per averlo con certezza devi togliere di mezzo il disco originario, affinché il sistema non si "confonda" se si trova 2 dischi uguali (uno è l'esatta copia dell'altro). A quel punto se non si avvia non hai nulla da perdere a reinstallare da zero, ma per installare da zero, ci deve essere un solo disco, inoltre devi mettere da parte (al sicuro) il disco originale che contiene preziosi dati, se non ne hai altre copie. Hai capito il ragionamento?
Se hai dubbi sulle impostazioni del bios, carica i settaggi di default, salva con F10, riavvia e vedi se fa il boot.

Ho smontato il vecchio hdd ed effettivamente funziona tutto senza problemi. Grazie mille!
Ora teoricamente è possibile tenere entrambi i dischi nel notebook oppure devo necessariamente o prima formattare l'hdd o tenerlo esterno?
 
Ultima modifica:
  • Mi piace
Reazioni: gpsambe

gpsambe

Utente Attivo
417
111
Ho smontato il vecchio hdd ed effettivamente funziona tutto senza problemi. Grazie mille!
Ora teoricamente è possibile tenere entrambi i dischi nel notebook oppure devo necessariamente o prima formattare l'hdd o tenerlo esterno?
Dipende da come è fatto il bios, in teoria è fattibile, in pratica ti conviene formattare in ntfs il vecchio disco con un altro pc o con un cavetto USB - sata , dopo aver salvato i dati.
 
  • Mi piace
Reazioni: Devil9

Devil9

Nuovo Utente
80
5
Dipende da come è fatto il bios, in teoria è fattibile, in pratica ti conviene formattare in ntfs il vecchio disco con un altro pc o con un cavetto USB - sata , dopo aver salvato i dati.
Immaginavo. Procedo al backup e a formattare l'hard disk. Grazie mille per il supporto
 
  • Mi piace
Reazioni: gpsambe

Entra

oppure Accedi utilizzando

Discussioni Simili