PROBLEMA sistemare boot dopo clonazione

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
questo è il problema... avevo un dual boot con grub che gestiva Ubuntu su un HDD e Windows 10 su un SSD. Ho fatto delle modifiche per mettere i drivers in GPT sotto UEFI e ho clonato Ubuntu dal suo HDD (da destinare poi a dati ) su un nuovo SSD formattato in Ext4. Grub a questo punto non funziona più e non sono riuscito a ripararlo neanche con Grub-customizer. Ho pensato a reinstallare Ubuntu sul nuovo SSD ma non vorrei perdere il mio Ubuntu attuale che ho personalizzato. Preciso che in UEFI non vedo il SSD dove è clonato Ubuntu mentre Gparted lo rileva normalmente. Cosa posso tentare per riavere il dual boot? cancellare la formattazione del SSD e reinstallare Ubuntu da live? ma come fare visto che UEFI non lo vede? grazie dei consigli
 

EmanueleC

Utente Èlite
5,058
1,527
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
Hard Disk
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
Scheda Video
GeForce GTX 750Ti 2gb
Alimentatore
Seasonic Focus Gold 450W
Case
BitFenix Neos
Sistema Operativo
Ubuntu 19.04
questo è il problema... avevo un dual boot con grub che gestiva Ubuntu su un HDD e Windows 10 su un SSD. Ho fatto delle modifiche per mettere i drivers in GPT sotto UEFI e ho clonato Ubuntu dal suo HDD (da destinare poi a dati ) su un nuovo SSD formattato in Ext4. Grub a questo punto non funziona più e non sono riuscito a ripararlo neanche con Grub-customizer. Ho pensato a reinstallare Ubuntu sul nuovo SSD ma non vorrei perdere il mio Ubuntu attuale che ho personalizzato. Preciso che in UEFI non vedo il SSD dove è clonato Ubuntu mentre Gparted lo rileva normalmente. Cosa posso tentare per riavere il dual boot? cancellare la formattazione del SSD e reinstallare Ubuntu da live? ma come fare visto che UEFI non lo vede? grazie dei consigli
Perché nella vecchia installazione lo hai installato non nella modalità UEFI?
 

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
era in legacy... credo... ma tutti i drivers erano MBR... ora ho convertito tutto in GPT... sia il SSD con W 10 sia l'SSD con Ubuntu (clonato) sia gli altri (NTFS con dati)
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,601
1,706
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
per clonare ubuntu da mbr ad uefi devi creare prima una tabella gpt sul disco di destinazione , poi creare una partizione efi da 1GB da montare in /boot/efi , clonare la vecchia root , aggiusrare fstab per la partizione efi e ripristinare il bootloader
 

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
az!...complicato assai!... mi potresti guidare meglio?...l'SSD è in GPT dove ho creato una partizione Ext4 con Gparted ma oltre questo non saprei come procedere... cosa è una partizione efi?... come si monta in boot/efi?...come clonare la vecchia Root?...fstab non so cosa sia e infine ripristinare il boot loader come?... sono parecchie indicazioni mi rendo conto ma la mia conoscenza di linux è solo superficiale... per evitare questa procedura ... se facessi una nuova installazione di ubuntu sul nuovo ssd avrei il mio dual boot con grub senza sbattermi troppo?
 
Ultima modifica:

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,601
1,706
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
da gparted, su un pc con collegati disco originale e disco di destinazione

selziona l'ssd, crea tabella partizioni gpt e crea una partizione da 1GB filesystem fat 32, applica i cambiamenti poi click sulla partizione appena creata con tasto destro e seleziona " gestione flag" , metti la spunta su " esp" e se non lo fa da solo anche su boot .

poi seleziona il dico d'origine da gparted, se necessario ridimensiona la vecchia partizione ( tasto destro, ridimensiona, sposta ) e poi sempre tasto detro " copia" , spostati su ssd e fai " incolla ", applica i cambiamewnti e aspetta che abbia finito .

poi devi montare le partizioni ( che identifichi comodamente da gparted )

Bash:
sudo -s


mount /dev/sdXY ( partizione clonata su ssd ) /mnt/

mkdir /mnt/boot/efi

mount /dev/sdXY ( partizione fat 32 creata prima ) /mnt/boot/efi

mount -o bind /dev /mnt/dev

mount -o bind /sys /mnt/sys

mount -o bind /proc /mnt/proc

chroot /mnt

grub-install /dev/sdX ( identifica il tuo ssd )

update-grub

apt-get update

apt-get upgrade

exit

reboot
stacca il disco vecchio e partirai da quello nuovo, senza perdita dati e con il boot uefi
 

pabloski

Utente Èlite
2,062
447
Ma Ubuntu, quando s'installa in modalità legacy, genera un kernel efistub? Perchè in caso contrario, anche usando GPT e la partizione EFI, id fatto si sta comunque usando un kernel legacy.

Che poi non si perde niente d'importante. Le uniche cose sono (1) possibilità di caricare settori più grandi di 512 bytes, (2) supporto delle risoluzioni più alte nel framebuffer.

Per cui non vedo quest'urgenza di supportare il boot in modalità UEFI.
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,601
1,706
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
il kernel di ubuntu è lo stesso , cambia lo script di grub .
 

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
opps!... prendo nota ed eseguo sperando di fare tutto bene... se no aggiorno il post ... per ora comunque grazie

problema... la procedura funziona fino a questo punto ...

root@ubuntu:/# grub-install /dev/sdb
Installazione per la piattaforma i386-pc.
grub-install: avviso: questa etichetta della partizione GPT non contiene BIOS Boot Partition, l'embed non è possibile.
grub-install: avviso: L'embed non è possibile. GRUB può essere installato con questa configurazione solo usando blocklist. Le blocklist non sono comunque affidabili e ne viene sconsigliato l'uso..
grub-install: errore: impossibile procedere con le blocklist.

... l'ho fatta 2 volte ma l'outpout è uguale... sbaglio qualche cosa? o magari l'SSD a cui si riferisce l'ultimo comando è il SSD primario dove sta W 10? (tra l'altro su questo SSD primario c'è anche una partizione da 100MB in Fat 32 con flag boot,esp)...
 
Ultima modifica:

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,601
1,706
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
ecco, chiaramente devi avviare la live come uefi
 

EmanueleC

Utente Èlite
5,058
1,527
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
Hard Disk
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
Scheda Video
GeForce GTX 750Ti 2gb
Alimentatore
Seasonic Focus Gold 450W
Case
BitFenix Neos
Sistema Operativo
Ubuntu 19.04
E avere i pacchetti di grub efi:
grub-efi-amd64-bin/focal,now 2.04-1ubuntu16 amd64 [installato, automatico]
grub-efi-amd64-signed/focal,now 1.133+2.04-1ubuntu16 amd64 [installato]
 

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
ecco, chiaramente devi avviare la live come uefi
ops!... ma non basta avere la live su penna in Fat 32 per essere uefi ? ...cosa dovrei fare oltre?

E avere i pacchetti di grub efi:
ma dove esattamente? ...nella live o nella UBUNTU 18.4 che ho nel SSD appena preparato? ... e in cso siano da mettere sulla live come dovrei fare? ...lanciare la live e poi scaricarli?

c'è poi una cosa strana sul mio UEFI... se metto UEFI solo non vedo come boottabile che la W.10 ... scomparsi sia la live su flash che il lettore CD/DVD...

AGGIORNO:
ho creato una nuova live di ubuntu con Rufus (GPT e UEFI) ma anche eseguendo la procedura come indicato mi blocco allo stesso punto...
"grub-install: avviso: questa etichetta della partizione GPT non contiene BIOS Boot Partition, l'embed non è possibile."
Non riesco a capire quale sia il problema ma presumo sia qualche cosa legata al mio bios-Uefi che come detto ha un Boot/CSM ma sia che metto in Auto sia in Disabled non vede ne il CD/DVD ne il nuovo SSD come driver di boot ... cosa posso ancora fare? ...anche se mi scoccia darmi per vinto sarei anche pronto a reinstallare Ubuntu sul nuovo SSD se questo potesse essere la soluzione di una reinstallazione di Grub funzionante...
 
Ultima modifica:

romrom

Utente Attivo
296
11
CPU
AMD Phenom II 3,2 GHz
Scheda Madre
ASUS M4A79 T Deluxe
Hard Disk
3 HD 3,5 TB
RAM
8 GB 1333 MHz
Scheda Video
ATI 5770
Scheda Audio
stereo
Monitor
Samsung SyncMaster 2232 BW
Alimentatore
Corsair TX 750 W
Case
Cooler Master black
Sistema Operativo
Windows 7 64 bit + Ubuntu 10.4
[QUOTE="romrom, post: 7460911, ....anche se mi scoccia darmi per vinto sarei anche pronto a reinstallare Ubuntu sul nuovo SSD se questo potesse essere la soluzione di una reinstallazione di Grub funzionante...
[/QUOTE]
Mi sono rassegnato a reinstallare ubuntu e ora grub funziona ma mentre win 10 e' ok ubuntu non funziona...schermo viola con qualche riga colorata e basta. E' un problema di drivers nvidia non riconosciuti che al cambio della video mi hanno fatto smanettare per essere sistemati. Ora da live posso aggiornare i drivers proprietari ma ovviamente dopo averli caricati mi chiede di fare restart...quindi il mio problema ora e' come caricarli nella live per installarli con ubuntu...mi sapete aiutare? Grazie
 

EmanueleC

Utente Èlite
5,058
1,527
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
Hard Disk
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
Scheda Video
GeForce GTX 750Ti 2gb
Alimentatore
Seasonic Focus Gold 450W
Case
BitFenix Neos
Sistema Operativo
Ubuntu 19.04
[QUOTE="romrom, post: 7460911, ....anche se mi scoccia darmi per vinto sarei anche pronto a reinstallare Ubuntu sul nuovo SSD se questo potesse essere la soluzione di una reinstallazione di Grub funzionante...
Mi sono rassegnato a reinstallare ubuntu e ora grub funziona ma mentre win 10 e' ok ubuntu non funziona...schermo viola con qualche riga colorata e basta. E' un problema di drivers nvidia non riconosciuti che al cambio della video mi hanno fatto smanettare per essere sistemati. Ora da live posso aggiornare i drivers proprietari ma ovviamente dopo averli caricati mi chiede di fare restart...quindi il mio problema ora e' come caricarli nella live per installarli con ubuntu...mi sapete aiutare? Grazie
I driver non li devi installare dalla live, ma a sistema installato, quando avvii Ubuntu ed hai la schermata viola, premi i tasti ctrl + alt + f2, fai il login e rimuovi i driver NVIDIA:
Codice:
sudo apt --purge autoremove nvidia*
al termine riavvia:
Codice:
reboot
Se si avvia normalmente Ubuntu, apri il menu e cerca "driver aggiuntivi" installa i più recenti.
 

Entra

oppure Accedi utilizzando