Sciopero partizioni ntfs

nico.linux

Utente Attivo
225
0
Il mio problema è questo:

Ero riusciuto a montare e configurare tutte le partizioni esistenti sul mio pc, anche quelle con file system ntfs. Ma quando ho voluto provare a creare dei collegamenti di queste sul desktop si sono smontate e non ne vogliono sapere di rimontarsi.

Quindi ho provato a rifare la procedura con cui ero riuscito a configurarle ma quando vado a fare
Codice:
sudo mount -a
dopo aver fatto
Codice:
sudo umount -a
mi visualizza questo output
Codice:
nico@ubuntu:~$ sudo mount -a
fusermount: mountpoint is not empty
fusermount: if you are sure this is safe, use the 'nonempty' mount option
Retrying mount ...
fusermount: mountpoint is not empty
fusermount: if you are sure this is safe, use the 'nonempty' mount option
Failed to mount NTFSUnmounting /dev/hda1 (Windows XP)
fusermount: mountpoint is not empty
fusermount: if you are sure this is safe, use the 'nonempty' mount option
Retrying mount ...
fusermount: mountpoint is not empty
fusermount: if you are sure this is safe, use the 'nonempty' mount option
Failed to mount NTFSUnmounting /dev/sda1 (NTFS Sata)

Windows XP e NTFS Sata sono le Etichette che uso in win xp per identificare le duw partizioni. Etichette che nulla centrano con quelle impostate su kubuntu come vedrete sotto nel mio fstab

Codice:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/hda3
UUID=e5b0ef30-4380-4ba6-94ca-f1fbff191d59 /               ext3    defaults,errors=remount-ro 0       1
# MOUNT DEI DISCHI FISSI NTFS con ntfs-3g
/dev/hda1 /media/windows ntfs-3g defaults,locale=it_IT.utf8 0 0
/dev/sda1 /media/ntfs_sata ntfs-3g defaults,locale=it_IT.utf8 0 0
# MOUNT PRECEDENTE A NTFS-3G
# /dev/hda1
# UUID=FCE0D5CEE0D58EF0 /media/windows     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
# /dev/sda1
# UUID=149086069085EE94 /media/ntfs_sata     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
# /dev/hda5
UUID=01D2-01D2  /media/incoming  vfat  defaults,utf8,umask=000,uid=1000,gid=46  0  0
# /dev/hdb1
UUID=3203-3207  /media/backup160gb     vfat    defaults,utf8,umask=007,gid=46 0       1
# /dev/sda3
UUID=2d222f6f-b002-419c-bb5a-167fed00a3b2  /media/ext3_sata  ext3  defaults  0  0
# /dev/sda5
UUID=45FB-B89D  /media/dati_sata  vfat  defaults,utf8,umask=000,uid=1000,gid=46  0  0
# /dev/hda2
UUID=a9f57480-68e1-4f0b-925a-71f07c77a25a none            swap    sw              0       0
# /dev/sda2
UUID=e7983d00-da07-43e1-96c0-0192bd5b23a9 none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0           /media/floppy  auto    rw,user,noauto  0       0

Come posso fare per risolvere questo problema e tornare a gestire le mie partizioni ntfs da kubuntu?
 

AMD64

Utente Èlite
3,808
19
CPU
Intel Core 2 Duo T9400
HDD
300GB
RAM
4GB
GPU
Nvidia GeForce 9600 M GT
OS
Kubuntu 10.04 x86_64 - Windows 7 x64
Forse gli uuid creano qualche problema, riprova così.
Codice:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda3 /               ext3    defaults,errors=remount-ro 0       1
# MOUNT DEI DISCHI FISSI NTFS con ntfs-3g
/dev/hda1 /media/windows ntfs-3g defaults,locale=it_IT.utf8 0 0
/dev/sda1 /media/ntfs_sata ntfs-3g defaults,locale=it_IT.utf8 0 0
# MOUNT PRECEDENTE A NTFS-3G
# /dev/hda1
# UUID=FCE0D5CEE0D58EF0 /media/windows     ntfs    defaults,nls=utf8,umask=007,gid=46 0       0
# /dev/sda1
# UUID=149086069085EE94 /media/ntfs_sata     ntfs    defaults,nls=utf8,umask=007,gid=46 0       0
/dev/hda5 /media/incoming  vfat  defaults,utf8,umask=000,uid=1000,gid=46  0  0
/dev/hdb1 /media/backup160gb     vfat    defaults,utf8,umask=007,gid=46 0       0
/dev/sda3 /media/ext3_sata  ext3  defaults  0  0
/dev/sda5 /media/dati_sata  vfat  defaults,utf8,umask=000,uid=1000,gid=46  0  0
/dev/hda2 none            swap    sw              0       0
/dev/sda2 none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0           /media/floppy  auto    rw,user,noauto  0       0
ma prima con ntfs3g funzionavano?

Comunque ho cambiato anche i valori PASS per le partizioni non linux, i controlli alle partizioni fat e ntfs deve farli windows, così dovresti avere anche un boot leggermente + veloce.
 

nico.linux

Utente Attivo
225
0
Innanzitutto auguri di buone feste pasquali a tutti.

Si.. prima funzionavano perfettamente con ntfs3g. potevo leggere, scrivere e naturalmente eseguire.

Ma il fatto è che non ho toccato fstab da quando l'ho modificato per ntfs3g..

Tutto è successo quando sono diventato root per cambiare le icone dei collegamenti sul desktop.

Siccome che non mi piaceva vedere l'icona a forma di cartella per indicare le partizioni su desktop le volevo cambiare con quelle che indicavano i dispositivi. Da utente normale ero riuscito a cambiare tutti tranne quelli relativi alle partizioni ntfs che ho cambiato diventando root e agendo sui collegamenti nella cartella desktop nella home utente.

Prima di fare questo avevo però smontato tutto ma quando sono andato a rimontare le partizioni ntfs non si erano rimointate e da allora sto cercando una soluzione per questo.
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 36 22.8%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 101 63.9%
  • Square Enix

    Voti: 13 8.2%
  • Capcom

    Voti: 7 4.4%
  • Nintendo

    Voti: 21 13.3%
  • Altro (Specificare)

    Voti: 15 9.5%

Discussioni Simili