Samsung 970 Pro Mac problem

Rioda

Nuovo Utente
2
0
Salve a tutti, ho ben pensato di sostituire l'SSD del mio Macbook con un SSD M.2 Samsung 970 Pro da 512Gb, ho acquistato anche un adattatore (sotto link degli articoli), ma ho riscontrato diversi problemi alla quale vorrei trovare una soluzione.

- Ho creato una Pen drive con l'installar di Catalina e quando ho montato l'SSD nuovo ho avviato il Macbook tenendo premuto Alt e successivamente procedendo all'inizializzazione del disco e l'installazione del S.O.
- Ho cominciato ad installare i programmi che mi servono per lavorare e dopo un bel po di utilizzo, quasi a sera, mi si riavvia e mi da un Kernel Panic.
Non facendoci caso, continuo a fare il mio col pc e decido di andare a letto.
- Vado a letto e l'indomani all'avviare il pc non mi si accendeva, schermata nera, nessun logo, nessun suono ma solo le ventole accese. Ho provato tutti i tentativi possibili di riavvio e rese PRAM, SMC, trick e track, ma nulla... provo ad inserire il vecchio disco e parte senza problemi, provo ad avviare l'unità senza nessun disco e ovviamente il sistema mi dice che non è stato rilevato nessun disco di avvio tramite la cartella col punto interrogativo. Poco dopo, non dandomi per vinto riprovo i vari modi di avvio con l'SSD 970 pro e dopo svariati tentativi si avvia e mi da un errore di Kernel Panic.
- Non dandoci peso continuo ad utilizzare il pc e dopo un poco che era in pausa non si è accendeva più, stesso fatto quanto scritto nel rigo sopra, stessi segnali.. monto, rimonto, provo varie combinazioni di tasti e alla fine si avvia.
- Così decido di documentarmi meglio sul KP e riscontro, forse a fortuna, che il problema era uTorrent Web. Mi presto a disinstallarlo ed effittivamente il problema finora non si è più ripresentato, ma quando il Macbook viene spento, sospeso o messo in stop per un periodo medio lungo, questo non vuole saperne di accendersi.
- Rimonto il vecchio SSD e funziona di cartella, ci lavoro e mi documento su questo accaduto, andando a trovare un forum che parlava di agire sul terminale in merito all'ibernazione.. così rimetto il 970 Pro e a primo colpo si accende, la prima cosa che faccio e agire sul terminale con i codici e anche questo problema sembra risolto. Faccio svariati test di spegnimento, riavvio con diverse pause, anche lunghe ma il computer si accende e si spegne come se nulla fosse.
A questo punto decido di dedicarmi alle prestazioni del nuovo SSD e "magicamente" lettura e scrittura non superano i 730/760 mb/s con TRIM attivato.
Faccio il reset Dell PRAM e il benchmark arriva a 1600 mb/s ma è tanto quando il vecchio SSD e dichiarati il 970 PRO ne ha sui 3.000 mb/s .. strano!
Decido montare il vecchio SSD e fare il benchmark ed effettivamente è di poco superiore a 1700 mb/s ... rimonto il 970 PRO e questo non mi si avvia come successo in precedenza.. di nuovo schermo nero, nessun segnale e solo le ventole accese.

A questo punto chiedo a vo: come faccio a risolvere i problemi legati all'avvio dell'SSD 970 Pro e successivamente delle sue prestazioni?
Premetto che l'SSD è compatibile con la mia unità in quanto anche sul tubo girano video di upgrade e benchmark con i miei stessi dispositivi.. Help!

MacBook Pro 15" Retina mid 2015 A1398 - 11,5
SSD:
https://www.amazon.it/gp/product/B07CJ3RVP3/?tag=tomsforum-21&linkCode=ogi
Adattatore: https://www.amazon.it/gp/product/B0788CKXJZ/?tag=tomsforum-21&linkCode=ogi

Guida sull'Ibernazione che ho eseguito, ho eseguito solo Disable Hibernations, e la pubblico nel caso ci capiste voi qualcosa di più o può tornarvi utile:
 

iotiaiuto2020

Nuovo Utente
12
3
Il problema non è l'SSD, il problema è che stai usando un adattatore! Questi SSD vanno connessi direttamente alla scheda madre, altrimenti danno solo che problemi. È come comprare una ferrari e andarci di seconda!
 

Entra

oppure Accedi utilizzando

Hot del momento