PROBLEMA [[RISOLTO] Problema installazione driver chiavetta wifi ArchLinux

131Diamond074

Nuovo Utente
50
2
Hardware Utente
CPU
i5-7400
Scheda Madre
asrock pro4 z170
Buongiorno a tutti,
Ho installato da poco arch linux, con DE Gnome. Trelasciando il fatto che non mi permette di installare l'interfaccia di rete (Non è grave perchè si può sostituire con il terminale), non mi installa i driver della chiavetta wifi dal suo cd.
Quando eseguo il file .sh da terminale (anche da root) mi dà l'errore riportato in foto.
20181027_105448.jpg

Non ho idea di cosa fare, perchè questa cosa mi rende impossibile sare quel sistema dato che sarei senza connessione.

Inoltre se provo a spostare le foto da una partizione del disco (questa con Arch) all' altra(Windows 10) mi dice che non ho i permessi nonostante io lo faccia da root.
20181027_105524.jpg

P.S. Con il cavo ethernet funziona
Grazie in anticipo a tutti per l'aiuto
 

Giacomo Furlan

Utente Attivo
268
65
Hardware Utente
CPU
AMD Ryzen 2700x
Dissipatore
BeQuiet! SilentLoop 360mm
Scheda Madre
Gigabyte X470 AORUS Gaming 7 WIFI AMD X470
Hard Disk
Corsair MP500 480GB
RAM
G.Skill Trident F4-3600C16D-16GTZ 16GB DDR 4 @ 3600 Mhz (XMP profile)
Scheda Video
MSI GeForce GTX 970 Gaming 4G
Scheda Audio
Focusrite Saffrire 6 USB
Monitor
AOC Professional U3477PQU 34" 21:9
Alimentatore
EVGA SuperNOVA 650 G3, 80 Plus GOLD 650W
Case
Sharkoon TG5
Sistema Operativo
Windows 10, Fedora 28
Come sopra per i driver. Non conoscendo ArchLinux non so se utilizzi ntfs-3g, oppure l'implementazione read-only del FS NTFS. In ogni caso se vuoi accedere alla partizione Windows in read/write (e non solo read) necessiti di un driver r/w (come appunto ntfs-3g) ed un unmount "pulito" (secondo i parametri dei file di indice di NTFS) (es. avviando Windows e spegnere il PC normalmente)... attenzione che a volte quando ci sono degli aggiornamenti in sospeso Windows non ti fa un unmount "pulito". Puoi sempre forzare il mount, ma c'è un avviso grande quanto una casa che ti dice che non è un buon modo.
 
  • Mi piace
Reactions: 131Diamond074

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,365
1,586
Hardware Utente
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
windows 10 lascia il disco in ibernazione, linux giustamente lo monta in RO e non lo legge , i driver del tuo wifi sono su aur
 
  • Mi piace
Reactions: 131Diamond074

Zar Marco

Utente Attivo
395
76
Hardware Utente
CPU
Intel I7 7700HQ
Hard Disk
Samsung M2 960 EVO NVMe 500GB, SSD Samsung 860 evo 1 Tb
RAM
24 Gb DDR4 2400 Mhz
Scheda Video
Nvidia GTX 1050
Sistema Operativo
Arch Linux--Gentoo--Void--Windows
Ma hai abilitato il tuo utente all'uso di sudo?
Comunque come detto da @centoventicinque potrebbe essere un errore causato dall'ibernazione di Windows 10, ma per questa affermazione vorrei vedere cosa ti dice il teminale se provi a montare la partizione di win. Detto ciò ntfs-3g devi averlo installato

Inviato da CLT-L09 tramite App ufficiale di Tom\'s Hardware Italia Forum
 
  • Mi piace
Reactions: 131Diamond074

131Diamond074

Nuovo Utente
50
2
Hardware Utente
CPU
i5-7400
Scheda Madre
asrock pro4 z170
Innanzitutto grazie a tutti per le risposte e scusate se rispondo solo ora ma in questi giorni non ho potuto provare.
E' da stamattina che sto provando ad installare i driver ma la risposta è questache vedete in foto.
Per windows è sicuramente come dite voi, il pc lo avevo riavviato e non spento prima di aprire Arch
Schermata da 2018-11-04 09-14-12.png


Ho inoltre provato (prima di installare i driver rtl) ad installare dkms, ma la risposta è questa:
Schermata da 2018-11-04 09-22-29.png
 
Ultima modifica:

« MoMy »

Utente Attivo
1,165
548
Hardware Utente
Dovresti averlo già installato il pacchetto dkms anche perché è una dipendenza del pacchetto AUR per i moduli che cerchi di installare.
pkgname=rtl8821au-dkms-git
_pkgbase=rtl8821au
pkgver=5.1.5.r59.gaf07b27
pkgrel=1
pkgdesc="rtl8821AU, rtl8812AU and rtl8811AU chipset driver with firmware v5.1.5"
arch=('i686' 'x86_64')
url="https://github.com/zebulon2/rtl8812au/tree/v5.1.5"
license=('GPL2')
depends=('dkms' 'bc')
comunque...
posta il risultato del comando #pacman -Q linux-headers dkms bc
 

« MoMy »

Utente Attivo
1,165
548
Hardware Utente
sudo pacman -S linux-headers e poi installa il pacchetto che hai compilato con sudo pacman -U /percorso/completo/pacchetto_che_hai_compilato
In caso ricompila.
 
Ultima modifica:

131Diamond074

Nuovo Utente
50
2
Hardware Utente
CPU
i5-7400
Scheda Madre
asrock pro4 z170
Spè che accendo la sfera magica, ci vuole un po' che si scaldi, sai è un diesel del '85. :asd:
ahahaha

comunque ammesso che, dato che non sono stati segnalati errori sia andata bene, comunque continua a non riconoscerla nelle periferiche di rete, questo è quello che mi esce con i comandi consigliati dalle guide su arch:
 

Allegati

« MoMy »

Utente Attivo
1,165
548
Hardware Utente
Abilita il modulo con modprobe e poi controlla se la scheda è vista. Ip link, iw, iwconfig, dhcpcd per verificare, abilitare la scheda. Infine, posta info testuali con relativi comandi e non le immagini. Tnx^^
 
  • Mi piace
Reactions: 131Diamond074

Entra

oppure Accedi utilizzando