[RISOLTO] Asus F2A A85 V PRO problema Audio

ShinoK

Nuovo Utente
98
6
CPU
AMD - A10-6800K - 4,4 GHz BE /w Noctua dual fan
Scheda Madre
Asus F2A A85 V PRO
HDD
OCZ SSD Agility 3 60 Gb (+ 4 HDD WD ) total 7 Tb internal + 1,5 TB external
RAM
Crucial Ballistix Elite da 2 x 4 GB DDR3-1866 PC3-14900 CL9
GPU
Sapphire R7 250x 1g Gddr5 Vapor-x
Audio
Realtek® ALC892 8-Channel High Definition Audio CODEC /w Onkyo HT - R538
Monitor
Sony Bravia KDL32L4000 (32)
PSU
Corsair CMPSU-750TW - 750W
Case
AEROCOOL Strike X-Xtreme black /w Noctua fans
OS
Windows 7 Professional sp1+openSUSE 13.1
Schema_pc.jpg
Salve a tutti,il mio problema e' il seguente:
Premetto che prima di sostituire i vari pezzi funzionava tutto a dovere e l'ho ritestato mettendo il vecchio pc in un'altro case e provandolo e funziona come dovrebbe. Il che significa che qualsiasi cosa usi come monitor l'audio esce sempre e cmq dall'uscita SPDIF. Mentre con il nuovo sistema mi da' il problema che vi spiego.

L'uscita Ottica e' nella scheda madre, l'HDMI e' collegato alla scheda video nello schema (non quella della scheda madre).
Quando ho la TV accesa e lo uso come monitor del pc devo per forza di cose selezionare l'uscita HDMI per l'audio sia dal programma audio della asus che nel SO che nel lettore (MPC-HC) e non mi permette l'uso dello SPDIF. Anche se seleziono l'uscita ottica e la metto predefinita non si sente nulla. Se clicco su prova vedo le barrette che si muovono ma l'audio non si sente (quindi secondo il SO sta funzionando e riceve il segnale).
Se pero' la spengo o passo all'altro monitor non si sente piu' nulla in nessun modo neanche cambiando e mettendo predefinite le altre opzioni.
Se riavvio il PC con la TV spenta e quindi come monitor uso il philips fin dall'inizio (vedi schema sopra) l'audio passa automaticamente allo SPDIF e si sente come dovrebbe (ma nel lettore devo cambiare dall'hdmi all'ottico se no non si sente nulla). Il che significa che lo SPDIF funziona.
Nel momento in cui accendo la TV per passare dal monitor alla TV,smette di funzionare e non c'e piu' l'audio a meno di non cambiare manualmente e usare l'uscita HDMI dappertutto.
Se voglio tornare a usare il monitor philips e spengo la TV non si sente piu' nulla in nessun modo neanche cambiando periferica a meno di non riavviare con solo il monitor philips acceso.
Ho reinstallato il SO due volte,provato con e senza driver ma da sempre quel problema. Ho speso un paio d'ore a cercare in rete e non ho trovato nessuno con questo problema e non so piu' che pesci pigliare.
Riassumendo:

PC Acceso con solo philips l'ottico funziona.
PC Acceso con solo philips ---> passaggio dal philips alla TV Sony devo usare come periferica l'hdmi o non si sente piu' nulla.
PC Acceso con solo TV Sony ---> passaggio dalla TV al Philips perdita completa dell'audio anche cambiando uscita/periferica a meno di un riavvio con solo philips acceso.

Mi sembra di capire che in qualche modo quando effettuo il passaggio dal monitor alla TV l'ottica venga disabilitata e non viene ripristinata al successivo passaggio.Ma non capisco il perche' e non ho trovato opzioni che facciano questo.
P.S. Bios/chipset e Windows sono aggiornati.
 
Ultima modifica:

serassone

UTENTE LEGGENDARIO
Utente Èlite
29,197
8,574
CPU
Core i5 3570K
Dissipatore
Noctua NH-U9B SE2
Scheda Madre
Gigabyte GA-Z77X-UD3H
HDD
Crucial MX500 500 GB | Crucial MX500 1 TB | WD Blue 1 TB | 2 x WD Green 3 TB
RAM
2 x 8 GB DDR3 1866 Corsair Vengeance
GPU
nVidia GT 1030
Audio
VIA integrata
Monitor
Asus VW246H 24" 1920x1080
PSU
Enermax MODU87+ 500W
Case
CoolerMaster Stacker
OS
Windows 10 Pro x64
Re: Asus F2A A85 V PRO problema Audio

Il monitor dove è collegato, alla scheda madre? Se è così, prova a collegarlo alla scheda grafica tramite adattatore DVI-VGA. Potresti anche provare a collegare il pc al ricevitore Onkyo tramite DVI, con un cavo HDMI-DVI, o con un adattatore, in modo da inviare il solo flusso video.
 

ShinoK

Nuovo Utente
98
6
CPU
AMD - A10-6800K - 4,4 GHz BE /w Noctua dual fan
Scheda Madre
Asus F2A A85 V PRO
HDD
OCZ SSD Agility 3 60 Gb (+ 4 HDD WD ) total 7 Tb internal + 1,5 TB external
RAM
Crucial Ballistix Elite da 2 x 4 GB DDR3-1866 PC3-14900 CL9
GPU
Sapphire R7 250x 1g Gddr5 Vapor-x
Audio
Realtek® ALC892 8-Channel High Definition Audio CODEC /w Onkyo HT - R538
Monitor
Sony Bravia KDL32L4000 (32)
PSU
Corsair CMPSU-750TW - 750W
Case
AEROCOOL Strike X-Xtreme black /w Noctua fans
OS
Windows 7 Professional sp1+openSUSE 13.1
Re: Asus F2A A85 V PRO problema Audio

In effetti mi sono scordato di spiegare dove sono collegati.
Entrambi sono collegati alla scheda video non alla scheda madre.
Mentre l'ottico e' parte del sistema audio della scheda madre.
La tv e' connessa via HDMI (che passa prima dal ricevitore, HDMI dal pc al ricevitore --> e dal ricevitore alla tv tramite HDMI) il monitor philips e' connesso direttamente tramite adattatore dvi -> vga.
 

serassone

UTENTE LEGGENDARIO
Utente Èlite
29,197
8,574
CPU
Core i5 3570K
Dissipatore
Noctua NH-U9B SE2
Scheda Madre
Gigabyte GA-Z77X-UD3H
HDD
Crucial MX500 500 GB | Crucial MX500 1 TB | WD Blue 1 TB | 2 x WD Green 3 TB
RAM
2 x 8 GB DDR3 1866 Corsair Vengeance
GPU
nVidia GT 1030
Audio
VIA integrata
Monitor
Asus VW246H 24" 1920x1080
PSU
Enermax MODU87+ 500W
Case
CoolerMaster Stacker
OS
Windows 10 Pro x64
Re: Asus F2A A85 V PRO problema Audio

Ok, lo schema che hai postato è chiaro, l'unico dubbio era il monitor. ;) Potresti provare a collegare la seconda presa DVI al ricevitore, tramite cavo DMI -> HDMI. In questo modo verrebbe veicolato solo il flusso video, perché il DVI non è abilitato per i flussi audio.
 

ShinoK

Nuovo Utente
98
6
CPU
AMD - A10-6800K - 4,4 GHz BE /w Noctua dual fan
Scheda Madre
Asus F2A A85 V PRO
HDD
OCZ SSD Agility 3 60 Gb (+ 4 HDD WD ) total 7 Tb internal + 1,5 TB external
RAM
Crucial Ballistix Elite da 2 x 4 GB DDR3-1866 PC3-14900 CL9
GPU
Sapphire R7 250x 1g Gddr5 Vapor-x
Audio
Realtek® ALC892 8-Channel High Definition Audio CODEC /w Onkyo HT - R538
Monitor
Sony Bravia KDL32L4000 (32)
PSU
Corsair CMPSU-750TW - 750W
Case
AEROCOOL Strike X-Xtreme black /w Noctua fans
OS
Windows 7 Professional sp1+openSUSE 13.1
Re: Asus F2A A85 V PRO problema Audio

Purtroppo non posso per 2 ragioni.Una e' che il pc e' nella stanza adiacente e dovrei spostare tutto.Ora come ora e' collegato tramite un cavo HDMI a tripla schermatura e contatti in oro di 7 metri per arrivare al ricevitore,stessa cosa per il cavo ottico.Il monitor philips e' solo vga e anche li' e' collegato tramite un cavo rgb (perche' il monitor ha solo quella) della stessa lunghezza ma va alla parete opposta dove ho la scrivania.Mi servirebbe un'altro adattatore da dvi a hdmi oltre a quello vga-->dvi che non ho. E lo controllo tramite un blocco che ha pulsante di accensione/reset,due porte usb e attacco per microfono e cuffie. E cmq il problema e': perche' se collego il vecchio pc funziona come dovrebbe e in quello nuovo no ? I cavi sono gli stessi,gli ingessi/uscite sono gli stessi,cambia l'hardware (scheda madre/video).
Sto ancora spulciando ogni informazione che trovo ...ma non vedo nessuna opzione che per esempio dia controllo assoluto all'HDMI disabilitando lo spdif (e successivamente non riattivarlo).
 

serassone

UTENTE LEGGENDARIO
Utente Èlite
29,197
8,574
CPU
Core i5 3570K
Dissipatore
Noctua NH-U9B SE2
Scheda Madre
Gigabyte GA-Z77X-UD3H
HDD
Crucial MX500 500 GB | Crucial MX500 1 TB | WD Blue 1 TB | 2 x WD Green 3 TB
RAM
2 x 8 GB DDR3 1866 Corsair Vengeance
GPU
nVidia GT 1030
Audio
VIA integrata
Monitor
Asus VW246H 24" 1920x1080
PSU
Enermax MODU87+ 500W
Case
CoolerMaster Stacker
OS
Windows 10 Pro x64
Re: Asus F2A A85 V PRO problema Audio

Purtroppo la causa è identificata, la nuova scheda madre, e a distanza non posso che dare indicazioni generiche. Ribadisco però che la prova si potrebbe fare, basterebbe procurarsi un adattatore di questo tipo:

CrazyCable® Premium Adattatore DVI-D su HDMI placcato in oro 24k supporta risoluzioni 720i/720p/1080i/1080p ideale per Samsung Smart TV, PC Windows, Mac, e molti altri: Amazon.it: Informatica

non mi sembra una spesa folle. Immagino che i driver audio siano aggiornati, prova però a visitare il sito Asus e vedi se ce ne sono di più nuovi. Potresti anche provare con i driver Realtek, scaricabili direttamente dal loro sito:

Realtek
 
  • Like
Reactions: ShinoK

ShinoK

Nuovo Utente
98
6
CPU
AMD - A10-6800K - 4,4 GHz BE /w Noctua dual fan
Scheda Madre
Asus F2A A85 V PRO
HDD
OCZ SSD Agility 3 60 Gb (+ 4 HDD WD ) total 7 Tb internal + 1,5 TB external
RAM
Crucial Ballistix Elite da 2 x 4 GB DDR3-1866 PC3-14900 CL9
GPU
Sapphire R7 250x 1g Gddr5 Vapor-x
Audio
Realtek® ALC892 8-Channel High Definition Audio CODEC /w Onkyo HT - R538
Monitor
Sony Bravia KDL32L4000 (32)
PSU
Corsair CMPSU-750TW - 750W
Case
AEROCOOL Strike X-Xtreme black /w Noctua fans
OS
Windows 7 Professional sp1+openSUSE 13.1
Re: Asus F2A A85 V PRO problema Audio

Ho trovato una "quasi-soluzione", disabilitando disabilita.jpg questi 2 l'audio rimane attivo sullo SPDIF. Quello che mi chiedo pero' e' perché se li disabilito dalla gestione dell'audio (che sia il programma della Asus o di Windows) e anche settandolo predefinito,nel momento che accendo la TV passa all'HDMI e non c'è verso di cambiarlo.Ne' ho trovato alcuna opzione che mi spieghi perché si comporta cosi'. Il chipset audio e' lo stesso (forse una versione o due precedente) nella vecchia scheda madre e se non ricordo male c'erano anche li',ma non li ho mai toccati.Il semplice fatto che setto predefinita una delle uscite dovrebbe essere sufficiente,non vedo perché devo andare in gestione dispositivi e disabilitarli da li' (visto che anche disabilitandoli dalla gestione audio di Windows non succedeva nulla). O perlomeno dovrebbe essere documentata da qualche parte.
Anche volendo rimandarla indietro non avrei saputo come spiegare il problema e non sono sicuro sarebbe stato accettato come difetto/problema.
L'importante e' che comunque sembra funzionare....ma sono quasi dieci giorni che mi scervello per una cosa cosi' :grat: e' abbastanza assurdo.

Grazie per l'interessamento e le risposte.


P.S. avevo gia' provato con i drivers base Realtek (non quelli forniti dalla Asus) ma non era cambiato nulla.
 
Ultima modifica:

serassone

UTENTE LEGGENDARIO
Utente Èlite
29,197
8,574
CPU
Core i5 3570K
Dissipatore
Noctua NH-U9B SE2
Scheda Madre
Gigabyte GA-Z77X-UD3H
HDD
Crucial MX500 500 GB | Crucial MX500 1 TB | WD Blue 1 TB | 2 x WD Green 3 TB
RAM
2 x 8 GB DDR3 1866 Corsair Vengeance
GPU
nVidia GT 1030
Audio
VIA integrata
Monitor
Asus VW246H 24" 1920x1080
PSU
Enermax MODU87+ 500W
Case
CoolerMaster Stacker
OS
Windows 10 Pro x64
Il driver AMD audio non si riferisce né al chipset né al codec audio (ovviamente, essendo Realtek), bensì alla scheda grafica; l'output HDMI della Sapphire, essendo abilitato a veicolare flussi audio, possiede un proprio driver di questo tipo; a maggior ragione continuo a pensare che utilizzando l'uscita DVI, tramite adattatore, il problema potrebbe essere risolto. Se però hai risolto in questo modo, bene così. ;)
 

ShinoK

Nuovo Utente
98
6
CPU
AMD - A10-6800K - 4,4 GHz BE /w Noctua dual fan
Scheda Madre
Asus F2A A85 V PRO
HDD
OCZ SSD Agility 3 60 Gb (+ 4 HDD WD ) total 7 Tb internal + 1,5 TB external
RAM
Crucial Ballistix Elite da 2 x 4 GB DDR3-1866 PC3-14900 CL9
GPU
Sapphire R7 250x 1g Gddr5 Vapor-x
Audio
Realtek® ALC892 8-Channel High Definition Audio CODEC /w Onkyo HT - R538
Monitor
Sony Bravia KDL32L4000 (32)
PSU
Corsair CMPSU-750TW - 750W
Case
AEROCOOL Strike X-Xtreme black /w Noctua fans
OS
Windows 7 Professional sp1+openSUSE 13.1
Si si,ma la cosa che mi stupisce e' che anche nel catalyst avevo contrassegnato l'uscita ottica come predefinita e non ci sono altre opzioni che mettano in preferenza l'hdmi rispetto all'ottico. Anche se ora avendoli disabilitati non c'è più la sezione audio nel catalyst e forse per questo lo spdif funziona con tutti i monitor. Quindi la nuova scheda video ha funzioni che la vecchia non aveva. Per esempio seppure la TV risultava come monitor nell'elenco delle periferiche una volta settato come predefinito lo spdif lo applicava e basta,inoltre non c'era la sezione audio cosa che c'è in questa ( e i driver erano gli stessi visto che erano usciti ben prima che la sostituissi e stavo già usando quella release anche nella precedente). In definitiva il "problema" sembra essere dettato dalla scheda grafica e da quelle funzioni in più che in maniera interna da' preferenza all'HDMI (perché non c'era nessuna opzione mi chiedesse niente del genere) ma poi non la "restituisce" ,non funzionando proprio più a meno di non tornare sulla tv o di riavviare con solo il philips acceso.
E' stato proprio quello a farmi pensare di provare a disabilitarle,la nuova sezione.
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 13 15.5%
  • Gearbox

    Voti: 1 1.2%
  • Xbox & Bethesda

    Voti: 59 70.2%
  • Square Enix

    Voti: 3 3.6%
  • Capcom

    Voti: 5 6.0%
  • Nintendo

    Voti: 13 15.5%
  • Altro (Specificare)

    Voti: 6 7.1%

Discussioni Simili