Query excel database

Kusaki

Utente Attivo
325
85
Hardware Utente
CPU
CPU Intel 1150 i5-4690K Ci5 Box (3,5GHz)
Scheda Madre
AS Rock Z97 Pro4
Hard Disk
Samsung EVO 860 250GB
RAM
Corsair Vengeance DDR3 1600 2x8 GB
Scheda Video
Nvidia GTX 1060 6GB
Alimentatore
Thermaltake Berlin 630W
Case
Corsair Carbide 200R
Sistema Operativo
Windows 10 Pro
Ciao Ragazzi
Vorrei creare un programmino che mi permette di cercare, mediante una query, un codice numerico in più liste.

Banalmente ipotizziamo io debba cercare un codice prodotto....vorrei poter inserire il codice e il programmino cercare su 3 file Excel diversi (per esempio i Magazzini) e restituire true o false come esito per ogni Magazzino. (es. Magazz. 1 False Magazz 2 False Magazz 3 True)

Si può fare con Excel? Altri modi?
 

BaldosArts

Utente Èlite
2,449
656
Hardware Utente
CPU
Intel Core i5 3570
Dissipatore
Zalman CNPS 9500 Led
Scheda Madre
ASRock z77 Extreme4
Hard Disk
SSD SanDisk Plus 480GB + SSD Samsung 830 128GB + HDD Toshiba P300 1TB
RAM
(2x8) 16GB Corsair Vengeance 1600MHz cl9
Scheda Video
Gigabyte GTX 750ti
Scheda Audio
integrata 7.1
Monitor
23" IPS DELL U2312HM
Alimentatore
Corsair CX550M semimodulare
Case
Cooler Master CM690 II USB3.0
Periferiche
Multifunzione HP OfficeJet 6950
Internet
FTTC TIM
Sistema Operativo
Windows 7 64bit
se vuoi fare tutto in Excel puoi usare la funzione CERCA.VERT(<dato>;<matrice>;<colonna>;<true/false>)
dove la <matrice> è tutto il foglio del magazzino che può essere anche su un file xls diverso.
 
  • Mi piace
Reactions: Kusaki

Kusaki

Utente Attivo
325
85
Hardware Utente
CPU
CPU Intel 1150 i5-4690K Ci5 Box (3,5GHz)
Scheda Madre
AS Rock Z97 Pro4
Hard Disk
Samsung EVO 860 250GB
RAM
Corsair Vengeance DDR3 1600 2x8 GB
Scheda Video
Nvidia GTX 1060 6GB
Alimentatore
Thermaltake Berlin 630W
Case
Corsair Carbide 200R
Sistema Operativo
Windows 10 Pro
se vuoi fare tutto in Excel puoi usare la funzione CERCA.VERT(<dato>;<matrice>;<colonna>;<true/false>)
dove la <matrice> è tutto il foglio del magazzino che può essere anche su un file xls diverso.
In ufficio usiamo office 2014/2015, che tu sappia si può fare il CERCA.VERT su più fogli?
L'ideale per me sarebbe avere 1 foglio diverso per ogni Magazzino, ma utilizzare un unica query di ricerca.

Una cosa di questo tipo:
screen_excel.png

Non sono pratico di Excel, ho una conoscenza molto molto basic del software, ma urge trovare una soluzione simile in ufficio.
 
Ultima modifica da un moderatore:

BaldosArts

Utente Èlite
2,449
656
Hardware Utente
CPU
Intel Core i5 3570
Dissipatore
Zalman CNPS 9500 Led
Scheda Madre
ASRock z77 Extreme4
Hard Disk
SSD SanDisk Plus 480GB + SSD Samsung 830 128GB + HDD Toshiba P300 1TB
RAM
(2x8) 16GB Corsair Vengeance 1600MHz cl9
Scheda Video
Gigabyte GTX 750ti
Scheda Audio
integrata 7.1
Monitor
23" IPS DELL U2312HM
Alimentatore
Corsair CX550M semimodulare
Case
Cooler Master CM690 II USB3.0
Periferiche
Multifunzione HP OfficeJet 6950
Internet
FTTC TIM
Sistema Operativo
Windows 7 64bit
certo, basta mettere la funzione su tutte e tre le caselle D5, D6, D7 ognuna che cerca in un foglio diverso.
Forse dovrai abbinarlo alla funzione SE per restituire TRUE/FALSE. adesso vedo come puoi farlo , ma io ho Libreoffice...
=SE(CERCA.VERT($D$3;mag1!$A$2:$B$7;2)=0;"true";"false")
la sintassi può essere diversa tra office e libreoffice
 
Ultima modifica:
  • Mi piace
Reactions: Kusaki

paperoful

Utente Attivo
313
48
Hardware Utente
Sistema Operativo
Windows XP
La funzione cerca.vert completa risulterebbe
CERCA.VERT($D$3;mag1!$A$2:$B$7;2;FALSO)
e restituirebbe il valore trovato nella colonna B del mag1, oppure restituirebbe #N/D in caso negativo. Se vuoi che le risposte siano proprio TRUE o FALSE devi abbinare la funzione SE e la funzione SE.ERRORE, quindi
=SE.ERRORE(SE(CERCA.VERT($D$3;'MAG1'!$A:$A;1;FALSO)=$D$3;"TRUE");"FALSE")
In pratica ricerca il codice in MAG1 col.A se lo trova confronta che il valore trovato sia uguale a quello in D3. La risposta può essere solo positiva quindi TRUE. Se invece non lo trova da un messaggio di errore (#N/D) che la funzione SE.ERRORE trasforma in FALSE.
 

Entra

oppure Accedi utilizzando