Problemi vari anaconda Ubuntu 18.04 LTS

enricovela

Utente Attivo
185
49
Hardware Utente
CPU
Ryzen 3600
Dissipatore
Stock
Scheda Madre
MSI Gaming plus max x470
Hard Disk
970 evo plus
RAM
16 GB @3000 MHz
Scheda Video
RX 5700 Pulse
Alimentatore
Straight power 11 650 W
Case
Cooler Master MB510L
Sistema Operativo
Ubuntu 18 / Windows 10
Su Ubuntu 18.04 è preinstallato solo python 3 e non python 2.

Siccome uso anche python 2.7, ho pensato(forse male) di installarlo direttamente con Anaconda.

Ora se scrivo qualche programmino in python e lancio da terminale con python2, sembrerebbe funzionare. Ho provato giusto a fare un grafico con matplotlib e numpy.

Ma se lancio anaconda-navigator le cose vanno diversamente:

1) Non riesco a ridimensionare la finestra del navigator, che questo poi è relativamente un problema

2) Non ne vuole sapere di aprimi spyder.

Da il seguente errore:

Bash:
pollo@pollo-Lenovo:~$ spyder
Errore di segmentazione (core dump creato)
pollo@pollo-Lenovo:~$
Qualcuno sa quale sia il problema? Ho fatto una cazzata ad non installare Python2 prima di anaconda?
 

1nd33d

Utente Attivo
653
279
Hardware Utente
CPU
Intel i5 3570K @ 4,5Ghz
Dissipatore
Scythe Mugen 2
Scheda Madre
Gigabyte Z77X-UD3H
Hard Disk
Samsung 840 PRO 256GB + Sandisk Ultra 250GB + Sandisk Plus 960GB
RAM
2x8GB Crucial Ballistix Tactical @2000Mhz CL9
Scheda Video
XFX RX480 GTR Black Edition
Scheda Audio
Auzentech X-Fi Forte
Monitor
AOC i2369VW
Alimentatore
Seasonic P660
Case
eh?
Periferiche
Razer Naga HEX v2
Sistema Operativo
Windows 10 64bit - Linux Mint 18
Potrebbe essere un bug di rendering grafico, prova
conda install pyopengl
nell'ambiente che vuoi usare. Comunque la causa sembrerebbe essere una nuova versione di pyqt quindi potresti provare a fare un downgrade di pyQt alla versione 5.6 (che pare essere compatibile)
 
  • Mi piace
Reactions: enricovela

enricovela

Utente Attivo
185
49
Hardware Utente
CPU
Ryzen 3600
Dissipatore
Stock
Scheda Madre
MSI Gaming plus max x470
Hard Disk
970 evo plus
RAM
16 GB @3000 MHz
Scheda Video
RX 5700 Pulse
Alimentatore
Straight power 11 650 W
Case
Cooler Master MB510L
Sistema Operativo
Ubuntu 18 / Windows 10
Grazie mille ;)

Codice:
 conda install pyopengl
Solving environment: done

## Package Plan ##

  environment location: /home/pollo/anaconda2

  added / updated specs:
    - pyopengl


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    numpy-1.13.3               |   py27hdbf6ddf_4         3.9 MB
    pyopengl-3.1.1a1           |      np113py27_0         1.0 MB
    freeglut-2.8.1             |                0         554 KB
    ------------------------------------------------------------
                                           Total:         5.5 MB

The following NEW packages will be INSTALLED:

    freeglut: 2.8.1-0             
    pyopengl: 3.1.1a1-np113py27_0 

The following packages will be REMOVED:

    anaconda: 5.2.0-py27_3         

The following packages will be DOWNGRADED:

    numpy:    1.14.3-py27hcd700cb_1 --> 1.13.3-py27hdbf6ddf_4

Proceed ([y]/n)? y


Downloading and Extracting Packages
numpy-1.13.3         |  3.9 MB | ####################################### | 100%
pyopengl-3.1.1a1     |  1.0 MB | ####################################### | 100%
freeglut-2.8.1       |  554 KB | ####################################### | 100%
Preparing transaction: done
Verifying transaction: done
Executing transaction: done

ora spyder parte, resta ancora il problema della finestra del navigator non ridimensionabile. Ma quello è relativamente un problema. Questa sera vedo di fare quanto hai detto su qt.
 

enricovela

Utente Attivo
185
49
Hardware Utente
CPU
Ryzen 3600
Dissipatore
Stock
Scheda Madre
MSI Gaming plus max x470
Hard Disk
970 evo plus
RAM
16 GB @3000 MHz
Scheda Video
RX 5700 Pulse
Alimentatore
Straight power 11 650 W
Case
Cooler Master MB510L
Sistema Operativo
Ubuntu 18 / Windows 10
Risolto anche il problema del navigator. Ho tolto la spunta da "enable high DPI scaling" ed ora la dimensione della finestra è quella giusta. Ieri non ci avevo fatto caso che c'era questa impostazione nelle preferenze.

Ho comunque portato qt alla 5.6. Però non capisco una cosa.

Se lancio:


Bash:
pollo@pollo-Lenovo:~$ pip list
Package                            Version                 
---------------------------------- -------------------------
----
----
QtAwesome                          0.4.4                   
qtconsole                          4.3.1                   
QtPy                               1.4.1   
-----
-----
------
perchè non mi riporta PyQt5? l'ho installato e se provo ad importarlo lo importa.

Ho provato con pip list dal mac e li me lo mette in elenco PyQt5 5.10.1
 

1nd33d

Utente Attivo
653
279
Hardware Utente
CPU
Intel i5 3570K @ 4,5Ghz
Dissipatore
Scythe Mugen 2
Scheda Madre
Gigabyte Z77X-UD3H
Hard Disk
Samsung 840 PRO 256GB + Sandisk Ultra 250GB + Sandisk Plus 960GB
RAM
2x8GB Crucial Ballistix Tactical @2000Mhz CL9
Scheda Video
XFX RX480 GTR Black Edition
Scheda Audio
Auzentech X-Fi Forte
Monitor
AOC i2369VW
Alimentatore
Seasonic P660
Case
eh?
Periferiche
Razer Naga HEX v2
Sistema Operativo
Windows 10 64bit - Linux Mint 18
Installare i pacchetti con conda non equivale a installarli con pip. Prova con il comando "conda list", dovresti vedere pyqt.
 
  • Mi piace
Reactions: enricovela

Entra

oppure Accedi utilizzando