Problema scheda di controllo Wd My Book 3 Tb

Black Arrow

Nuovo Utente
5
0
Buonasera ragazzi, vorrei sottoporvi il problema che ho con un WD My Book (di qualche anno ma usato veramente pochissimo) nella speranza che possiate aiutarmi.
Innanzitutto un pò di dati:

My Book modello: WDBFJK0030HBK-04

HDD interno WD Green 3.0TB mod. WD30EZRX

Dati PCB Box:
Codice su PCB: 4060-705149-000 REV A
Codice su connettore: 4061-705149-000 REV AA

Passiamo al problema, tempo fa avevo notato che, quando lo collegavo al Pc, il My Book funzionava correttamente ma non si accendeva più il led di stato.
Successivamente, diverse volte il disco non si accendeva e bisognava scollegare e ricollegare più volte l'alimentazione prima che partisse e venisse riconosciuto da Win10.
Ieri, l'ho collegato perchè mi servivano alcuni file, il led di stato si è acceso fisso ma il disco, nonostante i miei sforzi, non ne ha voluto sapere di partire nè W10 ha rilevato l'interfaccia USB.
Allora ho aperto il box e avvicinando l'orecchio al disco, ho sentito dapprima un ticchettio, ma più tipo serie di impulsi elettrici che rumori meccanici, poi solo un ronzio in prossimità del connettore di alimentazione.
A questo punto ho estratto il disco, l'ho installato in un box esterno USB 3.0 (uno StarTech) ed è partito tranquillamente ma W10 lo ha rilevato come da formattare.
Mi sono documentato, leggendo anche vari post qui sul Forum, ed ho così scoperto che i My Book codificano i dati "al volo" prima di scriverli sul disco rigido.
Quindi, se non risolvo, ho perso tutto!
Ovviamente il problema risiede nella scheda di controllo del box ma, in rete, un modello esattamente identico al mio non si trova.
C'è una 4061-705149-000 REV AA - 4060-705149-000 REV P1 ma, a detta del venditore (americano), ci sarebbe bisogno di dissaldare alcuni componenti e sostituirli con quelli della mia board.
A parte il costo non indifferente, 150,00 dollari (119,00 dollari + s.s.), non sarebbe di certo facile dissaldare e saldare dei componenti SMD ed anche ammesso di riuscirci, non avrei garanzie che poi la scheda funzioni.
Io non sono un esperto in elettronica ma mi viene da pensare che la mia scheda di controllo non riesca più ad alimentare correttamente il disco.
Quello che vorrei chiedere, a chi ha più esperienza di me, è se non ci sia qualche metodo per verificare se effettivamente è "andata" la sola sezione alimentazione e, in tal caso, se c'è qualcosa che si possa fare per far funzionare il disco (giusto il tempo necessario a scaricare i dati) senza ricorrere a soluzioni "rischiose" come l'utilizzo di una controller board modificata.
Grazie a tutti per l'attenzione 😉.
 
Ultima modifica:

leonardo6e56

Utente Attivo
1,630
225
CPU
12600k 5GHz 20MB cache
Dissipatore
Il bro della doccia
Scheda Madre
Z690 PRIME ASUS
HDD
Samsung evo 970+ 512 gb
RAM
Ballistix 16 gb 3200
GPU
FE RTX 3060ti 8 gb GDDR6
Audio
HD audio della scheda madre
Monitor
AOC 75 hz 20 pollici
PSU
Corsair CX650m (semimodulare)
Case
Bho
Periferiche
Tastiera ROG, mouse di mer*a, altre cose comuni
Net
Eth gigabit integrato
OS
Windows 10 (perchè si)
io avevo il tuo stesso problema identico su un vecchio my book essential 3 tb che non si accendeva manco (prima non lo identificava poi non si è più acceso) ho risolto in questo modo: aperto il my book, staccato il pcb controller (la schedina di alimentazione dove ci colleghi i cavi corrente e ss-usb) collegato un sata to usb, e recuperato i miei dato (ps ho gia provato a accenderlo col cacciavite 1 volta ci sono riuscito ma poi ho bruciato letteralmente la scheda) se ti da da formattare il disco puoi provare a aprire gestione disco, controllare la partizione dei dati e assegnargli una lettera di unità (controllare anche i file system)

poi puoi provare a fare dal cmd un checkdisk
fai
checkdisk d: (o la lettera dove c'è il disco) e prova
 

michael chiklis

Utente Èlite
5,473
1,951
CPU
Intel i7-3770 @ 3,4 GHz
Dissipatore
CRYORIG M9i
Scheda Madre
ASROCK Z77 Pro3
HDD
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX16C9T3K2/16X 32 GB (4x8GB)
GPU
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
PSU
Antec EA650G Pro 650W
Case
Montech Air900 Mesh-Nero
OS
Win7 x64
Se è crittografato (e quasi certamente lo è), non potrà fare nulla in gestione disco e non verrà visualizzata la partizione.
Il chkdsk non ha nemmeno senso, non può certo mettere a posto la partizione che non ha nulla che non va, il problema è che il disco è crittografato.

O trova un controller identico usb 4060-705149 (io ce l'ho), oppure bisogna decrittare il disco con metodi alternativi e poi riversare il tutto su un altro drive.
Anche usando una controller con identico part number, non è detto che funzionerà. Potrebbe essere necessario trasferire il chip della rom dal controller originale a quello donatore.
 
Ultima modifica:

Black Arrow

Nuovo Utente
5
0
Buonasera ragazzi e grazie per le risposte.

@leonardo6e56
Ho letto che i vecchi Essential non codificavano i dati per questo tu sei risucito ad accedervi ed a copiarli. Purtroppo tutti gli attuali My Book codificano i dati mentre li scrivono quindi, come giustamente ha scritto Michael, ogni tentativo, con metodi che non siano altamente professionali, è inutile. Il disco è perfetto, funziona ed è partizionato, solo che senza l'ausilio della scheda di controllo, il contenuto non può essere visualizzato.

@michael chiklis
Volevo chiederti, visto che in pratica il disco non viene alimentato, non potrebbe essere dovuto a qualche condensatore (vicino al connettore di alimentazione c'è un piccolo cilindretto con scritto 150, forse ohm)?
Ricordo che qualche anno fa, resuscitai un PVR Sat Topfield che non riconosceva più l'HD, sostituendo tutti i condensatori sulla scheda di alimentazione.
Altre soluzioni, tipo alimentare dall'esterno l'HDD sul connettore non penso siano praticabili e/o risolutive.
In merito alla sostituzione del controller, eventualmente il chip da sostituire sarebbe uno dei 3 integrati ad 8 piedini oppure il chip ASMedia? Nel primo caso, forse potrei riuscire a dissaldarlo e risaldarlo ma nel secondo, viste le dimensioni dei piedini, assolutamente no.
In ogni caso, il controller in tuo possesso, ha esattamente gli stessi codici compresa la Rev cioè:
PCB= 4060-705149-000 REV A - Connettore= 4061-705149-000 REV AA ?
Eventualmente, anche in privato, mi potresti gentilmente far sapere se la scheda in tuo possesso è in vendita, il suo costo, ecc.?
Non è che abbia dei dati vitali sul disco ma mi farebbe piacere recuparare molti ricordi (foto, video, ecc.).
Ti ringrazio anticipatamente
 

michael chiklis

Utente Èlite
5,473
1,951
CPU
Intel i7-3770 @ 3,4 GHz
Dissipatore
CRYORIG M9i
Scheda Madre
ASROCK Z77 Pro3
HDD
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX16C9T3K2/16X 32 GB (4x8GB)
GPU
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
PSU
Antec EA650G Pro 650W
Case
Montech Air900 Mesh-Nero
OS
Win7 x64
Di solito sulla scheda controller usb di questi hdd si guastano i due mosfet contenuti nell'integrato a 8 pin siglato APM4532 in posizione U4.
I mosfet serveno per attaccare/staccare l'alimentazione al disco (che a loro volta sono controllati dal micro controllore), se i mosfet sono guasti l'hdd non si accende.
Non so a quale cilindretto vicino al connettore di alimentazione ti stai riferendo, comunque è improbabile che sia un problema di condensatore, tra l'altro l'unita di misura della capacità dei condensatori è il micro-farad (uF).
Ohm è l'unità di misura delle resistenze.

Ci sarebbe una soluzione per riuscire ad utilizzare il tuo controller usb per decrittare i dati, ammesso che il problema sia davvero dei mosfet.
In pratica dovresti fare in modo di alimentare l'hdd direttamente sul connettore sata (dovresti segare la parte del connettore relativo alle alimentazioni e tenere solo la parte dati), eliminando anche i contatti per farci stare il cavo di alimentazione sata proveniente dall'alimentatore del pc.
s-l1600 (1).jpg

Un'altra alternativa, sempre ammesso che il problema sia dei mosfet, sarebbe quella di dissaldare l'IC APM4532 e di fare 2 ponti tra drain e source dei mosfet, saldando 2 fili (uno tra i pin 1 - 8 e l'altro tra i pin 3 - 6), in questo modo l'hdd resterà sempre acceso finchè non deciderai di togliere l'alimentazione. Lo scopo dei due mosfet sarebbe quello di far spegnere automaticamente l'hdd quando rimane inutilizzato per un certo periodo di tempo.
s-l1600.jpg

Il controller che ho io è il 4060-705149-000 REV A, sul connettore invece è riportato il codice 4061-705210-A00 REV AB, quello che conta è solo il primo.
 
Ultima modifica:
  • Mi piace
Reazioni: Moffetta88

Black Arrow

Nuovo Utente
5
0
Buonasera Michael, innanzitutto ti ringrazio infinitamente per la dettagliatissima risposta contenente tutte le possibili soluzioni al mio problema.
Credo che la cosa più semplice ed immediata possa essere quella di provare ad alimentare separatamente il disco.
Potrei tentare con una prolunga dati SATA (molto corta) per collegare la scheda al disco ed alimentare poi quest'ultimo con un adattatore Molex-Sata. In tal modo eviterei anche di tagliare il connettore.
Vedrò di procurarmi subito l'occorrente....
Spero siano proprio i Mosfet ed il tentativo vada a buon fine, in caso contrario proveremo con il controller compatibile di cui mi hai parlato in pm.
Per il momento grazie ed a presto.
 

michael chiklis

Utente Èlite
5,473
1,951
CPU
Intel i7-3770 @ 3,4 GHz
Dissipatore
CRYORIG M9i
Scheda Madre
ASROCK Z77 Pro3
HDD
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX16C9T3K2/16X 32 GB (4x8GB)
GPU
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
PSU
Antec EA650G Pro 650W
Case
Montech Air900 Mesh-Nero
OS
Win7 x64
Il motivo per cui ti avevo suggerito di tagliare solo la parte del connettore relativo all'alimentazione, era quello di tenere così com'è la parte del connettore relativa ai dati.
E' necessario collegare il connettore dati della schedina controller direttamente al disco esattamente come avverrebbe durante il normale utilizzo del disco inserito nel box MyBook.

Se vuoi evitare di segare il connettore, dovresti usare un cavo dati diverso rispetto a quelli soliti con i due connettori femmina.
Un lato deve essere maschio, l'altro femmina.
Tipo questo

Il lato femmina lo vai a collegare al disco come si farebbe normalmente con i dischi interni, il lato maschio lo dovrai collegare al connettore della pcb controller usb.
 

Dumah Brazorf

Utente cAttivo
Utente Èlite
4,356
1,734
Se pensate sia un problema di alimentazione del disco perchè date per scontato che sia la scheda e non l'alimentatore 12V ad avere problemi?
 

michael chiklis

Utente Èlite
5,473
1,951
CPU
Intel i7-3770 @ 3,4 GHz
Dissipatore
CRYORIG M9i
Scheda Madre
ASROCK Z77 Pro3
HDD
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX16C9T3K2/16X 32 GB (4x8GB)
GPU
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
PSU
Antec EA650G Pro 650W
Case
Montech Air900 Mesh-Nero
OS
Win7 x64
Se pensate sia un problema di alimentazione del disco perchè date per scontato che sia la scheda e non l'alimentatore 12V ad avere problemi?

Giusta osservazione.
E' vero, può essere l'alimentatore del MyBook ad essersi guastato, ma di solito non è lui.
Ho presunto che fosse guasta la scheda controller per abitudine, raramente mi capitano questi MyBook con l'alimentatore guasto e quando succede trovo comunque anche la schedina guasta.
Però è un'osservazione corretta, andrebbe prima testato con un altro alimentatore equivalente all'originale.

Un'altra prova che si potrebbe fare sarebbe quella di usare l'alimentatore del MyBook su un altro hdd esterno 3.5".
Se funziona allora di certo non è colpa dell'ali.
 

Black Arrow

Nuovo Utente
5
0
Salve ragazzi, innanzitutto vi ringrazio per l'aiuto che mi state dando.
In merito all'alimentatore del My Book, posso assicurarvi che funziona perfettamente perchè la prima cosa che ho fatto, è stata testarlo su un My Book 3.0 da 1Tb (versione con HDD serie Black!) che si è acceso regolarmente.
Ho provato anche ad alimentare il My Book con l'alimentatore dell'Essential e con un alimentatore di tipo universale (per notebook) ma con lo stesso esito: led acceso fisso, ronzio e disco immobile.
Credo quindi si possa escludere l'alimentatore come causa del problema.
Per quanto riguarda il cavo dati, ovviamente non è possibile utilizzare i normali cavi 7 pin per HDD, infatti ho parlato di "prolunga" che ha un connettore maschio e l'altro femmina.
Domenica sera ho ordinato questo (consegna prevista giovedì):

KALEA-INFORMATIQUE© - Set di prolunghe SATA DATA maschio/femmina, lunghezza 50 cm, confezione da 2 pezzi

E' praticamente uguale a quello suggerito da te Michael.
Ovviamente andrà modificato perchè il connettore che dovrò inserire nel PCB, è fatto per essere inserito nel connettore di un normale cavo dati SATA femmina/femmina. Andranno quindi tagliate le piccole alette in plastica ai lati dei contatti ed assottigliato il corpo (magari eliminando il rivestimento in gomma) perchè il connettore sul PCB è molto basso e non ci entrerebbe.
Comunque, appena mi arriva vedrò come fare.
Sinceramente non ho optato per il taglio del connettore, perchè avrei dovuto prima dissaldare la parte non utile (oppure utilizzare un taglierino o il Dremel), con il rischio di danneggiare qualcosa.
Inoltre, con il connettore intatto, mi riservo la possibilità di poter ricorrere all'opzione di eliminazione dell'integrato in U4 con ponticelli fra i contatti. Finchè non provo, non posso infatti sapere se la lunghezza del cavo dati possa influire negativamente.
Ma quand'anche dovesse andare bene con il cavo, potrò sempre perderci un pò di tempo effettuando la modifica in U4, hai visto mai questo controller servisse a qualche amico per recuperare i dati del suo My Book (ovviamente con PCB uguale).
Appena arriva il cavo e riesco a fare una prova vi farò sapere e... speriamo bene!!!
 
Ultima modifica:

Black Arrow

Nuovo Utente
5
0
Buonasera Ragazzi,
scusate per il notevole ritardo, purtroppo ho avuto diversi problemi e solo ora ho potuto dedicare un pò di tempo al disco e quindi vi aggiorno sulla situazione.
Ho provveduto a mettere in pratica le soluzioni suggerite da Michael con i seguenti risultati:

Alimentazione esterna dell'HDD
1. ho staccato il controller dal disco
2. ho collegato il controller all'HDD con una prolunga dati SATA 7 pin maschio/femmina
3. ho alimentato il controller con l'alimentatore del My Book e l'HDD con un alimentatore specifico.

Risultato: l'HDD parte tranquillamente ma non viene riconosciuto stabilmente nel senso che si sente il classico suono che Windows emette quando viene collegata una periferica USB e subito dopo si sente il suono della sua disconnessione. La cosa si è ripetuta ciclicamente per alcuni minuti poi più nessun suono.
Naturalmente ho provato a togliere l'alimentazione a disco e controller e riconnettere il tutto, a cambiare porta USB, ecc. ma senza alcun esito. Di fatto la periferica non viene mai identificata, cioè non compare nè in gestione risorse nè in gestione disco.

Eliminazione dell'integrato in U4
1. ho dissaldato l'IC U4
2. ho saldato dei ponticelli sui contatti 1-8 e 3-6
3. ho ricollegato il controller al disco
4. ho alimentato il My Book con il suo alimentatore

Risultato: il disco rigido si avvia correttamente (con il led di stato che si accende e lampeggia normalmente) e Win 10 lo riconosce, viene effettuata (con successo) la scansione della periferica esterna da Kaspersky, compare la notifica delle due partizioni presenti sul disco ma neanche il tempo di aprire gestione risorse o gestione disco che si sente il suono di Windows di disconnessione della periferica.
Inutili i tentativi di scollegare e ricollegare l'alimentazione, Win10 non emette più alcun suono e non rileva il disco.
Riprovando il giorno dopo, viene rilevata ed immediatamente disconnessa la periferica. Non ho più visto riconosciute, neanche per un breve istante, le partizioni come avvenuto la prima volta.

Sinceramente non so cosa pensare... Sicuramente i Mosfet erano "andati", tant'è che una volta eliminato l'IC, il disco è partito tranquillamente ma forse c'è anche qualche problema all'interfaccia USB.

A questo punto o decido di tentare con un controller usato compatibile (ma a parte la spesa non proprio contenuta, non avrei alcuna garanzia che la cosa funzioni) oppure mi rassegno ad aver perso i dati e getto via il box.
In quest'ultimo caso, mi potrei fidare a riutilizzare il disco con un box esterno USB 3 universale?
L'HDD è praticamente nuovo, ha infatti solo 38 ore di funzionamento e 154 avvii, e sembra funzionare perfettamente ma non so se il controller difettoso abbia in qualche modo potuto pregiudicare la durata della scheda elettronica del disco.
Voi cosa ne pensate?
 

michael chiklis

Utente Èlite
5,473
1,951
CPU
Intel i7-3770 @ 3,4 GHz
Dissipatore
CRYORIG M9i
Scheda Madre
ASROCK Z77 Pro3
HDD
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX16C9T3K2/16X 32 GB (4x8GB)
GPU
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
PSU
Antec EA650G Pro 650W
Case
Montech Air900 Mesh-Nero
OS
Win7 x64
Penso che a questo punto andrebbe tentata la sostituzione del controller, a parte il mosfet guasto è probabile che ci sia qualche altro componente guasto o qualche saldatura fredda.
In alcuni rari casi, se la pcb del disco è difettosa può causare la disconnessione del disco anche se si accende e ruota normalmente. E' raro ma ho riscontrato questo problema solo su dischi WD e Seagate, almeno finora. Praticamente è la stessa sintomatologia dei dischi con settori danneggiati sulla superficie.

A mio parere il problema sta sul controller usb, sostituendolo con uno identico dovresti poter recuperare i dati!

Puoi abbinare l'hdd ad un controller generico, basta che sia in grado di supportare dischi con capacità superiore ai 2 TB, così potrai riutilizzarlo dopo averlo inizializzato, MA PERDERAI TUTTI I DATI !
 

Entra

oppure Accedi utilizzando