Problema installazione Gentoo

abenobashi

Utente Attivo
36
2
CPU
Intel Q9550
Scheda Madre
Asus P5Q Pro Turbo
Hard Disk
Western Digital Caviar Green 1,5TB, 7200rpm, 64MB
RAM
Patriot Memory DDR2 1066MHz 4GB
Scheda Video
GTX 460 SuperClocked
Scheda Audio
Integrata
Monitor
TV T260 HD
Alimentatore
Thermaltake ToughPower 650W
Case
Enermax Phoenix
Sistema Operativo
Windows 7 Enterprise 32bit & 64bit
Sto seguendo il manuale in italiano che c'è sul sito ufficiale però sono arrivato alla parte in cui c'è da scaricare un archivio dello stage 3. Mi dirigo nella cartella /mnt/gentoo scrivendo:
Codice:
cd /mnt/gentoo
poi lo cerco di scaricare scrivendo:
Codice:
wget ftp://distfiles.gentoo.org/pub/gentoo/releases/x86/current-stage3/stage3-i686-*.tar.bz2
Però ricevo i seguenti errori:
Codice:
Resolving distfiles.gentoo.org... failed: Name or service not known
wget: unable to resolve host address 'distfiles.gentoo.org'
Se può aiutare dico già che lo sto installato da macchina virtuale con WMWare aggiornato all'ultima versione

Da quel poco che ho capito su altri forum dovrebbe trattarsi di una configurazione della rete fatta male. Sapreste illuminarmi per risolvere il mio problema?

Grazie anticipatamente
 

Dott.GoNzO

Utente Attivo
987
105
Sistema Operativo
Linux
ma la virtual machine è connessa ad internet? Come mai usi gentoo (sai che è una delle distro più complesse, vero?). Se la connessione non dovesse andare, vedi di utilizzare il tool desktop oppure edita il file /etc/network/interfaces (se non mi sbaglio).
 

abenobashi

Utente Attivo
36
2
CPU
Intel Q9550
Scheda Madre
Asus P5Q Pro Turbo
Hard Disk
Western Digital Caviar Green 1,5TB, 7200rpm, 64MB
RAM
Patriot Memory DDR2 1066MHz 4GB
Scheda Video
GTX 460 SuperClocked
Scheda Audio
Integrata
Monitor
TV T260 HD
Alimentatore
Thermaltake ToughPower 650W
Case
Enermax Phoenix
Sistema Operativo
Windows 7 Enterprise 32bit & 64bit
So bene che si tratta di una delle distro più difficili ma ho saputo anche che è personalizzabile fino alla radice per questo motivo ho accettato la sfida. Comunque si la virtual machine è collegata ad internet già in automatico siccome l'ho testato con Debian e li mi va. Per utilizzare il tool desktop come faccio? A cosa serve esattamente? Le impostazioni di rete le ho provate a settare io manualmente in questo modo:
Codice:
livecd root # ifconfig eth0 192.168.1.10/24
livecd root # route add default gw 192.168.1.1
livecd root # echo nameserver 192.168.1.1 > /etc/resolv.conf
La terza riga se ho capito bene serve per assegnare l'indirizzo ip al nome del server e poi salvare nel file apposito? Ah piccolo dubbio come faccio a vedere il nome del server siccome dubito si tratti di "nomeserver". Ho provato a digitare 'localhost' ma mi da errore. Pensi che sia quest'ultima riga a compromettermi la connessione?
 

Dott.GoNzO

Utente Attivo
987
105
Sistema Operativo
Linux
la terza riga si riferisce al server dns (che può anche essere il tuo router stesso).

per verificare se i settaggi sono corretti, visualizza il file che ti ho indicato (/etc/network/interfaces) con un editor di testo (anche su shell, non so se c'è già preinstallato nano oppure pico o altro).

dovresti vedere qualcosa tipo:

iface eth0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1

altrimenti inseriscilo tu.

tra i parametri che hai configurato penso che manchi il netmask.

per controllare se la connessione funziona prova a fare il ping di un sito, ad esempio ping -c 5 http://www.google.com
 

zorginho

Utente Attivo
1,235
80
CPU
AMD Phenom II 720 BE (4 core @ 3.3Ghz)
Scheda Madre
ASROCK 970 Extreme 3
Hard Disk
Samsung SSD 830 64Gb e 2 x Seagate ST3500418AS 500Gb raid 0
RAM
DDR3 1333Mhz 2x4GB Corsair XMS3 CL9
Scheda Video
ATI HD4870 Sapphire 1024MB
Scheda Audio
Creative inspire P580 + audio integrato Realtek
Monitor
ASUS LCD 21.5" VH222D
Alimentatore
Corsair CMPSU-650TXEU 650W
Case
su cui si prende sempre la corrente anche se l'alimentazione è staccata O.o""
Sistema Operativo
Windows 7 home premium x64
Io tempo fa provai ad installarla su virtualbox e la connessione internet andava bene semplicemente impostando il dhcp senza fare ulteriori modifiche... il problema è che mi bloccai nella parte della compilazione del kernel
 

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento