Problema formattazione SSD

laclasse92

Nuovo Utente
10
0
Ciao a tutti. Dopo un aggiornamento di Windows, il mio notebook è andato in loop in avvio impossibilitandomi l'accesso (aggiornamento 18%, impossibile aggiornare, riavvio, aggiornamento 18%...ecc...) e ho dunque deciso di fare un ripristino pulito con chiavetta usb.
Eseguendo questa operazione, l'SSD dove il s.o. è installato nè si formatta nè permette l'eliminazione le partizioni!
Mi spiego meglio: ho provato sia con DISKPART...clean nel prompt dei comandi sia con AOMEI Partition Assistant dopo aver installato Windows sul vecchio Hard Disk. La formattazione (o eliminazione della partizione) pare avvenire, ma dopo il refresh tutto torna come prima!
icon_dho.gif
icon_mad.gif

Com'è possibile una cosa del genere?
icon_dho.gif
icon_dho.gif
icon_dho.gif
 

quizface

Utente Èlite
12,854
4,154
Ciao a tutti. Dopo un aggiornamento di Windows, il mio notebook è andato in loop in avvio impossibilitandomi l'accesso (aggiornamento 18%, impossibile aggiornare, riavvio, aggiornamento 18%...ecc...) e ho dunque deciso di fare un ripristino pulito con chiavetta usb.
Eseguendo questa operazione, l'SSD dove il s.o. è installato nè si formatta nè permette l'eliminazione le partizioni!
Mi spiego meglio: ho provato sia con DISKPART...clean nel prompt dei comandi sia con AOMEI Partition Assistant dopo aver installato Windows sul vecchio Hard Disk. La formattazione (o eliminazione della partizione) pare avvenire, ma dopo il refresh tutto torna come prima!
icon_dho.gif
icon_mad.gif

Com'è possibile una cosa del genere?
icon_dho.gif
icon_dho.gif
icon_dho.gif
Ma tu, parti dalla chiavetta? Hai disconnesso tutti gli altri dischi, lasciando solo l' SSD? Quando l'installazione ti chiede dove installare Windows cancella tutte le partizioni che hai nel SSD e vai avanti, lascia che windows le rifaccia.
 

laclasse92

Nuovo Utente
10
0
Ma tu, parti dalla chiavetta? Hai disconnesso tutti gli altri dischi, lasciando solo l' SSD? Quando l'installazione ti chiede dove installare Windows cancella tutte le partizioni che hai nel SSD e vai avanti, lascia che windows le rifaccia.

La prima via tentata é stata quella. Avviato il pc dalla chiavetta, iniziato l'installer, selezionata la partizione contenente Windows per la nuova installazione, che però non avviene poiché non si riesce ad eliminare i dati esistenti. Per questo ho cercato di eliminare le partizioni manualmente in diversi modi, comando clean disk part col prompt e software terzo: pare inizialmente aver proceduto all'eliminazione della partizione, dandomi spazio disponibile il totale della SSD, ma dopo un refresh partizione e spazio occupato tornano esattamente come prima.
 

quizface

Utente Èlite
12,854
4,154
La prima via tentata é stata quella. Avviato il pc dalla chiavetta, iniziato l'installer, selezionata la partizione contenente Windows per la nuova installazione, che però non avviene poiché non si riesce ad eliminare i dati esistenti. Per questo ho cercato di eliminare le partizioni manualmente in diversi modi, comando clean disk part col prompt e software terzo: pare inizialmente aver proceduto all'eliminazione della partizione, dandomi spazio disponibile il totale della SSD, ma dopo un refresh partizione e spazio occupato tornano esattamente come prima.
Il problema e' in questa richiesta "iniziato l'installer, selezionata la partizione contenente Windows per la nuova installazione " non ti deve chiedere dove hai Windows, ma in che partizione installarlo. Se ti chiede dove hai Windows hai sbagliato la partenza.
 

laclasse92

Nuovo Utente
10
0
Forse mi sono spiegato male. Ovviamente non mi chiede dove ho Windows, ma la partizione da scegliere. Scegliendo quella dove ho installato Windows (di cui sono a conoscenza) l'installazione si interrompe per problemi. Dunque ho provato la via manuale cancellando prima le partizioni per poi provare ad installare su un drive pulito, ma le partizioni ricompaiono dopo poco come se niente fosse stato fatto.
Ora ho provato ad installare linux sul drive SSD, ma mi porta quest'errore:

Partition(s) 1 on /dev/nvme0n1 have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.

che credo siano il motivo per cui ho quelle problematiche anche installando Windows.
 

Liupen

SSD MAN
Utente Èlite
10,233
4,616
Forse mi sono spiegato male. Ovviamente non mi chiede dove ho Windows, ma la partizione da scegliere. Scegliendo quella dove ho installato Windows (di cui sono a conoscenza) l'installazione si interrompe per problemi. Dunque ho provato la via manuale cancellando prima le partizioni per poi provare ad installare su un drive pulito, ma le partizioni ricompaiono dopo poco come se niente fosse stato fatto.
Ora ho provato ad installare linux sul drive SSD, ma mi porta quest'errore:

Partition(s) 1 on /dev/nvme0n1 have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.

che credo siano il motivo per cui ho quelle problematiche anche installando Windows.
Di che ssd nvme si tratta... hai provato ad analizzarlo con il suo tool?
 

laclasse92

Nuovo Utente
10
0
E' una KINGSTON SA1000M8240G, analizzandola col tool da Failures NONE, Warnings NONE, Overall HEALTHY; alla sezione SSD Health ho SSD Wear Indicator 100%, SSD Spare Blocks 100%. Nella sezione eventi ho delle righe che credono rappresentino la causa del problema, ovvero
\\.\PhisicalDrive0: Detected as primary drive
\\.\PhisicalDrive1: Detected as secondary drive
\\.\PhisicalDrive2: Not Supported : identify failed;
(…)
Device 0 [phy=0] not available with reason 2
Device [phy=1] added to table at 0
Device 0 [phy=2] not available with reason 2
Di che ssd nvme si tratta... hai provato ad analizzarlo con il suo tool?
Post unito automaticamente:

Ho presentato il problema all'assistenza tecnica di Kingston, che dopo avermi chiesto qualche informazione mi ha detto che il prodotto pare difettoso e di avviare la procedura Amazon per il reso.
Ora mi chiedo, come posso inviare una SSD impossibile da formattare contenente dati sensibili, dato che vi era installato il s.o., a terzi che potrebbero facilmente accedervi (in modalità provvisoria potevo navigare tra i miei files)? Qualcuno ha esperienze in merito?
 
Ultima modifica:

Liupen

SSD MAN
Utente Èlite
10,233
4,616
E' una KINGSTON SA1000M8240G, analizzandola col tool da Failures NONE, Warnings NONE, Overall HEALTHY; alla sezione SSD Health ho SSD Wear Indicator 100%, SSD Spare Blocks 100%. Nella sezione eventi ho delle righe che credono rappresentino la causa del problema, ovvero
\\.\PhisicalDrive0: Detected as primary drive
\\.\PhisicalDrive1: Detected as secondary drive
\\.\PhisicalDrive2: Not Supported : identify failed;
(…)
Device 0 [phy=0] not available with reason 2
Device [phy=1] added to table at 0
Device 0 [phy=2] not available with reason 2

Post unito automaticamente:

Ho presentato il problema all'assistenza tecnica di Kingston, che dopo avermi chiesto qualche informazione mi ha detto che il prodotto pare difettoso e di avviare la procedura Amazon per il reso.
Ora mi chiedo, come posso inviare una SSD impossibile da formattare contenente dati sensibili, dato che vi era installato il s.o., a terzi che potrebbero facilmente accedervi (in modalità provvisoria potevo navigare tra i miei files)? Qualcuno ha esperienze in merito?

Ah ecco è difettoso...non è chiaro ma se la stessa Kingston l'ha ammesso così facilmente è probabile che sia un difetto noto del prodotto.
Per cancellare i dati potresti tentare un secure erase. Mi sembra che però il tool Kingston non supporti la funzione, quindi dovrai trovare un software di terze parti tipo
https://www.lifewire.com/hdderase-review-2619137
oppure con Parted Magic che uso ancora adesso
https://forum.tomshw.it/threads/com...-il-suo-stato-iniziale-di-performance.364801/
quando non ho a disposizione una scheda madre che ha la funzione integrata (questa sarebbe la soluzione più veloce)

PS mi sono riletto sopra...se hai AOMEI il software ha la funzione SE
 

laclasse92

Nuovo Utente
10
0
Ah ecco è difettoso...non è chiaro ma se la stessa Kingston l'ha ammesso così facilmente è probabile che sia un difetto noto del prodotto.
Per cancellare i dati potresti tentare un secure erase. Mi sembra che però il tool Kingston non supporti la funzione, quindi dovrai trovare un software di terze parti tipo
https://www.lifewire.com/hdderase-review-2619137
oppure con Parted Magic che uso ancora adesso
https://forum.tomshw.it/threads/com...-il-suo-stato-iniziale-di-performance.364801/
quando non ho a disposizione una scheda madre che ha la funzione integrata (questa sarebbe la soluzione più veloce)

PS mi sono riletto sopra...se hai AOMEI il software ha la funzione SE


Ho ormai smontato l'SSD... fra qualche giorno proverò a collegarla tramite un adattatore usb per testare sia effettivamente un problema di SSD o casomai il problema in qualche modo nel collegamento tra lo slot m2 e la scheda madre. Proverò a capire se effettivamente la formattazione è riuscita ma non si riesce a farla "vedere" alla cpu come da messaggio di gparted o se i dati sono ancora presenti. Kingston mi ha garantito che tutti i prodotti difettosi appena ricevuti sono soggetti a un erase fisico...
 

Liupen

SSD MAN
Utente Èlite
10,233
4,616
Ho ormai smontato l'SSD... fra qualche giorno proverò a collegarla tramite un adattatore usb per testare sia effettivamente un problema di SSD o casomai il problema in qualche modo nel collegamento tra lo slot m2 e la scheda madre. Proverò a capire se effettivamente la formattazione è riuscita ma non si riesce a farla "vedere" alla cpu come da messaggio di gparted o se i dati sono ancora presenti. Kingston mi ha garantito che tutti i prodotti difettosi appena ricevuti sono soggetti a un erase fisico...
Quello che ti ho proposto di fare è appunto un "erase fisico"
 
  • Mi piace
Reazioni: laclasse92

Liupen

SSD MAN
Utente Èlite
10,233
4,616
Quali metodi consigli per fare un erase fisico?

Il comando ATA chiamato Secure Erase
Ah ecco è difettoso...non è chiaro ma se la stessa Kingston l'ha ammesso così facilmente è probabile che sia un difetto noto del prodotto.
Per cancellare i dati potresti tentare un secure erase. Mi sembra che però il tool Kingston non supporti la funzione, quindi dovrai trovare un software di terze parti tipo
https://www.lifewire.com/hdderase-review-2619137
oppure con Parted Magic che uso ancora adesso
https://forum.tomshw.it/threads/com...-il-suo-stato-iniziale-di-performance.364801/
quando non ho a disposizione una scheda madre che ha la funzione integrata (questa sarebbe la soluzione più veloce)
PS mi sono riletto sopra...se hai AOMEI il software ha la funzione SE

corrisponde ad un reset alle impostazioni di fabbrica.
 
  • Mi piace
Reazioni: sghe23

Entra

oppure Accedi utilizzando

Discussioni Simili