PROBLEMA Problema di boot dopo scambio HD linux - win (no duall)

Su PC di lavoro nuovo con Asus P9X79 Pro, i7-3930K, 32GB RAM, installo da CD (netinstall)
Debian Wheezy su un SSD da 240GB. Fin qui tutto funziona bene.

Poi TOLGO fisicamente il disco SSD con Debian, e METTO un HD vuoto su cui installo Windows 7 (sp1).

Tutto cio' per poter usare un po' di utility di monitoraggio
e settaggio (per esempio quella di Asus che viene con la MB)
per fare un lievissimo OC da 24/7.

Finiti i settaggi, tolgo l'HD con win7, rimetto l'SSD con Debian.
e la MB (mamma bastarda) P9X79 mi dice che non c'e' nessun dispositivo bootabile,
nemmeno se scelgo l'SSD (che viene visto) dal menu' di boot.
Il disco peraltro e' leggibile se attaccato ad altri PC quindi non si e' fulminato.
E se rimetto l'HD con Win7 lui parte senza problemi.

Cosa e' successo?
Un mio collega mi sfotte dicendo che Windows mi ha infettato il BIOS...
Qualche idea ? A questo punto sono pronto a reistallare debian sul SSD, ma
tremo a cosa succedera' al primo reboot, se non capisco prima cosa e' capitato.

Ci puo' aver messo lo zampino l'UEFI ? Graditi suggerimenti/esorcismi...
ciao.
g.
 

davethecipo

Utente Èlite
3,326
1,155
Hardware Utente
CPU
i5 4660
Scheda Madre
H97 PC Mate
Hard Disk
qualcuno
RAM
8 GB
Scheda Video
R9 280
Monitor
Samsung SyncMaster 940BW 19'
Alimentatore
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
Sistema Operativo
Arch Linux con KDE...Windows 10
Più che reinstallare Debian daccapo proverei a reinstallare GRUB sull'MBR dell'SSD. Poi personalmente non ti so dire se ci sono magagne con UEFI
 
Sicuramente provero', ma leggendo in giro di problemi di boot simili anche se in scenari diversi, mi sta
venendo il forte sospetto che la MB vada a salvare i parametri dei boot UEFI in qualche
sua memoria non volatile e che lo scambio di HD abbia confuso le sue idee.

Mi riferisco a questa discussione, che riguardando Archlinux non sono riuscito a seguire completamente:
https://bbs.archlinux.org/viewtopic.php?id=155680
Ad un certo punto dicono:
"Some EFIs (perhaps most or even all of them) "helpfully" remove boot loaders from the NVRAM list if the computer
starts up and the firmware can't find the boot file. The problem, of course, is that if you temporarily unplug a disk that
holds valid boot loaders, you end up losing those boot loader entries."

ciao,
g.
 

davethecipo

Utente Èlite
3,326
1,155
Hardware Utente
CPU
i5 4660
Scheda Madre
H97 PC Mate
Hard Disk
qualcuno
RAM
8 GB
Scheda Video
R9 280
Monitor
Samsung SyncMaster 940BW 19'
Alimentatore
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
Sistema Operativo
Arch Linux con KDE...Windows 10
Ecco ti pareva. Ho letto fino a quel punto. A quanto pare dovresti risolvere usando rEFInd.

P.S: che tristezza questo UEFI...
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
5,414
1,609
Hardware Utente
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
Hard Disk
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
Scheda Video
gtx660TI 3GB / gtx 1080 TI
Scheda Audio
Azila
Monitor
40" 4k LG / asus 27"
Alimentatore
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
Sistema Operativo
archlinux X68_66
uefi in se non è la trostezza, è una gran cosa secondo me·

la tristezza è essere ancora nel limbo " uefi-bios"

per far morire bios e passare a uefi , con tutti i vantaggi che ne derivano deve morire XP , devono morire gli OS a 32 bit e se possibile deve morire il monopolio microsoft ( è colpa sua se siamo ancora messi così male, anzi, è colpa di XP )

firmato, uno che esegue felicemente archlinux a 64 bit su sistema 100% uefi
 

Entra

oppure Accedi utilizzando