[Problema] CODE::BLOCKS zlib1.dll mancante

lemeridien

Nuovo Utente
3
0
Salve a tutti,
ho cercato invano di installare oggi CODE Blocks per c++ ma ogni volta che tento di compilare ed eseguire il main.cpp base mi da sempre il seguente messaggio di errore

"impossibile avviare il programma perchè zlib1.dll non è presente nel computer. Per risolvere il problema ,prova a reinstallare il programma."
Premesso che ho provato piu' volte (pulendo anche con ccleaner i registri) non sono riuscito a risolvere il problema.
Suggerimenti?Grazie
 
M

Mursey

Ospite
zlib1.dll e' una libreria di code block oppure la vuoi usare tu nel tuo programma ?
 

lemeridien

Nuovo Utente
3
0
zlib1.dll e' una libreria di code block oppure la vuoi usare tu nel tuo programma ?

ah,guarda,non sono in grado di rispondere alla tua domanda,so che ho provato piu' volte e non ho risolto ,l'unica opzione che ha funzionato è stato il ripristino di sistema all'ultima data disponibile .
 
M

Mursey

Ospite
ah,guarda,non sono in grado di rispondere alla tua domanda,so che ho provato piu' volte e non ho risolto ,l'unica opzione che ha funzionato è stato il ripristino di sistema all'ultima data disponibile .

Direi che non la usi nel tuo codice, pare essere una libreria di sistema che viene rovinata da qualche malware o simili.
Il ripristino prende la dll corretta.
 

signore del tempo

Utente Èlite
3,228
491
CPU
Intel Core i5 4670K
Scheda Madre
Asus Z87-Plus
HDD
WD Caviar Green 500GB
RAM
G.Skill Ares 2x4GB 1600MHz
GPU
Sapphire 7850 1GB @ 1050MHz
Audio
Integrata
Monitor
Acer V193w
PSU
XFX ProSeries 550W Core Edition
Case
CM HAF 912 plus
OS
ArchLinux + KDE - Windows 10
Credo tu debba installare zlib, strano che non lo sia. Anche se mi sembra strano che C::B ne faccia uso.
 

lemeridien

Nuovo Utente
3
0
Direi che non la usi nel tuo codice, pare essere una libreria di sistema che viene rovinata da qualche malware o simili.
Il ripristino prende la dll corretta.
nel momento in cui carico anche un prog semplicissimo e provo a compilare code blocks mi segnala un errore e si blocca. ho risolto alla fine ripristinando il sistema. Grazie degli interventi
 

signore del tempo

Utente Èlite
3,228
491
CPU
Intel Core i5 4670K
Scheda Madre
Asus Z87-Plus
HDD
WD Caviar Green 500GB
RAM
G.Skill Ares 2x4GB 1600MHz
GPU
Sapphire 7850 1GB @ 1050MHz
Audio
Integrata
Monitor
Acer V193w
PSU
XFX ProSeries 550W Core Edition
Case
CM HAF 912 plus
OS
ArchLinux + KDE - Windows 10
nel momento in cui carico anche un prog semplicissimo e provo a compilare code blocks mi segnala un errore e si blocca. ho risolto alla fine ripristinando il sistema. Grazie degli interventi
Strano che sia "sparita". Come dice Mursey potresti avere qualche animaluccio, ma per questo ti mando alla sezione sicurezza ;)
 
  • Like
Reactions: Mursey

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 13 15.5%
  • Gearbox

    Voti: 1 1.2%
  • Xbox & Bethesda

    Voti: 59 70.2%
  • Square Enix

    Voti: 3 3.6%
  • Capcom

    Voti: 5 6.0%
  • Nintendo

    Voti: 13 15.5%
  • Altro (Specificare)

    Voti: 6 7.1%

Discussioni Simili