PROBLEMA Pc si riavvia da solo e si blocca randomicamente

Buongiorno a tutti, sono nuovo e spero di aver postato nella sezione giusta.
Detto questo, da circa sei mesi un mio amico mi ha assemblato un pc e fin da subito ho riscontrato un paio di problemi:

- il primo problema è che se metto il pc in standby questo si riavvia da solo non appena accendo la luce di casa (la luce in questione ha un interruttore a relè, tutti gli altri interruttori non danno problemi).

- secondo problema, un po piu fastidioso, è che randomicamente (in genere di piu' quando il pc non è sotto stress, quando gioco non ho mai riscontrato problemi) si blocca lo schermo e l'audio si freeza, dopo qualche secondo tutte le periferiche si spengono e il pc entra in uno stato di "stasi", acceso, con le ventole che girano non eccessivamente e l'unico modo per sbloccare la situazione è tramite il bottone di reset. Dopo aver premuto il bottone, si riaccende tranquillamente senza nessun errore schermata strana o altro. Questo problema all'inizio mi capitava una volta a settimana, anche due volte nello stesso giorno, dopodiché ho provato a cambiare alimentatore e il problema si è ripresentato dopo un mese circa. Ho fatto il test della ram e non ha trovato nessun problema.

I componenti sono
RAM Corsair Vengeance lpx 16Gb ddr4 3000MHz
AMD Ryzen 5 1600x
SSD Crucial 480Gb
Sapphire radeon rx570 nitro+
Moba asrock b450m
Case Termaltake Versa H21

Spero di essermi spiegato
 

nerf_commandline

Nuovo Utente
123
18
Hardware Utente
CPU
Amd Fx 8320 4.0 Ghz
Dissipatore
Noctua Nh-D14
Scheda Madre
Gigabyte Ga 990 XA-UD3
Hard Disk
SO: SSD Crucial MX200 250 GB
RAM
2 x 8 GB HyperX Savage, DDR3, 1866MHz,CL9
Scheda Video
Gigabyte HD 7970 Ghz Edition
Alimentatore
Cooler Master VS 650W Semi modulare
Case
Thermaltake Chaser A71
Sistema Operativo
Windows 10; Kali Linux
Il primo problema sembra di natura elettrica...ci potrebbero essere dei difetti nell'isolamento o nella massa della luce della camera e della presa a cui colleghi il pc.

Il secondo problema invece è molto simile ad uno che avevo tempo fa: o l'harddisk ti sta abbandonando oppure hai qualche difetto nei cavi di alimentazione o SATA
 

Entra

oppure Accedi utilizzando