PROBLEMA Pc Con Doppia Scheda Di Rete

Gigio972

Nuovo Utente
46
1
Ciao a tutti.
Ho un problema su un PC con Win10 64bit su cui sono installate 2 schede di rete che si dovrebbero connettere a due reti di classi diverse e fisicamente separate.
Ho cercato tanto in internet ma non ne sono venuto a capo. Potete aiutarmi

Rete n°1 sotto router fastweb non modificabile
Router IP 192.168.1.1 netmask 255.255.255.0
Computer della rete 192.168.1.2...ecc. nm 255.255.255.0 gatway 192.168.1.1
Tutto funziona a dovere

Rete n°2 sotto router dlink collegato tramite porta wan al router fastweb
Indirizzo IP del dlink 192.168.1.150 gatway 192.168.1.1
con il dlink creo una seconda rete con indirizzo 10.0.0.1 nm 255.0.0.0
Sotto questa secoda rete ci sono vari apparati con indirizzi 10.0.0.2... ecc nm 255.0.0.0 gatway 10.0.0.1
Nella seconda rete tutto funziona a dovere, anche l'accesso ad internet. Se collego un portatile in dhcp alla seconda rete funziona perfetto.

Io vorrei gestire però le due reti da un unco PC aziendale (quello appunto con le due schede di rete) In questo PC la prima rete funziona a dovere mentre la seconda, sia che lascio dhcp sia che metto ip statico manda in palla il computer. A volte quando la disabilito e poi la riabilito nemmeno la vede più come privata ma mi restituisce rete non identificata. Quando invece va bene manda in palla la connessione internet della prima. Ho provato a togliere il gatway alla seconda ma nulla.

E' un operazione che si può fare questa che vi ho detto oppure non è possibile gestire da windows due reti diverse con due schede. se fosse possibile dove sbaglio?

Grazie
 

Skills07

Moderatore
Staff Forum
Utente Èlite
18,829
5,504
CPU
Ryzen 7 2700x
Dissipatore
Deepcool gammax l240 v2
Scheda Madre
Aourus Gigabyte X-470 ultra gaming
Hard Disk
Samsung Evo 850 250gb,2tb toshiba, 500gb western digital, 256 Ssd silicon power
RAM
16 gb G.Skill Tridentz 3200 mhz RGB
Scheda Video
KFA2 Rtx 2070 super
Monitor
Acer Predator 144hz 2k IPS 27", Hp ES 24" 60 Hz FHD
Alimentatore
Seasonic Focus 650w 80 platinum
Case
Coolermaster h500p
Periferiche
Razer Electra V2
Internet
Fibra Tim 100mb
Sistema Operativo
Windows 10 Pro 64 bit
so che è possibile gestire due reti diverse all'interno di un pc..
Perchè lo vedo con le agenzie con cui mi collego a lavoro, alcune hanno sia rete allianz sia rete proprietaria.
Da internet explorer so che usano nelle opzioni internet uno switch di rete, cosi escono in internet con una rete o con un altra.
Poi come si faccia ad impostare ciò non lo so
 

Gigio972

Nuovo Utente
46
1
Cerco di spiegare un po meglio il problema
Due reti completamente separate. due router distinti e due switch distinti.
Una rete è 192.168.1.1 255.255.255.0 mentre l'altra è 10.0.0.1 255.0.0.0
Le reti funzionano perfettamente entrambe, l'unico problema che ho è che dal PC su cui sono intallate le due schede di rete e quindi i due cavi che vanno ai due switch, la prima rete (192.168.1.1) funziona perfettamente sia in dhcp che con indirizzo statico mentre la seconda mi da problemi sia in dhcp che con indirizzo statico. Questo avviene sia se disabilito la prima scheda sia che non la disabilito. La cosa strana è che vedo tutte le macchine sotto la rete 10.0.0.1 però quando provo ad aprire un web server di un apparecchio sembra aprirlo invece poi no, oppure lo apre male, tipo scritte messe male e pagina web non funzionante.
Lo stesso non accade se attacco al secondo switch (10.0.0.1) il portatile che invece funziona correttamente.
Quindi volevo capire se avendo un gruppo home e una rete aziendale c'è qualche instradamento che mi fa fallire la secoda rete anche disattivando la prima.


Grazie
 

Gigio972

Nuovo Utente
46
1
Problema risolto, o quasi. Ho semplicemente scambiato i cavi ed ora le reti funzionano invertite, nel senso che quella che prima non funzionava ora funziona mentre quella che funzionava ora non funziona. Ho scaricato anche gli ultimi driver della scheda ma nulla. Bah! mistero dell'informatica, è nuova di pacca

Grazie
 

Gigio972

Nuovo Utente
46
1
Se può essere di aiuto a qualcuno ora ho risolto veramente. Ho seguito alcune indicazioni su it.comp.reti locali.
Ho cambiato la rete sul router e sulle macchine da 10.0.0.1 255.0.0.0 a 192.168.2.1 255.255.255.0
Ho impostato la prima scheda con 192.168.1.4 255.255.255.0 192.168.1.1
Ho impostato la seconda scheda con 192.168.2.10 255.255.255.0
Ho lanciato route route ADD 192.168.2.0 MASK 255.255.255.0 192.168.2.1 e tutto funziona a dovere, sia internet che le due reti lan
Poi ho lanciato route -p ADD 192.168.2.0 MASK 255.255.255.0 192.168.2.1 e verificato che al riavvio fosse tutto ok!

Grazie ancora
 

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento