PROBLEMA Nuovo firmware SAMSUNG SSD 840 non accetta più SATA 3 (era: Non funziona più la il SATA 3)

maffaxxx

Nuovo Utente
1
0
Salve a tutti

ho un problema davvero strano, che mi è occorso da quando l'altroieri ho proceduto ad effettuare l'aggiornamento del firmware del mio SSD samsung 850, che è anche disco primario.

Prima di quel momentonon avevo alcun problema, l'SSD era collegato alla mobo tramite cavo SATA 3 alla porta SATA 3_2, avevo i miei bravi 6 gbs e tutti i valori di benchmark erano tutto sommato soddisfacenti.

Dopo aver effettuato l'aggiornamento del firmware tramite il Samsung Magician, il pc si è riavviato, al primo riavvio il sistema ha tentato di installare i driver per entrambi i dischi, non riuscendoci, nè l'SSD nè l'HD seagate, dicendomi "accesso bloccato", e al secondo riavvio arrivato al logo ripartiva daccapo, iniziando quello che dopo una mattinata e un numero imprecisato di parolacce ho scoperto essere il CLASSPNP.SYS loop. Dopo tutto il pomeriggio di prove, ho scoperto che

a) non ho trovato alcun modo per poter fare il rollback alla versione precedente del firmware

b) usare le funzioni di windows per ripristinare i driver non porta a niente

c) anche il HDD secondario -un seagate da 1,5 tera, viene visto e non visto a seconda di dove metto il jack del samsung.

d) dopo una serie di tentativi, supponendo che il workaround più alla mia portata fosse quello di metter mano ai driver AHCI, sono riuscito a scaricare dal sito della ASUS i driver più aggiornati, e a copincollare il contenuto dei driver x64 per l'AHCI in INF e driver, riuscendo così ad attivare entrambi i dischi sulle porte SATA II, dove tutto funziona bene in AHCI. Ma se provo a collegare l'SSD ad una delle due porte SATA 3 si ritorna punto a capo con il loop del logo e riavvio. Inoltre, resta il problema del tentativo da parte di win7 di installare i driver dei dischi ad ogni riavvio, cosa che fallisce di fare per "accesso bloccato"

e) una volta (1) sono riuscito a far partre il SSD dalla porta marvell SATA 3, ma il sistema non vedeva il seagate. al momento i marvell li ho disabilitati perchè non mi portano da nessuna parte.

f) però -parolacce- se vado a fare l'aggiornamento dei driver il sistema mi dice che ci sarebbe un driver migliore, ma quando prova ad aggiornarlo mi dice che l'accesso è negato. ho provato a mettere le impostazioni di accesso totale al mio user su tutti i file (sia nella cartella INF che DRIVER) del driver INTEL attualmente utilizzato -che poi è l'ultima versione che ho scaricato dal sito della ASUS relativa ai controller SATA- ma continua a dire che l'accesso è negato, e non mi vuole neppure dire cosa vorrebbe installare, e neanche far partire il gestione dispositivi come amministratore serve a niente.

Mi pare chiaro che il nuovo firmware del samsung ha combinato un gran casino. purtroppo a parte aspettare un nuovo firmware da quel lato non posso fare niente.

Disinstallando il driver INTEL il sistema si riavvia, ma ritorna di nuovo a quella versione del driver. Se cancello i files non trova più nessun driver da poter utilizzare e si blocca, per cui l'unica possibilità è andare sul BIOS passare a IDE (e non si vede più il seagate) ripristinare i file, ripassare su AHCI e tornare al miglior punto.

in sintesi, credo ci siano due problemi non so se distinti:

1) l'impossibilità di utilizzo di nessuna delle porte SATA III, anche con driver AHCI correttamente caricati;
2) la corruzione delle credenziali di amministratore (dal quale abitualmente mi loggo) che mi impedisce di poter mettere mano ai driver (e chissà cos'altro, ma lo scoprirò prima o poi purtroppo...)

Ora: c'è un modo di aggirare il problema, o di identificarlo meglio? E' possibile escludere il fatto che tutte e tre le porte SATA 3 siano danneggiate? E' possibile fare un rollback di questo stramaledetto firmware? E' possibile sbloccare i driver del controller IDE / SATA per fargli installare quello che vuole per vedere se mi riattiva le porte SATA 3?

grazie in anticipo :cry:


PC win 7 home premium 64 bit
ram 8 gb
mobo ASUS p8p67 le
driver attuale controller IDE ATA/ATAPI: Intel desktop/workstation express chipset SATA AHCI controller ver. 10.5.1026
SSD samsung 850 firmware dxt09b0q

sfc /scannow e chkdsk fatti
disco installazione originale celo, punto di ripristino no
windows 7 è in una partizione dedicata, ma ci sono alcuni programmi e preferisco non brasare e reinstallare se possibile

____________________________​

edit:

nel frattempo ho continuato a trafficare. Sono riuscito ad installare i driver più aggiornati per la mobo, chipset ahci scheda video e trivalente.

quindi mi è anche venuta un'idea per capire se la porta SATA III o il cavo avessero problemi: visto che le porte SATA sono retrocompatibili, ho provato a inserire l'HDD sul SATA III con il cavo SATA II per vedere se lo vedeva, e si vede perfettamente, e poi ho messo l'HDD sula porta SATA III con il cavo SATA III, e funziona (non solo, ho anche provato conil magician per vedere se c'erano anche solo piccoli miglioramenti, e per quanto piccoli sono evidenti).

___________​


ho quasirisolto il problema: riportando il driver ad msahci (quello più basico) invece che a quello avanzato intel riesco ad installare la SSD sulla SATA III. Suppongo che il casino che ha combinato il firmware sia stato cancellarmi msAHCI dalla cartella driver, e io ho aggiunto danno alla beffa copincollando i driver avanzati dalla cartella scaricata dal sito ASUS relativo alla mia mobo.

Rimane il problema di trovare un driver aggiornato che mi consenta di poter utilizzare la SSD. Quella che ho installato era sul DVD di installazione della MOBO, e non va evidentemente bene (anzi problabilmente devo anche trovare il modo di cancellarli). Come si può fare?

edit: problema risolto: ho installato gli ultimi driver per SATA intel fregandomene delle compatibilità.

lascio tutto per eventuali referenze a chi dovesse capitare qualcosa di simile.
 
Ultima modifica:

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot: Sei vaccinato? [sondaggio anonimo]

  • Primo ciclo vaccinale completo (1-2 dosi)

    Voti: 456 78.4%
  • Fatta 1a dose, in attesa della 2a

    Voti: 20 3.4%
  • Sono prenotato per la 1a dose

    Voti: 13 2.2%
  • Non so se vaccinarmi

    Voti: 16 2.7%
  • Non ho intenzione di vacciarmi

    Voti: 61 10.5%
  • Fatta anche la terza dose

    Voti: 16 2.7%