PROBLEMA Nessun accesso wifi

Zar Marco

Utente Attivo
440
94
CPU
Intel I7 7700HQ
HDD
Samsung M2 960 EVO NVMe 500GB, SSD Samsung 860 evo 1 Tb
RAM
24 Gb DDR4 2400 Mhz
GPU
Nvidia GTX 1050
OS
Arch Linux--Gentoo--Void--Windows
Ciao a tutti, ho sul pc alcune distro installate. Le ultime due installate mi stanno creando lo stesso problema che le altre non hanno. Pur vedendo l'hardware il wifi non riesce a trovare alcun accesso.

Posto il risultato di lspci -vv
Codice:
legionbook:/mnt/snaps-home/@exherbo-home/zar_marco # cat lspci-wifi
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
        Subsystem: Lenovo RTL8821AE 802.11ac PCIe Wireless Network Adapter
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 138
        Region 0: I/O ports at 4000 [size=256]
        Region 2: Memory at a4200000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee40004  Data: 4024
        Capabilities: [70] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 10.000W
                DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <64us
                        ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s (ok), Width x1 (ok)
                        TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis+, LTR+, OBFF Via message/WAKE#
                         AtomicOpsCap: 32bit- 64bit- 128bitCAS-
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis+, LTR+, OBFF Disabled
                         AtomicOpsCtl: ReqEn-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [100 v2] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr+ BadTLP- BadDLLP- Rollover- Timeout+ AdvNonFatalErr-
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
                AERCap: First Error Pointer: 00, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
                        MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
                HeaderLog: 00000000 00000000 00000000 00000000
        Capabilities: [140 v1] Device Serial Number 00-e0-4c-ff-fe-87-2b-01
        Capabilities: [150 v1] Latency Tolerance Reporting
                Max snoop latency: 3145728ns
                Max no snoop latency: 3145728ns
        Capabilities: [158 v1] L1 PM Substates
                L1SubCap: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+ L1_PM_Substates+
                          PortCommonModeRestoreTime=150us PortTPowerOnTime=150us
                L1SubCtl1: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+
                           T_CommonMode=0us LTR1.2_Threshold=163840ns
                L1SubCtl2: T_PwrOn=150us
        Kernel driver in use: rtl8821ae
        Kernel modules: rtl8821ae

questo è lshw -c network
Codice:
legionbook:/mnt/snaps-home/@exherbo-home/zar_marco # cat lshw-c-network
legion-of-exherbo:/home/zar_marco # lshw -c network                   
  *-network DISABLED       
       description: Ethernet interface
       product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: c8:3d:d4:f7:3a:09
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=rtl8821ae driverversion=4.20.3 firmware=N/A latency=0 link=no multicast=yes
       resources: irq:138 ioport:4000(size=256) memory:a4200000-a4203fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 10
       serial: 54:e1:ad:2c:fe:9e
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII
       resources: irq:19 ioport:3000(size=256) memory:a4104000-a4104fff memory:a4100000-a4103fff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enp0s20f0u2
       serial: ce:b4:c4:fa:b8:97
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.246 link=yes multicast=yes

questo invece l'output del deprecato ifconfig e di ip link
Codice:
legionbook:/mnt/snaps-home/@exherbo-home/zar_marco # cat wifi
zar_marco@legionofexherbo:~ % ifconfig
enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 54:e1:ad:2c:fe:9e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

zar_marco@legionofexherbo:~ % ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 54:e1:ad:2c:fe:9e brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether c8:3d:d4:f7:3a:09 brd ff:ff:ff:ff:ff:ff
zar_marco@legionofexherbo:~ %

ora vi sto scrivendo da arch, ma come si evince l'hardware viene visto ma poi sia con nmtui che con nmcli che con wpa_supplicant che con wicd non riesco a trovare alcun accesso ad internet.
Le due distro con il problema sono exherbo e funtoo.

Non riesco a capire come risolvere
 

maddo

Nuovo Utente
121
58
CPU
i5-4690k
Dissipatore
Noctua NH-D15 (doppia ventola con LNC)
Scheda Madre
Asus Z97 Pro Gamer
HDD
SSD Crucial MX500 256GB + WD Blue 1TB + SSD Sandisk UltraII 240GB
RAM
Corsair Vengeance LP DDR3 2x8GB 1600MHz CL9
GPU
Nvidia MSI GTX 970 GAMING 4G
Monitor
HP 24es
PSU
EVGA 650 G2
Case
Fractal Design Define R5
Periferiche
IZITIK-105M keyboard; Logitech G602 Wireless Mouse
Net
Infostrada Fibra 100/20Mbps
OS
openSUSE Leap 15 KDE x86_64
Mi puoi postare l'output del comando lsmod | grep iw?

EDIT: Nvm non avevo visto il report di lshw, hai l'interfaccia wifi disabilitata, prova a dare il comando
Bash:
sudo ifconfig wlp3s0 up
 
Ultima modifica:

maddo

Nuovo Utente
121
58
CPU
i5-4690k
Dissipatore
Noctua NH-D15 (doppia ventola con LNC)
Scheda Madre
Asus Z97 Pro Gamer
HDD
SSD Crucial MX500 256GB + WD Blue 1TB + SSD Sandisk UltraII 240GB
RAM
Corsair Vengeance LP DDR3 2x8GB 1600MHz CL9
GPU
Nvidia MSI GTX 970 GAMING 4G
Monitor
HP 24es
PSU
EVGA 650 G2
Case
Fractal Design Define R5
Periferiche
IZITIK-105M keyboard; Logitech G602 Wireless Mouse
Net
Infostrada Fibra 100/20Mbps
OS
openSUSE Leap 15 KDE x86_64
Hai provato a dare quel comando? Perché dal tuo report di lshw si evince che la tua scheda wifi è disabilitata.
 

Moffetta88

Moderatore
Staff Forum
Utente Èlite
10,872
6,846
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
Hai per caso installato anche windows?
 

maddo

Nuovo Utente
121
58
CPU
i5-4690k
Dissipatore
Noctua NH-D15 (doppia ventola con LNC)
Scheda Madre
Asus Z97 Pro Gamer
HDD
SSD Crucial MX500 256GB + WD Blue 1TB + SSD Sandisk UltraII 240GB
RAM
Corsair Vengeance LP DDR3 2x8GB 1600MHz CL9
GPU
Nvidia MSI GTX 970 GAMING 4G
Monitor
HP 24es
PSU
EVGA 650 G2
Case
Fractal Design Define R5
Periferiche
IZITIK-105M keyboard; Logitech G602 Wireless Mouse
Net
Infostrada Fibra 100/20Mbps
OS
openSUSE Leap 15 KDE x86_64

Zar Marco

Utente Attivo
440
94
CPU
Intel I7 7700HQ
HDD
Samsung M2 960 EVO NVMe 500GB, SSD Samsung 860 evo 1 Tb
RAM
24 Gb DDR4 2400 Mhz
GPU
Nvidia GTX 1050
OS
Arch Linux--Gentoo--Void--Windows
Alla fine su exherbo avevo controllato tutto tranne dmesg. Dava errore al cfg80211, installato crda, ricompilato qualche pacchetto ed ora sembra fungere. Se domani va ancora metto risolto

Inviato da CLT-L09 tramite App ufficiale di Tom\'s Hardware Italia Forum
 

Entra

oppure Accedi utilizzando

Hot: PS5 VS XBOX X/S?

  • Playstation 5

    Voti: 433 63.4%
  • XBOX Series X/S

    Voti: 250 36.6%

Discussioni Simili