RISOLTO Lenovo Thinkpad T440s errore 2100 (Detection Error on HDD0)

Stato
Discussione chiusa ad ulteriori risposte.

Rikito

Nuovo Utente
19
0
CPU
Intel Core i7-9700K
Dissipatore
Corsair Hydro 100i RGB Platinum SE
Scheda Madre
Asus ROG Strix z390-E Gaming
HDD
Samsung 970 Evo Plus 500 GB
RAM
Corsair Vengeance RGB PRO 32 GB 3200 Mhz
GPU
ASUS ROG Strix GeForce RTX 2080 super OC edition
Monitor
BenQ EL2870U UHD
PSU
Corsair RM750 80Plus Gold
Case
Corsair Crystal Series 680X
Net
Tremendo
OS
Windows 10 Home 64bit
Ciao a tutti.
Mentre stavo usando normalmente il mio portatile, questo si è freezato, dopo averlo riavviato è rimasto il loop nella schermata di caricamento di Windows indefinitamente, e dopo un ulteriore riavvio ha completamente smesso di andare oltre il bios, dando errore 2100, ovvero che non riesce a rilevare l'SSD. Controllando online ho notato che generalmente vengono consigliate queste tre soluzioni:
1- Controllare il collegamento con l'SSD, dato che per alcuni può essere "ballerino", e controllare che sia pulito.
2- Staccare e riattaccare la "batteria" (anche se quasi sempre non viene specificato se s'intende la batteria primaria, quella secondaria rimovibile anche senza smontare il portatile, o quella del CMOS).
3- Nel bios, impostare la priorità di boot al UEFI piuttosto che al Legacy, ma sembra che abbia senso come soluzione solo se questo problema si è verificato per la prima volta durante l'avvio, mentre a me l'ha fatto durante l'utilizzo.
Più qualche altra soluzione software interna a Windows che per ovvi motivi non posso mettere in pratica

Ho controllato l'SSD e non ha problemi di collegamento, il connettore è ben saldo e pulito. Ho quindi provato a staccare e riattaccare le batterie, sia singolarmente che tutte insieme, e nulla. A quel punto ho letteralmente scollegato ogni singola componente dalla scheda madre, e una volta ricollegato tutto il pc è tornato a funzionare senza problemi, ha dato giusto un errore sulla data e l'ora ma una volta reimpostate nel bios tutto è partito come se nulla fosse. Il computer ha funzionato perfettamente per circa una mezz'oretta, poi è tornato come prima, e adesso anche staccare e riattaccare tutto non ha effetto.
Non mi è sembrato di aver fatto nulla di strano prima che avvenisse questo problema, l'unica cosa sospetta che mi viene in mente è che nelle ultime ore prima del freeze, l'indicatore della batteria la dava carica intorno al 90% fisso nonostante il pc fosse stato attaccato alla corrente tutto il giorno, ma visto che in quei momenti era un po più caldo del solito pensavo di star facendo roba che lo appesantisse facendogli consumare più batteria rispetto a quella che riusciva a caricare.

Ho provato a contattare l'assistenza Lenovo ma giustamente la garanzia del mio pc del 2013 è scaduta da bene o male un millennio, quindi non posso andare oltre le solite due risposte automatizzate che non aiutano.

Metto subito le mani avanti dicendo che non ho a disposizione un altro SSD da sostituire a quello del laptop per controllare se è quello il problema, né posso rivolgermi a negozietti che fanno riparazioni in zona.

Avete un'idea di quello che posso fare? Dite che mi tocca ricomprare tutto?

Grazie in anticipo
 

mr_loco

quello cattivo
Utente Èlite
20,311
7,913
quando non è possibile avviare il sistema, consiglio sempre di utilizzare una chiavetta USB con una distro live di linux, questo ti permette di avere accesso a tutti i file presenti nell'SSD e a controllare l'integrità delle partizioni con gparted
se il notebook riesce a fare il boot, ma si ferma al caricamento del sistema, perchè non riconosce l'SSD, probabilmente è quello il problema
 

Rikito

Nuovo Utente
19
0
CPU
Intel Core i7-9700K
Dissipatore
Corsair Hydro 100i RGB Platinum SE
Scheda Madre
Asus ROG Strix z390-E Gaming
HDD
Samsung 970 Evo Plus 500 GB
RAM
Corsair Vengeance RGB PRO 32 GB 3200 Mhz
GPU
ASUS ROG Strix GeForce RTX 2080 super OC edition
Monitor
BenQ EL2870U UHD
PSU
Corsair RM750 80Plus Gold
Case
Corsair Crystal Series 680X
Net
Tremendo
OS
Windows 10 Home 64bit
quando non è possibile avviare il sistema, consiglio sempre di utilizzare una chiavetta USB con una distro live di linux, questo ti permette di avere accesso a tutti i file presenti nell'SSD e a controllare l'integrità delle partizioni con gparted
Ci ho provato, ma nulla. Mi dà sempre lo stesso identico errore allo stesso punto. Ho provato anche a escludere nel bios tutte le altre opzioni di boot ma niente.
Forse però ho sbagliato io qualcosa? Non sono per nulla pratico con linux o sistemi operativi in usb. Ho usato un tool chiamato Rufus e formattato la chiavetta mettendoci l'ISO di Ubuntu, non so se ho fatto giusto o se mi manca qualche passaggio fondamentale.
se il notebook riesce a fare il boot, ma si ferma al caricamento del sistema, perchè non riconosce l'SSD, probabilmente è quello il problema
Praticamente rimane bloccato sulla schermata col logo della Lenovo per un minuto/due e poi mi dà il messaggio d'errore. Solo dopo posso aprire il bios, quindi non credo che il problema si verifichi durante il caricamento del sistema operativo, ma potrei star dicendo una vaccata
 

mr_loco

quello cattivo
Utente Èlite
20,311
7,913
Ci ho provato, ma nulla. Mi dà sempre lo stesso identico errore allo stesso punto. Ho provato anche a escludere nel bios tutte le altre opzioni di boot ma niente.
Forse però ho sbagliato io qualcosa? Non sono per nulla pratico con linux o sistemi operativi in usb. Ho usato un tool chiamato Rufus e formattato la chiavetta mettendoci l'ISO di Ubuntu, non so se ho fatto giusto o se mi manca qualche passaggio fondamentale.
significa che non parte la chiavetta USB ma il disco principale, dal bios devi mettere come boot principale l'USB e dopo il normale disco
 

Rikito

Nuovo Utente
19
0
CPU
Intel Core i7-9700K
Dissipatore
Corsair Hydro 100i RGB Platinum SE
Scheda Madre
Asus ROG Strix z390-E Gaming
HDD
Samsung 970 Evo Plus 500 GB
RAM
Corsair Vengeance RGB PRO 32 GB 3200 Mhz
GPU
ASUS ROG Strix GeForce RTX 2080 super OC edition
Monitor
BenQ EL2870U UHD
PSU
Corsair RM750 80Plus Gold
Case
Corsair Crystal Series 680X
Net
Tremendo
OS
Windows 10 Home 64bit
significa che non parte la chiavetta USB ma il disco principale, dal bios devi mettere come boot principale l'USB e dopo il normale disco
Ok scusa dopo aver riavviato nuovamente il pc stavolta ha funzionato. Gparted non sembra rilevare proprio l'SSD
 

Rikito

Nuovo Utente
19
0
CPU
Intel Core i7-9700K
Dissipatore
Corsair Hydro 100i RGB Platinum SE
Scheda Madre
Asus ROG Strix z390-E Gaming
HDD
Samsung 970 Evo Plus 500 GB
RAM
Corsair Vengeance RGB PRO 32 GB 3200 Mhz
GPU
ASUS ROG Strix GeForce RTX 2080 super OC edition
Monitor
BenQ EL2870U UHD
PSU
Corsair RM750 80Plus Gold
Case
Corsair Crystal Series 680X
Net
Tremendo
OS
Windows 10 Home 64bit
in alto a destra non ti da un menu a tendina con la lista dei dispositivi? altrimenti è andato l'SSD
Allora mi sà che è quello, su "dispositivi" da solamente la chiavetta. Non avevo mai sentito però di un SSD che smette di funzionare, torna a funzionare perfettamente senza aver perso nessun dato e poi si ri-rompe. A questo punto proverò a chiedere al giro per un SSD di ricambio temporaneo per controllare se è effettivamente quello il problema
 

mr_loco

quello cattivo
Utente Èlite
20,311
7,913
Allora mi sà che è quello, su "dispositivi" da solamente la chiavetta. Non avevo mai sentito però di un SSD che smette di funzionare, torna a funzionare perfettamente senza aver perso nessun dato e poi si ri-rompe. A questo punto proverò a chiedere al giro per un SSD di ricambio temporaneo per controllare se è effettivamente quello il problema
se fosse solamente corrotta la partizione, l'SSD doveva essere presente ma non accessibile, nel tuo caso è praticamente assente, come se fosse scollegata
 

Rikito

Nuovo Utente
19
0
CPU
Intel Core i7-9700K
Dissipatore
Corsair Hydro 100i RGB Platinum SE
Scheda Madre
Asus ROG Strix z390-E Gaming
HDD
Samsung 970 Evo Plus 500 GB
RAM
Corsair Vengeance RGB PRO 32 GB 3200 Mhz
GPU
ASUS ROG Strix GeForce RTX 2080 super OC edition
Monitor
BenQ EL2870U UHD
PSU
Corsair RM750 80Plus Gold
Case
Corsair Crystal Series 680X
Net
Tremendo
OS
Windows 10 Home 64bit
se fosse solamente corrotta la partizione, l'SSD doveva essere presente ma non accessibile, nel tuo caso è praticamente assente, come se fosse scollegata
Ok sono riuscito a recuperare un altro SSD e l'ho sostituito al vecchio. Tutto funzionante. A quanto pare si era effettivamente rotto. Grazie mille dell'aiuto!
 
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando

Discussioni Simili