Kubuntu si avvia in seconda

nico.linux

Utente Attivo
225
0
ciao ragazzi. Il mio problema ve lo spiego direttamente facendovi un esempio di quel che succede

Quando vado ad accendere il pc compare la schermata di grub dove vado a scegliere Kubuntu. questo si carica normalmente ma poi non mi dà nessun output video. Come se non riconoscesse più i driver installati. Riavvio per vedere se la cosa era momentanea ma purtroppo non succede nulla di diverso.

Allora riavvio il sistema facendo caricare windows xp stavolta. Questo parte perfettamente quindi faccio l'ennesima prova. Riavvio e faccio caricare kubuntu dopo aver avviato il pc la prima volta con win xp. E Kubuntu si carica e funziona normalmente. Perchè?

Vi lascio qualche altra informazone aggiuntiva sulle quali potrete avvalorare le vostre spiegazioni. Sto compando un nuovo pc e quindi in parte mi finanzio vendendo i componenti vecchi. Avendo sempre avuto 2 pc ho sempre tenuto uno principale e uno muletto.

Adesso invece ho momentaneamente un unico pc che è l'unione dei componenti migliori dei 2. Ovviamente ho formattato e rimesso a manina tutto quanto però logicamente l'hardware è cambiato. Questo pc ha queste caratteristiche:

MB: Asus K8V SE Deluxe
CPU: AMD Sempron 3000+
RAM: 1GB
VC: ATI Radeon 9800 PRO
SC: SB Live! 1024 PRO

e poi ci sono 3 dischi fissi. 2 IDE e 1 SATA.

1° discofisso IDE: 200GB
2° discofisso IDE: 160GB (montato su rack estraibile da 5,25)
3° discofisso SATA 320GB

I sistemi operativi sono installati entrambi sul 1° IDE su partizioni differenti. Il metodo di partizionamento è già stato testato dalle precedenti installazioni.

Spendo 2 parole in difesa della scheda video. So che molti portanno pensare che è qui il problema ma i driver sono settati correttamente in kubuntu tant'è vero che l'accelerazione hardware è abilitata e anche i salvaschermi open gl vanno una scheggia.

Credo che mi sono prolungato abbastanza. Voi avete qualche idea sul perchè mi faccia così?
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
hai provato ad avviare kubuntu in modalità testo (runlevel 3) al posto che direttamente in modalità grafica? non vorrei ci sia qualcosa di legato alla sezione video che non riesce ad inizializzarsi troppo bene "a freddo"
 

nico.linux

Utente Attivo
225
0
Ho provato a fare CTRL-ALT-F1 ma senza risultati utili. Avvia fsck ogni volta per controllare ogni partizione del mio pc ma questo lo notavo anche quando non facevo ctrl-alt-f1.

Kubuntu si comporta così:
quando si avvia: dopo aver fatto fsck fa un refresh del monitor dopo di chè compare il cursore del mouse ed inizia a caricare x
quando non si avvia: dopo il refresh non compare nulla e rimane lo schermo nero

Per modalità testo cosa intedi, l'opzione single da mettere a fine riga del kernel in modo da essere root?
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
per pura modalità testo intendo l'avvio senza il caricamento automatico del server X, in lilo basta dare dopo il "nome" del sistema da avviare il valore 3 , con grub non saprei ma google ti è d'aiuto di certo.

Volendo puoi cmq usare il single mode e vedere da esso se i vari file di log di Xorg danno info utili.
 

nico.linux

Utente Attivo
225
0
Ciao airex,

Adesso che sto avendo un pò più di tempo sto tornando su questo problema.

Ammetto che non mi sono ancora informato su come accedere a runlivel3 su grub ma cmq so come ci si accede in single mode (sempre grazie ai tuoi consigli).

Cmq.. stando in modalità testuale cosa dovrei vedere?
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
dai un'occhiata al file /var/log/Xorg.0.log e vedi se trovi segnalazioni di errore, iniziano con (EE)
 

nico.linux

Utente Attivo
225
0
Ho fatto come mi hai detto e per comodità mi sono salvato Xorg.0.log in un file .txt

Non ci sono errori tuttavia ha segnalato 4 warning relativi a fglrx

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used

infine riporto qui parti interessanti del mio Xorg.0.log secondo il mio punto di vista
Codice:
(II) Primary Device is: PCI 01:00:0
(II) ATI Proprietary Linux Driver Version Identifier:8.34.8
(II) ATI Proprietary Linux Driver Release Identifier: LGDr8.34g1                           
(II) ATI Proprietary Linux Driver Build Date: Feb 20 2007 11:49:19
(II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.34.1.1.2.3-driver-lnx-x86-x86_64-327152
(--) Assigning device section with no busID to primary device
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset Supported AMD Graphics Processor (0x4E48) found

...

(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1280x1024@75Hz
(II) fglrx(0): 1152x870@75Hz
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 108.0 MHz   Image Size:  338 x 270 mm
(II) fglrx(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688 h_border: 0
(II) fglrx(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066 v_border: 0
(II) fglrx(0): Serial No:  BZ  320881
(II) fglrx(0): Monitor name: Philips 170C
(II) fglrx(0): Ranges: V min: 56  V max: 76 Hz, H min: 30  H max: 83 kHz, PixClock max 140 MHz

In questi due spezzoni del log che ho riportato ho notato due cose

1) La periferica primaria sta settata sul BusId 1:0:0 mentre fglrx la cerca in 1:0:1

2) Lo schermo in fase di avvio fa sempre un refresh e adesso capisco perchè. Nelle modalità vesa supportate da fglrx non c'è quella che predilige il mio monitor cioè 1280x1024@60Hz

Sapendo queste cose c'è soluzione a questo problema?
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
con "/sbin/lspci -v" puoi capire quale è l'identificativo reale della tua scheda video e modificare di conseguenza /etc/X11/xorg.conf, cmq leggendo il log pare proprio che siamo di fronte all'ennesimo caso di configurazione "iper contorta" di xorg presente in molte distro, in cui sono presenti triliardi di opzioni che non hanno uso nel 90% dei casi (tavolette wacom, puntatori ad antimateria, console dell'enterprise,...)

la riga
(II) fglrx(0): #0: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
sta ad indicare che per la scheda 0 il 1280x1024 sia presente ... si potrebbe avere una copia del tuo xorg.conf?
 

nico.linux

Utente Attivo
225
0
Certo Airex. Te lo copio subito

Ecco il mio xorg.conf
Codice:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "aticonfig-Screen[0]" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

    # path to defoma fonts
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load  "i2c"
    Load  "bitmap"
    Load  "ddc"
    Load  "dri"
    Load  "extmod"
    Load  "freetype"
    Load  "glx"
    Load  "int10"
    Load  "vbe"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "it"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier  "stylus"
    Driver      "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier  "eraser"
    Driver      "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier  "cursor"
    Driver      "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"        # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier   "Philips 170C"
    Option        "DPMS"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
    Driver      "ati"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]"
    Driver      "fglrx"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
    Monitor    "Philips 170C"
    DefaultDepth     24
    SubSection "Display"
        Depth     1
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     4
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     8
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device     "aticonfig-Device[0]"
    Monitor    "aticonfig-Monitor[0]"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

Section "Extensions"
        Option  "Composite" "0"
EndSection
In effetti ci sono molte "wacom" ma io ho preferito non toccare nulla non sapendo dove mettere le mani. Avevo paura di pasticciarci troppo.

Edit: Per quanto riguarda il refresh credo di essermi espresso in maniera confusa. Non intendevo dire che non c'era la risoluzione adatta ma che non c'era quella risoluzione alla frequenza adatta. Il log mostra una risoluzione di quel tipo solo a 75Hz mentre il monitor la richiede a 60Hz. Spero di essere stato più chiaro adesso
 

nico.linux

Utente Attivo
225
0
Scusa se rompo :lol: airex mi hai lasciato a me stesso :blush:

Secondo te, anzi secondo voi (se no sembra che mi rivolgo solo ad airex) non c'è speranza?

Perfavore aiutatemi se potete
 

airex

Utente Èlite
2,394
12
CPU
Intel Core2Duo E6750
Scheda Madre
Gigabyte GA-G33M-DS2R
HDD
1x80GB Sata2 + 1x320GB Sata2
RAM
2 x 2048MB DDR2 800MHz
GPU
NVidia 8800GT 1GB
Audio
Intel HDA
Monitor
LCD Samsung 19"
PSU
LC Power Green Power V2.0 - 550 Watt
OS
Linux Slackware64
non ci vedo nulla di strano in quello xorg.conf, una cosa che potresti cercare di inserire è l'esatta string ModeLine relativa al tuo monitor per la risoluzione che vuoi.

Trovi tool in rete che ti permettono di ottenere tale stringa
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 36 22.6%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 101 63.5%
  • Square Enix

    Voti: 14 8.8%
  • Capcom

    Voti: 7 4.4%
  • Nintendo

    Voti: 21 13.2%
  • Altro (Specificare)

    Voti: 15 9.4%

Discussioni Simili