[PROBLEMA] Internet su FreeBSD

  • Nuovo server! Potrebbero esserci ancora piccoli problemi legati alle disponibilità dei servizi del Forum. Scopri di più
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#1
Ei,

oggi ho installato FreeBSD sul mio fisso a 32 bit. Ho fatto anche fare il fetching di archivi per il debug del sistema e kernel e, quindi, dato che mi aveva chiesto prima di installare e non dopo di configurare internet, usando la scheda wireless esterna(tp-link tl-wn725n) e mettendo la corretta passwd. Mi connetteva senza fare storie, fatto ipv4 e dhcp, skippato ipv6 perchè non ritenuto necessario ai fini di installazione e semplice prova di freebsd; faccio ping di google e mi dà: "ping cannot resolve hostname lookup failure". L'interfaccia è wlan0. Se volete faccio un video dell'installazione + varie prove compreso rc.conf.

Che faccio?

Grazie,

DarkSmasher
 
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#3
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#5
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#7
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#9
I primi due sharp li hai messi tu, o erano nel file di configurazione?
Perchè se erano presenti nel file, vuol dire che stai usando come DNS 127.0.0.1 invece di 192.168.1.1
Sei in DHCP o l'indirizzo 192.168.1.2 te lo sei messo tu?
Gli sharp non li ho messi io. Sono con DHCP e non ho mai toccato quel file.
 
#11
Da quella configurazione e dai sintomi, e' lampante che i dns non sono settati. La configurazione del dhcp dovrebbe restituire anche i dns, ma non lo fa. O ha scazzato il sistema o hai sbagliato qualcosa in fase d'installazione.

Non ricordo precisamente i dettagli della configurazione di rete sotto FreeBSD, ma ti posso dire che il demone responsabile e' dhclient. Il suo file di configurazione e' /etc/dhclient.conf

Io proverei a dare il comand dhclient da terminale. Se setta i dns poi si vede che altro manca. Oppure dai uno sguardo al file di configurazione, perche' forse e' specificato li' di lasciar stare la configurazione dei dns.

Se dhclient non si occupa dei dns, puoi editare manualmente /etc/resolv.conf e aggiungere uno o piu' dns manualmente.
 
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#12
Bash:
cat /etc/network/interfaces
Sì è giusto che tu non abbia mai toccato quel file e manco lo devi modificare, perchè se vado a memoria, quel file viene riscritto ogni volta
Non esiste /etc/network/interfaces, esiste o network.sibr o networks(un file).
Post unito automaticamente:

Da quella configurazione e dai sintomi, e' lampante che i dns non sono settati. La configurazione del dhcp dovrebbe restituire anche i dns, ma non lo fa. O ha scazzato il sistema o hai sbagliato qualcosa in fase d'installazione.

Non ricordo precisamente i dettagli della configurazione di rete sotto FreeBSD, ma ti posso dire che il demone responsabile e' dhclient. Il suo file di configurazione e' /etc/dhclient.conf

Io proverei a dare il comand dhclient da terminale. Se setta i dns poi si vede che altro manca. Oppure dai uno sguardo al file di configurazione, perche' forse e' specificato li' di lasciar stare la configurazione dei dns.

Se dhclient non si occupa dei dns, puoi editare manualmente /etc/resolv.conf e aggiungere uno o piu' dns manualmente.
Se faccio dhclient wlan0 mi dice che è già avviato con pid 700, esce e mi rifà di nuovo la stessa cosa.

Ogni tanto mi fa: (data di oggi e ora) freebsd dhclient[613]: send_packet: No buffer space available
 
Ultima modifica:
#13
Non esiste /etc/network/interfaces, esiste o network.sibr o networks(un file).
Quella e' una tipica cosa di Linux. FreeBSD non ce l'ha.

DarkSmasher ha detto:
Se faccio dhclient wlan0 mi dice che è già avviato con pid 700, esce e mi rifà di nuovo la stessa cosa.

Ogni tanto mi fa: (data di oggi e ora) freebsd dhclient[613]: send_packet: No buffer space available
L'errore dipende dal fatto che sta cercando di comunicare su interfacce che non sono connesse a nulla. Nel tuo caso age0.

L'altro messaggio indica che dhclient era gia' stato avviato. Ed in effetti senza non avresti potuto avere un ip assegnato a wlan0.

Detto questo, puoi provare a collegare il sistema via ethernet e vedere se da' lo stesso problema. Oppure guardare il /etc/dhclient.conf. O ancora tagliare la testa al toro e settare i dns manualmente in /etc/resolv.conf.

Occhio che potrebbe dipendere dal router. Anni fa mi capito' con Linux la stessa identica cosa ed era dovuta al fatto che il router non implementava il dns proxy.
 
257
37
Hardware Utente
CPU
Portatile: Intel Core i3-6006U Fisso: Intel Core2 Duo
Dissipatore
Fisso: Stock Intel
Hard Disk
Portatile: Hard Disk 500 GB SATA III Fisso: Hard Disk 250 GB SATA II -> AHCI + RAID Controller
RAM
Portatile: 4 GB DDR4 SDRAM Fisso: 2048 MB DDR2
Scheda Video
Portatile: Intel HD 520 Graphics Fisso: NVIDIA GT 8400 GS
Monitor
Monitor ASUS
Periferiche
Fisso: Tastiera HP e mouse Logitech wireless
Internet
ADSL Tim...
Sistema Operativo
Portatile: Linux Mint 18.3 Sylvia Fisso: Lubuntu 18.10
#14
Quella e' una tipica cosa di Linux. FreeBSD non ce l'ha.



L'errore dipende dal fatto che sta cercando di comunicare su interfacce che non sono connesse a nulla. Nel tuo caso age0.

L'altro messaggio indica che dhclient era gia' stato avviato. Ed in effetti senza non avresti potuto avere un ip assegnato a wlan0.

Detto questo, puoi provare a collegare il sistema via ethernet e vedere se da' lo stesso problema. Oppure guardare il /etc/dhclient.conf. O ancora tagliare la testa al toro e settare i dns manualmente in /etc/resolv.conf.

Occhio che potrebbe dipendere dal router. Anni fa mi capito' con Linux la stessa identica cosa ed era dovuta al fatto che il router non implementava il dns proxy.
Posso fare bridge o deve essere ethernet diretto?
Nel caso volessi settare i dns a mano, mi dice con vi che il file è lockato, come faccio a unlockarlo e a scriverci? Ho prova chown ma non ha dato risultati... Ovviamente interagisco sempre da root.
 

Discussioni Simili