DOMANDA Impostare Scheda Video Dedicata Come Principale

Greygotz

Nuovo Utente
24
0
Ciao a tutti! Sono nuovo nel forum e spero di essere nella sezione giusta.
Vorrei capire come posso impostare la scheda video dedicata del mio portatile (geforce gt 540M) come principale, invece della intel hd, integrata.

Cercherò di spiegare la situazione:

In passato da impostazioni, proprietà e programmi vari mi appariva solitamente come scheda video in uso dal computer la geforce, mentre adesso ovunque guardo appare sempre la intel.
Per esempio anche avviando il gioco Skyrim, nelle impostazioni video mi lascia selezionare solo la intel come scheda video (quando una volta appariva la nvidia), settando di conseguenza le impostazioni in qualità bassa. Sembra non usare la geforce. Eppure nella gestione periferiche la scheda risulta presente e correttamente funzionante. Ho anche provato ad impostarla dal pannello di controllo nvidia, sia come impostazione globale, che per il programma specifico, ma non cambia niente.

C'è da dire che nell'icona in basso a dx del pc, che dice quali programmi sono in uso dall gpu nvidia, sembrerebbe apparire per esempio in uso anche Skyrim. Ma questo poi nell'effettivo non sembra usare la nvidia perchè non si avvia con le impostazioni alte (come dovrebbe fare se riconoscesse la dedicata) e se le imposto manualmente in qualità alta il gioco va scattoso (come non dovrebbe invece fare).

Per fare un altro esempio sciocco, anche su CCleaner, nella parte alta dove indica i principali componenti hardware del pc, ora mi dà la intel mentre ricordo bene che una volta appariva la Geforce.

Questo problema non saprei dire di preciso da quanto tempo ce l'ho; e aggiungo che nel frattempo c'è stato un cambio di hard disk da un hdd a un ssd (con annessa reinstallazione da zero di windows).
Il mio sospetto è che una volta (parecchio tempo fa, ancora prima di formattare se non ricordo male), volendo fare una installazione pulita dei driver aggiornati nvidia, ho per errore disinstallato la scheda video da gestione periferiche invece dei driver. La cosa sembrava essersi risolta con un riaggiornamento dei driver ed infatti la scheda risulta ancora ora presente e funzionante, ma effettivamente immagino possa essere stato da quella volta lì che si è impostata la intel come predefinita ed ora non riesco più ad impostare a dedicata.
Se disattivo la integrata da gestione periferiche lo schermo mi diventa nero, e se lo faccio in modalità provvisoria, anche riavviando il pc normalmente, poi mi usa i driver plug n play di base, ma la nvidia non vuole proprio impostarla come principale.

So che si può fare anche dal BIOS ma purtroppo nel mio pc (asus k53sv) è installata la versione American Megatrends 324 del bios e la voce in cui si può impostare la scheda video principale da usare non è proprio presente. Ho letto che sarebbe da aggiornare il bios in questo caso ma anche qui nel sito asus l'ultima versione disponibile del bios per il mio pc è la 320, addirittura inferiore a quella che ho! Esiste per caso un modo di sbloccare opzioni di impostazione ulteriori o aggiuntive nel bios?

In conclusione quello che ho non è effettivamente un problema così grave, perchè nella maggior parte dei casi il sistema sembrerebbe usare la dedicata in caso di necessità, ma in altri (per esempio con skyrim) non vuole saperne.
Qualcosa è cambiato e sto diventando matto per capire cosa, visto che una volta non si comportava in questo modo.

Scusate per il papiro, ho voluto essere il più chiaro possibile.
Accetto volentieri ogni tipo di consiglio. Vi prego aiutatemi!
Grazie a tutti per l'attenzione! ciao!!
 
Ultima modifica:

mr.frizz

Utente Grafene
Utente Èlite
93,243
17,845
CPU
i7 2600k@4.5
Dissipatore
truespirit 140
Scheda Madre
msi z77a-g45
Hard Disk
500 spinpoint f3 + 840 pro 256 + sandisk ultraII 240
RAM
2*4gb tridentZ 2133 cl9
Scheda Video
Sapphire Rx 580 nitro oc+ 4GB
Scheda Audio
integrata
Monitor
lg m2232
Alimentatore
corsair tx650v1
Case
Corsair 300r WW
Sistema Operativo
7 ultimate 64
hai aggiornato i driver?
 

Greygotz

Nuovo Utente
24
0
hai aggiornato i driver?
Gli ho aggiornati tramite geforce experience, tramite gestione periferiche, e scaricando manualmente i driver dal sito, sia nvidia che asus...non sono riuscito a risolvere.
La prima volta che avevo aggiornato gli ultimi driver nvidia tramite geforce experience, avevo contemporaneamente installato la special edition di skyirim. E' stato lì che, provando anche l'altra versione precedente per vedere le differenze, ho notato che skyrim originale usava la intel come scheda video. Ho provato ad aggiornare quindi i driver anche dalla gestione periferiche, non avendolo fatto prima, e mi ha messo dei driver precedenti...questi però avevano cambiato qualcosa (l'unica volta che ci sono stati dei risultati) perchè skyrim originale a quel punto riconosceva la geforce e impostava i settaggi alti! A quel punto ho notato che era la special edition che non andava piu ora, perchè mi crashava il gioco ancora prima di avviare la partita.
Ho riaggiornato gli ultimi driver (installazione pulita) da geforce experience, solo che sono tornato al punto di partenza, anzi ora anche reinstallando, disinstallando e aggiornando i driver in mille modi non sono più riuscito a riavere skyrim che riconosce la geforce..l'ha fatto solo una volta e non so come mai.
 

mr.frizz

Utente Grafene
Utente Èlite
93,243
17,845
CPU
i7 2600k@4.5
Dissipatore
truespirit 140
Scheda Madre
msi z77a-g45
Hard Disk
500 spinpoint f3 + 840 pro 256 + sandisk ultraII 240
RAM
2*4gb tridentZ 2133 cl9
Scheda Video
Sapphire Rx 580 nitro oc+ 4GB
Scheda Audio
integrata
Monitor
lg m2232
Alimentatore
corsair tx650v1
Case
Corsair 300r WW
Sistema Operativo
7 ultimate 64
ok eliminali tutti e scarica e installa solo i driver presi dal sito del produttore del portatile ;)
 

Greygotz

Nuovo Utente
24
0
ok eliminali tutti e scarica e installa solo i driver presi dal sito del produttore del portatile ;)
Magnifico grazie!! Ho ripulito per bene il pc da ogni tipo di driver nvidia (stavolta ho usato il software Display Driver Unistaller) ed installato i driver scaricati dal sito del produttore.
Ho selezionato la scheda geforce come impostazione globale dal pannello di controllo nvidia ed ora a quanto pare và finalmente!
La versione dei driver però è piuttosto vecchiotta (268.56 contro 375.86)...ma installando la versione ultima torna ad avere lo stesso problema di prima perciò terrei quella vecchia a questo punto...mi penalizzerà molto a livello di prestazioni o cambia poco?
 

mr.frizz

Utente Grafene
Utente Èlite
93,243
17,845
CPU
i7 2600k@4.5
Dissipatore
truespirit 140
Scheda Madre
msi z77a-g45
Hard Disk
500 spinpoint f3 + 840 pro 256 + sandisk ultraII 240
RAM
2*4gb tridentZ 2133 cl9
Scheda Video
Sapphire Rx 580 nitro oc+ 4GB
Scheda Audio
integrata
Monitor
lg m2232
Alimentatore
corsair tx650v1
Case
Corsair 300r WW
Sistema Operativo
7 ultimate 64
con quella vga cambierà poco
una prova che puoi fare, è vedere se sul sito del produttore altri portatili con nvidia hanno driver più recenti, e provare con quelli
è un pò macchinoso ma è l unico modo sicuro per aggiornare i driver senza perdere lo switching
 

Entra

oppure Accedi utilizzando

Hot del momento