PROBLEMA Ho installato Xubuntu 15.10 e non funziona il wifi

CarBla

Nuovo Utente
20
3
GPU
Nvidia GeForce GTX 550Ti
OS
Windows10
[Risolto] Ho installato Xubuntu 15.10 e non funziona il wifi

Sono un neofita e, come da titolo, ho installato Xubuntu 15.10 sul mio notebook e, dopo varie prove, sono riuscito a sbloccare la parte hardware del Wifi. Tuttavia, non riesco ancora a connettermi, perché sembra che il sistema operativo individui la scheda di rete come bluetooth piuttosto che come una scheda wirless. Se disattivo il bluetooth si disattiva l'hardware del wireless.
Che fare? Sul terminale al comando rfkill list wlan mi risulta:
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
Ciò anche a bluetooth disattivato.Che fare? Suggerimenti?
Help me
Attenzione, vedo il led acceso solo col bluetooth attivato, ma se inserisco il comando iwconfig ho il seguente responso:
lo no wireless extension.

enp8s0 no wireless extension.
 
Ultima modifica:

Hobet

Utente Attivo
609
222
CPU
i5 6600k
Dissipatore
AIO H100
Scheda Madre
ASUS z170 Deluxe
HDD
1 WD Blue 1 TB; evo 850 500gb
RAM
Vengeance 4x4
GPU
GTX 1070ti MSI
Audio
Nope
Monitor
MG278Q
Case
750D Corsair
Net
Fastweb 200/30
OS
PucyBuntu
Per iniziare digita da terminale il seguente comando per vedere il chipset presente sul tuo pc:

lspci | grep -i wireless

poi magari spara su terminale un semplice:
ifconfig

e posta il risultato, e infine per strafare sempre da terminale il seguente comando:

mousepad /var/log/boot.log

e allegaci il file per vedere se durante il boot xubuntu rileva problemi di vario genere.
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,327
2,256
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
hai una broadcom , servono i driver al 99%

posta qua l'output di lspci
 

Ico Bellungi

Utente Èlite
2,921
626
Prova anche a collegarlo via ethernet ed ad andare sul gestore aggiornamenti. Poi clicchi Impostazioni-->driver aggiuntivi e vedi se ti propone dei driver proprietari per la scheda wifi
 

CarBla

Nuovo Utente
20
3
GPU
Nvidia GeForce GTX 550Ti
OS
Windows10
Scusatemi, non ho abbandonato la discussione, ne tanto meno ho risolto il problema!
1) ho provato a collegarlo via Ethernet, ma è come se non riconoscesse neppure il cavo;
2) non ho capito quale comando dare sul terminale per avere le informazioni da postarvi.
Grazie, comunque per le risposte

- - - Updated - - -

comunque, se non ho sbagliato, digitando sul terminale il comando "lspci", mi da il seguente responso:

cibi@carmelo-HPPavilion:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0)
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2)
00:13.3 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3)
00:13.4 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4)
00:13.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV620 HDMI Audio [Radeon HD 3400 Series]
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 02)
cibi@carmelo-HPPavilion:~$
 

Archer_65

Utente Attivo
1,327
121
CPU
Intel Core i5-4460 | AMD Ryzen 5 2500U
Dissipatore
Stock
Scheda Madre
AsRock H97 Pro4 | Huawei Mainboard
HDD
Samsung 860 Evo 500GB+ Seagate Barracuda 1TB 7200RPM | SSD Liteon 256GB
RAM
DDR3 Crucial Ballistix Sport 8GB 1600MHz | DDR4 8GB
GPU
Sapphire R9 280 3GB Dual-X | Vega 8
Audio
Integrata | Integrata
Monitor
LG 29UM58 21:9 | 14" FHD
PSU
Antec Neo Eco 620W 80+ Bronze
Case
NZXT Phantom 240 | Matebook D
Periferiche
CM Masterkeys Lite L
OS
Windows 10 | Windows 10+Manjaro Deepin
Scusatemi, non ho abbandonato la discussione, ne tanto meno ho risolto il problema!
1) ho provato a collegarlo via Ethernet, ma è come se non riconoscesse neppure il cavo;
2) non ho capito quale comando dare sul terminale per avere le informazioni da postarvi.
Grazie, comunque per le risposte

- - - Updated - - -

comunque, se non ho sbagliato, digitando sul terminale il comando "lspci", mi da il seguente responso:

cibi@carmelo-HPPavilion:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0)
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2)
00:13.3 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3)
00:13.4 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4)
00:13.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV620 HDMI Audio [Radeon HD 3400 Series]
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 02)
cibi@carmelo-HPPavilion:~$
Devi installare i driver, non ci sono dubbi
 

xskah

Utente Attivo
328
131
Non conosco bene le distro della famiglia *buntu, però un mese fa, su notebook di un amico, che ha la stessa identica scheda wifi che hai tu, feci prove "installate" di distro linux tra cui appunto Ubuntu e Xubuntu, entrambi 14.04. Su entrambi in fase d'installazione spuntando la casellina dei prodotti di terze parti (o qualcosa del genere), i driver Broadcom furono installati automaticamente. Adesso dovrai cercarli ed installarli tu.
Mi sembra strano che l'ethernet non funzioni le Realtek sono supportate bene sotto linux.
 

EmanueleC

Utente Èlite
5,444
1,739
CPU
Ryzen 5 2600x
Dissipatore
stock
Scheda Madre
ROG STRIX B450-F GAMING
HDD
1TB Toshiba, Toshiba TR200 240 GB
RAM
Corsair DDR4 3000 Mhz 2x8 GB
GPU
GeForce GTX 750Ti 2gb
PSU
Seasonic Focus Gold 450W
Case
BitFenix Neos
OS
Fedora 33
Inserisci il cavo di rete, cerca "driver aggiuntivi" installa i driver del wifi.
 

Allegati

  • driver_agg.png
    driver_agg.png
    79.6 KB · Visualizzazioni: 203

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,327
2,256
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66

CarBla

Nuovo Utente
20
3
GPU
Nvidia GeForce GTX 550Ti
OS
Windows10
Il problema è, come già detto sopra, che non si collega neppure col cavo Ethernet. Quindi non c'è una soluzione alternativa?
 

cdtux

Utente Èlite
1,722
764
CPU
I7 3770
Scheda Madre
Asrock Z77 Extreme 4
HDD
Samsung 850 pro 250GB
RAM
Corsair Vengeance LP 16GB
GPU
EVGA GTX670 SC
Monitor
Dell U2412M
PSU
Corsair TX850M
Case
Corsair Graphite 760T
OS
Debian / Kali Linux / Win
Strano che non funzioni anche l'ethernet, quando l'hai installato (e in live) funzionava la rete??
Potresti postarci l'output del comando:

Codice:
ifconfig
 

CarBla

Nuovo Utente
20
3
GPU
Nvidia GeForce GTX 550Ti
OS
Windows10
ecco ifconfig:
cibi@carmelo-HPPavilion:~$ ifconfig
enp8s0 Link encap:Ethernet HWaddr 00:21:cc:38:8f:70
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:851 errors:0 dropped:0 overruns:0 frame:0
TX packets:851 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:66710 (66.7 KB) TX bytes:66710 (66.7 KB)


cibi@carmelo-HPPavilion:~$

- - - Updated - - -

al comando iwconfig ho la seguente risposta:
lo no wireless extensions.

eth0 no wireless extensions.

- - - Updated - - -

Un aggiornamento. Ho scaricato su altro pc e poi trasferito sul pc con xubuntu il pacchetto "b43-fwcutter", l'ho installato con il comando "sudo dpkg -i b43-fwcutter*", ma continua a non collegarsi ed a non darmi alcuna "wireless extensions- ethernet extensions"
 

cdtux

Utente Èlite
1,722
764
CPU
I7 3770
Scheda Madre
Asrock Z77 Extreme 4
HDD
Samsung 850 pro 250GB
RAM
Corsair Vengeance LP 16GB
GPU
EVGA GTX670 SC
Monitor
Dell U2412M
PSU
Corsair TX850M
Case
Corsair Graphite 760T
OS
Debian / Kali Linux / Win
ecco ifconfig:
cibi@carmelo-HPPavilion:~$ ifconfig
enp8s0 Link encap:Ethernet HWaddr 00:21:cc:38:8f:70
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:851 errors:0 dropped:0 overruns:0 frame:0
TX packets:851 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:66710 (66.7 KB) TX bytes:66710 (66.7 KB)


cibi@carmelo-HPPavilion:~$

- - - Updated - - -

al comando iwconfig ho la seguente risposta:
lo no wireless extensions.

eth0 no wireless extensions.

- - - Updated - - -

Un aggiornamento. Ho scaricato su altro pc e poi trasferito sul pc con xubuntu il pacchetto "b43-fwcutter", l'ho installato con il comando "sudo dpkg -i b43-fwcutter*", ma continua a non collegarsi ed a non darmi alcuna "wireless extensions- ethernet extensions"

Andiamo per gradi:

Ethernet:
Il risultato del comando che hai postato mostra che la scheda di rete è attiva ma non collegata.
Assicurati che il cavo di rete sia collegato e che le lucine della porta di rete si accendano (per escludere un eventuale guasto).
Fatto ciò, dovresti avere una schermata di questo tipo:

Schermata del 2016-03-08 11:36:09.png

In caso negativo postaci il risultato del comando:
Codice:
sudo service network-manager status
(che come si può intuire serve per sapere lo stato del servizio network-manager)


WIFI:
Il pacchetto b43-fwcutter non è sufficiente, devi installare anche il firmware-b43-installer

NB. I pacchetti che devi scaricare devono essere relativi alla release che usi, ovvero wily
 

CarBla

Nuovo Utente
20
3
GPU
Nvidia GeForce GTX 550Ti
OS
Windows10
Andiamo per gradi:

Ethernet:
Il risultato del comando che hai postato mostra che la scheda di rete è attiva ma non collegata.
Assicurati che il cavo di rete sia collegato e che le lucine della porta di rete si accendano (per escludere un eventuale guasto).
Fatto ciò, dovresti avere una schermata di questo tipo:

Visualizza allegato 198189

In caso negativo postaci il risultato del comando:
Codice:
sudo service network-manager status
(che come si può intuire serve per sapere lo stato del servizio network-manager)


WIFI:
Il pacchetto b43-fwcutter non è sufficiente, devi installare anche il firmware-b43-installer

NB. I pacchetti che devi scaricare devono essere relativi alla release che usi, ovvero wily

Allora, innanzitutto grazie per il consiglio.
Ecco cosa ho provato a fare.
1) Ho provato ad installare manualmente il b43- fwcutter e il firmware e questo è stato il risultato:

Codice:
cibi@carmelo-HPPavilion:~$ sudo dpkg -i /home/cibi/b43-fwcutter_019-2_i386.deb
[sudo] password for cibi: 
(Lettura del database... 150765 file e directory attualmente installati.)
Preparativi per estrarre .../b43-fwcutter_019-2_i386.deb...
Estrazione di b43-fwcutter (1:019-2) su (1:015-9)...
Configurazione di b43-fwcutter (1:019-2)...
Elaborazione dei trigger per man-db (2.7.4-1)...
cibi@carmelo-HPPavilion:~$ sudo dpkg -i /home/cibi/firmware-b43-installer_019-2_all.deb
(Lettura del database... 150765 file e directory attualmente installati.)
Preparativi per estrarre .../firmware-b43-installer_019-2_all.deb...
Estrazione di firmware-b43-installer (1:019-2) su (1:019-2)...
Configurazione di firmware-b43-installer (1:019-2)...
No chroot environment found. Starting normal installation
--2016-03-09 11:46:33--  http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2
Resolving www.lwfinger.com (www.lwfinger.com)... failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘www.lwfinger.com’
Some problem occurred during the firmware download. Please check your internet connection.
cibi@carmelo-HPPavilion:~$

2) Poi ho collegato il cavo Ethernet e questo è stato il responso del netwok-manager

Codice:
cibi@carmelo-HPPavilion:~$ sudo service network-manager status
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since mer 2016-03-09 11:28:30 CET; 21min ago
 Main PID: 620 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─620 /usr/sbin/NetworkManager --no-daemon


mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <info>  urfkill disap...
mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <info>  use BlueZ ver...
mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <info>  ModemManager ...
mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <info>  ofono is now ...
mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <info>  wpa_supplican...
mar 09 11:28:31 carmelo-HPPavilion NetworkManager[620]: <warn>  failed to enu...
mar 09 11:28:36 carmelo-HPPavilion NetworkManager[620]: <info>  startup complete
mar 09 11:28:41 carmelo-HPPavilion NetworkManager[620]: <info>  WiFi hardware...
mar 09 11:28:41 carmelo-HPPavilion NetworkManager[620]: <info>  WWAN hardware...
mar 09 11:40:20 carmelo-HPPavilion NetworkManager[620]: <info>  kernel firmwa...
Hint: Some lines were ellipsized, use -l to show in full.
cibi@carmelo-HPPavilion:~$

Non ho ancora risolto il problema. E adesso che faccio?
 

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 37 23.0%
  • Gearbox

    Voti: 3 1.9%
  • Xbox & Bethesda

    Voti: 102 63.4%
  • Square Enix

    Voti: 14 8.7%
  • Capcom

    Voti: 7 4.3%
  • Nintendo

    Voti: 21 13.0%
  • Altro (Specificare)

    Voti: 15 9.3%

Discussioni Simili