[Guida WINDOWS] Installazione Hackintosh Yosemite 10.10 (Intel/AMD) + NIRESH (Chameleon)

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
oXs5ElN.png

Eccoci qui per parlare nuovamente di Hackintosh, questa volta prendendo però in esame una distribuzione modificata, ovvero la Niresh.

Questa differisce dalla versione App Store in quanto viene distribuita *non* in formato .app (e quindi masterizzabile solo con Mac OS X) ma in formato .dmg, ossia un formato immagine che può essere masterizzata anche con Windows. Per i possessori di Mac OS X (o di distribuzioni virtualizzate basate su OS X, come ad esempio Hackintosh) consigliamo di seguire la guida con il metodo Clover con supporto a El Capitan.


Ovviamente si potrà usare la stessa Niresh per creare in un secondo momento la chiavetta con metodo Clover e quindi passare direttamente a El Capitan, usando così questa guida da ponte per chi non possiede un Mac.


Ci tengo inoltre a precisare che Niresh è una distribuzione non ufficiale di Apple, pertanto non linkeremo alcun download ad essa ma è facilmente scaricabile in qualunque circuito HTTP (ufficiale) e Torrent (non ufficiale).
Niresh differisce dalla Vanilla (quindi la versione ufficiale di Apple) in quanto contiene al suo interno i kext (per i profani, i driver) già preconfigurati per far funzionare un buon 90% di periferiche non firmate da Apple.


Esistono inoltre alternative a Niresh, di cui non parleremo ma che comunque possono essere scaricate come alternativa e installate tramite il metodo di cui parleremo.


eTVFYHr.png


0 - LEGGERE PRIMA DI PROSEGUIRE
Nota bene: la seguente guida è a scopo illustrativo. La community Tomshw.it declina ogni responsabilità in merito all'utilizzo errato o che va contro le leggi vigenti in Italia. Non ci riteniamo inoltre responsabili di danneggiamenti a componenti Hardware o Software ad Aziende o Privati. Buona lettura.


1 - Cosa ci occorre
Per prima cosa assicuratevi di avere:

  • La versione .dmg di Hackintosh Niresh
  • Un computer totalmente (o parzialmente) compatibile con Hackintosh (se avete dubbi chiedete qui)*
  • Una chiavetta USB da almeno 8GB
  • Il programma Transmac (scaricabile da qui, la trial andrà benissimo)


*Assicuratevi di avere un BIOS Legacy e *non* UEFI, in quanto il bootloader di default (Chameleon) gira solo su Legacy.


2 - Preparazione della chiavetta USB


La creazione della chiavetta sarà talmente banale che non tratteremo l’argomento, invece vi consigliamo di seguire questo breve video da un paio di minuti che vi spiega come formattare a dovere la chiavetta:
https://www.youtube.com/watch?v=6jXkGAwP8H8


3 - Configurazione del BIOS


A questo punto bisogna configurare in maniera appropriata il BIOS. Solitamente per accedervi l’hotkey è il tasto CANC, quindi settate come di seguito:

  • Se HPET è disponibile, settiamolo su Attivo e in modalità 64 bit
  • Se Executive Disabled Bit (tecnologia chiamata anche XD), attivatela
  • Se Virtualization Technology (conosciuta anche come VT-x o VT-d), attivatela
  • Impostate USB Legacy su ON, se da problemi impostatela su OFF
  • Se UEFI è attivato, disabilitatelo
  • Salvate il BIOS e riavviate


Se non riuscite ad attivare il Setup del BIOS, chiedete qui.


4 - Avviare il Boot da USB
Ora bisogna richiamare l’USB da Boot, per farlo dopo aver riavviato il pc clicchiamo su F3 oppure F7 oppure F8 oppure F12 (dipende dalla vostra scheda madre).


Se non riuscite ad avviare l’USB in fase di boot, chiedete qui.


5 - Fase di Boot
All’avvio da USB ci troviamo di fronte il Boot Apple (il logo della mela) modificato con il logo Hackintosh.zone . Qui potrebbero nascere i primi problemi, in quanto molto spesso la barra di caricamento si blocca non lasciando alcun messaggio di errore.
Per risolvere alla maggior parte degli inconvenienti, vi consigliamo di googlare (prometto una guida in futuro!) così da trovare la soluzione a quasi tutti i tipi di problemi.


6 - Fase di Installazione
Se tutto è andato per il verso giusto ci troviamo di fronte alla prima installazione di Hackintosh Yosemite. Procediamo dunque in questo modo:



  • Selezioniamo la lingua madre
  • Dalla barra in alto, selezioniamo Utilities (Utilità) => Disk Utility (o Utilità Disco)
    WbRxq13.png
  • Selezioniamo il Volume che vogliamo usare per la nostra partizione, clicchiamo quindi su Erase (Inizializza) e scegliamo il formato Mac OS Extendend (Journaled). Clicchiamo ora su Erase (Inizializza)
    mBbTdtA.png
  • Attendiamo la formattazione, quindi chiudiamo Utility Disco e ritorniamo sullo script d’installazione dove installeremo Yosemite
    dhVWmIE.png
  • (Per Esperti) Se volete potete configurare, con il pulsante Customize in basso a sinistra, le boot flags che volete utilizzare per il prossimo boot, senza quindi dover riconfigurare Chameleon (o Clover)
  • (Per Esperti) Se avete necessità, installare Clover anzichè Chameleon - per chi ha bisogno di bootare in EFI
 

MarioDepa96

Nuovo Utente
128
15
Ho provato anche con questa guida ma quando sta bootando la chiavetta mi appare per mezzo secondo il logo di yosemite zone ma poi boota w8
 

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
Quello avevo risolto con /haswell visto il processore montato, ma alla fine mi ha dato un errore di CPU panic. Ormai ci ho rinunciato ma grazie delle guide
Purtroppo l'hackintosh è sempre un salto nel vuoto... magari in futuro sarai più fortunato con l'uscita della nuova Niresh ;)
BTW ci sono molti altri metodi: iAtkos, iBoot e altri che non ho mai usato ma provare non costa nulla (se hai tempo da dedicarci)
 

DroidBoy

Utente Attivo
163
7
CPU
i7 4820k
Scheda Madre
Alienware x79
RAM
Dominator platinum 4x2
GPU
nvidia geforce gtx 760
Audio
Integrata
Monitor
LG 22EN33
PSU
850 W
Case
Alienware AURORA ALX
OS
Windows 10 pro (x64)
Vi prego datemi una mano, ormai sarà la 6 volta che reinstallo osx, ed ogni volta mi imbatto in un problema non da poco. In pratica quando riavvio il sistema, nel bios la modalita AHCI cambia automaticamente da "manual" ad "auto". Nel mio bios infatti per la modalità AHCI, ci sono solo le opzioni "auto" e "manual", in modalità "manual" il sistema parte tranquillamente invece nella modalità "auto" no, e se lo lascio in "auto" il boot si ferma su una schermata nera con un "underscore" che lampeggia nell'angolo in alto a sx. Pero ho notato una cosa, la prima volta che ho riavviato, cioe nella fase d'installazione, quando me l'ha chiesto il sistema, questo cambio non è avvenuto, invece dopo il primo avvio, e le fasi di "Repair permissions" e "Rebuild chache", che il sistema ha effettuato in automatico al primo avvio, la modalità ha cominciato a cambiare in automatico. Quindi questo mi ha fatto pensare, magari esistono dei boot-flags che fanno questo cambio, e magari sono stati applicati dal sistema. E cosi? Esiste un modo per risolvere questo problema?

Vi ringrazio in anticipo.
 

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
Vi prego datemi una mano, ormai sarà la 6 volta che reinstallo osx, ed ogni volta mi imbatto in un problema non da poco. In pratica quando riavvio il sistema, nel bios la modalita AHCI cambia automaticamente da "manual" ad "auto". Nel mio bios infatti per la modalità AHCI, ci sono solo le opzioni "auto" e "manual", in modalità "manual" il sistema parte tranquillamente invece nella modalità "auto" no, e se lo lascio in "auto" il boot si ferma su una schermata nera con un "underscore" che lampeggia nell'angolo in alto a sx. Pero ho notato una cosa, la prima volta che ho riavviato, cioe nella fase d'installazione, quando me l'ha chiesto il sistema, questo cambio non è avvenuto, invece dopo il primo avvio, e le fasi di "Repair permissions" e "Rebuild chache", che il sistema ha effettuato in automatico al primo avvio, la modalità ha cominciato a cambiare in automatico. Quindi questo mi ha fatto pensare, magari esistono dei boot-flags che fanno questo cambio, e magari sono stati applicati dal sistema. E cosi? Esiste un modo per risolvere questo problema?

Vi ringrazio in anticipo.
Prova a bootare con -x -v -s
 

DroidBoy

Utente Attivo
163
7
CPU
i7 4820k
Scheda Madre
Alienware x79
RAM
Dominator platinum 4x2
GPU
nvidia geforce gtx 760
Audio
Integrata
Monitor
LG 22EN33
PSU
850 W
Case
Alienware AURORA ALX
OS
Windows 10 pro (x64)
Posso inserirli direttamente nel bootloader? Perche quando accendo il pc, non mi da la possibilità di inserire boot-flags, mi appare solo la schermata Nir**** con la bara di caricamento, poi entra nel desktop.

Grazie per la risposta

- - - Updated - - -

Prova a bootare con -x -v -s
ho provato a bootare con quei flags, ma il problema persiste . Non capisco perche il cmos si reseta, la batteria l'ho cambiata, quindi quella e da escludere. Altre idee?
 

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
Posso inserirli direttamente nel bootloader? Perche quando accendo il pc, non mi da la possibilità di inserire boot-flags, mi appare solo la schermata Nir**** con la bara di caricamento, poi entra nel desktop.

Grazie per la risposta

- - - Updated - - -


ho provato a bootare con quei flags, ma il problema persiste . Non capisco perche il cmos si reseta, la batteria l'ho cambiata, quindi quella e da escludere. Altre idee?
Chiedi nella sezione Schede Madri, non è evidentemente un problema lato software (perlomeno, Hackintosh non può resettare il BIOS).
FORSE va in Kernel Panic e la scheda madre va in reset ma IMHO è un problema quasi impossibile.
 

DroidBoy

Utente Attivo
163
7
CPU
i7 4820k
Scheda Madre
Alienware x79
RAM
Dominator platinum 4x2
GPU
nvidia geforce gtx 760
Audio
Integrata
Monitor
LG 22EN33
PSU
850 W
Case
Alienware AURORA ALX
OS
Windows 10 pro (x64)
Chiedi nella sezione Schede Madri, non è evidentemente un problema lato software (perlomeno, Hackintosh non può resettare il BIOS).
FORSE va in Kernel Panic e la scheda madre va in reset ma IMHO è un problema quasi impossibile.

Allora, il problema del cmos reset l'ho risolto, ma adesso ne e comparso un'altro. In pratica dopo aver scelto l'unita d'avvio dal menu di clover, il display diventa nero, e l'unico modo per entrare dentro il sistema è, usando il boot-flag "nv_disable=1" che pero rende il sistema molto lento. Qualche idea?
 

DroidBoy

Utente Attivo
163
7
CPU
i7 4820k
Scheda Madre
Alienware x79
RAM
Dominator platinum 4x2
GPU
nvidia geforce gtx 760
Audio
Integrata
Monitor
LG 22EN33
PSU
850 W
Case
Alienware AURORA ALX
OS
Windows 10 pro (x64)

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
Si l'avvevo gia letto questo 3d, ma non sono riuscito a risolvere il problema. C'e una cosa peró; dopo l'installazione di yose. , avvevo installato quel tool post installazione che tu hai postato nel 3d di elCapt. , si e stata una mossa un po azzardata, pero con questo ho risolto il problema del CMOS reset, pero e nato quest'altro problema. Puo dipendere da questo?

Grazie
Cioè ti si resetta il CMOS dopo la post installazione?
 

DroidBoy

Utente Attivo
163
7
CPU
i7 4820k
Scheda Madre
Alienware x79
RAM
Dominator platinum 4x2
GPU
nvidia geforce gtx 760
Audio
Integrata
Monitor
LG 22EN33
PSU
850 W
Case
Alienware AURORA ALX
OS
Windows 10 pro (x64)
Cioè ti si resetta il CMOS dopo la post installazione?
No, intendevo che il problema del cmos reset l'ho risolto con il tool post installazione (clover legacy intendo), da te postato nella guida di elcapt. .
Cmq ho risolto anche il problema dello schermo nero, impostando nel file "config.plist" di clover, nVidia=true, e tutti gli altri a false(Graphics->Inject->nVidia=true, per intenderci).
Un'ultima domanda. E possibile saltare il menu di clover, in modo che quando avvio il computer, l'HD venga selezionato in automatico, senza che stia li a selezionarlo ogni volta.

Grazie per l'aiuto cmq.
 

Stefano Novelli

Amministratore
Staff Forum
4,249
5,142
No, intendevo che il problema del cmos reset l'ho risolto con il tool post installazione (clover legacy intendo), da te postato nella guida di elcapt. .
Cmq ho risolto anche il problema dello schermo nero, impostando nel file "config.plist" di clover, nVidia=true, e tutti gli altri a false(Graphics->Inject->nVidia=true, per intenderci).
Un'ultima domanda. E possibile saltare il menu di clover, in modo che quando avvio il computer, l'HD venga selezionato in automatico, senza che stia li a selezionarlo ogni volta.

Grazie per l'aiuto cmq.

Ma questa è la guida su Chameleon. Stai bootando in Chameleon o Clover?
 

Entra

oppure Accedi utilizzando