RISOLTO Frequenti avvisi DNS_PROBE_FINISHED_NXDOMAIN

Stato
Discussione chiusa ad ulteriori risposte.

SuperSandro

Utente Attivo
148
12
Premessa:

* PC Windows 10 (64 bit)
* Botebook Windows 10 (32 bit)
* Non ho linea fissa, ma uso un Samsung S9+ con SIM Iliad (da oltre tre anni) che uso come router in tethering.

Problema:

Da alcune settimane, quando navigo sul web, capita spesso (ma molto, molto spesso) che le pagine vengono caricate con un certo ritardo oppure compare una schermata bianca che segnala l'errore DNS_PROBE_FINISHED_NXDOMAIN. A questo punto è sufficiente fare un refresh e la pagina viene correttamente.

Perché?
Post automatically merged:

Dimenticavo: quando invece navigo sul web sullo smartphone non succede mai, ma proprio MAI.
 

Moffetta88

Moderatore
Staff Forum
Utente Èlite
16,717
9,876
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
Direi di fare una cosa intanto, scarica malwarebytes e fai una bella scansione con relativa pulizia ^__^
Poi direi di impostare i DNS su 1.1.1.1 sui computer e di non lasciare quelli generati da Illiad.
Per modificare i DNS su Windows 10 è molto semplice.
Vai in Impostazioni -> Rete e Internet -> Stato
Qui dovresti trovare la dicitura Modifica opzioni scheda, pigialo e nella nuova schermata ti uscirà l'elenco delle schede di rete fisiche e virtuali installate nel computer.
Fai click con il destro su quella interessata ( immagino wifi ) e fai proprietà. nella nuova scheda hai un elenco di componenti, premi su Protocollo Internet Versione 4 (TCP/IPv4) e quindi su Proprietà.
A questo punto metti la spunta solo a Utilizza i seguenti indirizzi server DNS ed inserisci:
- 1.1.1.1 come primario
- 8.8.8.8 come secondario
 

SuperSandro

Utente Attivo
148
12
Direi di fare una cosa intanto, scarica malwarebytes e fai una bella scansione con relativa pulizia ^__^
Poi direi di impostare i DNS su 1.1.1.1 sui computer e di non lasciare quelli generati da Illiad.
[eccetera]
... uhmm ... grazie per il consiglio: mi riprometto di seguire le indicazioni suggerite non appena mi documenterò sul significato di quei parametri. Però per TRE anni non ho mai avuto problemi.
Leggendo la risposta ("...scarica malwarebytes e fai una bella scansione ...") voglio dapprima verificare se il problema è legato al programma Fing che avevo installato qualche tempo fa per verificare i dispositivi connessi e che si attiva automaticamente ogni volta che accendo il PC. Ora l'ho disattivato per seguire il comportamento del PC.
 

Moffetta88

Moderatore
Staff Forum
Utente Èlite
16,717
9,876
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
Fing è un software che uso anche io su smartphone, non ha problemi.
I dns sono dei "server" che traducono gli indirizzi IP in nomi..
Esempio terra-terra: 142.250.180.142 ---> google.com
Molte volte i DNS forniti dagli ISP fan schifo, e quindi è sempre consigliato usarne di terzi, come quelli di google ( 8.8.8.8 o cloudflare 1.1.1.1 )
 

SuperSandro

Utente Attivo
148
12
Fing è un software che uso anche io su smartphone, non ha problemi.
I dns sono dei "server" che traducono gli indirizzi IP in nomi..
Esempio terra-terra: 142.250.180.142 ---> google.com
Molte volte i DNS forniti dall'ISP fan schifo, e quindi è sempre consigliato usarne di terzi, come quelli di google ( 8.8.8.8 o cloudflare 1.1.1.1 )
Ah, ok, temevo per Fing... ;)
Comunque, niente da fare: anche senza Fing ci sono ritardi. Sapevo dei DNS, ma non che ci sono parametri "universali" e affidabili. Ora provo; del resto, se qualcosa va storto posso sempre selezionare "imposta automaticamente..." Giusto?
 

Moffetta88

Moderatore
Staff Forum
Utente Èlite
16,717
9,876
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
Quelli che ti ho dato io sono affidabili.. se no non te li scrivevo scusa nè.. Mica son qui a pettinare i castori!
Sì basta che pigi il "imposta automaticamente" e ti va a selezionare quelli forniti da illiad..
 

SuperSandro

Utente Attivo
148
12
Quelli che ti ho dato io sono affidabili.. se no non te li scrivevo scusa nè.. Mica son qui a pettinare i castori!
Sì basta che pigi il "imposta automaticamente" e ti va a selezionare quelli forniti da illiad..
Eh... va be'... infatti riconoscevo l'affidabilità dell'informazione che i hai dato. ;)
Ok, ora ho impostato quei parametri ed è comparsa la schermata "Diagnostica di rete di Windows - Rilevamento di Problemi - Avvio della diagnostica di rete in corso ..."
Comunque, se sto scrivendo, vuol dire che non ci sono particolari problemi.
Se ho risolto, ovviamente, avviserò. Intanto grazie!
 

Moffetta88

Moderatore
Staff Forum
Utente Èlite
16,717
9,876
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
E' possibile che devi prima scollegarti dal wifi e poi ricollegarti.
 

SuperSandro

Utente Attivo
148
12
E' possibile che devi prima scollegarti dal wifi e poi ricollegarti.
...uhmm... no: nessun problema. Finora (però è passata appena mezz'ora) non ci sono più i ritardi lamentati e nemmeno le schermate di avviso. Domattina proverò anche sul notebook (Win 10, 32 bit) che utilizzo per leggere i giornali quando faccio colazione.
 

SuperSandro

Utente Attivo
148
12
Ultime notizie:

1) Tutto ok sul PC: non compaiono più le schermate di errore e le connessioni mi sembrano più veloci.

2) Anche sul vecchio notebook Windows 10 (32 bit) ho impostato quei parametri e le finestre di errore non compaiono più. Avevo dimenticato di dire che questo notebook è connesso a un router TP Link 600 in cui c'è anche lì un'altra SIM Iliad. Il router è usato prevalentemente per gestire l'ambiente Alexa dei dispositivi disseminati in casa, ma anche per le connessioni al vecchio notebook, a un Chromebook Asus e a un notebook HP che da Windows ho "convertito" a Ubuntu.

3) Son contento. Però...


----------------------------------------

4) Che fare con le impostazioni Chromebook Asus?

Vado su: Impostazioni / Rete / Reti note / [nome_mia_rete] / Avanzate / Rete / Selezione di default: "Configura automaticamente indirizzo IP"

C'è anche la possibilità di selezionare "Server dei nomi" la cui impostazione di default è: "Assegnazione automatica nomi ai server", ma sono possibili queste altre scelte:

* Server de nomi Google: 8.8.4.4 , 8.8.8.8
* Assegna nomi personalizzati a server: (8.8.4.4) (8.8.8.8) 0.0.0.0) (0.0.0.0)

Prima di fare casini, credo che dovrei anzitutto deselezionare "Configura automaticamente indirizzo IP", poi selezionare "Server dei nomi Google" ma non solo i parametri sono diversi da quelli che hai suggerito, ma non saprei come modificarli (cliccandoci sopra non accetta modifiche).
Per ora lascio tutto com'è (Assegnazioni di default).

----------------------------------------


5) Notebook Linux Ubuntu

Ahimè, non sono molto pratico di Linux (anzi, non lo sono per niente) e non riesco a individuare le impostazioni per la gestione degli indirizzi IP.
Clicco in alto a destra su Nome_mia_rete / Impostazioni wi-fi / ipv4 / Manuale...
...poi dovrei digitare 1,1,1,1,8,8,8,8 nel campo DNS?
Non vorrei fare casini, quindi desisto.
----------------------------------------

Intanto, grazie mille per le preziose informazioni che hanno risolto una grossa seccatura.
 

Allegati

  • 2022_01_05_Linux_DNS.jpg
    2022_01_05_Linux_DNS.jpg
    59.2 KB · Visualizzazioni: 20
Ultima modifica:

Moffetta88

Moderatore
Staff Forum
Utente Èlite
16,717
9,876
CPU
i5-4690
Dissipatore
DEEPCOOL CAPTAIN 240EX
Scheda Madre
MSI Z97 U3 PLUS
HDD
KINGSTON SSD KC400 240GB
RAM
24GB BALLISTIX SPORT @2133MHz
GPU
STRIX GTX980 DC2OC
Audio
INTEGRATA
Monitor
AOC G2590VXQ
PSU
BEQUIET! System Power 7 500W
Case
DEEPCOOL MATREXX 55
Periferiche
NESSUNA
Net
FTTC FASTWEB
OS
UBUNTU/WINDOWS10
Sul chromebook se selezioni "Server de nomi Google" dovresti essere a posto.
Su linux ( ubuntu ) è molto semplice.
Vai sulle impostazioni, selezioni rete, a fianco della tua connessione premi sull'ingranaggio
1641369601539.png


Nella pagina che si apre vai su IPv4
1641369695619.png


Per prima cosa togli la spunta alla voce Automatico del DNS, poi inserisci 1.1.1.1,8.8.8.8 son separati da virgola, ed infine pigi su applica in alto. Scolleghi la rete e la ricolleghi per rendere effettive le modifiche
 
  • Mi piace
Reazioni: SuperSandro
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando