PROBLEMA Flickering in game in modalità schermo intero

kapz5500

Utente Attivo
238
26
CPU
intel i7-3770
Scheda Madre
MSI H77MA-G43
HDD
Crucial MX500 500gb + 2x 320gb Seagate Momentus XT
RAM
2x4gb Kingston @1333mhz
GPU
Sapphire Radeon R9 295x2
Monitor
Asus PB287Q
PSU
Corsair AX860
Case
Corsair Obsidian 450D
OS
Windows 10 Pro
Ciao a tutti amici del forum!! Spero di essere esaustivo e chiaro nell'esposizione del mio problema, eventualmente sono disponibile a qualsiasi chiarimento!

Da qualche settimana la mia scheda video (una Sapphire R9 295x2) fa i capricci. Premesso che in questo momento sul PC ho installato solo GTA V, riporterò i problemi che purtroppo sto sperimentando in questo gioco!

Considerate che in data odierna (dopo vari tentativi a vuoto e tanti, tanti santi cascati dalle mie parti) sono arrivato ad una conclusione:
gli artefatti che vi mostrerò sotto spoiler, così come freeze vari improvvisi durante il gioco che mi costringevano a resettare l'intero sistema nei giorni passati, erano tutti accomunati da un solito "bug": artefatti, flickering rapidissimo in game ecc si verificano quando le impostazioni sono settate su "modalità schermo intero". Se imposto il gioco in "modalità finestra" oppure in "finestra senza bordi", apparentemente la situazione è "giocabile" (indico questo termine sotto virgolette poiché in queste due ultime modalità il gioco non è mai stato fluido, è come se andasse sui 40 fps così ad occhio).

Consideriamo che queste sono attualmente le mie impostazioni Radeon:

amd.PNG

Modalità "schermo intero" attivata: nella schermata iniziale del gioco appare in alto questo artefatto (riga non uniforme orizzontale che va in alto e in basso freneticamente) :
IMG_4262.JPG

Se entro nelle impostazioni grafiche del gioco, agendo sul v-sync accade ciò:

v-sync disattivato: gioco fluido, ma una "barra" nera si muove freneticamente in senso verticale (non catturabile tramite foto) rendendo il tutto ingiocabile. Presenza inoltre di freeze totalmente randomici che mi costringono a riavviare il pc tramite reset.
v-sync impostato su "mezza": movimenti di gioco fluidi ma ingiocabile per via di un flickering molto rapido (barra nera scomparsa, solo flickering)
v-sync impostato su "sì": stessa situazione di sopra, ma con flickering ancora più rapido.

Per chi fosse arrivato fin qui con la lettura approfitto per dire che avendo un'altra R9 295x2 a casa ho effettuato le medesime prove anche con questa (anche per escludere che il problema fosse proprio nella scheda video) e anche lei si comporta nella stessa maniera.

Ragazzi vi dico la verità a questo punto non so più che cosa tentare, anche perché questo conflitto con la modalità a schermo intero si è presentata all'improvviso. Mi scuso se il post sia effettivamente un po' lungo ma ci tenevo a spiegare nel modo più chiaro possibile il mio problema... confido nel vostro aiuto e ovviamente resto a disposizione per altri chiarimenti!!

Grazie a tutti in anticipo :brindiamo:
 

Allegati

  • amd.PNG
    amd.PNG
    1.4 MB · Visualizzazioni: 138
Ultima modifica:

demadavide

Utente Èlite
4,803
1,683
CPU
i7 6700k
Dissipatore
Cooler Master Hyper T4
Scheda Madre
MSI z170a sli plus
HDD
HD western digital 1TB + ssd samsung 850evo 500 gb
RAM
Corsair 16gb (8x2) ddr4 2400 mhz
GPU
MSI gtx 1080 Armor OC boost 1962 mhz
Audio
realtek
Monitor
LG 24" Full HD 60 hz 1ms
PSU
Evga 650 w plus gold Gq
Case
Corsair Carbide 300r rosso nero :)
OS
windows 10 pro 64 bit
Ciao a tutti amici del forum!! Spero di essere esaustivo e chiaro nell'esposizione del mio problema, eventualmente sono disponibile a qualsiasi chiarimento!

E' circa una settimana che la mia scheda video (una Sapphire R9 295x2) fa i capricci. Premesso che in questo momento sul PC ho installato solo GTA V, riporterò i problemi che purtroppo sto sperimentando in questo gioco!

Tutto è iniziato con dei freeze improvvisi durante il gioco che mi costringevano, la quasi totalità delle volte, a riavviare forzatamente il PC con il tasto reset poiché si bloccava tutto il sistema.
Poco prima, nelle impostazioni grafiche del gioco, avevo impostato la tassellazione su "molto alta" e la "distanza di scaling estesa" (che ho letto essere molto avida a livello di fps) era già precedentemente impostata a circa il 50% del totale consentito. E' più o meno in questo momento che sono iniziati i freeze.

Ho azzerato quindi la distanza di scaling estesa: freeze ancora presenti.
Ho impostato progressivamente la tassellazione prima su "alta", poi su "normale" e infine disattivata come era prima: freeze ancora presenti in tutte queste situazioni.

Parallelamente, pensando ad un problema legato alle temperature poiché il colore all'interno del case era di un "arancione" più tentende al rosso del solito (apro una piccola parentesi dicendo che di solito tengo d'occhio le temperature con una combinazione di led nel case del pc, un sensore di temperatura posto davanti alla ventola in estrazione del radiatore della scheda video, il tutto collegato ad un Corsair Commander Mini) e ad un carico di lavoro magari troppo alto, sono andato sulle impostazioni radeon e tramite Wattman ho effettuato un piccolo undervolt della GPU passando da questi valori:


A 1230 mV sul controllo della tensione, togliendo quindi 20mV rispetto alle impostazioni di fabbrica e ho aumentato il "limite gpu" a un 5% in più. Non esattamente quello che si intende un overclock estremo insomma. Per forza di cose le temperature sono diminuite di qualche grado, tuttavia i freeze erano ancora presenti (in ogni caso quando si riavvia il pc tramite reset, le impostazioni di AMD Wattman per sicurezza tornano a quelle di fabbrica).

Passiamo finalmente alla data odierna!! Sono andato sulle impostazioni globali di AMD e andando sulla voce "attendi aggiornamento verticale" ho messo la spunta su "attivo, salvo diverse specifiche dell'applicazione" (prima era su "inattivo, salvo diverse specifiche dell'applicazione").

Ecco, qualora vi servissero, le altre impostazioni globali AMD:


A questo punto si verificano questi fenomeni:

nella schermata iniziale del gioco appare in alto questo artefatto (riga non uniforme orizzontale che va in alto e in basso freneticamente) :

Se entro nelle impostazioni grafiche del gioco, agendo sul v-sync accade ciò:

v-sync disattivato: gioco fluido, ma una "barra" nera si muove freneticamente in senso verticale (non catturabile tramite foto) rendendo il tutto ingiocabile
v-sync impostato su "mezza": movimenti di gioco fluidi ma ingiocabile per via di un flickering molto rapido (barra nera scomparsa, solo flickering)
v-sync impostato su "sì": stessa situazione di sopra, ma con flickering ancora più rapido.

Ragazzi vi dico la verità a questo punto non so più che cosa tentare, mi scuso se il post sia effettivamente un po' lungo ma ci tenevo a spiegare nel modo più chiaro possibile il mio problema... confido nel vostro aiuto e ovviamente resto a disposizione per altri chiarimenti!!

Grazie a tutti in anticipo :brindiamo:
Una cosa semplice: hai disinstallato i driver con ddu uninstaller e poi rimessi gli ultimi ?
 

kapz5500

Utente Attivo
238
26
CPU
intel i7-3770
Scheda Madre
MSI H77MA-G43
HDD
Crucial MX500 500gb + 2x 320gb Seagate Momentus XT
RAM
2x4gb Kingston @1333mhz
GPU
Sapphire Radeon R9 295x2
Monitor
Asus PB287Q
PSU
Corsair AX860
Case
Corsair Obsidian 450D
OS
Windows 10 Pro
Ciao!! Effettivamente ho DDU sul pc, ma dagli ultimi aggiornamenti a questa parte sto eseguendo sempre l’installazione pulita che se non sbaglio dovrebbe rimuovere i vecchi files...provare per provare comunque, posso fare un tentativo e poi riaggiornarti!
Grazie per ora :)
 

kapz5500

Utente Attivo
238
26
CPU
intel i7-3770
Scheda Madre
MSI H77MA-G43
HDD
Crucial MX500 500gb + 2x 320gb Seagate Momentus XT
RAM
2x4gb Kingston @1333mhz
GPU
Sapphire Radeon R9 295x2
Monitor
Asus PB287Q
PSU
Corsair AX860
Case
Corsair Obsidian 450D
OS
Windows 10 Pro
Una cosa semplice: hai disinstallato i driver con ddu uninstaller e poi rimessi gli ultimi ?

Rieccomi Davide, purtroppo porto cattive notizie!! Ho fatto la prova anche con DDU...i problemi rimangono gli stessi elencati sul post originale :(
Se nel frattempo qualcuno avesse suggerimenti sarò ben felice di fare qualche altro tentativo...
 

kapz5500

Utente Attivo
238
26
CPU
intel i7-3770
Scheda Madre
MSI H77MA-G43
HDD
Crucial MX500 500gb + 2x 320gb Seagate Momentus XT
RAM
2x4gb Kingston @1333mhz
GPU
Sapphire Radeon R9 295x2
Monitor
Asus PB287Q
PSU
Corsair AX860
Case
Corsair Obsidian 450D
OS
Windows 10 Pro
Riporto in alto il post in quanto modificato senza volerne creare uno identico
 

Entra

oppure Accedi utilizzando

Hot: Quale crypto per il futuro?

  • Bitcoin

    Voti: 122 45.9%
  • Ethereum

    Voti: 109 41.0%
  • Cardano

    Voti: 40 15.0%
  • Polkadot

    Voti: 14 5.3%
  • Monero

    Voti: 17 6.4%
  • XRP

    Voti: 25 9.4%
  • Uniswap

    Voti: 7 2.6%
  • Litecoin

    Voti: 16 6.0%
  • Stellar

    Voti: 16 6.0%
  • Altro (Specifica)

    Voti: 40 15.0%

Discussioni Simili