PROBLEMA EVGA GTX 970 e DisplayPort: Schermo nero

BitCrafter

Utente Attivo
279
14
CPU
Intel® Core™ i7-4790K (8M Cache, up to 4.40 GHz)
Dissipatore
Noctua NH-D14
Scheda Madre
Gigabyte GA-Z97X-Gaming 5
HDD
SSD: Samsung MZ-7KE256BW SSD 850 PRO | HD: Western Digital WD1003FZEX Caviar Black
RAM
G-Skill TridentX F3-1600C7D-16GTX
GPU
eVGA GeForce GTX 970 ACX 2.0 4096 MB GDDR5
Audio
Creative SB X-Fi Titanium PCI-e Bulk
Monitor
LG 34GK950F-B UltraGear 34" 21:9 Curved 1ms QHD nIPS HDR 400 FSync2 | SAMSUNG XL2370 23" FHD 2ms
PSU
XFX 1050W Black Edition
Case
Fractal Design Define XL-R2 (Black)
Periferiche
Keyboard: Cooler Master MasterKeys Pro L RGB - Mouse: Logitech Performance MX
OS
Windows 10 Professional X64
Ciao a tutti,
un paio di mesi fa ho acquistato il monitor LG 34GK950F-B e l'ho collegato all'ingresso DisplayPort della mia vecchia eVGA GeForce GTX 970 ACX 2.0.
Sin da subito sembrava andare tutto bene poi al riavvio mi si è presentato un bello schermo nero come se dalla scheda video non venisse inviato il segnale al monitor.

Indagando online ho capito essere un problema di driver della scheda video, in particolare sembra essere un problema che affligge la display port delle GTX 970/980.
In un post in cui se ne parla (link) viene data una soluzione macchinosa ma funzionante per aggirare il problema e far riconoscere correttamente il monitor in DP come principale.

Da quello che si scrive in quel post, se si collega un monitor alla DisplayPort, NVIDIA "pensa" di base che si abbiano due monitor e invia il segnale non so dove invece che a quell'uscita.

Ogni tanto il problema si ripresenta ma riavviando il PC si sistema nuovamente da solo, oggi invece sono stato costretto a ricollegare il cavo HDMI perchè non c'era verso di ricevere il segnale e dopo un po' di attacca e stacca e riavvi ancora una volta si è sistemato da solo.

Scrivo qui perchè spero che qualcun'altro abbia avuto questo stesso problema e magari ha trovato una soluzione permanente (aldilà del cambio di scheda video, che ora non ho possibilità di fare), inoltre vi chiedo una vostra opinione per escludere quantomeno che il problema possa derivare dal monitor stesso (anche se dubito perchè ora sono in DP e funziona perfettamente)

Qualcuno sa darmi qualche dritta? O dirmi almeno che l'unica soluzione permanente è cambiare scheda video? :lol:

Grazie mille!
 
Soluzione
Sto provando, senza modificare alcun software a staccare e riattacare la connessione DP.
Partendo da una situazione stabile, se vado a muovere un po' il connettore nel retro del pc il segnale scompare.
Credo che il problema sia proprio che non si inserisce del tutto, o che sia il connettore sulla VGA difettoso (problemone).
Sto provando a limare leggermente il connettore per vedere di inserirlo di più e capire se così risolvo il problema.
Spero di fare cavolate :D
Post automatically merged:

Ho fatto la prova di limatura.
Incredibile ma vero però dopo aver tolto praticamente tutta la copertura di plastica e SOLO nel punto in cui il case bloccava l'inserimento del connettore, ho collegato il cavo ed ho finalmente sentito quel...

alberto1991

Utente Attivo
1,181
86
CPU
i5 4690
Scheda Madre
MSI H97 PC-MATE
HDD
WD 500gb Sata III Caviar Blue + WD 500gb sata II Caviar Black
RAM
Kingston 8gb 1600mhz 1.65v ( 1333mhz 1.5v )
GPU
Sapphire r9 290 tri-x
Audio
Integrata
Monitor
Samsung SyncMaster 930MP
PSU
Thermaltake berlin 630w 80+
Case
Thermaltake commander ms-i snow edition
OS
Windows 10 pro 64-bit
  • Like
Reactions: BitCrafter

BitCrafter

Utente Attivo
279
14
CPU
Intel® Core™ i7-4790K (8M Cache, up to 4.40 GHz)
Dissipatore
Noctua NH-D14
Scheda Madre
Gigabyte GA-Z97X-Gaming 5
HDD
SSD: Samsung MZ-7KE256BW SSD 850 PRO | HD: Western Digital WD1003FZEX Caviar Black
RAM
G-Skill TridentX F3-1600C7D-16GTX
GPU
eVGA GeForce GTX 970 ACX 2.0 4096 MB GDDR5
Audio
Creative SB X-Fi Titanium PCI-e Bulk
Monitor
LG 34GK950F-B UltraGear 34" 21:9 Curved 1ms QHD nIPS HDR 400 FSync2 | SAMSUNG XL2370 23" FHD 2ms
PSU
XFX 1050W Black Edition
Case
Fractal Design Define XL-R2 (Black)
Periferiche
Keyboard: Cooler Master MasterKeys Pro L RGB - Mouse: Logitech Performance MX
OS
Windows 10 Professional X64
hai provato ad aggiornare il firmware cercando in rete molti hanno avuto il tuo problema con le porte dp


Non conoscevo questo aggiornamento firmware, ad ogni modo ho provato a installarlo.
L'installazione è terminata con successo, ho riavviato, tutto ok ma quando sono andato per scollegare il cavo HDMI (ora ho sia HDMI che DP collegati allo stesso monitor) ha rifatto il giochino di questa mattina e di nuovo, dopo vari attacca e stacca si è riaggiustato da solo.

Sono confuso :D

C'è modo di verificare la versione DisplayPort della VGA per vedere se è stata effettivamente aggiornata?
Posso provare altro?

Grazie mille
 

alberto1991

Utente Attivo
1,181
86
CPU
i5 4690
Scheda Madre
MSI H97 PC-MATE
HDD
WD 500gb Sata III Caviar Blue + WD 500gb sata II Caviar Black
RAM
Kingston 8gb 1600mhz 1.65v ( 1333mhz 1.5v )
GPU
Sapphire r9 290 tri-x
Audio
Integrata
Monitor
Samsung SyncMaster 930MP
PSU
Thermaltake berlin 630w 80+
Case
Thermaltake commander ms-i snow edition
OS
Windows 10 pro 64-bit
provare a tenere il monitor come se fosse clonato su due schermi, il fatto è salta può darsi che sia anche l'uscita dp difettosa o il cavo stesso dp che dia problemi troppe varianti.
 
  • Like
Reactions: Andreagamer1999

BitCrafter

Utente Attivo
279
14
CPU
Intel® Core™ i7-4790K (8M Cache, up to 4.40 GHz)
Dissipatore
Noctua NH-D14
Scheda Madre
Gigabyte GA-Z97X-Gaming 5
HDD
SSD: Samsung MZ-7KE256BW SSD 850 PRO | HD: Western Digital WD1003FZEX Caviar Black
RAM
G-Skill TridentX F3-1600C7D-16GTX
GPU
eVGA GeForce GTX 970 ACX 2.0 4096 MB GDDR5
Audio
Creative SB X-Fi Titanium PCI-e Bulk
Monitor
LG 34GK950F-B UltraGear 34" 21:9 Curved 1ms QHD nIPS HDR 400 FSync2 | SAMSUNG XL2370 23" FHD 2ms
PSU
XFX 1050W Black Edition
Case
Fractal Design Define XL-R2 (Black)
Periferiche
Keyboard: Cooler Master MasterKeys Pro L RGB - Mouse: Logitech Performance MX
OS
Windows 10 Professional X64
provare a tenere il monitor come se fosse clonato su due schermi, il fatto è salta può darsi che sia anche l'uscita dp difettosa o il cavo stesso dp che dia problemi troppe varianti.

Quello che ho notato è che il connettore non si inserisce completamente nella scheda video perchè c'è il case che lo blocca, potrebbe essere questo il problema?
 

alberto1991

Utente Attivo
1,181
86
CPU
i5 4690
Scheda Madre
MSI H97 PC-MATE
HDD
WD 500gb Sata III Caviar Blue + WD 500gb sata II Caviar Black
RAM
Kingston 8gb 1600mhz 1.65v ( 1333mhz 1.5v )
GPU
Sapphire r9 290 tri-x
Audio
Integrata
Monitor
Samsung SyncMaster 930MP
PSU
Thermaltake berlin 630w 80+
Case
Thermaltake commander ms-i snow edition
OS
Windows 10 pro 64-bit
Quello che ho notato è che il connettore non si inserisce completamente nella scheda video perchè c'è il case che lo blocca, potrebbe essere questo il problema?
potrebbe essere però strano che non si inserisce completamente
 

BitCrafter

Utente Attivo
279
14
CPU
Intel® Core™ i7-4790K (8M Cache, up to 4.40 GHz)
Dissipatore
Noctua NH-D14
Scheda Madre
Gigabyte GA-Z97X-Gaming 5
HDD
SSD: Samsung MZ-7KE256BW SSD 850 PRO | HD: Western Digital WD1003FZEX Caviar Black
RAM
G-Skill TridentX F3-1600C7D-16GTX
GPU
eVGA GeForce GTX 970 ACX 2.0 4096 MB GDDR5
Audio
Creative SB X-Fi Titanium PCI-e Bulk
Monitor
LG 34GK950F-B UltraGear 34" 21:9 Curved 1ms QHD nIPS HDR 400 FSync2 | SAMSUNG XL2370 23" FHD 2ms
PSU
XFX 1050W Black Edition
Case
Fractal Design Define XL-R2 (Black)
Periferiche
Keyboard: Cooler Master MasterKeys Pro L RGB - Mouse: Logitech Performance MX
OS
Windows 10 Professional X64
potrebbe essere però strano che non si inserisce completamente

Eh anche a me è sembrato strano ma la GTX 970 ha l'ingresso un po' spostato e si vede proprio che il connettore sbatte contro il case, provo a risolvere questa cosa in qualche modo e spero si risolva. Speriamo.

Una domanda, ho pensato potesse anche essere il il bios della vga vecchio solo che non so dove verificare l'ultima versione disponibile.
Secondo GPU-Z attualmente ho il 84.04.1F.00.72.
Conviene tentare un aggiornamento oppure rischio di fare più danni che altro?
 

alberto1991

Utente Attivo
1,181
86
CPU
i5 4690
Scheda Madre
MSI H97 PC-MATE
HDD
WD 500gb Sata III Caviar Blue + WD 500gb sata II Caviar Black
RAM
Kingston 8gb 1600mhz 1.65v ( 1333mhz 1.5v )
GPU
Sapphire r9 290 tri-x
Audio
Integrata
Monitor
Samsung SyncMaster 930MP
PSU
Thermaltake berlin 630w 80+
Case
Thermaltake commander ms-i snow edition
OS
Windows 10 pro 64-bit
evita ho letto che aggiornando il bios non si risolve il problema
 
  • Like
Reactions: BitCrafter

BitCrafter

Utente Attivo
279
14
CPU
Intel® Core™ i7-4790K (8M Cache, up to 4.40 GHz)
Dissipatore
Noctua NH-D14
Scheda Madre
Gigabyte GA-Z97X-Gaming 5
HDD
SSD: Samsung MZ-7KE256BW SSD 850 PRO | HD: Western Digital WD1003FZEX Caviar Black
RAM
G-Skill TridentX F3-1600C7D-16GTX
GPU
eVGA GeForce GTX 970 ACX 2.0 4096 MB GDDR5
Audio
Creative SB X-Fi Titanium PCI-e Bulk
Monitor
LG 34GK950F-B UltraGear 34" 21:9 Curved 1ms QHD nIPS HDR 400 FSync2 | SAMSUNG XL2370 23" FHD 2ms
PSU
XFX 1050W Black Edition
Case
Fractal Design Define XL-R2 (Black)
Periferiche
Keyboard: Cooler Master MasterKeys Pro L RGB - Mouse: Logitech Performance MX
OS
Windows 10 Professional X64
Sto provando, senza modificare alcun software a staccare e riattacare la connessione DP.
Partendo da una situazione stabile, se vado a muovere un po' il connettore nel retro del pc il segnale scompare.
Credo che il problema sia proprio che non si inserisce del tutto, o che sia il connettore sulla VGA difettoso (problemone).
Sto provando a limare leggermente il connettore per vedere di inserirlo di più e capire se così risolvo il problema.
Spero di fare cavolate :D
Post automatically merged:

Ho fatto la prova di limatura.
Incredibile ma vero però dopo aver tolto praticamente tutta la copertura di plastica e SOLO nel punto in cui il case bloccava l'inserimento del connettore, ho collegato il cavo ed ho finalmente sentito quel bellissimo "click" che tanto aspettavo :D

Il monitor si è accesso subito senza problemi e ora anche muovendolo con le dita è del tutto stabile.

Forse, e dico forse (non voglio gufarmela), il problema era proprio quello ed ora ho risolto :brindiamo:
 
Ultima modifica:
  • Like
Reactions: alberto1991
Soluzione

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 14 16.1%
  • Gearbox

    Voti: 1 1.1%
  • Xbox & Bethesda

    Voti: 62 71.3%
  • Square Enix

    Voti: 3 3.4%
  • Capcom

    Voti: 5 5.7%
  • Nintendo

    Voti: 13 14.9%
  • Altro (Specificare)

    Voti: 7 8.0%

Discussioni Simili