RISOLTO Errore aggiornamento Kali linux

Stato
Discussione chiusa ad ulteriori risposte.

Antonio361

Nuovo Utente
2
0
Salve a tutti ho provato ad aggiornare Kali con il classico comando "sudo apt update && sudo apt upgrade", ma mi da errore così ho provato "sudo apt --fix-broken install" ed il risultato è stato questo.

Codice:
mrblack㉿kali)-[~]
└─$ sudo apt update && sudo apt upgrade                                   100 ⨯
Trovato:1 http://kali.download/kali kali-rolling InRelease
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto  
901 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto  
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 python2 : Pre-dipende: python2-minimal (= 2.7.18-2) ma la versione 2.7.18-3 è installata
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
Codice:
┌──(mrblack㉿kali)-[~]
└─$ sudo apt --fix-broken install                                         100 ⨯
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto  
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  imagemagick-6-common liblqr-1-0 libmagickcore-6.q16-6 libmagickwand-6.q16-6
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  atftpd libpython2-stdlib python2
Pacchetti suggeriti:
  python2-doc python-tk
I seguenti pacchetti saranno aggiornati:
  atftpd libpython2-stdlib python2
3 aggiornati, 0 installati, 0 da rimuovere e 898 non aggiornati.
35 non completamente installati o rimossi.
È necessario scaricare 0 B/112 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] S
Preconfigurazione dei pacchetti in corso
(Lettura del database... 268234 file e directory attualmente installati.)
Preparativi per estrarre .../atftpd_0.7.git20210915-2_amd64.deb...
Failed to stop atftpd.service: Failed to activate service 'org.freedesktop.syste
md1': timed out (service_start_timeout=25000ms)
See system logs and 'systemctl status atftpd.service' for details.
dpkg: attenzione: il sottoprocesso vecchio pacchetto atftpd script pre-removal h
a restituito lo stato di errore 1
dpkg: viene provato lo script dal nuovo pacchetto...
Fix broken syntax in /etc/default/atftpd
Failed to stop atftpd.service: Failed to activate service 'org.freedesktop.syste
md1': timed out (service_start_timeout=25000ms)
See system logs and 'systemctl status atftpd.service' for details.
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/atftpd_0.7.git202
10915-2_amd64.deb (--unpack):
 il sottoprocesso nuovo pacchetto atftpd script pre-removal ha restituito lo sta
to di errore 1
Failed to reload daemon: Failed to activate service 'org.freedesktop.systemd1':
timed out (service_start_timeout=25000ms)
dpkg: errore durante la pulizia:
 il sottoprocesso installato pacchetto atftpd script post-installation ha restit
uito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/atftpd_0.7.git20210915-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Sinceramente non so più cosa fare qualcuno può aiutarmi?
 
Ultima modifica da un moderatore:

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,605
2,489
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
disinstalla atftp, riavvia il pc, aggiorna,pulisci la cache dei pacchetti e reinstalla atftp, magari questo step fallo dopo aver spianato kali e messo ubuntu.
 

Antonio361

Nuovo Utente
2
0
Grazie anche se ho risolto il problema eseguendo questi comandi

"sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get update

sudo apt-get -f install"
 

centoventicinque

Moderatore
Staff Forum
Utente Èlite
6,605
2,489
CPU
Intel core I5 4950/ i5 3550
Dissipatore
coolermaster Mod Anonima sequestri
Scheda Madre
anonima sequestri/ p8z77le
HDD
crucial bx500 480GB+raid0 wd blue 500GB / 8Xwd red 2TB[9420I+4X seagate 2TB [intel] 2x850 pro 256GB
RAM
16GB ddr3 1600 / 16 GB ddr3 hyperx
GPU
gtx660TI 3GB / gtx 1080 TI
Audio
Azila
Monitor
40" 4k LG / asus 27"
PSU
cm masterwatt 650 / microstar 750W
Case
anonimo itek/rack 2U
OS
archlinux X68_66
si, grossomodo fa la stessa cosa!
 
  • Mi piace
Reazioni: Antonio361
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando

Discussioni Simili