DualBoot XP-Ubuntu

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
Salve a tutti scrivo qui oggi perché dopo aver partizionato e installato Ubuntu su questa partizione dell'hard disk, all'avvio del PC non mi viene richiesto il SO da scegliere. Adesso mi sorge un dubbio, per caso dovrei installare un qualche boot manager su XP in modo che ad ogni avvio del PC mi viene richiesto quale SO scegliere?

Qulasiasi aiuto è ben accetto :)...
 

alelinuxbsd

Utente Attivo
340
42
Sistema Operativo
linux
L'elenco ti deve comparire in fase di avvio automaticamente.
Io ho l'impressione che tu hai installato linux e poi windows, purtroppo windows sovrascrive l'mbr dell'hdd, per cui al riavvio non vedi l'elenco.
Puoi usare sia il boot manager di windows per entrare in linux oppure reinstallare grub.
Amministrazione Sistema Grub
 

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
L'elenco ti deve comparire in fase di avvio automaticamente.
Io ho l'impressione che tu hai installato linux e poi windows, purtroppo windows sovrascrive l'mbr dell'hdd, per cui al riavvio non vedi l'elenco.
Puoi usare sia il boot manager di windows per entrare in linux oppure reinstallare grub.
Amministrazione Sistema Grub
No io avevo prima installato XP, dopodiché ho partizionato il pc con Gparted e installato Linux, quindi non credo sia quello il problema. Premetto che Grub non l'ho installato da nessuna parte, quindi potrebbe essere quello il motivo.

PS: ma Grub è un programma che si installa su linux , su XP o è un programma che va avviato da BIOS???
 

alelinuxbsd

Utente Attivo
340
42
Sistema Operativo
linux
Grub è il boot manager di linux, se non l'hai installato, capisco perché non ti compare l'elenco dei sistemi operativi.
 

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
Grub è il boot manager di linux, se non l'hai installato, capisco perché non ti compare l'elenco dei sistemi operativi.
Ma dove va installato? Su linux? Se è li, allora non so come fare dato che non riesco ad avviare il secondo SO. Comunque scusami tanto per le tante domande, ma sono molto niubbo su queste cose :blush:...
 

davethecipo

Utente Èlite
3,326
1,157
CPU
i5 4660
Scheda Madre
H97 PC Mate
Hard Disk
qualcuno
RAM
8 GB
Scheda Video
R9 280
Monitor
Samsung SyncMaster 940BW 19'
Alimentatore
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
Sistema Operativo
Arch Linux con KDE...Windows 10
GRUB dovrebbe essere installato di default con Ubuntu, non ricordo se il processo di installazione permette di non installarlo.

Apri un terminale (lo trovi in Applicazioni/Accessori) e se scrivi grub-install -v, ti compare qualcosa? Se si, significa che è installato, e basta dare il comando
Codice:
sudo grub-install /dev/vattelapesca
Al posto di /dev/vattelapesca ci devi scrivere il nome del disco fisso (di solito sono sda, sdb, eccetera), per capirlo apri Gparted. In questo modo GRUB viene installato nell'MBR del disco fisso.

Comunque, ora che ci penso, non capisco come fai ad avviare linux senza un boot manager! GRUB sarà installato per forza, al massimo non ti ha riconosciuto la partizione Windows (cosa che a me non è mai successa in anni)...insomma non ho capito la situazione del tuo PC! :boh:
 

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
GRUB dovrebbe essere installato di default con Ubuntu, non ricordo se il processo di installazione permette di non installarlo.

Apri un terminale (lo trovi in Applicazioni/Accessori) e se scrivi grub-install -v, ti compare qualcosa? Se si, significa che è installato, e basta dare il comando
Codice:
sudo grub-install /dev/vattelapesca
Al posto di /dev/vattelapesca ci devi scrivere il nome del disco fisso (di solito sono sda, sdb, eccetera), per capirlo apri Gparted. In questo modo GRUB viene installato nell'MBR del disco fisso.

Comunque, ora che ci penso, non capisco come fai ad avviare linux senza un boot manager! GRUB sarà installato per forza, al massimo non ti ha riconosciuto la partizione Windows (cosa che a me non è mai successa in anni)...insomma non ho capito la situazione del tuo PC! :boh:
Il mio problema sta proprio nel fatto che non riesco ad avviare linux, all'avvio parte solo XP, anche io ho letto che Grub è già di default su ubuntu, solo che non mi spiego come mai all'avvio non mi chieda quale OS avviare, mah...
 

davethecipo

Utente Èlite
3,326
1,157
CPU
i5 4660
Scheda Madre
H97 PC Mate
Hard Disk
qualcuno
RAM
8 GB
Scheda Video
R9 280
Monitor
Samsung SyncMaster 940BW 19'
Alimentatore
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
Sistema Operativo
Arch Linux con KDE...Windows 10
  • Mi piace
Reactions: io2106

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
Proverò e poi vi faccio sapere, comunque grazie per l'aiuto :)...

PS:@Davide Olianas, ma quel problema che mi dici è per caso legato al fatto che si abbia installato XP dopo Ubuntu? Perché se è così quello non è il mio caso, dato che come secondo SO ho messo proprio Ubuntu.
 

davethecipo

Utente Èlite
3,326
1,157
CPU
i5 4660
Scheda Madre
H97 PC Mate
Hard Disk
qualcuno
RAM
8 GB
Scheda Video
R9 280
Monitor
Samsung SyncMaster 940BW 19'
Alimentatore
Enermax Liberty 620W
Case
Enermax Pandora Midi Tower Black
Sistema Operativo
Arch Linux con KDE...Windows 10
Si, mi rendo conto che la cosa accade quando installi Windows dopo Ubuntu, però se il S.O parte, significa che un boot manager esiste...magari durante l'installazione di ubuntu hai scelto (o per sbaglio) di non installare GRUB? Dico solo che è l'unica idea che mi è venuta in mente per spiegare la situazione :boh: Poi magari arriva qualche illuminato che capisce davvero come sono andate le cose :D
 
  • Mi piace
Reactions: io2106

io2106

Utente Attivo
164
1
CPU
INTEL Core i5 2500k @3,30 GHz
Dissipatore
Noctua NH-D14
Scheda Madre
BIOSTAR TP67B+
Hard Disk
Samsung Spinpoint F4 320GB (HD Int.) + 640GB (HD Est.)
RAM
G.Skill Ripjaws-X 8GB (2x4GB) CL9
Scheda Video
Asus EAH5870 v2
Monitor
Samsung T240HD (1920x1200)
Alimentatore
Cooler Master Silent PRO M700 (Modulare)
Case
Antec Nineteen Hundred
Sistema Operativo
Windows 10 Home 64Bit
Si, mi rendo conto che la cosa accade quando installi Windows dopo Ubuntu, però se il S.O parte, significa che un boot manager esiste...magari durante l'installazione di ubuntu hai scelto (o per sbaglio) di non installare GRUB? Dico solo che è l'unica idea che mi è venuta in mente per spiegare la situazione :boh: Poi magari arriva qualche illuminato che capisce davvero come sono andate le cose :D
Ok tutto risolto, ti ringrazio molto, il problema stava proprio nel fatto che mancava Grub, quasi sicuramente sono stato io a non installarlo:P. Grazie mille ancora :).
 
Ultima modifica:

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento