[PROBLEMA] Differenza porte SATA sulla Mobo e Errore: no such partition

ViPaaK

Utente Attivo
Buonasera.
Recentemente ho riscontrato problemi di avvio del mio pc. All'installazione di un nuovo OS (indipendentemente da quale, ne ho provati veramente tanti) mi appariva l'errore:
"ahci 0000:03:00.0: AHCI controller unavaiable!" Dopo vari tentativi mi è venuto in mente di cambiare la porta di attacco d ell'hdd sulla mobo sulla mobo e ha funzionato tutto perfettamente (per ora). Ho notato però che ci sono due gruppi di attacchi con le seguenti diciture:
1)
SATA3_A0, SATA3_A1,
SATA3_0
SATA2_1
2)
SATA2_2, SATA2_3, SATA2_4, SATA2_5
Qualcuno sa spiegarmi la differenza? Grazie!
 

michael chiklis

Utente Attivo
4,392
1,270
Hardware Utente
CPU
Intel i5-3550 @ 3,3 GHz
Scheda Madre
ASROCK Z77 Pro3
Hard Disk
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX1600C9AD3/2G 8 GB (4x2GB)
Scheda Video
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
Alimentatore
Tecno 1000 W modulare
Sistema Operativo
Win7 x64
L'AHCI mode funziona solo su porte sata3.
Verifica sul manuale della tua mobo per capire se l'haci è abilitato su tte 3 le porte sata3 che hai (andando per sensazione, credo che solo le porte SATA3_A0 e SATA3_A1) siano compatibili in modalità ahci. Verifica sul manuale per esserne certo.
 

ViPaaK

Utente Attivo
La mia mobo è un'asrock b75 Pro3-M e sto cercando con scarso successo il manuale online sul sito ufficiale perchè avendo questo PC da oltre 5 anni non so dove possa aver messo quello cartaceo, sempre se l'ho mai avuto.
In realtà non ho proprio capito cosa sia l'AHCI e a cosa serva.
Spostando i vari cavi e mettendo:
SSD su SATA3_0,
HDD su SATA3_A0 e
Lettore DVD su SATA2_1,
avviando il boot menu mi trovo visibili tutti e tre i dispositivi con scritto sulla sinistra AHCI P0 per i primi due e AHCI P1 per l'ultimo.
Qualunque io scelga mi appare questo errore:
error: no such partition
Entering rescue mode...
grub rescue>
Eppure sono sicuro che sull'HDD c'è un sistema operativo Debian
 

Liupen

UTENTE LEGGENDARIO
9,372
3,951
Hardware Utente
CPU
Intel i7 4770K @ 4,6 GHz
Dissipatore
Corsair H80i
Scheda Madre
Asus Maximus VI Gene rel.2
Hard Disk
SSD Samsung 850 PRO 512GB + 850 EVO 1TB + 850 EVO 500GB + Seagate SSHD 1TB + BACKUP
RAM
DDR3 Corsair Vengeance 16 GB (4x4Gb 1600Hz / 8 8 8 24)
Scheda Video
ASUS STRIX GeForce GTX 970 - Clock @ 1403Mhz boost / Memoria @ 7160Mhz
Scheda Audio
(integrata)
Monitor
Samsung T24E390
Alimentatore
Enermax triathlor 650w 80plus bronze
Case
Zalman Z9 Plus full fan
Periferiche
Asus ROG GK2000 + GX850
Sistema Operativo
Windows 10
La mia mobo è un'asrock b75 Pro3-M e sto cercando con scarso successo il manuale online sul sito ufficiale perchè avendo questo PC da oltre 5 anni non so dove possa aver messo quello cartaceo, sempre se l'ho mai avuto.
In realtà non ho proprio capito cosa sia l'AHCI e a cosa serva.
Spostando i vari cavi e mettendo:
SSD su SATA3_0,
HDD su SATA3_A0 e
Lettore DVD su SATA2_1,
avviando il boot menu mi trovo visibili tutti e tre i dispositivi con scritto sulla sinistra AHCI P0 per i primi due e AHCI P1 per l'ultimo.
Qualunque io scelga mi appare questo errore:
error: no such partition
Entering rescue mode...
grub rescue>
Eppure sono sicuro che sull'HDD c'è un sistema operativo Debian
Il tuo chipset intel B75 non riesce a gestire tutte le porte sata.
Le porte aggiunte hanno un controller differente (Asmedia).
Ecco perchè ti ritrovi delle diciture differenti:
Quelle con la scritta sata2_x sono porte sata (ne hai 5) gestite da intel da max 300MB/s. Quella (1) chiamata sata3_0 è l'unica porta sata 3 gestita intel (ed è quella a cui andrebbe connesso l'ssd). Le altre due con scritto sata3_Ax sono le aggiunte (su quelle non ci attaccare niente).
Tutte le porte sata supportano AHCI. Le funzionalità delle porte aggiuntive sono sempre problematiche.
A parte questo, direi che se fai un dual boot devi farlo correttamente.
 

michael chiklis

Utente Attivo
4,392
1,270
Hardware Utente
CPU
Intel i5-3550 @ 3,3 GHz
Scheda Madre
ASROCK Z77 Pro3
Hard Disk
Samsung 860 Evo
RAM
DDR3-1600 Kingston KHX1600C9AD3/2G 8 GB (4x2GB)
Scheda Video
NVIDIA GeForce GTX 550 Ti
Monitor
Samsung SyncMaster T200
Alimentatore
Tecno 1000 W modulare
Sistema Operativo
Win7 x64
Molto probabilmente Liupen ha ragione, infatti io non ne ero certo, per questo ti ho risposto che andavo a sensazione.
Di mestiere non mi occupo di mobo e nemmeno del loro assemblaggio, mi occupo di altro ma sempre in ambito informatico/elettronico, comunque se avessi avuto il manuale della mobo sotto mano ti avrei potuto rispondere con precisione.
Post automaticamente unito:

Ho appena trovato il manuale.
E' proprio come ti ha detto Liupen
 
Ultima modifica:
  • Mi piace
Reactions: Liupen e ViPaaK

ViPaaK

Utente Attivo
In che senso 'farlo correttamente'?
Comunque ho messo:
SSD su SATA3_0 (come avevo anche letto qui)
HDD su SATA2_1
Lettore DVD su SATA2_2
come mi avete consigliato. Il problema è che continua a darmi quell'errore.
Ho seguito questo video, ma nulla da fare!
 
Ultima modifica:

Liupen

UTENTE LEGGENDARIO
9,372
3,951
Hardware Utente
CPU
Intel i7 4770K @ 4,6 GHz
Dissipatore
Corsair H80i
Scheda Madre
Asus Maximus VI Gene rel.2
Hard Disk
SSD Samsung 850 PRO 512GB + 850 EVO 1TB + 850 EVO 500GB + Seagate SSHD 1TB + BACKUP
RAM
DDR3 Corsair Vengeance 16 GB (4x4Gb 1600Hz / 8 8 8 24)
Scheda Video
ASUS STRIX GeForce GTX 970 - Clock @ 1403Mhz boost / Memoria @ 7160Mhz
Scheda Audio
(integrata)
Monitor
Samsung T24E390
Alimentatore
Enermax triathlor 650w 80plus bronze
Case
Zalman Z9 Plus full fan
Periferiche
Asus ROG GK2000 + GX850
Sistema Operativo
Windows 10
In che senso 'farlo correttamente'?
Comunque ho messo:
SSD su SATA3_0 (come avevo anche letto qui)
HDD su SATA2_1
Lettore DVD su SATA2_2
come mi avete consigliato. Il problema è che continua a darmi quell'errore.
Ho seguito questo video, ma nulla da fare!
Eh, intendo appunto che hai fatto casini con il manager di boot di Linux.
Come vedi i dischi sul gestionale?
Bene come hai attaccato i device lasciando fuori Asmedia
 

Liupen

UTENTE LEGGENDARIO
9,372
3,951
Hardware Utente
CPU
Intel i7 4770K @ 4,6 GHz
Dissipatore
Corsair H80i
Scheda Madre
Asus Maximus VI Gene rel.2
Hard Disk
SSD Samsung 850 PRO 512GB + 850 EVO 1TB + 850 EVO 500GB + Seagate SSHD 1TB + BACKUP
RAM
DDR3 Corsair Vengeance 16 GB (4x4Gb 1600Hz / 8 8 8 24)
Scheda Video
ASUS STRIX GeForce GTX 970 - Clock @ 1403Mhz boost / Memoria @ 7160Mhz
Scheda Audio
(integrata)
Monitor
Samsung T24E390
Alimentatore
Enermax triathlor 650w 80plus bronze
Case
Zalman Z9 Plus full fan
Periferiche
Asus ROG GK2000 + GX850
Sistema Operativo
Windows 10
Scusa l'ignoranza ma non ho capito cosa mi hai chiesto.
Comunque se ho fatto casini non so come ho fatto.
Se ho capito bene su hdd hai debian (Linux) e su ssd hai installato per provare diversi sistemi operativi...
Grub che è il software di boot loader delle distribuzioni Linux è corrotto per i troppi casini tentativi fatti per l'installazione. Grub vorrebbe ora che fosse fatto un ripristino/riparazione.
Non sto a proporti le mila guide che trovi on line, compreso il supporto Debian; la cosa migliore è una reinstallazione, pulendo per bene ssd e hdd (prima salva i dati).
 

ViPaaK

Utente Attivo
Sull'hdd ho debian come vede anche gparted da un avvio live tramite USB
Sull'ssd non ho nulla, forse c'è Windows ma non sono sicuro perchè anche staccando l'hdd all'avvio dal boot menu da lo stesso errore.
In entrambi non ci sono dati importanti, per fortuna, anche perchè non saprei come recuperarli, quindi posso cancellare tutto volendo.
 

Entra

oppure Accedi utilizzando