Dente di sega con Ryzen 7 3700x

AnonME

Nuovo Utente
Buongiorno a tutti.

Ho un problema con le temperature del Ryzen 7 3700x che ho montato sul PC che ho assemblato da un paio di settimane. La MoBo è una X570 Aorus Ultra e il dissipatore un AIO DeepCool Gammaxx 240.

La temperatura, infatti, lasciando le impostazioni energetiche di default (ma anche quelle specifiche per AMD Ryzen) risulta oscillare in IDLE di circa 6-7 gradi con una frequenza di circa 4GHz. Riporto di seguito il grafico di OCCT, dato che è ben leggibile e le temperature combaciano con quelli di altri software (in particolare SIV, programma della Gigabyte):
355838

Il PC in questo caso non era veramente in IDLE in quanto sto scrivendo questo post, quindi la variazione della temperatura media è dovuta a quello, ma il dente di sega è ben notevole.

Non appena passo alla combinazione a risparmio energetico, la frequenza della CPU cala a 2.19GHz e il problema sparisce (la linea azzurra combacia con l'attivazione della modalità a risparmio energetico):
355839

In alternativa posso modificare le impostazioni avanzate di risparmio energia specificando come livello minimo e massimo di utilizzo del processore del 99% e la temperatura si stabilizza come sopra, nella modalità a risparmio energetico (in questo caso la frequenza passa a 3.59GHz).

Il tutto non sarebbe un grosso problema, se non che mi costringe ad utilizzare una curva di raffreddamento personalizzata ben specifica per la quale fino a 60 °C la velocità della ventola rimane bassa, per poi "esplodere" sopra ai 65 °C, in quanto con le impostazioni di default avevo delle notevoli e fastidiosi variazioni della velocità della ventola:
355842

Mi sembra molto strano che per risolvere il problema debba utilizzare delle impostazioni del genere in quanto quelle di default risultano estremamente fastidiose. Ho verificato se ci fosse una funzionalità di Smoothing per quanto riguarda la mia MoBo ma non ho trovato alcuna impostazione. So che l'ideale sarebbe regolare la velocità delle ventole sulla temperatura del liquido di raffredamento ma questo AIO non me lo permette.

Avete qualche suggerimento? È normale che la temperatura del processore oscilli in questo modo?

Grazie in anticipo
 

demon03

Utente Èlite
3,182
1,301
Hardware Utente
CPU
AMD Ryzen 5 2600X @4.2 all cores 1.287v
Dissipatore
DeepCool Gammaxx L240 V2
Scheda Madre
Asus Prime X-470 Pro
Hard Disk
Samsung 860 evo 250GB + Toshiba 1TB
RAM
16GB G.Skill Trident Z RGB 3200 @3600 cl16
Scheda Video
Msi GTX 1660Ti Gaming X
Monitor
Aoc 24V2Q
Alimentatore
Corsair TX650M 80+Gold
Case
Sharkoon TG5
Internet
Alice Mega 200M
Sistema Operativo
Windows 10 Pro
Hai impostato la pompa al massimo?
 
  • Mi piace
Reactions: BWD87

mdk14

Utente Attivo
334
44
Hardware Utente
CPU
3700x 4,2ghz 1,30v
Dissipatore
Noctua NH-U12A
Scheda Madre
X570i Aorus Pro Wifi
Hard Disk
Crucial MX500 1TB
RAM
Corsair 2x16 3200 CL16
Scheda Video
Vega 56 Pulse
Monitor
Asus MG279Q
Alimentatore
Corsair SF600 Platinum
Case
Fractal Design Nano S
Ciao, ho comprato anche io da poco il 3700x e ho scoperto solo poco dopo averlo montato, come te, che ha un comportamento alquanto anomalo per quanto riguarda voltaggio e temperature.
Da quello che si legge online è il suo comportamento naturale (amd dichiara che lavora tra 1.2-1.5 senza problemi), ha il voltaggio ballerino con delle punte più alte nel momento in cui si apre/usa qualcosa e di conseguenza le temperature salgono e scendono di continuo.

La tua situazione sulla carta è anche un poco peggio della mia, in quanto il mio si "fermava" sotto i 50° come temperature di punta, parlo non sottosforzo o con firefox aperto per dire, così facendo ho settato la ventola fissa fino a 50° al 40% e poi a salire ma questa cosa è soggettiva in base alla tolleranza del rumore, qualità delle ventole ecc.
Non so da cosa possa dipendere, se dal case e relativo airflow, le ventole o il dissipatore che usi, fatto sta che probabilmente la cosa migliore da fare è quella di cercare il miglior voltaggio con frequenza fissa di 4.2-4.3ghz.
In idle senza niente aperto se non hwinfo per monitorare le temperature dovrebbe rimanere sempre sui 30° circa.

Prima di fare i dovuti test però puoi provare a cambiare solo il dynamic vcore a -0,075 e vedere se ti migliora sufficientemente la cosa a livello di temperature, il vcore e la frequenza rimarranno con valori ballerini.

L'unica cosa diversa è che io ho sempre tenuto il profilo bilanciato di windows e non ho verificato quanto cambiasse col risparmio energetico.
 

AnonME

Nuovo Utente
Hai impostato la pompa al massimo?
Sì, è collegata a CPU_OPT e impostata al massimo :)
Ciao, ho comprato anche io da poco il 3700x e ho scoperto solo poco dopo averlo montato, come te, che ha un comportamento alquanto anomalo per quanto riguarda voltaggio e temperature.
Da quello che si legge online è il suo comportamento naturale (amd dichiara che lavora tra 1.2-1.5 senza problemi), ha il voltaggio ballerino con delle punte più alte nel momento in cui si apre/usa qualcosa e di conseguenza le temperature salgono e scendono di continuo.

La tua situazione sulla carta è anche un poco peggio della mia, in quanto il mio si "fermava" sotto i 50° come temperature di punta, parlo non sottosforzo o con firefox aperto per dire, così facendo ho settato la ventola fissa fino a 50° al 40% e poi a salire ma questa cosa è soggettiva in base alla tolleranza del rumore, qualità delle ventole ecc.
Non so da cosa possa dipendere, se dal case e relativo airflow, le ventole o il dissipatore che usi, fatto sta che probabilmente la cosa migliore da fare è quella di cercare il miglior voltaggio con frequenza fissa di 4.2-4.3ghz.
In idle senza niente aperto se non hwinfo per monitorare le temperature dovrebbe rimanere sempre sui 30° circa.

Prima di fare i dovuti test però puoi provare a cambiare solo il dynamic vcore a -0,075 e vedere se ti migliora sufficientemente la cosa a livello di temperature, il vcore e la frequenza rimarranno con valori ballerini.

L'unica cosa diversa è che io ho sempre tenuto il profilo bilanciato di windows e non ho verificato quanto cambiasse col risparmio energetico.
Farò qualche prova. Ridurre il Dynamic VCore che altre ripercussioni avrebbe?
 

BWD87

Moderatore
Staff Forum
Utente Èlite
25,537
16,600
Hardware Utente
CPU
Core I/ 4790K @4,9GHz 1.39v delidded
Dissipatore
Corsair Hydro h100x (2x sp120 pwm push + ventole stock pull)
Scheda Madre
msi Z97S SLI Krait Edition
Hard Disk
ADATA XPG SX6000 128GB (SO) + Crucial MX500 1TB (giochi) + Seagate Barracuda 1TB (storage vario)
RAM
32Gb Corsair Dominator Platinum 2400 @2666 cl13-15-15-31
Scheda Video
MSI GeForce GTX 1070Ti AERO + kraken g12/kraken x31 @2114core/4554vram
Monitor
MSI Optix MAG241C
Alimentatore
Corsair TX550M
Case
Corsair Carbide 400R moddato
Periferiche
Ventole case: 3x silent wings 2 in, 2x sp140 led in, 1x sp140 led out, 2x ml120 pro led + 2x ml120 rad 240; 2x sp120 pwm rad 120
Sistema Operativo
Windows 10
Che pasta termica hai utilizzato? A quanti gradi ti arriva la cpu con uno stress test?
 

mdk14

Utente Attivo
334
44
Hardware Utente
CPU
3700x 4,2ghz 1,30v
Dissipatore
Noctua NH-U12A
Scheda Madre
X570i Aorus Pro Wifi
Hard Disk
Crucial MX500 1TB
RAM
Corsair 2x16 3200 CL16
Scheda Video
Vega 56 Pulse
Monitor
Asus MG279Q
Alimentatore
Corsair SF600 Platinum
Case
Fractal Design Nano S
Farò qualche prova. Ridurre il Dynamic VCore che altre ripercussioni avrebbe?
Se diminiusci troppo inizi a perdere qualcosa lato performance, quando feci le prove fino a -0,075 andava tutto regolare, oltre quel valore nei test avevo punteggi più bassi.
 
  • Mi piace
Reactions: BWD87

AnonME

Nuovo Utente
Che pasta termica hai utilizzato? A quanti gradi ti arriva la cpu con uno stress test?
Questo è un grafico con Aida Extreme (solo CPU e FPU) appena avviato. Oltre a quel picco la temperatura si stabilizza attorno ai 70 gradi (ora lo lascerò andare qualche minuto ma la temperatura non dovrebbe variare). La pasta termica è quella che fornivano con il dissipatore.
355901

Giustamente una volta partito il test, se il problema è collegato al boost, riconoscendo che le temperature sono troppo alte e non potendo più farlo, la temperatura rimane stabile e la frequenza si attesta a 3.95GHz

EDIT: faccio subito un rapido edit, in quanto in effetti i picchi ogni tanto ci sono, come se provasse a pompare la frequenza per vedere dove può arrivare. Sono comunque abbastanza rari:
355902
 
Ultima modifica:

BWD87

Moderatore
Staff Forum
Utente Èlite
25,537
16,600
Hardware Utente
CPU
Core I/ 4790K @4,9GHz 1.39v delidded
Dissipatore
Corsair Hydro h100x (2x sp120 pwm push + ventole stock pull)
Scheda Madre
msi Z97S SLI Krait Edition
Hard Disk
ADATA XPG SX6000 128GB (SO) + Crucial MX500 1TB (giochi) + Seagate Barracuda 1TB (storage vario)
RAM
32Gb Corsair Dominator Platinum 2400 @2666 cl13-15-15-31
Scheda Video
MSI GeForce GTX 1070Ti AERO + kraken g12/kraken x31 @2114core/4554vram
Monitor
MSI Optix MAG241C
Alimentatore
Corsair TX550M
Case
Corsair Carbide 400R moddato
Periferiche
Ventole case: 3x silent wings 2 in, 2x sp140 led in, 1x sp140 led out, 2x ml120 pro led + 2x ml120 rad 240; 2x sp120 pwm rad 120
Sistema Operativo
Windows 10
Questo è un grafico con Aida Extreme (solo CPU e FPU) appena avviato. Oltre a quel picco la temperatura si stabilizza attorno ai 70 gradi (ora lo lascerò andare qualche minuto ma la temperatura non dovrebbe variare). La pasta termica è quella che fornivano con il dissipatore.

Giustamente una volta partito il test, se il problema è collegato al boost, riconoscendo che le temperature sono troppo alte e non potendo più farlo, la temperatura rimane stabile e la frequenza si attesta a 3.95GHz
È tutto normale imho, a maggior ragione con dissipatore e pasta termica stock
 

AnonME

Nuovo Utente
Che pasta termica hai utilizzato? A quanti gradi ti arriva la cpu con uno stress test?
È tutto normale imho, a maggior ragione con dissipatore e pasta termica stock
Il dissipatore non è stock, è questo: https://www.amazon.it/gp/product/B07QFWQXZ1/?tag=tomsforum-21

In ogni caso anche sparando la ventola al 100% i picchi ci sono. Se fosse un problema di dissipazione mi aspetterei che si risolvessero in quel caso...
 
  • Mi piace
Reactions: BWD87

BWD87

Moderatore
Staff Forum
Utente Èlite
25,537
16,600
Hardware Utente
CPU
Core I/ 4790K @4,9GHz 1.39v delidded
Dissipatore
Corsair Hydro h100x (2x sp120 pwm push + ventole stock pull)
Scheda Madre
msi Z97S SLI Krait Edition
Hard Disk
ADATA XPG SX6000 128GB (SO) + Crucial MX500 1TB (giochi) + Seagate Barracuda 1TB (storage vario)
RAM
32Gb Corsair Dominator Platinum 2400 @2666 cl13-15-15-31
Scheda Video
MSI GeForce GTX 1070Ti AERO + kraken g12/kraken x31 @2114core/4554vram
Monitor
MSI Optix MAG241C
Alimentatore
Corsair TX550M
Case
Corsair Carbide 400R moddato
Periferiche
Ventole case: 3x silent wings 2 in, 2x sp140 led in, 1x sp140 led out, 2x ml120 pro led + 2x ml120 rad 240; 2x sp120 pwm rad 120
Sistema Operativo
Windows 10
Il dissipatore non è stock, è questo: https://www.amazon.it/gp/product/B07QFWQXZ1/?tag=tomsforum-21

In ogni caso anche sparando la ventola al 100% i picchi ci sono. Se fosse un problema di dissipazione mi aspetterei che si risolvessero in quel caso...
ah si scusa l'avevi già detto il dissipatore. No ma tanto i picchi ci saranno sempre con qualsiasi dissipatore, più o meno marcati. Comunque per ora ti consiglio di cambiare pasta termica con quella mensionata in questa guida. La pasta termica in dotazione con il gammax non è il massimo, anzi...

Poi eventualmente proveremo ad abbassare un pò il vcore per risparmiare qualche grado e stabilizzare le temp
 

Alinoblu

Utente Èlite
5,268
449
Hardware Utente
CPU
AMD Ryzen 5 3600 @ 4.2Ghz tutti i core @ 1.224v
Dissipatore
Noctua NH-D14
Scheda Madre
MSI B450 Tomahawk MAX
Hard Disk
Silicon Power A80 NVME 1Tb - Sandisk SSD Plus 480Gb - Corsair M4-CT 256Gb - Seagate Barracuda 500Gb
RAM
Corsair Vengeance LPX 3600 Mhz 2 x 8Gb
Scheda Video
XFX RX 5700 XT Thicc III Ultra
Scheda Audio
Integrato
Monitor
Samsung Syncmaster p2350 23" full HD
Alimentatore
Cooler Master Silent Pro 850W
Case
Cooler Master Sniper Pure Black
Sistema Operativo
Windows 10 Professional
Ho riscontrato lo stesso comportamento, in idle, col mio 3600. Anche abbassando il vcore e settando manualmente il moltiplicatore per tutti i core, PBO su off, in idle la temperatura oscilla.
AMD dice che è normale, e che già il fatto di utilizzare un software per monitorare frequenza e temperatura della CPU, causa un carico ciclico sulla stessa, che si traduce in cambio di frequenza\voltaggio e di conseguenza temperatura.
Dovresti in effetti vedere in corrispondenza dell'aumento della temperatura un aumento della frequenza.
Insomma "Dice che lo deve fare" da quello che ho capito...
 

Niemand

Utente Èlite
5,954
1,429
Hardware Utente
i grafici postati fanno riferimento alla temperatura ma in realtà quello che accade è che la CPU ha dei picchi di utilizzo.
se si monitora con HWinfo lo vedi.
Non ha senso pensare al dissipatore: il problema è capire cosa occupa la CPU.
 
Ho notato anche io lo stesso comportamento con il mio 3700x (montato su MSI mpg x570 e Kraken X52) con tutti i parametri di default tranne XMP attivato e Windows appena installato.
Questi sono i grafici di temperatura e frequenza su Afterburner mentre vi sto scrivendo.
Ho utilizzato tutte e tre le combinazioni: Bilanciato (Windows), Ryzen (Bilanciato) e Risparmio energetico.
Tutto.JPG

BILANCIATO WINDOWS: andamento variabile, clock da 3.2 a 4.4 Ghz, temperature 30-50°
RYZEN: andamento variabile, clock da 3.6 a 4.4 Ghz, temperature 30-50°
RISPARMIO: andamento costante, clock a 2.2 Ghz, temperature 27°

Mi chiedevo se è normale un andamento di questo tipo a indle, avete anche voi un comportamento simile? C'è modo di evitarlo?
Sicuramente non è un problema di raffreddamento, sotto carico con Cinebench (4.4Ghz e 100%) dopo diversi cicli raggiungo una temperatura massima costante di 60°.
Saluti
 

AnonME

Nuovo Utente
Ciao a tutti e scusate il messaggio dopo circa due settimane, tra feste e altro mi sono perso le notifiche di risposta :)

i grafici postati fanno riferimento alla temperatura ma in realtà quello che accade è che la CPU ha dei picchi di utilizzo.
se si monitora con HWinfo lo vedi.
Non ha senso pensare al dissipatore: il problema è capire cosa occupa la CPU.
Non penso che l'aumento della temperatura sia dovuta a dei picchi di utilizzo: li vedrei anche in altri momenti, non appena faccio qualche operazione, ma in quei casi c'è un aumento della temperatura medio, e i picchi rimangono con la stessa periodicità. Inoltre, avvengono anche con il PC in IDLE con la stragrande maggioranza dei processi chiusi. Inoltre, a volte appaiono anche con la CPU già sotto stress al 100% (ad esempio durante un test con AIDA) quindi in quel non possono esserci dei picchi.

Ho letto un thread di qualcuno di AMD su reddit e spiega piuttosto bene questo comportamento, anche se personalmente non mi torna. Lascio qua il thread: https://www.reddit.com/r/Amd/comments/ctcj2z/more_culprits_that_cause_the_observer_effect/

Nello specifico, quello che non mi torna è che senza aver alcun tool di monitoraggio attivo non dovrei avere la ventola che comincia a fare alti e bassi, questo perchè la temperatura dovrebbe essere stabile, e invece ciò accade.

Ryzen Master riesce a monitorare bene la temperatura (che risulta differente di qualche grado) ma rimane il problema che anche senza monitoraggio attivo la ventola della CPU ha questo problema. L'ideale sarebbe se la velocità della ventola fosse in relazione alla temperatura monitorata da Ryzen Master, ma ciò non credo sia possibile.

Ho utilizzato tutte e tre le combinazioni: Bilanciato (Windows), Ryzen (Bilanciato) e Risparmio energetico.

BILANCIATO WINDOWS: andamento variabile, clock da 3.2 a 4.4 Ghz, temperature 30-50°
RYZEN: andamento variabile, clock da 3.6 a 4.4 Ghz, temperature 30-50°
RISPARMIO: andamento costante, clock a 2.2 Ghz, temperature 27°

Mi chiedevo se è normale un andamento di questo tipo a indle, avete anche voi un comportamento simile? C'è modo di evitarlo?
Sicuramente non è un problema di raffreddamento, sotto carico con Cinebench (4.4Ghz e 100%) dopo diversi cicli raggiungo una temperatura massima costante di 60°.
Saluti
Aggiungo che anche a me con risparmio energetico non ha picchi, ma è sufficiente in realtà andare nelle opzioni di risparmio energetico e ridurre ENTRAMBE le velocità minima e massima del processore a 99% per avere un clock di 3.5GHz e non avere più il problema dei picchi.
 

Niemand

Utente Èlite
5,954
1,429
Hardware Utente
Non penso che l'aumento della temperatura sia dovuta a dei picchi di utilizzo: li vedrei anche in altri momenti, non appena faccio qualche operazione, ma in quei casi c'è un aumento della temperatura medio, e i picchi rimangono con la stessa periodicità. Inoltre, avvengono anche con il PC in IDLE con la stragrande maggioranza dei processi chiusi. Inoltre, a volte appaiono anche con la CPU già sotto stress al 100% (ad esempio durante un test con AIDA) quindi in quel non possono esserci dei picchi.
ripeto che misurare la temperatura senza vedere la percentuale di utilizzo della CPU e i Watt che vengono trasformati in calore ha poco senso.
scarica HWInfo64 e fai il monitoraggio di tutti i parametri rilevanti.
di seguito le rilevazioni di un i5 8400 in idle:
1578784354910.png
si vedono molto bene le oscillazioni anche se è in idle, a causa di processi in background.
Magari con Ryzen 2 in background senza risparmio energetico ci sono processi MOLTO più impegnativi....
 
  • Mi piace
Reactions: BWD87

Entra

oppure Accedi utilizzando