Crash memory corruption detected in low memory quando cerco di avviare una distro linux

Stato
Discussione chiusa ad ulteriori risposte.

GraveKeeper

Utente Èlite
4,699
2,163
CPU
AMD Ryzen 7 3700X
Dissipatore
Enermax LiqMax III ARGB 240 Nero ARGB
Scheda Madre
Asus Tuf Gaming B550-PLUS (WIFI)
HDD
Samsung 970 EVO Plus 500GB NVMe + Crucial MX500 1TB + 2 x WD10EZEX Blue 1TB
RAM
Adata XPG Spectrix 16gb (2x8) 3200Mhz RGB
GPU
Asus NVIDIA GeForce GTX 750ti OC 2GB (in attesa di meglio)
Audio
Behringer U-PHORIA UM2 (chissà, magari un giorno prenderò una Scarlett Solo)
Monitor
LG 27GN800 UltraGear QHD IPS 27" 1ms 144Hz
PSU
ITEK GF 750W 80Gold
Case
NZXT H510i Nero
Periferiche
Studio Monitor Speakers Presonus Eris E3.5, Audio Technica ATH-M30x
OS
Windows 10 Home 64-bit
Ok, la storia è un po' complicata ma non molto. Possiedo un vecchio Toshiba Satellite Pro A300 che in passato mi ha dato spesso problemi di riavvi improvvisi, ho aperto varie discussioni sul forum al tempo.

Dopo un cambio di portatile dovuto per il tempo, decido di smontarlo, cambiare la pasta termica con della nuova MX4, poichè probabilmente i riavvi erano dovuti a temperature elevate, e fare delle prove poichè avevo intenzione come progetto originale di convertirlo in una piccola macchina da retrogaming (nulla di eccessivo date le caratteristiche), installandoci Retroarch come OS tramite il progetto Lakka.

Quindi lavoro praticamente col portatile a pezzi smontato sulla scrivania con tutto sul piano, mobo usb eccetera.

Provo lakka e sembra funzionare. Dopo un po' di tempo che passa ho detto riproviamo e vediamos e va ancora, e noto che spesso mi dà problemi, riavvi, crash, freeze.

Decido di provare altre distro linux. Provo ElementaryOS da chiavetta ultima versione, e ottengo l'errore in foto che ovviamente dura un secondo e poi si riavvia.

Allora dico sarà elementaryOS che è fatto male (nonstante tempo fa con una vecchia versione non ebbi problemi), provo un vecchio cd di linux mint 17 per capire se il problema è elementaryos o la chiavetta. Risultato stesso errore e riavvio.

Freezando in qualche modo riesco a tenere l'errore a schermo per ottenere la foto.

Dato l'errore decido di fare un memtest: voglio farlo da chiavetta ma non viene proprio riconosciuta e scopro che non funziona su bios vecchi. Mi ricordo di avere un cd di lubuntu in giro che possiede memtest e lo provo. Ovviamente lubuntu non si avvia e dà un riavvio, ma se avvio il memtest invece della live non ho problemi.

Lo lascio andare tutta notte e faccio 11 pass positivi così da escludere la ram. M'informo sull'errore online; oltre a un problema di ram, leggo che può essere causato dai bios vecchi che vanno a occupare una piccola parte della ram di sistema, e linux trovando parte della ram occupata la rileva come corrotta, ma che la gente dichiara ignorando l'errore di poter comunque avviare normalmente cosa che io non posso fare. Continuando a leggere in giro però vengo a sapere che anche se questo è un errore noto, proprio perchè noto dovrebbe essere stato risolto nelle ultime versioni di linux, per cui se si poteva sospettare per il mint 17, di certo, elementaryos aggiornato non dovrebbe dare quel problema, senza considerare ceh come ho detto ero tempo fa riuscito ad avviarlo senza problemi.

Ah, per chiarire ulteriormente, riesco ad arrivare al menu iniziale di lubuntu, come anche elementaryos fa la scritta "Booting elementaryos in" col countdown, dopo avviene l'errore. Inoltre non ho problemi di temperature.

A questo punto mi ritrovo con una grossa incognita? Avete qualche suggerimento o potete aiutarmi in qualche modo? O possiamo indicare la mobo e direi che posso abbandonare il progetto?
Quando Lakka partiva non dava problemi però.

Grazie mille in anticipo a chi potrà aiutarmi.
 

Allegati

  • DSCN0342.JPG
    DSCN0342.JPG
    3.5 MB · Visualizzazioni: 37

daniel_tex

Utente Attivo
63
13
Ciao,
hai provato Debian?

Poi... riesci a vedere i log? Se non esponi l'errore o se non riesci capire il tipo di errore andrai a tentoni come chi cerca di aiutarti!

Da live ti dà lo stesso problema?

Ciao,
 

GraveKeeper

Utente Èlite
4,699
2,163
CPU
AMD Ryzen 7 3700X
Dissipatore
Enermax LiqMax III ARGB 240 Nero ARGB
Scheda Madre
Asus Tuf Gaming B550-PLUS (WIFI)
HDD
Samsung 970 EVO Plus 500GB NVMe + Crucial MX500 1TB + 2 x WD10EZEX Blue 1TB
RAM
Adata XPG Spectrix 16gb (2x8) 3200Mhz RGB
GPU
Asus NVIDIA GeForce GTX 750ti OC 2GB (in attesa di meglio)
Audio
Behringer U-PHORIA UM2 (chissà, magari un giorno prenderò una Scarlett Solo)
Monitor
LG 27GN800 UltraGear QHD IPS 27" 1ms 144Hz
PSU
ITEK GF 750W 80Gold
Case
NZXT H510i Nero
Periferiche
Studio Monitor Speakers Presonus Eris E3.5, Audio Technica ATH-M30x
OS
Windows 10 Home 64-bit
Ciao,
hai provato Debian?

Poi... riesci a vedere i log? Se non esponi l'errore o se non riesci capire il tipo di errore andrai a tentoni come chi cerca di aiutarti!

Da live ti dà lo stesso problema?

Ciao,

Non hai letto bene. No, non ho provato debian, ma è evidente che un qualche problema c'è. Al momento non c'è un disco fisso tutte le prove sono fatte da live usb/cd e ovviamente non partendo del tutto l'os non ho modo di vedere alcun log.

La mia intenzione comunque è capire l'errore, non avere per dire debian funzionante, perchè alla fine ci metterei lakka come ho detto.
 

DispatchCode

Moderatore
Staff Forum
1,494
1,153
CPU
Intel 1200 I9-10900KF 3.75GHz 10x 125W
Dissipatore
Gigabyte Aorus Waterforce X360 ARGB
Scheda Madre
Asus 1200 TUF Z590-Plus Gaming ATX DDR4
HDD
1TB NVMe PCI 3.0 x4, 1TB 7200rpm 64MB SATA3
RAM
DDR4 32GB 3600MHz CL18 ARGB
GPU
Nvidia RTX 3080 10Gb DDR6
Audio
Integrata 7.1 HD audio
Monitor
AOC C27g2u 165Hz
PSU
Gigabyte P850PM
Case
Phanteks Enthoo Evolv X ARGB
Periferiche
MSI Vigor GK30, mouse Logitech
Net
30Mbps/3Mbps con Eolo
OS
Windows 10 64bit

GraveKeeper

Utente Èlite
4,699
2,163
CPU
AMD Ryzen 7 3700X
Dissipatore
Enermax LiqMax III ARGB 240 Nero ARGB
Scheda Madre
Asus Tuf Gaming B550-PLUS (WIFI)
HDD
Samsung 970 EVO Plus 500GB NVMe + Crucial MX500 1TB + 2 x WD10EZEX Blue 1TB
RAM
Adata XPG Spectrix 16gb (2x8) 3200Mhz RGB
GPU
Asus NVIDIA GeForce GTX 750ti OC 2GB (in attesa di meglio)
Audio
Behringer U-PHORIA UM2 (chissà, magari un giorno prenderò una Scarlett Solo)
Monitor
LG 27GN800 UltraGear QHD IPS 27" 1ms 144Hz
PSU
ITEK GF 750W 80Gold
Case
NZXT H510i Nero
Periferiche
Studio Monitor Speakers Presonus Eris E3.5, Audio Technica ATH-M30x
OS
Windows 10 Home 64-bit
È dovuto ad una scansione della memoria bassa da parte del kernel. Non so che versioni usi, e se il BIOS è aggiornato.

Ne aveva parlato bigendian qui https://forum.tomshw.it/threads/lot-di-linux-e-altri-os.304889/page-679#post-7720725

Magari può esserti d'aiuto.

E' esattamente il problema che avevo letto, ma ho letto anche che alcuni utenti riuscivano ad accedere all'os nonostante l'errore, invece io ho un crash. A parte quello il bios è effettivamente non aggiornato credo, ma l'aggiornamento va fatto da windows 7, che purtroppo non si può avviare in live, quindi dovrei trovare un disco da qualche parte...
 

GraveKeeper

Utente Èlite
4,699
2,163
CPU
AMD Ryzen 7 3700X
Dissipatore
Enermax LiqMax III ARGB 240 Nero ARGB
Scheda Madre
Asus Tuf Gaming B550-PLUS (WIFI)
HDD
Samsung 970 EVO Plus 500GB NVMe + Crucial MX500 1TB + 2 x WD10EZEX Blue 1TB
RAM
Adata XPG Spectrix 16gb (2x8) 3200Mhz RGB
GPU
Asus NVIDIA GeForce GTX 750ti OC 2GB (in attesa di meglio)
Audio
Behringer U-PHORIA UM2 (chissà, magari un giorno prenderò una Scarlett Solo)
Monitor
LG 27GN800 UltraGear QHD IPS 27" 1ms 144Hz
PSU
ITEK GF 750W 80Gold
Case
NZXT H510i Nero
Periferiche
Studio Monitor Speakers Presonus Eris E3.5, Audio Technica ATH-M30x
OS
Windows 10 Home 64-bit
Piccolo aggiornamento, ho recuperato un disco hitachi 2.5 senza alcun problema, e ho tirato fuori la mia chiavetta di windows 7 (l'ultimo supportato per bene dal portatile) da usare anche senza key avendole finite, giusto per lanciare l'update del bios.

Risultato: non riesco ad installare windows, la chiavetta viene riconosciuta, esce la schermata loading windows files, poi il caricamento di windows, dopodichè schermo nero e freeze/crash/riavvio.

Non so cosa pensare.
 
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando