[CONFIGURAZIONE] NAS+Router messo in sicurezza

Stato
Discussione chiusa ad ulteriori risposte.

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
Salve ragazzi,

premetto che è la prima volta che mi avvicino a creare una rete LAN e sono molto a digiuno...

OBIETTIVO:
- Creare una rete LAN
- Metterla in SICUREZZA
- Condividere con altri utenti LIMITANDONE/GESTENDONE gli accessi

Configurazione Attuale:
- NAS D-Link DNS-320 (10/100/1000) = 76€
- Router Asus DSL N-13 (10/100) = 46€
- in futuro SMART Switch Longshine LCS-GS8208-A Gigabit 8 porte (10/100/1000) = 68€


Impostazione di default (che poi ho cambiato per mettere in sicurezza):
Router Asus DSL N-13
Default user = Admin
Default Pasword = admin
Default WPA2-Key = 9876543210
Default IP = 192.168.1.1
Default Gateway = 192.168.100.1

NAS D-Link DNS-320
Quando collegato ha preso automaticamente un indirizzo IP dal l'indirizzo IP del Router... --> e qui tutto bene con i parametri di Default

Ho Creato un Dynamic DNS dal sito D-Link
https://www.dlinkddns.com
per poter acedere al NAS dal WEB impostando un nome-DNS fisso associato ad un IP del router dinamico variabile

PROBLEMA di cui si chiede lume: :inchino:
Ho impostato:
Hostname = mionome.dlinkddns.com
IP in DNS = 87.17.57.211 (l'ha preso in automatico, è IP dinamico WAN di Alice)
Browser IP Address = 87.11.50.126 (l'ha preso in automatico, è IP dinamico assegnato al mio PC)
New IP Address
= ???non so cosa mettere -> dalle indicazioni ho capito che devo rimettere IP assegnato al mio PC quindi 87.11.50.126 e così o fatto ma... (1) :boh:


Come da indicazioni manuale D-Link, "penso di essere riuscito" (2) :boh: ad aprire la porta 80 del Router per accedere dall'esterno (WAN) al NAS.
Dal Router Asus DSL N-13 Advance Setup / NAT / Virtual Servers e ho impostato quanto indicato di seguito
Server NameExternal Port StartExternal Port EndProtocolInternal Port StartInternal Port EndServer IP AddressRemove
NAS D-Link NDS-3208080TCP8080xxx.xxx.xxx.xxx
(IP del NAS)
PROBLEMA:
Ora, quando metto nel browser il mio nome-dns mionome.dlinkddns.com, il servizio DNS mi porta alla pagina WEB del mio Router chiedendomi utente e password per acedere al Router e non mi indirizza direttamente alla cartella HardDisk che è dentro al NAS?

- Cosa ho sbagliato?

- Secondo me c'è qualcosa che non va nei punti (1) :boh: e nel punto (2) :boh: di cui non ne sono convinto?

- Gentilmente mi potreste fare chiarezza sui passaggi da fare per configurare il Router + NAS con tutte le varie impostazioni di sicurezza?

- Appena risolto questo passo... mi acquisterò uno Smart Switch Longshine LCS-GS8208-A Gigabit che interporrò tra il Router e il NAS in modo da controllare, dividere (sub-net) e filtrare gruppi di utenti...
So che magari se chiamo un sistemista di rete farebbe tutto lui all'istante... ma volete mettere la soddisfazione nel farlo io con qualche dritta da voi del forum?!?! :love:

Poi lo Smart Switch indicato sembra abbastanza semplice da configurare.
Metto le mani avanti e posto il manuale in modo da ricevere subito magari qualche consiglio
http://longshine.de/longshine/products/1000mbit/GS8208A/GS8208A-manual_eng.pdf

:help: Attendo ansioso di capire dove sbaglio...

Grazie
Saluto
 
Ultima modifica:

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
:help:

nessuno ha esperienza in merito
:inchino:

mi manca solo questo aspetto poi ho completato la mia rete e sopratutto "ho imparato" a configurare la mia rete :varie13:
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
yuppete :help:
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
nessuno mi può aiutare....

dai... non fate i timidi... :birra:
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
novità?...


qualcuno mi può aiutare?


dai... su ragazzi e ragazze ...

...offro un lecca lecca usato a tutti quelli che mi aiutereanno :chupachup


attendo... ed un grazie a tutti...
 

pjotor

Utente Attivo
33
4
CPU
Intel Core i5-2500K, 4300 MHz (43 x 100) TERMALRIGT HR-02 Macho TY-140 X 2
Scheda Madre
Asus P8Z68-V Pro/Gen3
HDD
SSD OCZ-AGILITY3 120 Gb HD 1xWD Caviar Green 1.5TB SATA3 2xST3500418AS (500 GB, 7200 RPM, SATA-II)
RAM
Corsair Vengeance CMZ16GX3M4A1600C9 4x4Gb
GPU
SAPPHIRE ATI RADEON HD 5870 VAPOR X
Audio
INTEGRATA CREATIVE INSPIRE T5400 5.1
Monitor
Philips 231T [23" LED] TV FULL HD
PSU
CORSAIR Professional Series HX850W
Case
ANTEC NINE HUNDRED TWO V2 SCHITE SLIM 120 1200Rpm side
OS
Microsoft Windows 7 Ultimate 64 Bit
non ho il tuo nas ma mi sembra normale che ti chieda utente e password..
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
...finalmente la prima risposta... :inchino: grazie... grazie... pjotor

Che chieda user e psw è normale... ma il problema che se metto user e psw del router entra nel router e non nel nas.

Mi spiego meglio:

1) nel mio browser per navigare in internet nell'indirizzo metto mionome.dlinkddns.com (quello creato con il servizio sul sito dlink)

2) automaticamente vengo dirottato nella pagina del mio Router (Asus DSL-N13) che mi chiede user e password

3) se metto user e password del Router Asus DSL-N13 mi accetta la password e mi apre la pagina dei settaggi/configurazione del Router

4) non saprei che altro utente e password inserire... secondo me ho sbagliato qualcosa nel configurare l'indirizzamento DNS dal sito dlink, oppure visto che le istruzioni dlink dicono di aprire la porta 80 sul router (almeno così ho capito) magari non ho aperto correttamente la porta interessata

Di seguito ripeto il passo già indicato ad inizio post di cui ho perplessità:

Ho Creato un Dynamic DNS dal sito D-Link
https://www.dlinkddns.com
per poter acedere al NAS dal WEB impostando un nome-DNS fisso associato ad un IP del router dinamico variabile

PROBLEMA di cui si chiede lume:
Ho impostato:
Hostname = mionome.dlinkddns.com
IP in DNS = 87.17.57.211 (l'ha preso in automatico, è IP dinamico WAN di Alice)
Browser IP Address = 87.11.50.126 (l'ha preso in automatico, è IP dinamico assegnato al mio PC)
New IP Address = ???non so cosa mettere -> dalle indicazioni ho capito che devo rimettere IP assegnato al mio PC quindi 87.11.50.126 e così o fatto


Quindi... mi sai indicare a grandi linee quali sono i passi da fare per creeare una configurazione protetta e sicura dal lato intrusioni di sconosciuti?
Io ho capito che devo:
a) creare un DNS Dinamico (sempio usando https://www.dlinkddns.com )
b) aprire la porta del Router per potervi acedere dall'esterno
c) quando da qualsiasi browser in remoto sul web inserisco l'indirizzo creato per esempio mionome.dlinkddns.com, in automatico avviene l'instradamento verso l'indirizzo reale del NAS

- Sono corretti i passaggi?
- Se i passaggi sono corretti allora sbaglio qualcosa nella configurazione, e penso sia nel momento che creo il DNS-Dinamico sul sito dlink... Mi sai dire dove sbaglio?

Se tu ci capisci qualcosa chiedo aiuto... :help:

Grazie
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
ma hai fatto un redirect della porta 80 sulla porta del nas? mi spiego meglio dovresti cambiare la porta 80 del nas in un altra porta ad esempio la 8080 e dal router di alice fare il redirect della porta 80 sulla porta 8080 così da non entrare nel router ed entrare nella nas
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
ecco... probabilmente è questo il problema.... ho letto qualcosa sul manuale... non ci ho capito molto... e ho fatto qualcosa ma sicuramente di sbagliato :muro:


Premetto io ho:
- NAS D-Link DNS-320
- Router Asus DSL N-13

Come indicato sopra ho impostato sul Router Asus questi parametri pensando di aver aperto la porta 80... ma non so cosa vuole dire aprire la porta e magari ho sbagliato qualcosa.

Dal Router Asus DSL N-13 Advance Setup / NAT / Virtual Servers e ho impostato quanto indicato nella tabella ad inizio post

Mentre sul NAS non ho impostato niente perchè dal manuale diceva solo di impostare la porta sul Router... quindi penso che il NAS sia già configurato di default ?!?!??

I parametri che ho messo nel Router (tabella ad inizio post) sono corretti?

Probabilmente il problema sta proprio li !! (spero)
In effetti dai parametri del Router vedo che tutto è impostato ad 80 e non come dici tu qualcosa ad 80 e qualcosa a 8080

Quindi se ho capito bene:
- porta in ingresso sul Router 80
- porta in uscita dal Router 8080
- porta in ingresso sun NAS 8080

Visto che nel Router parla di Start e End dove devo mettere i parametri?
External Port Start =
External Port End =
Internal Port Start =
Internal Port End =

Poi devo modificare quindi anche il NAS?

Scusa ignoranza, ma gentilmente potresti farmi un esempio pratico e dirmi se la configurazione che ho fatto nella tabella (inizio post) è errata?

grazie ancora
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
NAS D-Link NDS-3208080TCP8080xxx.xxx.xxx.xxx
(IP del NAS)


secondo me dovresti cambiare la porta 80 del nas in un'altro e fare il redirect verso quella porta ad esempio il nas ha la porta 8080 e dovresti fare 80 80 8080 8080 e vedi se va
 

Mirko.Ma

Utente Attivo
99
1
CPU
per il momento EeePC -> in creazione Workstation
Scheda Madre
Asus P5WDG2-WS PRO + Intel Core2 Quad Q6600 @ 2.40GHz
HDD
Vari
RAM
Patriot 4x2GB = 8GB non ECC
GPU
Sapphire HD6670 Ultimate fanLess
Audio
SB Audigy2
Monitor
LCD + Proiettore
Case
AeroCool
OS
Windows XP64 / Windows7 Ultimate x64
ho il NAS staccato... al più presto provo... e spero di darti conferma che funziona tutto :sisi:
 

Federico83

UTENTE LEGGENDARIO
Utente Èlite
35,208
6,219
CPU
Ryzen 7 3700X
Dissipatore
NDH15
Scheda Madre
Gigabyte auros X570 elite
HDD
4.5TB + 7 di NAS lol
RAM
16 GB G.Skill 3200
GPU
RTX2070
Monitor
IIyama 28" 4K
PSU
Cooler Master GX 650
Case
REV200
OS
Windows10x64pro
teoricamente si lo ho fatto con un mio piccolo webserver di prova a casa
 

Ryam

Utente Attivo
13
0
Il post è vecchio, cmq nel "New IP Address = ???" dovresti mettere l'ip del tuo nas, tipo 192.168.1.xxx
 
Stato
Discussione chiusa ad ulteriori risposte.

Entra

oppure Accedi utilizzando

Hot: E3 2021, chi ti è piaciuto di più?

  • Ubisoft

    Voti: 30 22.6%
  • Gearbox

    Voti: 2 1.5%
  • Xbox & Bethesda

    Voti: 87 65.4%
  • Square Enix

    Voti: 10 7.5%
  • Capcom

    Voti: 6 4.5%
  • Nintendo

    Voti: 18 13.5%
  • Altro (Specificare)

    Voti: 11 8.3%

Discussioni Simili