DOMANDA Come collegare un NAS a Ubuntu (via ethernet)

Leog

Nuovo Utente
58
5
Salve, possiedo un NAS (Network Attached Storage) collegato via ethernet al mio pc con tramite uno switch a 1000Mb. Tuttavia, riguardo alla connessione a Internet, questa avviene attraverso un altro router, più lontano, via wireless.
Sotto Windows, questo NAS è riconosciuto e utilizzato abbastanza correttamente, eccetto un piccolo problema. Sotto Ubuntu, invece, non so affatto come farlo riconoscere e usarlo, anche se ho provato a leggere un po' di documentazione su Internet.
Il software di accompagnamento del NAS, so già che non è compatibile con Linux, ma per ora vorrei almeno che Linux "vedesse" questo HDD di rete. Qualcuno può aiutarmi? Grazie!
 
Ultima modifica:

Ico Bellungi

Utente Èlite
2,921
626
Un NAS dovrebbe essere utilizzabile con qualunque sistema operativo senza usare nessun software particolare.
Prova a mapparlo da Linux dal tuo file manager scrivendo smb://indirizzo_ip_del_NAS
 

Leog

Nuovo Utente
58
5
Scusa se ti rispondo solo ora, ma vedevo che nessuno interveniva!
...infatti ero sicuro che potesse essere usato anche da Linux.
Visto che mi consigli di usare un file manager, me ne potresti anche suggerire uno che reputi valido, pratico e grafico? Per esempio, sotto win uso l'ottimo Freecommander XE.
Devo inserire quella stringa ogni volta che voglio collegarmi al NAS?

Ho provato a inserire l'IP del NAS come posizione da sfogliare nel programma "File" di Ubuntu, ma mi risponde:

"Impossibile mostrare smb://...
Errore: Recupero dell'elenco delle condivisioni dal server non riuscito
Selezionare un altro visualizzatore e tentare di nuovo."

Per quanto riguarda la rete LAN, invece dice continuamente disconnesso.
 
Ultima modifica:

Ico Bellungi

Utente Èlite
2,921
626
Almeno risponde al ping?
Strano che non ci arrivi. Prova a mettere solo l'indirizzo ip nel file manager, vedi se compare qualcosa
 

Leog

Nuovo Utente
58
5
Almeno risponde al ping?
Strano che non ci arrivi. Prova a mettere solo l'indirizzo ip nel file manager, vedi se compare qualcosa
Ho provato a scrivere sia solo l'IP, sia network:///ip_del_NAS dentro al file managere, ma dice errore.

Come si usa il comando ping sotto ubuntu?
Grazie!
 

Ico Bellungi

Utente Èlite
2,921
626
ping ip_del_server
Non è come su win che fa solo 4 tentativi e ti dà il risultato, su linux va avanti fino all'infinito (in realtà fino al riempimento di non ricordo quale buffer) e per interromperlo devi dare ctrl+c
 

Leog

Nuovo Utente
58
5
Ho provato a fare il ping e mi risponde:

DESTINATION HOST UNREACHABLE

e poi riprova all'infinito.
Caro Ico, nella mia ignoranza, ti chiedo se per caso dovrei aggiungere righe simili alle seguenti al file etc/network/interfaces :

auto eth0
iface eth0 inet dhcp
 
Ultima modifica:

Ico Bellungi

Utente Èlite
2,921
626
No, nessuna modifica ai file di configurazione della rete, non ce n'è bisogno.
Se non raggiungi il NAS dal pc o sta in una zona della rete irraggiungibile dal tuo pc per qualche ragione o sbagli indirizzo IP. Oppure ha il protocollo ICMP disabilitato, ma è improbabile
 

Leog

Nuovo Utente
58
5
No, nessuna modifica ai file di configurazione della rete, non ce n'è bisogno.
Se non raggiungi il NAS dal pc o sta in una zona della rete irraggiungibile dal tuo pc per qualche ragione o sbagli indirizzo IP. Oppure ha il protocollo ICMP disabilitato, ma è improbabile
Fra il pc e il NAS c'è solo lo switch. Ne deduco che sbaglio IP. Adesso mi trovo a usare il PC in modalità Win, visto che ho il dual-boot. Mi sono segnato di nuovo l'indirizzo IP, per riportarlo in Linux, visto che sotto Win lo vede. Però potrò avviare Ubuntu solo fra un 20 minuti ancora, poiché adesso non posso uscire da Windows.


Ecco adesso ho provato a usare, sotto Ubuntu, l'indirizzo IP del NAS funzionante sotto WIndows, ma non è cambiato nulla. Non sembra essere questa la strada!
Sia il file manager che il comando ping non riescono a rilevare il NAS.

Potrebbe essere un problema di driver dell'interfaccia LAN del mio PC-Ubuntu?
 
Ultima modifica:

mrkdj

Utente Attivo
151
21
CPU
Amd Fx-8350
Scheda Madre
Asus Sabertooth 990fx r2.0
Hard Disk
SSD 840 EVO 250GB + WD Caviar Green 2TB
RAM
2xCorsair Vengeance LP 4GB
Scheda Video
Geforce GTX 650 Ti Boost +Geforce G210
Monitor
Dell U2412M + Acer AL1916W
Alimentatore
XFX 550w
Case
Carbide 300R
Sistema Operativo
Archlinux
Fra il pc e il NAS c'è solo lo switch. Ne deduco che sbaglio IP. Adesso mi trovo a usare il PC in modalità Win, visto che ho il dual-boot. Mi sono segnato di nuovo l'indirizzo IP, per riportarlo in Linux, visto che sotto Win lo vede. Però potrò avviare Ubuntu solo fra un 20 minuti ancora, poiché adesso non posso uscire da Windows.


Ecco adesso ho provato a usare, sotto Ubuntu, l'indirizzo IP del NAS funzionante sotto WIndows, ma non è cambiato nulla. Non sembra essere questa la strada!
Sia il file manager che il comando ping non riescono a rilevare il NAS.

Potrebbe essere un problema di driver dell'interfaccia LAN del mio PC-Ubuntu?
navighi su internet da ubuntu?
 

Leog

Nuovo Utente
58
5
navighi su internet da ubuntu?
Sì, da Ubuntu navigo tranquillamente su Internt, ma, come ho detto mi connetto a Internet NON tramite lo switch che sta collegato a sua volta col NAS, bensì attraverso un altro router indipendente, che comunica via wireless. In altre parole ho due reti con lo stesso PC: una PC-Router (wireless) e una PC-Switch-NAS (Ethernet).
Spero che questo non sia un problema.
 

mrkdj

Utente Attivo
151
21
CPU
Amd Fx-8350
Scheda Madre
Asus Sabertooth 990fx r2.0
Hard Disk
SSD 840 EVO 250GB + WD Caviar Green 2TB
RAM
2xCorsair Vengeance LP 4GB
Scheda Video
Geforce GTX 650 Ti Boost +Geforce G210
Monitor
Dell U2412M + Acer AL1916W
Alimentatore
XFX 550w
Case
Carbide 300R
Sistema Operativo
Archlinux
prova a dirci un po' gli ip di router, nas e pc
 

Leog

Nuovo Utente
58
5
prova a dirci un po' gli ip di router, nas e pc
NAS: 169.254.197.232

"Infrastruttura di rete": Technicolor TG582n (1223VFN6Z): 192.168.1.254
"Dispositivi multimediali": Technicolor TG582n: .................192.168.1.253

Scheda Ethernet LAN sotto Windows (sotto linux non so
come si veda, se mi aiutate voi...) 169.254.22.148
-subnet mask ........................... 255.255.0.0
-gateway predefinito ................. (nessuno)

Scheda LAN Wireless (sotto Windows) 192.168.1.66
-subnet mask................................. 255.255.255.0
-gateway predefinito....................... 192.168.1.254
 
Ultima modifica:

mrkdj

Utente Attivo
151
21
CPU
Amd Fx-8350
Scheda Madre
Asus Sabertooth 990fx r2.0
Hard Disk
SSD 840 EVO 250GB + WD Caviar Green 2TB
RAM
2xCorsair Vengeance LP 4GB
Scheda Video
Geforce GTX 650 Ti Boost +Geforce G210
Monitor
Dell U2412M + Acer AL1916W
Alimentatore
XFX 550w
Case
Carbide 300R
Sistema Operativo
Archlinux
http://lmgtfy.com/?q=vedere+indirizzo+ip+linux

Ma penso di avere capito quale è il problema.
Ubuntu non lavora come windows e quindi non crea una connessione ad hoc automaticamente.

Prova a postare il risultato di
Codice:
route -n
 

Leog

Nuovo Utente
58
5
Grazie, x il sugg.!

eseguendo il comando ifconfig :
Codice:
leog@leog-X55CR:~$ ifconfig
eth0      Link encap:Ethernet  IndirizzoHW 74:d0:2b:16:90:cf  
          indirizzo inet6: fe80::76d0:2bff:fe16:90cf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:8771 (8.7 KB)  Byte TX:31765 (31.7 KB)
          Interrupt:19 

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:320 errors:0 dropped:0 overruns:0 frame:0
          TX packets:320 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0 
          Byte RX:58704 (58.7 KB)  Byte TX:58704 (58.7 KB)

wlan0     Link encap:Ethernet  IndirizzoHW 6c:71:d9:69:15:c7  
          indirizzo inet:192.168.1.66  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::6e71:d9ff:fe69:15c7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1201 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1205 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:1081210 (1.0 MB)  Byte TX:160485 (160.4 KB)
eseguendo route -n :
Codice:
leog@leog-X55CR:~$ route -n
Tabella di routing IP del kernel
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
Scusate la prolissità!
 

Entra

oppure Accedi utilizzando

Discussioni Simili

Hot del momento