PROBLEMA Asus X550CC Wifi che crasha randomicamente.

Alsettesla

Nuovo Utente
Salve a tutti, scrivo qui perchè credo sia il miglior forum in italia per avere pareri e suggerimenti su un problema simile. Possiedo da un anno e mezzo un Notebook Asus X550CC, esso è stato formattato due o tre volte per passare prima da W8 a W7, poi ho ripartizionato il disco e messo prima Linux Mint + Windows 7 In Dual Boot e successivamente (causa s*****ttata informatica tra L'interfaccia grafica di Mint ed il mio pc ) sono passato da Mint a Ubuntu 14.04. Il problema si è generato quando ho deciso di togliere mint, quando l'interfaccia grafica Cinnamon portava continuamente il sistema a bloccarsi notavo delle continue disconnessioni che non dipendevano dal router alla quale ero collegato. Passato ad ubuntu il problema ha continuato imperterrito a maledire il mio povero macinino, inoltre anche su windows dà lo stesso problema.

La scheda di rete è una AR9485 Wireless Network Adapter Qualcomm Atheros.

Inoltre ho provato a fare dei Log da terminale su ubuntu usando i comandi "cat /var/log/syslog" e "dmesg" ottenendo dei log estremamente simili

Con Dmesg ho ottenuto il seguente log (versione striminzita che contiene le righe che poi si ripetono infinite volte)
[15791.836664] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
[15791.959736] ath: phy0: Chip reset failed
[15791.959749] ath: phy0: Unable to reset channel, reset status -22
[15791.959808] ath: phy0: Unable to set channel
[15792.179272] ath: phy0: RX failed to go idle in 10 ms RXSM=0xffffffff
[15792.191309] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
[15792.204098] ath: phy0: Failed to wakeup in 500us
[15792.420851] ath: phy0: RX failed to go idle in 10 ms RXSM=0xffffffff
[15792.432723] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff

mentre con "cat/var/log/syslog" ho ottenuto questo log (riassunto in un cinque righe che si ripetono per taaaaaante volte)

Apr 15 15:25:53 xxxx-X550CC kernel: [ 559.154934] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Apr 15 15:25:54 xxxx-X550CC kernel: [ 559.275081] ath: phy0: Chip reset failed
Apr 15 15:25:54 xxxx-X550CC kernel: [ 559.275088] ath: phy0: Unable to reset channel, reset status -22
Apr 15 15:25:54 xxxx-X550CC kernel: [ 559.275112] ath: phy0: Unable to set channel
Apr 15 15:25:54 xxxx-X550CC kernel: [ 559.357181] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff

Ho cercato su internet entrambi i log trovando gente con il mio stesso problema ma le soluzioni che essi hanno adottato in un modo o nell'altro o non sono riuscito ad attuarle perchè sono piuttosto alle prime armi con linux o non hanno semplicemente risolto il mio problema. Considerando che comunque la cosa interessa anche windows ho pensato che fosse un problema prettamente hardware della mia scheda wireless ma non ho idea di come funzioni la compatibilità delle schede di rete per un computer portatile.

Ringrazio tutti per l'eventuale aiuto, a presto :vv:


 

KiTo

Utente Attivo
273
52
Hardware Utente
CPU
i7 2600K
Scheda Madre
Asus P8Z68-V PRO
Hard Disk
SSD256GB+HDD1500GB
RAM
8GB DDR3 1.5v C9 1600MHz
Scheda Video
nV GT550ti 1GB
Scheda Audio
int.
Monitor
Samsung P2350
Alimentatore
Corsair TX750
Case
TT Lanmoto
Sistema Operativo
da XP a W10
Potrebbe essere un conflitto sull'assegnazione delle risorse, controlla che Asus non abbia aggiornato il bios. Oppure è solo difettosa, potresti pensare di sostituire la schedina wifi, non sono saldate. Oppure la soluzione più sciocca e semplice sarebbe usare una penna usb wifi di quelle piccolette.
 

Entra

oppure Accedi utilizzando