Alienware area51 e Kali Linux

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
Salve a tutti, Come da titolo nel post sto cercando di installare kali linux sul mio alienware area 51, ma senza riuscirci.
Prima che mi chiediate del perchè kali linux e non qualsiasi altra distribuzione linux, vi rispondo semplicemente perchè sto seguendo un corso ceh comptia, è kali linux è tra i requisiti indispensabili. Ho anche pensato di installare debian e poi inserire i tool, ma è stato richiesto kali.
ora veniamo al punto:
Ho provato diverse soluzioni ma ogni volta un problema diverso.
Partiamo dal sistema operativo gia preinstallato che è windows 10 quindi vorrei utilizzarlo in dual boot, userei anche 2hd diversi uno per ogni sistema operativo. windows è installato su un nvme mentre linux su di un ssd. inizialmente volevo installare tutto sul nvme ma non mi viene riconosciuto nell'installer di linux (non compare tra la selezione dei dischi) quindi ho optato per inserirlo nell'ssd.
20200325_155433.jpg

Il bios è un uefi, e come si può vedere dalle partizioni sono entrambe efi.
da qui i primi problemi. Durante l'installer di kali riconosce la presenza di un altro sistema operativo ma non lo riconosce come uefi quindi mi chiede se forzare l'installazione.
20200325_145418.jpg

se clicco no, procedo con l'installazione ma non mi aggiunge il bootloader al bios, se faccio si procede con installazione e crea il bootloader al bios, ma non riconosce la presenza del secondo sistema operativo e quindi richiede di installare grub.
20200325_150125.jpg

In ogni caso al completamento dell'installazione, appena avvio os kali, la schermata resta bloccata come in foto:
20200325_145010.jpg

ovviamente è tutto bloccato e non effettua nessun comando
ho provato versione su hdd, versione live ecc... il risultato è sempre lo stesso. effettuo installazione tramite chiavetta usb caricata con rufus. potrebbero centrare niente i driver della scheda video?
Grazie milla un saluto a tutti.
 

« MoMy »

Utente Attivo
1,298
593
Visto che a occhio hai un pc performante, non era possibile installare in vm?
Quale scheda video monta?
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
è l'unica soluzione che non ho provato. però ho provato a far partire installazione da windows ma al riavvio al momento della selezione dei sistemi operativi, selezionando kali mi compare un altra schermata.
20200323_132647.jpg

ho una rtx2060 in quanto non ho intenzione di giocare in risoluzioini sopra il fhd.
Posso cmq provare a montare un vm. quali mi consiglieresti?
 

« MoMy »

Utente Attivo
1,298
593
Ti posso dire che la rtx2060 è supportata dl kernel linux con il modulo nouveau, quindi non necessita di magheggi (da qualche problemino, ma il sistema comunque si avvierebbe).
Io uso Virtualbox e avendo un portatile con hardware simile al tuo, non ho problemi nel dedicare 4 cpu e 4 GB di ram a un OS virtualizzato. In più leggo qui nel forum che spesso kali è usata/consigliata in usb persistence o in wm e spesso in abbinamento con un dongle/adapter wifi (alfa) per... studiare ciò che dovete studiare.

ho provato a far partire installazione da windows ma al riavvio al momento della selezione dei sistemi operativi, selezionando kali mi compare un altra schermata
Credo di non aver capito.
Vuoi ripristinare win o reinstallarlo?
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
Credo di non aver capito.
Vuoi ripristinare win o reinstallarlo?
No, era un altra prova fatta da me, provando a far partire l'installazione da windows.
leggo qui nel forum che spesso kali è usata/consigliata in usb persistence o in wm e spesso in abbinamento con un dongle/adapter wifi (alfa) per... studiare ciò che dovete studiare.
Ok la mia preoccupazione e che al momento di test o quando il fabbisogno di calcolo e superiore la macchina tentenni co un sistema vm, cmq ci provero intanto ad usarlo con la vm. ma vorrei cmq provare a inserirlo fisso in macchina.
Ho provato con usb persistance ma niente anche in quel modo mi da sempre schermo nero con righe come in foto.
 

« MoMy »

Utente Attivo
1,298
593
Non conosco kali quindi provo a indovinare.
Durante l' avvio proprio nei primi processi, compare una schermata dal nome Grub (simil immagine sotto)?


Se così fosse premi sulla tastiera la lettera ''e'' (di Empoli), visualizzerai un' insieme di scritte/codici, cerca la riga che contiene ''quiet'', cancella il parametro quiet e al suo posto scrivi nomodeset poi premi i tasti ctrl +x per uscire e continuare col boot. Facci sapere, tanto per capire se è una questione di moduli video.
A parte che forse si avvia in recovery mode, ma non ho esperienza in merito.
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
ok è un pò diverso effettivamente, ho fatto come hai detto e questo è il risultato:
20200325_225119.jpg

ho modificato la linea in questione "quite splash" con dicitura "nomodeset splash" foto scattata un attimo prima.
adesso la macchina si blocca così:
20200325_225654.jpg

invece senza cambiare la dicitura appare lo schermo nero con riga. qui almeno si vede..
 

« MoMy »

Utente Attivo
1,298
593
Si blocca a un passo dal boot completo.
Oltre la nvidia il tuo pc dovrebbe avere una gpu integrata intel?
Al limite si potrebbe installare i moduli per la intel e mettere in blacklist i nouveau usando l' installer di kali (avrai notato sicuramente l' opzione live cioè prova senza installare).
In pratica sarebbe così: Si avvia la live di kali, usando il terminale si monta la partizione radice ( / ) e altre subdirectory, ci si loga come admin (utente root), si configura una connessione internet (meglio se via cavo ethernet), si installa i moduli/driver per la intel e si blacklista i nouveau, si esce e si avvia normalmente.
Per ora ti lascio la procedura chroot così te la studi un po' (se mai già non la conosci) https://wiki.ubuntu-it.org/AmministrazioneSistema/Chroot
e appena posso aggiorno il post con la guida per avviare una connessione ethernet/wireless da terminale.

Bye^^
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
si si essendo un 9700k ha la vga integrata...ora leggo la guida, grazie intanto
Post automaticamente unito:

Ciao, ho provato ad usare anche la versione live, ma non mi avvia nemmeno quella. solita schermata nera con righe e non va oltre.
ho provato versione live con safe mode e si ferma alla seguente schermata:
volevo disattivare vga integrata dal bios, ma non è possibile.
20200326_113851.jpg
 
Ultima modifica:

« MoMy »

Utente Attivo
1,298
593
Mi sembra strano dal momento che usa moduli generici.
Il modulo per la intel è già presente e quindi non serve armeggiare con chroot e poi come parametro d' avvio al posto di nomodeset prova questo: nouveau.modeset=0
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
ho inserito solo il valore che mi hai detto cancellando completamente la dicitura "quiet splash" ma ancora niente resta bloccato in questa nuova schermata:
20200326_182610.jpg
 

« MoMy »

Utente Attivo
1,298
593
Quel che vedo non è la live, giusto?

Quando sei al punto premi i tasti ctrl + alt + F2 per avviare una shell tty. Non è detto ma proviamo.
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
Allora ho riprovato avviando il live, cambiando la stringa di comando quiet con nouveau... e si blocca alle scritte di prima, però la shell riesce ad aprirla
 

« MoMy »

Utente Attivo
1,298
593
Quel che vedo non è la live, giusto?
Forse mi son espresso male, ma volevo capire che ciò che vedevo non riguardasse la live.
Ora come ora la live di kali non ci interessa perché al momento non ci è utile.

Quindi se premi ctrl + alt + F2. Quando sei nel terminale TTY2 fai una prova semplice, ti loghi con il tuo username/passwd e poi digita startx.
Se si blocca o da errore non sarebbe male se lo riportassi qui.
 

Lucomputer

Utente Attivo
43
2
CPU
i7 9700k
Hard Disk
nvme m.2 primario/ssd pro samsung secondario
RAM
8gb ddr4 2600
Scheda Video
rtx 2060
Sistema Operativo
windows 10
Come ormai consuetudine si è bloccato alla seguente schermata:
20200326_222648.jpg
 

Entra

oppure Accedi utilizzando